بولتن امنیتی اندروید - آوریل 2022

منتشر شده در 4 آوریل 2022 | به روز شده در 5 آوریل 2022

بولتن امنیتی اندروید حاوی جزئیاتی از آسیب پذیری های امنیتی است که بر دستگاه های اندرویدی تأثیر می گذارد. سطوح وصله امنیتی 2022-04-05 یا جدیدتر تمام این مشکلات را برطرف می کند. برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

شرکای Android حداقل یک ماه قبل از انتشار از همه مشکلات مطلع می شوند. وصله کد منبع برای این مشکلات در مخزن پروژه منبع باز Android (AOSP) منتشر شده و از این بولتن پیوند داده شده است. این بولتن همچنین شامل پیوندهایی به وصله های خارج از AOSP است.

شدیدترین این مسائل یک آسیب پذیری امنیتی بالا در مولفه Framework است که می تواند منجر به افزایش محلی امتیاز بدون نیاز به مجوزهای اجرایی اضافی شود. ارزیابی شدت بر اساس تأثیری است که بهره‌برداری از آسیب‌پذیری احتمالاً روی دستگاه آسیب‌دیده می‌گذارد، با این فرض که پلت‌فرم و تخفیف‌های سرویس برای اهداف توسعه خاموش شده‌اند یا در صورت دور زدن موفقیت‌آمیز انجام شوند.

برای جزئیات بیشتر در مورد حفاظت های پلتفرم امنیتی اندروید و Google Play Protect که امنیت پلتفرم اندروید را بهبود می بخشد، به بخش کاهش دهنده های Android و Google Play Protect مراجعه کنید.

کاهش خدمات اندروید و گوگل

این خلاصه‌ای از کاهش‌های ارائه شده توسط پلتفرم امنیتی Android و محافظت‌های خدماتی مانند Google Play Protect است. این قابلیت ها احتمال سوء استفاده موفقیت آمیز از آسیب پذیری های امنیتی در اندروید را کاهش می دهد.

  • بهره برداری از بسیاری از مسائل در اندروید با پیشرفت در نسخه های جدیدتر پلتفرم اندروید دشوارتر شده است. ما همه کاربران را تشویق می کنیم تا در صورت امکان به آخرین نسخه اندروید بروزرسانی کنند.
  • تیم امنیتی Android به طور فعال از طریق Google Play Protect برای سوء استفاده نظارت می کند و به کاربران در مورد برنامه های بالقوه مضر هشدار می دهد. Google Play Protect به طور پیش‌فرض در دستگاه‌های دارای سرویس‌های Google Mobile فعال است و به ویژه برای کاربرانی که برنامه‌هایی را از خارج از Google Play نصب می‌کنند، مهم است.

جزئیات آسیب پذیری سطح وصله امنیتی 01/04/2022

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی که در سطح وصله 01-04-2022 اعمال می‌شود، ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. مسائل در جداول زیر توضیح داده شده اند و شامل شناسه CVE، مراجع مرتبط، نوع آسیب پذیری ، شدت و نسخه های به روز شده AOSP (در صورت لزوم) می باشند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است، مانند لیست تغییرات AOSP، به شناسه اشکال مرتبط می کنیم. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند. دستگاه‌های دارای Android 10 و بالاتر ممکن است به‌روزرسانی‌های امنیتی و همچنین به‌روزرسانی‌های سیستم Google Play را دریافت کنند.

چارچوب

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افزایش محلی امتیاز بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2021-0694 الف-183147114 EoP بالا 11
CVE-2021-39794 الف-205836329 EoP بالا 11، 12، 12 لیتر
CVE-2021-39796 الف-205595291 EoP بالا 10، 11، 12، 12 لیتر
CVE-2021-39797 الف-209607104 EoP بالا 12، 12 لیتر
CVE-2021-39798 الف-213169612 EoP بالا 12، 12 لیتر
CVE-2021-39799 الف-200288596 EoP بالا 12، 12 لیتر

چارچوب رسانه ای

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افشای اطلاعات از راه دور بدون نیاز به امتیازات اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2021-39803 الف-193790350 شناسه بالا 10، 11، 12، 12 لیتر
CVE-2021-39804 الف-215002587 DoS بالا 11، 12، 12 لیتر

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افزایش محلی امتیاز بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2021-39808 الف-209966086 EoP بالا 10، 11، 12
CVE-2021-39805 الف-212694559 شناسه بالا 12، 12 لیتر
CVE-2021-39809 الف-205837191 شناسه بالا 10، 11، 12، 12 لیتر

به روز رسانی سیستم گوگل پلی

مسائل زیر در اجزای Project Mainline گنجانده شده است.

مولفه CVE
MediaProvider CVE-2021-39795
کدک های رسانه ای CVE-2021-39803

جزئیات آسیب پذیری سطح وصله امنیتی 05/04/2022

در بخش‌های زیر، جزئیات هر یک از آسیب‌پذیری‌های امنیتی که در سطح وصله ۰۵-۰۴-۲۰۲۲ اعمال می‌شوند را ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. مسائل در جداول زیر توضیح داده شده اند و شامل شناسه CVE، مراجع مرتبط، نوع آسیب پذیری ، شدت و نسخه های به روز شده AOSP (در صورت لزوم) می باشند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است، مانند لیست تغییرات AOSP، به شناسه اشکال مرتبط می کنیم. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند.

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افزایش محلی امتیاز از حساب مهمان بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2021-39807 الف-209446496 EoP بالا 10، 11، 12، 12 لیتر

اجزای هسته

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افزایش محلی امتیاز بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت مولفه
CVE-2021-0707 الف-155756045
هسته بالادست
EoP بالا dma-buf
CVE-2021-39801 الف-209791720
هسته بالادست [ 2 ] [ 3 ]
EoP بالا یون
CVE-2021-39802 الف-213339151
هسته بالادست [ 2 ] [ 3 ] [ 4 ]
EoP بالا مدیریت حافظه
CVE-2021-39800 الف-208277166
هسته بالادست [ 2 ] [ 3 ]
شناسه بالا یون

اجزای مدیاتک

این آسیب‌پذیری‌ها بر اجزای MediaTek تأثیر می‌گذارند و جزئیات بیشتر مستقیماً از MediaTek در دسترس است. ارزیابی شدت این مسائل به طور مستقیم توسط مدیاتک ارائه شده است.

CVE منابع شدت مولفه
CVE-2022-20081
الف-218242055
M-ALPS06461919 *
بالا A-GPS
CVE-2021-25477
الف-220262213
M-MOLY00684727 *
بالا مودم LTE RRC

قطعات کوالکام

این آسیب‌پذیری‌ها بر اجزای کوالکام تأثیر می‌گذارند و با جزئیات بیشتر در بولتن امنیتی یا هشدار امنیتی کوالکام توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع شدت مولفه
CVE-2021-35081
الف-213239834
QC-CR#3028274
بحرانی WLAN
CVE-2021-35112
الف-201574693
QC-CR#3049280
بحرانی نمایش دادن
CVE-2021-35123
الف-213239948
QC-CR#3032290
بحرانی بلوتوث
CVE-2021-30334
الف-213239835
QC-CR#2963049 [ 2 ]
QC-CR#3052789
بالا نمایش دادن
CVE-2021-35091
الف-204905109
QC-CR#3008877
بالا نمایش دادن
CVE-2021-35095 الف-204905206
QC-CR#2996895
بالا هسته
CVE-2021-35130
الف-213240026
QC-CR#3057133
بالا نمایش دادن

اجزای منبع بسته کوالکام

این آسیب‌پذیری‌ها بر اجزای منبع بسته کوالکام تأثیر می‌گذارند و در بولتن امنیتی یا هشدار امنیتی مناسب کوالکام با جزئیات بیشتر توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع شدت مولفه
CVE-2021-30339
A-202025975 * بحرانی جزء منبع بسته
CVE-2021-30341
A-202024969 * بحرانی جزء منبع بسته
CVE-2021-30342
A-202025860 * بحرانی جزء منبع بسته
CVE-2021-30343
A-202025978 * بحرانی جزء منبع بسته
CVE-2021-30347 A-202025598 * بحرانی جزء منبع بسته
CVE-2021-35104 A-213240044 * بحرانی جزء منبع بسته
CVE-2021-30281 A-202025858 * بالا جزء منبع بسته
CVE-2021-30338
A-202025859 * بالا جزء منبع بسته
CVE-2021-30340 A-202025736 * بالا جزء منبع بسته
CVE-2021-30344 A-192612963 * بالا جزء منبع بسته
CVE-2021-30345 A-202025737 * بالا جزء منبع بسته
CVE-2021-30346 A-202025862 * بالا جزء منبع بسته
CVE-2021-30349 A-202025797 * بالا جزء منبع بسته
CVE-2021-30350
A-202025979 * بالا جزء منبع بسته
CVE-2021-35070
A-202025864 * بالا جزء منبع بسته
CVE-2021-35100 A-213240046 * بالا جزء منبع بسته

پرسش و پاسخ متداول

این بخش به سوالات متداولی که ممکن است پس از خواندن این بولتن رخ دهد پاسخ می دهد.

1. چگونه تشخیص دهم که آیا دستگاه من برای رفع این مشکلات به روز شده است؟

برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

  • سطوح وصله امنیتی 2022-04-01 یا جدیدتر تمام مسائل مرتبط با سطح وصله امنیتی 2022-04-01 را برطرف می کند.
  • سطوح وصله امنیتی 2022-04-05 یا جدیدتر، تمام مسائل مرتبط با سطح وصله امنیتی 2022-04-05 و تمام سطوح وصله قبلی را برطرف می کند.

سازندگان دستگاه‌هایی که شامل این به‌روزرسانی‌ها می‌شوند باید سطح رشته وصله را روی موارد زیر تنظیم کنند:

  • [ro.build.version.security_patch]:[01-04-2022]
  • [ro.build.version.security_patch]:[05-04-2022]

برای برخی از دستگاه‌های اندروید 10 یا بالاتر، به‌روزرسانی سیستم Google Play دارای یک رشته تاریخی است که با سطح وصله امنیتی 01-04-2022 مطابقت دارد. لطفاً برای جزئیات بیشتر در مورد نحوه نصب به‌روزرسانی‌های امنیتی، این مقاله را ببینید.

2. چرا این بولتن دارای دو سطح وصله امنیتی است؟

این بولتن دارای دو سطح وصله امنیتی است تا شرکای Android انعطاف پذیری لازم را داشته باشند تا زیرمجموعه ای از آسیب پذیری ها را که در همه دستگاه های اندرویدی مشابه هستند با سرعت بیشتری برطرف کنند. شرکای Android تشویق می شوند تا تمام مشکلات موجود در این بولتن را برطرف کنند و از آخرین سطح وصله امنیتی استفاده کنند.

  • دستگاه‌هایی که از سطح وصله امنیتی 01-04-2022 استفاده می‌کنند باید شامل تمام مشکلات مرتبط با آن سطح وصله امنیتی، و همچنین رفع تمام مشکلات گزارش‌شده در بولتن‌های امنیتی قبلی باشند.
  • دستگاه‌هایی که از سطح وصله امنیتی 2022-04-05 یا جدیدتر استفاده می‌کنند باید همه وصله‌های قابل‌اجرا در این (و قبلی) بولتن‌های امنیتی را شامل شوند.

شرکا تشویق می شوند تا اصلاحات مربوط به همه مشکلاتی را که در حال رفع آنها هستند در یک به روز رسانی واحد جمع کنند.

3. ورودی های ستون Type به چه معناست؟

ورودی های ستون نوع جدول جزئیات آسیب پذیری به طبقه بندی آسیب پذیری امنیتی اشاره دارد.

مخفف تعریف
RCE اجرای کد از راه دور
EoP بالا بردن امتیاز
شناسه افشای اطلاعات
DoS خود داری از خدمات
N/A طبقه بندی در دسترس نیست

4. ورودی های ستون References به چه معناست؟

ورودی‌های زیر ستون مراجع جدول جزئیات آسیب‌پذیری ممکن است حاوی پیشوندی باشد که سازمانی را که مقدار مرجع به آن تعلق دارد، مشخص می‌کند.

پیشوند ارجاع
آ- شناسه باگ اندروید
QC- شماره مرجع کوالکام
M- شماره مرجع مدیاتک
N- شماره مرجع NVIDIA
ب- شماره مرجع Broadcom
U- شماره مرجع UNISOC

5. یک * در کنار شناسه باگ اندروید در ستون References به چه معناست؟

مسائلی که به صورت عمومی در دسترس نیستند دارای علامت * در کنار شناسه مرجع مربوطه هستند. به‌روزرسانی برای آن مشکل عموماً در آخرین درایورهای باینری دستگاه‌های Pixel موجود در سایت Google Developer موجود است.

6. چرا آسیب‌پذیری‌های امنیتی بین این بولتن و بولتن‌های امنیتی دستگاه/شریک، مانند بولتن Pixel تقسیم شده است؟

آسیب‌پذیری‌های امنیتی که در این بولتن امنیتی مستند شده‌اند برای اعلام آخرین سطح وصله امنیتی در دستگاه‌های اندرویدی مورد نیاز هستند. آسیب‌پذیری‌های امنیتی اضافی که در بولتن‌های امنیتی دستگاه/شریک مستند شده‌اند، برای اعلام سطح وصله امنیتی لازم نیست. سازندگان دستگاه‌ها و چیپ‌ست‌های Android نیز ممکن است جزئیات آسیب‌پذیری امنیتی خاص محصولات خود را منتشر کنند، مانند Google ، Huawei ، LGE ، Motorola ، Nokia یا Samsung .

نسخه ها

نسخه تاریخ یادداشت
1.0 4 آوریل 2022 بولتن منتشر شد
1.1 5 آوریل 2022 بولتن اصلاح شد تا شامل پیوندهای AOSP باشد
2.0 18 جولای 2022 جدول CVE اصلاح شده