עלון אבטחה של אנדרואיד—פברואר 2017

פורסם ב-06 בפברואר 2017 | עודכן ב-8 בפברואר 2017

עלון האבטחה של אנדרואיד מכיל פרטים על פרצות אבטחה המשפיעות על מכשירי אנדרואיד. לצד העלון, פרסמנו עדכון אבטחה למכשירי Google באמצעות עדכון אוויר (OTA). תמונות הקושחה של מכשיר Google שוחררו גם לאתר Google Developer . רמות תיקון האבטחה של 5 בפברואר 2017 ואילך מטפלות בכל הבעיות הללו. עיין בלוח הזמנים של עדכון Pixel ו-Nexus כדי ללמוד כיצד לבדוק את רמת תיקון האבטחה של מכשיר.

שותפים קיבלו הודעה על הבעיות המתוארות בעלון ב-3 בינואר 2017 או קודם לכן. תיקוני קוד מקור עבור בעיות אלה שוחררו למאגר Android Open Source Project (AOSP) וקישרו מעלון זה. עלון זה כולל גם קישורים לתיקונים מחוץ ל-AOSP.

החמורה ביותר מבין הבעיות הללו היא פגיעות אבטחה קריטית שעלולה לאפשר ביצוע קוד מרחוק במכשיר מושפע באמצעות מספר שיטות כגון דואר אלקטרוני, גלישה באינטרנט ו-MMS בעת עיבוד קובצי מדיה. הערכת החומרה מבוססת על ההשפעה שאולי תהיה לניצול הפגיעות על מכשיר מושפע, בהנחה שהפלטפורמה וההפחתות השירות מושבתות למטרות פיתוח או אם יעקפו בהצלחה.

לא קיבלנו דיווחים על ניצול פעיל של לקוחות או שימוש לרעה בבעיות אלה שדווחו לאחרונה. עיין בסעיף הפחתת השירותים של אנדרואיד וגוגל לפרטים על הגנות פלטפורמת האבטחה של אנדרואיד והגנות שירות כגון SafetyNet , המשפרות את האבטחה של פלטפורמת אנדרואיד.

אנו מעודדים את כל הלקוחות לקבל עדכונים אלה למכשירים שלהם.

הכרזות

  • בעלון זה כולל שתי מחרוזות ברמת תיקון אבטחה כדי לספק לשותפים של Android את הגמישות לתקן במהירות רבה יותר תת-קבוצה של פגיעויות הדומות בכל מכשירי Android. ראה שאלות ותשובות נפוצות למידע נוסף:
    • 2017-02-01 : מחרוזת רמת תיקון אבטחה חלקית. מחרוזת רמת תיקון אבטחה זו מציינת שכל הבעיות הקשורות ל-2017-02-01 (וכל מחרוזות רמת תיקון האבטחה הקודמות) מטופלות.
    • 2017-02-05 : השלם מחרוזת רמת תיקון האבטחה. מחרוזת רמת תיקון אבטחה זו מציינת שכל הבעיות הקשורות ל-2017-02-01 ו-2017-02-05 (וכל המחרוזות הקודמות ברמת תיקון האבטחה) מטופלות.
  • מכשירי Google נתמכים יקבלו עדכון OTA יחיד עם רמת תיקון האבטחה של 5 בפברואר 2017.

הפחתות שירותי אנדרואיד וגוגל

זהו סיכום של ההקלות המסופקות על ידי פלטפורמת האבטחה אנדרואיד והגנות שירות, כגון SafetyNet. יכולות אלו מפחיתות את הסבירות שניתן יהיה לנצל בהצלחה פרצות אבטחה באנדרואיד.

  • ניצול בעיות רבות באנדרואיד מקשה על ידי שיפורים בגרסאות חדשות יותר של פלטפורמת אנדרואיד. אנו ממליצים לכל המשתמשים לעדכן לגרסה העדכנית ביותר של אנדרואיד במידת האפשר.
  • צוות אבטחת אנדרואיד עוקב באופן פעיל אחר שימוש לרעה באמצעות Verify Apps ו- SafetyNet , שנועדו להזהיר משתמשים מפני יישומים שעלולים להזיק . Verify Apps מופעל כברירת מחדל במכשירים עם שירותי Google Mobile וחשוב במיוחד למשתמשים המתקינים אפליקציות מחוץ ל-Google Play. כלי השתרשות מכשירים אסורים ב-Google Play, אך Verify Apps מזהיר משתמשים כאשר הם מנסים להתקין אפליקציית השתרשות שזוהתה - לא משנה מאיפה היא מגיעה. בנוסף, Verify Apps מנסה לזהות ולחסום התקנה של יישומים זדוניים ידועים המנצלים פגיעות של הסלמה של הרשאות. אם יישום כזה כבר הותקן, Verify Apps יודיע למשתמש וינסה להסיר את היישום שזוהה.
  • בהתאם, יישומי Google Hangouts ו-Messenger אינם מעבירים מדיה אוטומטית לתהליכים כגון Mediaserver.

תודות

ברצוננו להודות לחוקרים אלו על תרומתם:

כמו כן, ברצוננו להודות לאנשים הבאים על תרומתם לעלון זה:

  • Pengfei Ding (丁鹏飞), Chenfu Bao (包沉浮), ולנקס ווי (韦韬) מ-Baidu X-Lab (百度安全实验室)

רמת תיקון האבטחה של 2017-02-01—פרטי פגיעות

בסעיפים שלהלן, אנו מספקים פרטים עבור כל אחת מפגיעות האבטחה החלות על רמת התיקון של 2017-02-01. יש תיאור של הבעיה, רציונל חומרה וטבלה עם ה-CVE, הפניות משויכות, חומרה, מכשירי Google מעודכנים, גרסאות AOSP מעודכנות (כאשר רלוונטי) ותאריך הדיווח. כאשר יהיה זמין, נקשר את השינוי הציבורי שטיפל בבעיה למזהה הבאג, כמו רשימת השינויים של AOSP. כאשר שינויים מרובים מתייחסים לבאג בודד, הפניות נוספות מקושרות למספרים בעקבות מזהה הבאג.

פגיעות של ביצוע קוד מרחוק ב-Surfaceflinger

פגיעות של ביצוע קוד מרחוק ב-Surfaceflinger עלולה לאפשר לתוקף המשתמש בקובץ בעל מבנה מיוחד לגרום לפגיעה בזיכרון במהלך עיבוד קבצי מדיה ונתונים. בעיה זו מדורגת כקריטית בשל האפשרות של ביצוע קוד מרחוק בהקשר של תהליך Surfaceflinger.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0405 A-31960359 קריטי את כל 7.0, 7.1.1 4 באוקטובר 2016

פגיעות של ביצוע קוד מרחוק ב-Mediaserver

פגיעות של ביצוע קוד מרחוק ב-Mediaserver עלולה לאפשר לתוקף המשתמש בקובץ בעל מבנה מיוחד לגרום לפגיעה בזיכרון במהלך עיבוד קבצי מדיה ונתונים. בעיה זו מדורגת כקריטית בשל האפשרות של ביצוע קוד מרחוק בהקשר של תהליך Mediaserver.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0406 A-32915871 [ 2 ] קריטי את כל 6.0, 6.0.1, 7.0, 7.1.1 14 בנובמבר 2016
CVE-2017-0407 א-32873375 קריטי את כל 6.0, 6.0.1, 7.0, 7.1.1 12 בנובמבר 2016

פגיעות של ביצוע קוד מרחוק ב-libgdx

פגיעות של ביצוע קוד מרחוק ב-libgdx עלולה לאפשר לתוקף המשתמש בקובץ בעל מבנה מיוחד להפעיל קוד שרירותי בהקשר של תהליך חסר הרשאות. בעיה זו מדורגת כגבוהה בשל האפשרות של ביצוע קוד מרחוק באפליקציה שמשתמשת בספרייה זו.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0408 A-32769670 גָבוֹהַ את כל 7.1.1 9 בנובמבר 2016

פגיעות של ביצוע קוד מרחוק ב-libstagefright

פגיעות של ביצוע קוד מרחוק ב-libstagefright עלולה לאפשר לתוקף המשתמש בקובץ בעל מבנה מיוחד להפעיל קוד שרירותי בהקשר של תהליך חסר הרשאות. בעיה זו מדורגת כגבוהה בשל האפשרות של ביצוע קוד מרחוק באפליקציה שמשתמשת בספרייה זו.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0409 A-31999646 גָבוֹהַ את כל 6.0, 6.0.1, 7.0, 7.1.1 Google פנימי

הפגיעות של העלאת הרשאות ב-Java.Net

העלאת הרשאות בספריית Java.Net עלולה לאפשר לתוכן אינטרנט זדוני להפנות משתמש לאתר אחר ללא רשות מפורשת. בעיה זו מדורגת כגבוהה מכיוון שהיא עקיפת מרחוק של דרישות האינטראקציה של המשתמשים.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2016-5552 A-31858037 גָבוֹהַ את כל 7.0, 7.1.1 30 בספטמבר 2016

הפגיעות של העלאת הרשאות בממשקי API של Framework

הפגיעות של העלאת הרשאות בממשקי ה-API של Framework עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של תהליך בעל הרשאות. בעיה זו מדורגת כגבוהה מכיוון שניתן להשתמש בה כדי לקבל גישה מקומית ליכולות מוגברות, שבדרך כלל אינן נגישות לאפליקציה של צד שלישי.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0410 A-31929765 גָבוֹהַ את כל 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2 באוקטובר 2016
CVE-2017-0411 A-33042690 [ 2 ] גָבוֹהַ את כל 7.0, 7.1.1 21 בנובמבר 2016
CVE-2017-0412 A-33039926 [ 2 ] גָבוֹהַ את כל 7.0, 7.1.1 21 בנובמבר 2016

הפגיעות של העלאת הרשאות ב-Mediaserver

הפגיעות של העלאת הרשאות ב-Mediaserver עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של תהליך מיוחס. בעיה זו מדורגת כגבוהה מכיוון שניתן להשתמש בה כדי לקבל גישה מקומית ליכולות מוגברות, שבדרך כלל אינן נגישות לאפליקציה של צד שלישי.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0415 A-32706020 גָבוֹהַ את כל 6.0, 6.0.1, 7.0, 7.1.1 4 בנובמבר 2016

הפגיעות של העלאת הרשאות ב- Audioserver

הפגיעות של העלאת הרשאות ב-Audioserver עלולה לאפשר ליישום זדוני מקומי להפעיל קוד שרירותי בהקשר של תהליך מיוחס. בעיה זו מדורגת כגבוהה מכיוון שניתן להשתמש בה כדי לקבל גישה מקומית ליכולות מוגברות, שבדרך כלל אינן נגישות לאפליקציה של צד שלישי.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0416 A-32886609 [ 2 ] גָבוֹהַ את כל 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google פנימי
CVE-2017-0417 A-32705438 גָבוֹהַ את כל 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7 בנובמבר 2016
CVE-2017-0418 A-32703959 [ 2 ] גָבוֹהַ את כל 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7 בנובמבר 2016
CVE-2017-0419 A-32220769 גָבוֹהַ את כל 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 15 באוקטובר 2016

פגיעות של חשיפת מידע ב-AOSP Mail

פגיעות של חשיפת מידע ב-AOSP Mail עלולה לאפשר לאפליקציה זדונית מקומית לעקוף הגנות של מערכת הפעלה המבודדות נתוני יישומים מיישומים אחרים. בעיה זו מדורגת כגבוהה מכיוון שניתן להשתמש בה כדי לקבל גישה לנתונים שאין לאפליקציה גישה אליהם.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0420 A-32615212 גָבוֹהַ את כל 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 12 בספטמבר 2016

פגיעות של חשיפת מידע ב-AOSP Messaging

פגיעות של חשיפת מידע ב-AOSP Messaging עלולה לאפשר לאפליקציה זדונית מקומית לעקוף הגנות של מערכת הפעלה המבודדות נתוני יישומים מיישומים אחרים. בעיה זו מדורגת כגבוהה מכיוון שניתן להשתמש בה כדי לקבל גישה לנתונים שאין לאפליקציה גישה אליהם.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0413 A-32161610 גָבוֹהַ את כל 6.0, 6.0.1, 7.0, 7.1.1 13 באוקטובר 2016
CVE-2017-0414 A-32807795 גָבוֹהַ את כל 6.0, 6.0.1, 7.0, 7.1.1 10 בנובמבר 2016

פגיעות של חשיפת מידע בממשקי API של Framework

פגיעות של חשיפת מידע בממשקי ה-API של Framework עלולה לאפשר לאפליקציה זדונית מקומית לעקוף הגנות של מערכת הפעלה המבודדות נתוני יישומים מיישומים אחרים. בעיה זו מדורגת כגבוהה מכיוון שניתן להשתמש בה כדי לקבל גישה לנתונים שאין לאפליקציה גישה אליהם.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0421 A-32555637 גָבוֹהַ את כל 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google פנימי

פגיעות מניעת שירות ב- Bionic DNS

פגיעות של מניעת שירות ב- Bionic DNS עלולה לאפשר לתוקף מרוחק להשתמש בחבילת רשת בעלת מבנה מיוחד כדי לגרום להתקן להיתקע או לאתחל מחדש. נושא זה מדורג כגבוה בשל האפשרות של מניעת שירות מרחוק.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0422 A-32322088 גָבוֹהַ את כל 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 20 באוקטובר 2016

הפגיעות של העלאת הרשאות ב-Bluetooth

פגיעות העלאת הרשאות ב-Bluetooth עלולה לאפשר לתוקף קרוב לנהל את הגישה למסמכים במכשיר. בעיה זו מדורגת כמתונה מכיוון שהיא דורשת תחילה ניצול של פגיעות נפרדת בערימת ה-Bluetooth.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0423 A-32612586 לְמַתֵן את כל 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2 בנובמבר 2016

פגיעות של חשיפת מידע ב-AOSP Messaging

פגיעות של חשיפת מידע ב-AOSP Messaging עלולה לאפשר לתוקף מרוחק המשתמש בקובץ בעל מבנה מיוחד לגשת לנתונים מחוץ לרמות ההרשאה שלו. בעיה זו מדורגת כמתונה מכיוון שהיא מהווה מעקף כללי להגנה מעמיקה ברמת המשתמש או ניצול טכנולוגיית הפחתת בתהליך מיוחס.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0424 A-32322450 לְמַתֵן את כל 6.0, 6.0.1, 7.0, 7.1.1 20 באוקטובר 2016

פגיעות של חשיפת מידע ב- Audioserver

פגיעות של חשיפת מידע ב- Audioserver עלולה לאפשר ליישום זדוני מקומי לגשת לנתונים מחוץ לרמות ההרשאה שלו. בעיה זו מדורגת כמתונה מכיוון שניתן להשתמש בה כדי לגשת לנתונים רגישים ללא רשות.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0425 A-32720785 לְמַתֵן את כל 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7 בנובמבר 2016

פגיעות של חשיפת מידע במערכת הקבצים

פגיעות של חשיפת מידע במערכת הקבצים עלולה לאפשר ליישום זדוני מקומי לגשת לנתונים מחוץ לרמות ההרשאה שלו. בעיה זו מדורגת כמתונה מכיוון שניתן להשתמש בה כדי לגשת לנתונים רגישים ללא רשות.

CVE הפניות חוּמרָה מכשירי Google מעודכנים גרסאות AOSP מעודכנות תאריך דיווח
CVE-2017-0426 A-32799236 [ 2 ] לְמַתֵן את כל 7.0, 7.1.1 Google פנימי

רמת תיקון האבטחה של 2017-02-05—פרטי פגיעות

בסעיפים שלהלן, אנו מספקים פרטים עבור כל אחת מפגיעות האבטחה החלות על רמת התיקון של 2017-02-05. יש תיאור של הבעיה, רציונל חומרה וטבלה עם ה-CVE, הפניות משויכות, חומרה, מכשירי Google מעודכנים, גרסאות AOSP מעודכנות (כאשר רלוונטי) ותאריך הדיווח. כאשר יהיה זמין, נקשר את השינוי הציבורי שטיפל בבעיה למזהה הבאג, כמו רשימת השינויים של AOSP. כאשר שינויים מרובים מתייחסים לבאג בודד, הפניות נוספות מקושרות למספרים בעקבות מזהה הבאג.

פגיעות של ביצוע קוד מרחוק בדרייבר ההצפנה של Qualcomm

פגיעות של ביצוע קוד מרחוק במנהל ההימורים של Qualcomm עלולה לאפשר לתוקף מרוחק לבצע קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כקריטית בשל האפשרות של ביצוע קוד מרחוק בהקשר של הליבה.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2016-8418 A-32652894
QC-CR#1077457
קריטי אף אחד* 10 באוקטובר 2016

* מכשירי Google נתמכים ב-Android 7.0 ואילך שהתקינו את כל העדכונים הזמינים אינם מושפעים מפגיעות זו.

הפגיעות של העלאת הרשאות במערכת קבצי הליבה

הפגיעות של העלאת הרשאות במערכת קבצי הליבה עלולה לאפשר ליישום זדוני מקומי להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כקריטית בשל האפשרות של פגיעה מקומית קבועה במכשיר, אשר עשויה לדרוש חידוש מערכת ההפעלה כדי לתקן את המכשיר.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0427 A-31495866* קריטי Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL 13 בספטמבר 2016

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

הפגיעות של העלאת הרשאות במנהל ההתקן של NVIDIA GPU

הפגיעות של העלאת הרשאות במנהל ההתקן של NVIDIA GPU עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כקריטית בשל האפשרות של פגיעה מקומית קבועה במכשיר, אשר עשויה לדרוש חידוש מערכת ההפעלה כדי לתקן את המכשיר.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0428 A-32401526*
N-CVE-2017-0428
קריטי Nexus 9 25 באוקטובר 2016
CVE-2017-0429 A-32636619*
N-CVE-2017-0429
קריטי Nexus 9 3 בנובמבר 2016

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

העלאת פגיעות הרשאות בתת-מערכת רשת ליבה

הפגיעות של העלאת הרשאות בתת-מערכת הרשת של הליבה עלולה לאפשר ליישום זדוני מקומי להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כקריטית בשל האפשרות של פגיעה מקומית קבועה במכשיר, אשר עשויה לדרוש חידוש מערכת ההפעלה כדי לתקן את המכשיר.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2014-9914 A-32882659
גרעין במעלה הזרם
קריטי Nexus 6, Nexus Player 9 בנובמבר 2016

הפגיעות של העלאת הרשאות במנהל התקן Wi-Fi של Broadcom

הפגיעות של העלאת הרשאות במנהל ההתקן של Broadcom Wi-Fi עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כקריטית בשל האפשרות של פגיעה מקומית קבועה במכשיר, אשר עשויה לדרוש חידוש מערכת ההפעלה כדי לתקן את המכשיר.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0430 A-32838767*
B-RB#107459
קריטי Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Google פנימי

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

פגיעויות ברכיבי קוואלקום

הפגיעות הבאה משפיעה על רכיבי Qualcomm ומתוארת בפירוט נוסף בעלון האבטחה של Qualcomm AMSS לספטמבר 2016.

CVE הפניות חוּמרָה* מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0431 A-32573899** קריטי אף אחד*** פנימי של קוואלקום

* דירוג החומרה של נקודות תורפה אלו נקבע על ידי הספק.

** התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

*** מכשירי Google נתמכים ב-Android 7.0 ואילך שהתקינו את כל העדכונים הזמינים אינם מושפעים מפגיעות זו.

הפגיעות של העלאת הרשאות במנהל ההתקן של MediaTek

הפגיעות של העלאת הרשאות במנהל ההתקן של MediaTek עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כגבוהה מכיוון שהיא דורשת תחילה פגיעה בתהליך מיוחס.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0432 A-28332719*
M-ALPS02708925
גָבוֹהַ אף אחד** 21 באפריל, 2016

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

** מכשירי Google נתמכים ב-Android 7.0 ואילך שהתקינו את כל העדכונים הזמינים אינם מושפעים מפגיעות זו.

הפגיעות של העלאת הרשאות במנהל ההתקן של מסך המגע של Synaptics

הפגיעות של העלאת הרשאות במנהל ההתקן של מסך המגע של Synaptics עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של ערכת השבבים של מסך המגע. בעיה זו מדורגת כגבוהה מכיוון שהיא דורשת תחילה פגיעה בתהליך מיוחס.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0433 A-31913571* גָבוֹהַ Nexus 6P, Nexus 9, Android One, Pixel, Pixel XL 8 בספטמבר 2016
CVE-2017-0434 A-33001936* גָבוֹהַ פיקסל, פיקסל XL 18 בנובמבר 2016

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

הפגיעות של העלאת הרשאות במנהל ההתקן של Qualcomm Secure Execution Environment Communicator

העלאת הרשאות פגיעות בכונן Qualcomm Secure Execution Environment Communicator עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כגבוהה מכיוון שהיא דורשת תחילה פגיעה בתהליך מיוחס.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2016-8480 A-31804432
QC-CR#1086186 [ 2 ]
גָבוֹהַ Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 28 בספטמבר 2016

הפגיעות של העלאת הרשאות במנהל התקן הסאונד של Qualcomm

הפגיעות של העלאת הרשאות במנהל התקן הסאונד של Qualcomm עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כגבוהה מכיוון שהיא דורשת תחילה פגיעה בתהליך מיוחס.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2016-8481 A-31906415*
QC-CR#1078000
גָבוֹהַ Nexus 5X, Nexus 6P, Pixel, Pixel XL 1 באוקטובר 2016
CVE-2017-0435 A-31906657*
QC-CR#1078000
גָבוֹהַ Nexus 5X, Nexus 6P, Pixel, Pixel XL 1 באוקטובר 2016
CVE-2017-0436 A-32624661*
QC-CR#1078000
גָבוֹהַ Nexus 5X, Nexus 6P, Pixel, Pixel XL 2 בנובמבר 2016

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

הפגיעות של העלאת הרשאות במנהל התקן Wi-Fi של Qualcomm

הפגיעות של העלאת הרשאות במנהל ההתקן של Qualcomm Wi-Fi עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כגבוהה מכיוון שהיא דורשת תחילה פגיעה בתהליך מיוחס.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0437 A-32402310
QC-CR#1092497
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 25 באוקטובר 2016
CVE-2017-0438 A-32402604
QC-CR#1092497
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 25 באוקטובר 2016
CVE-2017-0439 A-32450647
QC-CR#1092059
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 25 באוקטובר 2016
CVE-2016-8419 א-32454494
QC-CR#1087209
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 26 באוקטובר 2016
CVE-2016-8420 א-32451171
QC-CR#1087807
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 26 באוקטובר 2016
CVE-2016-8421 A-32451104
QC-CR#1087797
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 26 באוקטובר 2016
CVE-2017-0440 A-33252788
QC-CR#1095770
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 11 בנובמבר 2016
CVE-2017-0441 A-32872662
QC-CR#1095009
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 11 בנובמבר 2016
CVE-2017-0442 A-32871330
QC-CR#1092497
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 13 בנובמבר 2016
CVE-2017-0443 א-32877494
QC-CR#1092497
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 13 בנובמבר 2016
CVE-2016-8476 א-32879283
QC-CR#1091940
גָבוֹהַ Nexus 5X, Pixel, Pixel XL 14 בנובמבר 2016

הפגיעות של העלאת הרשאות במנהל התקן סאונד של Realtek

הפגיעות של העלאת הרשאות במנהל התקן הסאונד של Realtek עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כגבוהה מכיוון שהיא דורשת תחילה פגיעה בתהליך מיוחס.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0444 A-32705232* גָבוֹהַ Nexus 9 7 בנובמבר 2016

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

הפגיעות של העלאת הרשאות במנהל ההתקן של מסך המגע של HTC

הפגיעות של העלאת הרשאות במנהל ההתקן של מסך המגע של HTC עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כגבוהה מכיוון שהיא דורשת תחילה פגיעה בתהליך מיוחס.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0445 A-32769717* גָבוֹהַ פיקסל, פיקסל XL 9 בנובמבר 2016
CVE-2017-0446 A-32917445* גָבוֹהַ פיקסל, פיקסל XL 15 בנובמבר 2016
CVE-2017-0447 A-32919560* גָבוֹהַ פיקסל, פיקסל XL 15 בנובמבר 2016

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

פגיעות של חשיפת מידע במנהל התקן וידאו של NVIDIA

פגיעות של חשיפת מידע במנהל התקן הווידאו של NVIDIA עלולה לאפשר ליישום זדוני מקומי לגשת לנתונים מחוץ לרמות ההרשאה שלו. בעיה זו מדורגת כגבוהה מכיוון שניתן להשתמש בה כדי לגשת לנתונים רגישים ללא הרשאת משתמש מפורשת.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0448 A-32721029*
N-CVE-2017-0448
גָבוֹהַ Nexus 9 7 בנובמבר 2016

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

הפגיעות של העלאת הרשאות במנהל התקן Wi-Fi של Broadcom

הפגיעות של העלאת הרשאות במנהל ההתקן של Broadcom Wi-Fi עלולה לאפשר לאפליקציה זדונית מקומית להפעיל קוד שרירותי בהקשר של הליבה. בעיה זו מדורגת כמתונה מכיוון שהיא מצריכה תחילה פגיעה בתהליך מיוחס וממתינה על ידי תצורות הפלטפורמה הנוכחיות.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0449 A-31707909*
B-RB#32094
לְמַתֵן Nexus 6, Nexus 6P 23 בספטמבר 2016

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

הפגיעות של העלאת הרשאות ב- Audioserver

הפגיעות של העלאת הרשאות ב-Audioserver עלולה לאפשר ליישום זדוני מקומי להפעיל קוד שרירותי בהקשר של תהליך מיוחס. בעיה זו מדורגת כמתונה מכיוון שהיא מתמתן על ידי תצורות הפלטפורמה הנוכחיות.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0450 A-32917432* לְמַתֵן Nexus 9 15 בנובמבר 2016

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

הפגיעות של העלאת הרשאות במערכת קבצי הליבה

הפגיעות של העלאת הרשאות במערכת קבצי הליבה עלולה לאפשר ליישום זדוני מקומי לעקוף הגנות המונעות הסלמה של הרשאות. בעיה זו מדורגת כמתונה מכיוון שהיא מעקף כללי להגנה מעמיקה ברמת המשתמש או לניצול טכנולוגיית הפחתת.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2016-10044 A-31711619* לְמַתֵן Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Google פנימי

* התיקון לבעיה זו אינו זמין לציבור. העדכון כלול במנהלי ההתקן הבינאריים העדכניים ביותר עבור מכשירי Nexus הזמינים מאתר Google Developer .

פגיעות של חשיפת מידע ב-Qualcomm Secure Execution Environment Communicator

פגיעות של חשיפת מידע ב-Qualcomm Secure Execution Environment Communicator עלולה לאפשר ליישום זדוני מקומי לגשת לנתונים מחוץ לרמות ההרשאה שלו. בעיה זו מדורגת כמתונה מכיוון שהיא דורשת תחילה פגיעה בתהליך מיוחס.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2016-8414 א-31704078
QC-CR#1076407
לְמַתֵן Nexus 5X, Nexus 6P, Android One, Pixel, Pixel XL 23 בספטמבר 2016

פגיעות של חשיפת מידע במנהל התקן הסאונד של Qualcomm

פגיעות של חשיפת מידע במנהל התקן הסאונד של Qualcomm עלולה לאפשר לאפליקציה זדונית מקומית לגשת לנתונים מחוץ לרמות ההרשאה שלו. בעיה זו מדורגת כמתונה מכיוון שהיא דורשת תחילה פגיעה בתהליך מיוחס.

CVE הפניות חוּמרָה מכשירי Google מעודכנים תאריך דיווח
CVE-2017-0451 א-31796345
QC-CR#1073129 [ 2 ]
לְמַתֵן Nexus 5X, Nexus 6P, Android One, Pixel, Pixel XL 27 בספטמבר 2016

שאלות ותשובות נפוצות

סעיף זה עונה על שאלות נפוצות שעלולות להתרחש לאחר קריאת עלון זה.

1. כיצד אוכל לקבוע אם המכשיר שלי מעודכן כדי לטפל בבעיות אלו?

כדי ללמוד כיצד לבדוק את רמת תיקון האבטחה של מכשיר, קרא את ההוראות בלוח הזמנים של עדכוני Pixel ו-Nexus .

  • רמות תיקון האבטחה של 2017-02-01 ואילך מטפלות בכל הבעיות הקשורות לרמת תיקון האבטחה של 2017-02-01.
  • רמות תיקון האבטחה של 2017-02-05 ואילך מטפלות בכל הבעיות הקשורות לרמת תיקון האבטחה של 2017-02-05 ולכל רמות התיקון הקודמות.

יצרני מכשירים הכוללים עדכונים אלה צריכים להגדיר את רמת מחרוזת התיקון ל:

  • [ro.build.version.security_patch]:[2017-02-01]
  • [ro.build.version.security_patch]:[2017-02-05]

2. מדוע לעליון זה יש שתי רמות תיקון אבטחה?

לעלון זה יש שתי רמות תיקון אבטחה כך שלשותפי אנדרואיד יש את הגמישות לתקן קבוצת משנה של נקודות תורפה הדומות בכל מכשירי Android במהירות רבה יותר. שותפי Android מוזמנים לתקן את כל הבעיות בעלון זה ולהשתמש ברמת תיקון האבטחה העדכנית ביותר.

  • מכשירים המשתמשים ברמת תיקון האבטחה של 1 בפברואר 2017 חייבים לכלול את כל הבעיות הקשורות לרמת תיקון האבטחה הזו, כמו גם תיקונים עבור כל הבעיות שדווחו בעלוני אבטחה קודמים.
  • מכשירים המשתמשים ברמת תיקון האבטחה של 5 בפברואר 2017 ואילך חייבים לכלול את כל התיקונים הרלוונטיים בעלוני אבטחה זה (וקודמים).

שותפים מוזמנים לאגד את התיקונים עבור כל הבעיות בהן הם מטפלים בעדכון יחיד.

3. כיצד אוכל לקבוע אילו מכשירי Google מושפעים מכל בעיה?

In the 2017-02-01 and 2017-02-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • February 06, 2017: Bulletin published.
  • February 08, 2017: Bulletin revised to include AOSP links.