بولتن امنیتی اندروید - سپتامبر 2020

منتشر شده در 08 سپتامبر 2020 | به روز شده در 10 سپتامبر 2020

بولتن امنیتی اندروید حاوی جزئیاتی از آسیب پذیری های امنیتی است که بر دستگاه های اندرویدی تأثیر می گذارد. سطوح وصله امنیتی 2020-09-05 یا بالاتر، همه این مشکلات را برطرف می کند. برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

شرکای Android حداقل یک ماه قبل از انتشار از همه مشکلات مطلع می شوند. وصله کد منبع برای این مشکلات در مخزن پروژه منبع باز Android (AOSP) منتشر شده و از این بولتن پیوند داده شده است. این بولتن همچنین شامل پیوندهایی به وصله های خارج از AOSP است.

شدیدترین این مشکلات یک آسیب پذیری امنیتی حیاتی در مؤلفه Media Framework است که می تواند یک مهاجم راه دور را با استفاده از یک فایل ساخته شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند. ارزیابی شدت بر اساس تأثیری است که بهره‌برداری از آسیب‌پذیری احتمالاً روی دستگاه آسیب‌دیده می‌گذارد، با این فرض که پلت‌فرم و تخفیف‌های سرویس برای اهداف توسعه خاموش شده‌اند یا در صورت دور زدن موفقیت‌آمیز انجام شوند.

برای جزئیات بیشتر در مورد حفاظت های پلتفرم امنیتی اندروید و Google Play Protect که امنیت پلتفرم اندروید را بهبود می بخشد، به بخش کاهش دهنده های Android و Google Play Protect مراجعه کنید.

کاهش خدمات اندروید و گوگل

این خلاصه‌ای از کاهش‌های ارائه شده توسط پلتفرم امنیتی Android و محافظت‌های خدماتی مانند Google Play Protect است. این قابلیت ها احتمال سوء استفاده موفقیت آمیز از آسیب پذیری های امنیتی در اندروید را کاهش می دهد.

  • بهره برداری از بسیاری از مسائل در اندروید با پیشرفت در نسخه های جدیدتر پلتفرم اندروید دشوارتر شده است. ما همه کاربران را تشویق می کنیم تا در صورت امکان به آخرین نسخه اندروید بروزرسانی کنند.
  • تیم امنیتی Android به طور فعال از طریق Google Play Protect برای سوء استفاده نظارت می کند و به کاربران در مورد برنامه های بالقوه مضر هشدار می دهد. Google Play Protect به طور پیش‌فرض در دستگاه‌های دارای سرویس‌های Google Mobile فعال است و به ویژه برای کاربرانی که برنامه‌هایی را از خارج از Google Play نصب می‌کنند، مهم است.

جزئیات آسیب پذیری سطح وصله امنیتی 01/09/2020

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی که در سطح وصله ۲۰۲۰-۰۹-۰۱ اعمال می‌شوند، ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. شرحی از مشکل و جدولی با CVE، مراجع مرتبط، نوع آسیب‌پذیری ، شدت و نسخه‌های به‌روزرسانی‌شده AOSP (در صورت لزوم) وجود دارد. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است به شناسه اشکال مرتبط می کنیم، مانند لیست تغییرات AOSP. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند.

چارچوب

شدیدترین آسیب پذیری در این بخش می تواند یک برنامه مخرب محلی را قادر سازد تا الزامات تعامل کاربر را برای دسترسی به مجوزهای اضافی دور بزند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2020-0074 A-146204120 [ 2 ] EoP بالا 8.0، 8.1، 9، 10
CVE-2020-0388
الف-156123285 EoP بالا 10
CVE-2020-0391
الف-158570769 EoP بالا 9، 10
CVE-2020-0401
الف-150857253 EoP بالا 8.0، 8.1، 9، 10
CVE-2020-0382
A-152944488 [ 2 ] شناسه بالا 10
CVE-2020-0389
الف-156959408 شناسه بالا 10
CVE-2020-0390
الف-157598026 شناسه بالا 10
CVE-2020-0395
A-154124307 [ 2 ] شناسه بالا 8.0، 8.1، 9، 10
CVE-2020-0397
A-155092443 [ 2 ] شناسه بالا 8.0، 8.1، 9، 10
CVE-2020-0399
A-153993591 [ 2 ] [ 3 ] شناسه بالا 8.0، 8.1، 9، 10

چارچوب رسانه ای

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم از راه دور را با استفاده از یک فایل ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2020-0245
الف-152496149 شناسه بالا 10
RCE بحرانی 8.0، 8.1، 9
CVE-2020-0392
الف-150226608 EoP بالا 9، 10
CVE-2020-0381
الف-150159669 شناسه بالا 8.0، 8.1، 9، 10
CVE-2020-0383
الف-150160279 شناسه بالا 8.0، 8.1، 9، 10
CVE-2020-0384
الف-150159906 شناسه بالا 8.0، 8.1، 9، 10
CVE-2020-0385
الف-150160041 شناسه بالا 8.0، 8.1، 9، 10
CVE-2020-0393
الف-154123412 شناسه بالا 9، 10

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم از راه دور را با استفاده از یک انتقال ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2020-0380
الف-146398979 RCE بحرانی 8.0، 8.1، 9، 10
CVE-2020-0396
A-155094269 [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] [ 7 ] [ 8 ] [ 9 ] شناسه بحرانی 8.0، 8.1، 9، 10
CVE-2020-0386
الف-155650356 EoP بالا 8.0، 8.1، 9، 10
CVE-2020-0394
الف-155648639 EoP بالا 8.0، 8.1، 9، 10
CVE-2020-0379
الف-150156492 شناسه بالا 8.0، 8.1، 9، 10

به روز رسانی سیستم گوگل پلی

مسائل زیر در اجزای Project Mainline گنجانده شده است.

مولفه CVE
کدک های رسانه ای CVE-2020-0245
اجزای چارچوب رسانه CVE-2020-0383

جزئیات آسیب پذیری سطح وصله امنیتی 05/09/2020

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی که در سطح وصله ۲۰۲۰-۰۹-۰۵ اعمال می‌شوند، ارائه می‌کنیم. آسیب‌پذیری‌ها تحت مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند و شامل جزئیاتی مانند CVE، مراجع مرتبط، نوع آسیب‌پذیری ، شدت ، مؤلفه (در صورت لزوم) و نسخه‌های به‌روزشده AOSP (در صورت لزوم) می‌شوند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است به شناسه اشکال مرتبط می کنیم، مانند لیست تغییرات AOSP. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعدادی که پس از شناسه اشکال مرتبط هستند، مرتبط می شوند.

هسته

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم محلی را با استفاده از یک فایل ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت مولفه
CVE-2019-19769
الف-150693748
هسته بالادست [ 2 ]
EoP بالا زیر سیستم ذخیره سازی
CVE-2020-0404
الف-111893654
هسته بالادست
EoP بالا درایور USB
CVE-2020-0407
A-153450752 * شناسه بالا F2FS

اجزای مدیاتک

این آسیب‌پذیری‌ها بر اجزای MediaTek تأثیر می‌گذارند و جزئیات بیشتر مستقیماً از MediaTek در دسترس است. ارزیابی شدت این مسائل به طور مستقیم توسط مدیاتک ارائه شده است.

CVE منابع شدت مولفه
CVE-2020-0123
الف-149871374
DTV02098055 *
بالا درایور صدای اندروید تی وی
CVE-2020-0229
الف-156333725
ALPS05023182 *
بالا mdla
CVE-2020-0278
الف-160812574
ALPS05132252 *
بالا ATF
CVE-2020-0342
الف-160812576
ALPS05132765 *
بالا ATF

قطعات کوالکام

این آسیب‌پذیری‌ها بر اجزای کوالکام تأثیر می‌گذارند و با جزئیات بیشتر در بولتن امنیتی یا هشدار امنیتی کوالکام توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع شدت مولفه
CVE-2019-10527
الف-147102899
QC-CR#2421611
QC-CR#2421602 [ 2 ]
QC-CR#2419153 *
بالا هسته
CVE-2019-14117
الف-147104886
QC-CR#2525999
بالا هسته
CVE-2020-3613
الف-148816706
QC-CR#2239987
بالا هسته
CVE-2020-3656
الف-157905780
QC-CR#2580967
بالا هسته
CVE-2020-11124
الف-157906588
QC-CR#2611487
بالا هسته

اجزای منبع بسته کوالکام

این آسیب‌پذیری‌ها بر اجزای منبع بسته کوالکام تأثیر می‌گذارند و در بولتن امنیتی یا هشدار امنیتی مناسب کوالکام با جزئیات بیشتر توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه شده است.

CVE منابع شدت مولفه
CVE-2019-10628
A-147102780 * بحرانی جزء منبع بسته
CVE-2019-10629
A-147101658 * بحرانی جزء منبع بسته
CVE-2019-13994
A-147104051 * بحرانی جزء منبع بسته
CVE-2020-3621
A-148816726 * بحرانی جزء منبع بسته
CVE-2020-3634
A-150695049 * بحرانی جزء منبع بسته
CVE-2019-10596
A-147104369 * بالا جزء منبع بسته
CVE-2019-13992
A-147102898 * بالا جزء منبع بسته
CVE-2019-13995
A-147104253 * بالا جزء منبع بسته
CVE-2019-14074
الف-145546792 * بالا جزء منبع بسته
CVE-2020-3617
A-150697774 * بالا جزء منبع بسته
CVE-2020-3620
A-148817068 * بالا جزء منبع بسته
CVE-2020-3622
A-148817285 * بالا جزء منبع بسته
CVE-2020-3629
A-148816991 * بالا جزء منبع بسته
CVE-2020-3671
A-148529608 * بالا جزء منبع بسته
CVE-2020-11129
A-157905420 * بالا جزء منبع بسته
CVE-2020-11133
A-157905987 * بالا جزء منبع بسته
CVE-2020-11135
A-157906313 * بالا جزء منبع بسته

پرسش و پاسخ متداول

این بخش به سوالات متداولی که ممکن است پس از خواندن این بولتن رخ دهد پاسخ می دهد.

1. چگونه تشخیص دهم که آیا دستگاه من برای رفع این مشکلات به روز شده است؟

برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

  • سطوح وصله امنیتی 2020-09-01 یا جدیدتر تمام مسائل مرتبط با سطح وصله امنیتی 2020-09-01 را برطرف می کند.
  • سطوح وصله امنیتی 2020-09-05 یا بعد از آن، تمام مسائل مرتبط با سطح وصله امنیتی 05-09-2020 و تمام سطوح وصله قبلی را برطرف می کند.

سازندگان دستگاه‌هایی که شامل این به‌روزرسانی‌ها می‌شوند باید سطح رشته وصله را روی موارد زیر تنظیم کنند:

  • [ro.build.version.security_patch]:[01-09-2020]
  • [ro.build.version.security_patch]:[05-09-2020]

برای برخی از دستگاه‌های اندروید 10 یا بالاتر، به‌روزرسانی سیستم Google Play دارای یک رشته تاریخی است که با سطح وصله امنیتی 01-09-2020 مطابقت دارد. لطفاً برای جزئیات بیشتر در مورد نحوه نصب به‌روزرسانی‌های امنیتی، این مقاله را ببینید.

2. چرا این بولتن دارای دو سطح وصله امنیتی است؟

این بولتن دارای دو سطح وصله امنیتی است تا شرکای Android انعطاف پذیری لازم را داشته باشند تا زیرمجموعه ای از آسیب پذیری ها را که در همه دستگاه های اندرویدی مشابه هستند با سرعت بیشتری برطرف کنند. شرکای Android تشویق می شوند تا تمام مشکلات موجود در این بولتن را برطرف کنند و از آخرین سطح وصله امنیتی استفاده کنند.

  • دستگاه‌هایی که از سطح وصله امنیتی 01-09-2020 استفاده می‌کنند باید شامل تمام مشکلات مرتبط با آن سطح وصله امنیتی و همچنین رفع تمام مشکلات گزارش‌شده در بولتن‌های امنیتی قبلی باشند.
  • دستگاه‌هایی که از سطح وصله امنیتی 2020-09-05 یا جدیدتر استفاده می‌کنند، باید همه وصله‌های قابل‌اجرا در این (و قبلی) بولتن‌های امنیتی را شامل شوند.

شرکا تشویق می شوند تا اصلاحات مربوط به همه مشکلاتی را که در حال رفع آنها هستند در یک به روز رسانی واحد جمع کنند.

3. ورودی های ستون Type به چه معناست؟

ورودی های ستون نوع جدول جزئیات آسیب پذیری به طبقه بندی آسیب پذیری امنیتی اشاره دارد.

مخفف تعریف
RCE اجرای کد از راه دور
EoP بالا بردن امتیاز
شناسه افشای اطلاعات
DoS خود داری از خدمات
N/A طبقه بندی در دسترس نیست

4. ورودی های ستون References به چه معناست؟

ورودی‌های زیر ستون مراجع جدول جزئیات آسیب‌پذیری ممکن است حاوی پیشوندی باشد که سازمانی را که مقدار مرجع به آن تعلق دارد، مشخص می‌کند.

پیشوند ارجاع
آ- شناسه باگ اندروید
QC- شماره مرجع کوالکام
M- شماره مرجع مدیاتک
N- شماره مرجع NVIDIA
ب- شماره مرجع Broadcom

5. یک * در کنار شناسه باگ اندروید در ستون References به چه معناست؟

مسائلی که به صورت عمومی در دسترس نیستند دارای یک * در کنار شناسه اشکال Android در ستون References هستند. به‌روزرسانی برای آن مشکل عموماً در آخرین درایورهای باینری دستگاه‌های Pixel موجود در سایت Google Developer موجود است.

6. چرا آسیب‌پذیری‌های امنیتی بین این بولتن و بولتن‌های امنیتی دستگاه/شریک، مانند بولتن Pixel تقسیم می‌شوند؟

آسیب‌پذیری‌های امنیتی که در این بولتن امنیتی مستند شده‌اند برای اعلام آخرین سطح وصله امنیتی در دستگاه‌های اندرویدی مورد نیاز هستند. آسیب‌پذیری‌های امنیتی اضافی که در بولتن‌های امنیتی دستگاه/شریک مستند شده‌اند، برای اعلام سطح وصله امنیتی لازم نیست. سازندگان دستگاه‌ها و چیپ‌ست‌های Android نیز ممکن است جزئیات آسیب‌پذیری امنیتی خاص محصولات خود را منتشر کنند، مانند Google ، Huawei ، LGE ، Motorola ، Nokia یا Samsung .

نسخه ها

نسخه تاریخ یادداشت
1.0 08 سپتامبر 2020 بولتن منتشر شد
1.1 10 سپتامبر 2020 بولتن اصلاح شد تا شامل پیوندهای AOSP باشد