Bollettino sulla sicurezza Android: giugno 2016

Pubblicato il 06 giugno 2016 | Aggiornato l'8 giugno 2016

L'Android Security Bulletin contiene i dettagli delle vulnerabilità di sicurezza che interessano i dispositivi Android. Oltre al bollettino, abbiamo rilasciato un aggiornamento di sicurezza per i dispositivi Nexus tramite un aggiornamento over-the-air (OTA). Le immagini del firmware Nexus sono state rilasciate anche al sito degli sviluppatori di Google . I livelli di patch di sicurezza del 1 giugno 2016 o successivi risolvono questi problemi. Fare riferimento alla documentazione di Nexus per informazioni su come controllare il livello di patch di sicurezza.

I partner sono stati informati dei problemi descritti nel bollettino il 2 maggio 2016 o prima. Ove applicabile, le patch del codice sorgente per questi problemi sono state rilasciate nel repository Android Open Source Project (AOSP).

Il problema più grave è una vulnerabilità di sicurezza critica che potrebbe consentire l'esecuzione di codice in modalità remota su un dispositivo interessato tramite più metodi come e-mail, navigazione Web e MMS durante l'elaborazione di file multimediali. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, supponendo che la piattaforma e le attenuazioni del servizio siano disabilitate per scopi di sviluppo o se bypassate correttamente.

Non abbiamo avuto segnalazioni di sfruttamento attivo da parte dei clienti o abuso di questi problemi appena segnalati. Fare riferimento alla sezione Mitigazioni dei servizi Android e Google per i dettagli sulle protezioni della piattaforma di sicurezza Android e sulle protezioni dei servizi come SafetyNet, che migliorano la sicurezza della piattaforma Android.

Invitiamo tutti i clienti ad accettare questi aggiornamenti sui propri dispositivi.

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle attenuazioni fornite dalla piattaforma di sicurezza Android e dalle protezioni del servizio, come SafetyNet. Queste funzionalità riducono la probabilità che le vulnerabilità della sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento per molti problemi su Android è reso più difficile dai miglioramenti nelle versioni più recenti della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android, ove possibile.
  • Il team di sicurezza di Android monitora attivamente gli abusi con Verify Apps e SafetyNet , progettati per avvisare gli utenti di applicazioni potenzialmente dannose . Verifica app è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano applicazioni al di fuori di Google Play. Gli strumenti di rooting dei dispositivi sono vietati all'interno di Google Play, ma Verifica app avvisa gli utenti quando tentano di installare un'applicazione di rooting rilevata, indipendentemente da dove provenga. Inoltre, Verifica app tenta di identificare e bloccare l'installazione di applicazioni dannose note che sfruttano una vulnerabilità di escalation dei privilegi. Se tale applicazione è già stata installata, Verifica app avviserà l'utente e tenterà di rimuovere l'applicazione rilevata.
  • A seconda dei casi, le applicazioni Google Hangouts e Messenger non passano automaticamente i file multimediali a processi come Mediaserver.

Ringraziamenti

Vorremmo ringraziare questi ricercatori per il loro contributo:

  • Di Shen ( @returnsme ) di KeenLab ( @keen_lab ), Tencent: CVE-2016-2468
  • Gal Beniamini ( @laginimaineb ): CVE-2016-2476
  • Gengjia Chen ( @chengjia4574 ), pjf ( weibo.com/jfpan ) di IceSword Lab, Qihoo 360 Technology Co. Ltd.: CVE-2016-2492
  • Hao Chen, Guang Gong e Wenlin Yang di Mobile Safe Team, Qihoo 360 Technology Co. Ltd.: CVE-2016-2470, CVE-2016-2471, CVE-2016-2472, CVE-2016-2473, CVE-2016- 2498
  • Iwo Banas : CVE-2016-2496
  • Jianqiang Zhao( @jianqiangzhao ) e pjf ( weibo.com/jfpan ) di IceSword Lab, Qihoo 360 Technology Co. Ltd.: CVE-2016-2490, CVE-2016-2491
  • Lee Campbell di Google: CVE-2016-2500
  • Maciej Szawłowski del team di sicurezza di Google: CVE-2016-2474
  • Marco Nelissen e Max Spector di Google: CVE-2016-2487
  • Contrassegna il marchio di Google Project Zero: CVE-2016-2494
  • Mingjian Zhou ( @Mingjian_Zhou ), Chiachih Wu ( @chiachih_wu ) e Xuxian Jiang del C0RE Team : CVE-2016-2477, CVE-2016-2478, CVE-2016-2479, CVE-2016-2480, CVE-2016-2481 , CVE-2016-2482, CVE-2016-2483, CVE-2016-2484, CVE-2016-2485, CVE-2016-2486
  • Scott Bauer ( @ScottyBauer1 ): CVE-2016-2066, CVE-2016-2061, CVE-2016-2465, CVE-2016-2469, CVE-2016-2489
  • Vasily Vasilev: CVE-2016-2463
  • Weichao Sun ( @sunblate ) di Alibaba Inc.: CVE-2016-2495
  • Xiling Gong del dipartimento della piattaforma di sicurezza Tencent: CVE-2016-2499
  • Zach Riggle ( @ebeip90 ) dell'Android Security Team: CVE-2016-2493

Dettagli vulnerabilità di sicurezza

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2016-06-01. C'è una descrizione del problema, una logica di gravità e una tabella con il CVE, il bug Android associato, la gravità, i dispositivi Nexus aggiornati, le versioni AOSP aggiornate (ove applicabile) e la data segnalata. Quando disponibile, collegheremo la modifica AOSP che ha risolto il problema all'ID del bug. Quando più modifiche si riferiscono a un singolo bug, ulteriori riferimenti AOSP sono collegati a numeri che seguono l'ID del bug.

Vulnerabilità nell'esecuzione di codice in remoto in Mediaserver

Una vulnerabilità legata all'esecuzione di codice in modalità remota in Mediaserver potrebbe consentire a un utente malintenzionato che utilizza un file appositamente predisposto di causare il danneggiamento della memoria durante l'elaborazione di file multimediali e dati. Questo problema è considerato Critico a causa della possibilità di esecuzione di codice in modalità remota nel contesto del processo Mediaserver. Il processo Mediaserver ha accesso a flussi audio e video, nonché accesso a privilegi a cui normalmente le app di terze parti non potrebbero accedere.

La funzionalità interessata è fornita come parte fondamentale del sistema operativo e sono disponibili più applicazioni che consentono di raggiungerla con contenuti remoti, in particolare MMS e riproduzione di file multimediali tramite browser.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2463 27855419 Critico Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 25 marzo 2016

Vulnerabilità nell'esecuzione di codice in remoto in libwebm

Le vulnerabilità legate all'esecuzione di codice in modalità remota con libwebm possono consentire a un utente malintenzionato che utilizza un file appositamente predisposto di causare il danneggiamento della memoria durante l'elaborazione di file multimediali e dati. Questo problema è considerato Critico a causa della possibilità di esecuzione di codice in modalità remota nel contesto del processo Mediaserver. Il processo Mediaserver ha accesso a flussi audio e video, nonché accesso a privilegi a cui normalmente le app di terze parti non potrebbero accedere.

La funzionalità interessata è fornita come parte fondamentale del sistema operativo e sono disponibili più applicazioni che consentono di raggiungerla con contenuti remoti, in particolare MMS e riproduzione di file multimediali tramite browser.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2464 23167726 [ 2 ] Critico Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Aumento della vulnerabilità dei privilegi nel driver video Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver video Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di una compromissione permanente del dispositivo locale, che potrebbe richiedere il reflash del sistema operativo per riparare il dispositivo.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2465 27407865* Critico Nesso 5, Nesso 5X, Nesso 6, Nesso 6P 21 febbraio 2016

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi nel driver audio Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver audio Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di una compromissione permanente del dispositivo locale, che potrebbe richiedere il reflash del sistema operativo per riparare il dispositivo.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2466 27947307* Critico Nesso 6 27 febbraio 2016
CVE-2016-2467 28029010* Critico Nexus 5 13 marzo 2014

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi nel driver GPU Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver della GPU Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di una compromissione permanente del dispositivo locale, che potrebbe richiedere il reflash del sistema operativo per riparare il dispositivo.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2468 27475454* Critico Nesso 5, Nesso 5X, Nesso 6, Nesso 6P, Nesso 7 2 marzo 2016
CVE-2016-2062 27364029* Critico Nexus 5X, Nexus 6P 6 marzo 2016

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi nel driver Wi-Fi di Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver Wi-Fi Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di una compromissione permanente del dispositivo locale, che potrebbe richiedere il reflash del sistema operativo per riparare il dispositivo.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2474 27424603* Critico Nesso 5X Google interno

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi nel driver Wi-Fi Broadcom

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver Wi-Fi Broadcom potrebbe consentire a un'applicazione dannosa locale di richiamare chiamate di sistema modificando le impostazioni e il comportamento del dispositivo senza i privilegi per farlo. Questo problema è classificato come Alto perché potrebbe essere utilizzato per ottenere l'accesso locale a capacità elevate.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2475 26425765* Alto Nexus 5, Nexus 6, Nexus 6P, Nexus 7 (2013), Nexus 9, Nexus Player, Pixel C 6 gennaio 2016

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi nel driver audio Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver audio Qualcomm potrebbe consentire a un'applicazione dannosa di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un servizio in grado di chiamare il conducente.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2066 26876409* Alto Nesso 5, Nesso 5X, Nesso 6, Nesso 6P 29 gennaio 2016
CVE-2016-2469 27531992* Alto Nesso 5, Nesso 6, Nesso 6P 4 marzo 2016

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi in Mediaserver

Una vulnerabilità legata all'acquisizione di privilegi più elevati in Mediaserver potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un'applicazione di sistema con privilegi elevati. Questo problema è classificato come Alto perché potrebbe essere utilizzato per ottenere l'accesso locale a funzionalità elevate, come i privilegi di autorizzazione Firma o Firma o Sistema, che non sono accessibili a un'applicazione di terze parti.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2476 27207275 [ 2 ] [ 3 ] [ 4 ] Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 11 febbraio 2016
CVE-2016-2477 27251096 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 17 febbraio 2016
CVE-2016-2478 27475409 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 3 marzo 2016
CVE-2016-2479 27532282 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 6 marzo 2016
CVE-2016-2480 27532721 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 6 marzo 2016
CVE-2016-2481 27532497 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 6 marzo 2016
CVE-2016-2482 27661749 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 14 marzo 2016
CVE-2016-2483 27662502 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 14 marzo 2016
CVE-2016-2484 27793163 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 22 marzo 2016
CVE-2016-2485 27793367 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 22 marzo 2016
CVE-2016-2486 27793371 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 22 marzo 2016
CVE-2016-2487 27833616 [ 2 ] [ 3 ] Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Aumento della vulnerabilità dei privilegi nel driver della fotocamera Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver della fotocamera Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un servizio in grado di chiamare il conducente.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2061 27207747* Alto Nexus 5X, Nexus 6P 15 febbraio 2016
CVE-2016-2488 27600832* Alto Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013) Google interno

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi nel driver video Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver video Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un servizio in grado di chiamare il conducente.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2489 27407629* Alto Nesso 5, Nesso 5X, Nesso 6, Nesso 6P 21 febbraio 2016

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi nel driver della fotocamera NVIDIA

Una vulnerabilità legata all'acquisizione di privilegi elevati nel driver della fotocamera NVIDIA potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un servizio per chiamare il conducente.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2490 27533373* Alto Nesso 9 6 marzo 2016
CVE-2016-2491 27556408* Alto Nesso 9 8 marzo 2016

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi nel driver Wi-Fi di Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver Wi-Fi Qualcomm potrebbe consentire a un'applicazione dannosa di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un servizio in grado di chiamare il conducente.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2470 27662174* Alto Nesso 7 (2013) 13 marzo 2016
CVE-2016-2471 27773913* Alto Nesso 7 (2013) 19 marzo 2016
CVE-2016-2472 27776888* Alto Nesso 7 (2013) 20 marzo 2016
CVE-2016-2473 27777501* Alto Nesso 7 (2013) 20 marzo 2016

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi nel driver di gestione dell'alimentazione MediaTek

Un'elevazione dei privilegi nel driver di gestione dell'alimentazione MediaTek potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede prima la compromissione del dispositivo e un'elevazione al root per chiamare il driver.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2492 28085410* Alto Android Uno 7 aprile 2016

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Aumento della vulnerabilità dei privilegi nel livello di emulazione della scheda SD

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel livello di emulazione dello spazio utente della scheda SD potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un'applicazione di sistema con privilegi elevati. Questo problema è classificato come Alto perché potrebbe essere utilizzato per ottenere l'accesso locale a funzionalità elevate, come i privilegi di autorizzazione Firma o Firma o Sistema, che non sono accessibili a un'applicazione di terze parti.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2494 28085658 Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 7 aprile 2016

Aumento della vulnerabilità dei privilegi nel driver Wi-Fi Broadcom

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver Wi-Fi Broadcom potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come Alto perché richiede innanzitutto la compromissione di un servizio per chiamare il conducente.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2493 26571522* Alto Nexus 5, Nexus 6, Nexus 6P, Nexus 7 (2013), Nexus Player, Pixel C Google interno

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Vulnerabilità Remote Denial of Service in Mediaserver

Una vulnerabilità di tipo Denial of Service in remoto in Mediaserver potrebbe consentire a un utente malintenzionato di utilizzare un file appositamente predisposto per causare il blocco o il riavvio di un dispositivo. Questo problema è classificato come Alto a causa della possibilità di negazione del servizio in remoto.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2495 28076789 [ 2 ] Alto Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 6 aprile 2016

Elevazione della vulnerabilità dei privilegi nell'interfaccia utente di Framework

Una vulnerabilità relativa all'acquisizione di privilegi più elevati nella finestra di dialogo dell'autorizzazione dell'interfaccia utente di Framework potrebbe consentire a un utente malintenzionato di accedere a file non autorizzati nell'archiviazione privata. Questo problema è classificato come moderato perché potrebbe essere utilizzato per ottenere autorizzazioni " pericolose " in modo improprio.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2496 26677796 [ 2 ] [ 3 ] Moderare Tutto Nexus 6.0, 6.1 26 maggio 2015

Vulnerabilità di divulgazione di informazioni nel driver Wi-Fi di Qualcomm

Una divulgazione di informazioni nel driver Wi-Fi Qualcomm potrebbe consentire a un'applicazione dannosa locale di accedere a dati al di fuori dei suoi livelli di autorizzazione. Questo problema è classificato come Moderato perché richiede innanzitutto la compromissione di un servizio in grado di chiamare il conducente.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2498 27777162* Moderare Nesso 7 (2013) 20 marzo 2016

* La patch per questo problema non è in AOSP. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito Google Developer .

Vulnerabilità di divulgazione di informazioni in Mediaserver

Una vulnerabilità di divulgazione di informazioni in Mediaserver potrebbe consentire a un'applicazione di accedere a informazioni riservate. Questo problema è classificato come moderato perché potrebbe essere utilizzato per accedere ai dati senza autorizzazione.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2499 27855172 Moderare Tutto Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 24 marzo 2016

Vulnerabilità di divulgazione di informazioni in Activity Manager

Una vulnerabilità di divulgazione di informazioni nel componente Activity Manager potrebbe consentire a un'applicazione di accedere a informazioni riservate. Questo problema è classificato come moderato perché potrebbe essere utilizzato per accedere ai dati senza autorizzazione.

CVE Bug Android Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2500 19285814 Moderare Tutto Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che possono verificarsi dopo la lettura di questo bollettino.

1. Come faccio a determinare se il mio dispositivo è aggiornato per risolvere questi problemi?

I livelli di patch di sicurezza del 1 giugno 2016 o successivi risolvono questi problemi (fare riferimento alla documentazione di Nexus per istruzioni su come controllare il livello di patch di sicurezza). I produttori di dispositivi che includono questi aggiornamenti devono impostare il livello della stringa di patch su: [ro.build.version.security_patch]:[2016-06-01]

2. Come faccio a determinare quali dispositivi Nexus sono interessati da ciascun problema?

Nella sezione Dettagli vulnerabilità di sicurezza , ogni tabella ha una colonna Dispositivi Nexus aggiornati che copre la gamma di dispositivi Nexus interessati aggiornati per ogni problema. Questa colonna ha alcune opzioni:

  • Tutti i dispositivi Nexus : se un problema riguarda tutti i dispositivi Nexus, la tabella conterrà "Tutti i Nexus" nella colonna dei dispositivi Nexus aggiornati . "All Nexus" racchiude i seguenti dispositivi supportati : Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013), Nexus 9, Android One, Nexus Player e Pixel C.
  • Alcuni dispositivi Nexus : se un problema non riguarda tutti i dispositivi Nexus, i dispositivi Nexus interessati vengono elencati nella colonna Dispositivi Nexus aggiornati .
  • Nessun dispositivo Nexus : se nessun dispositivo Nexus è interessato dal problema, la tabella riporterà "Nessuno" nella colonna Dispositivi Nexus aggiornati .

Revisioni

  • 06 giugno 2016: pubblicato il bollettino.
  • 07 giugno 2016:
    • Bollettino rivisto per includere i collegamenti AOSP.
    • CVE-2016-2496 rimosso dal bollettino.
  • 08 giugno 2016: CVE-2016-2496 aggiunto di nuovo al bollettino.