Google se compromete a impulsar la igualdad racial para las comunidades afrodescendientes. Obtén información al respecto.

Boletín de seguridad de Android: febrero de 2017,Boletín de seguridad de Android: febrero de 2017

Publicado 06 de febrero de 2017 | Actualizado el 8 de febrero de 2017

El Boletín de seguridad de Android contiene detalles de las vulnerabilidades de seguridad que afectan a los dispositivos Android. Junto con el boletín, lanzamos una actualización de seguridad para los dispositivos de Google a través de una actualización inalámbrica (OTA). Las imágenes del firmware del dispositivo de Google también se publicaron en el sitio para desarrolladores de Google . Los niveles de parches de seguridad del 5 de febrero de 2017 o posteriores abordan todos estos problemas. Consulte el programa de actualización de Pixel y Nexus para obtener información sobre cómo verificar el nivel del parche de seguridad de un dispositivo.

Los socios fueron notificados de los problemas descritos en el boletín el 03 de enero de 2017 o antes. Los parches de código fuente para estos problemas se publicaron en el repositorio del Proyecto de código abierto de Android (AOSP) y se vincularon desde este boletín. Este boletín también incluye enlaces a parches fuera de AOSP.

El más grave de estos problemas es una vulnerabilidad de seguridad crítica que podría permitir la ejecución remota de código en un dispositivo afectado a través de múltiples métodos, como correo electrónico, navegación web y MMS al procesar archivos multimedia. La evaluación de la gravedad se basa en el efecto que podría tener la explotación de la vulnerabilidad en un dispositivo afectado, suponiendo que las mitigaciones de la plataforma y el servicio estén deshabilitadas para fines de desarrollo o si se eluden con éxito.

No hemos recibido informes de explotación activa de clientes o abuso de estos problemas recientemente informados. Consulte la sección Mitigaciones de servicios de Android y Google para obtener detalles sobre las protecciones de la plataforma de seguridad de Android y las protecciones de servicios como SafetyNet , que mejoran la seguridad de la plataforma Android.

Alentamos a todos los clientes a aceptar estas actualizaciones en sus dispositivos.

Anuncios

  • Este boletín tiene dos cadenas de nivel de parche de seguridad para brindar a los socios de Android la flexibilidad de solucionar más rápidamente un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android. Consulte Preguntas y respuestas comunes para obtener información adicional:
    • 2017-02-01 : cadena de nivel de parche de seguridad parcial. Esta cadena de nivel de parche de seguridad indica que se abordaron todos los problemas asociados con 2017-02-01 (y todas las cadenas de nivel de parche de seguridad anteriores).
    • 2017-02-05 : cadena de nivel de parche de seguridad completa. Esta cadena de nivel de parche de seguridad indica que se abordaron todos los problemas asociados con 2017-02-01 y 2017-02-05 (y todas las cadenas de nivel de parche de seguridad anteriores).
  • Los dispositivos de Google compatibles recibirán una única actualización OTA con el nivel de parche de seguridad del 5 de febrero de 2017.

Mitigaciones de servicios de Android y Google

Este es un resumen de las mitigaciones proporcionadas por la plataforma de seguridad de Android y las protecciones de servicios, como SafetyNet. Estas capacidades reducen la probabilidad de que las vulnerabilidades de seguridad puedan explotarse con éxito en Android.

  • La explotación de muchos problemas en Android se hace más difícil debido a las mejoras en las versiones más recientes de la plataforma Android. Alentamos a todos los usuarios a actualizar a la última versión de Android siempre que sea posible.
  • El equipo de seguridad de Android monitorea activamente el abuso con Verify Apps y SafetyNet , que están diseñados para advertir a los usuarios sobre aplicaciones potencialmente dañinas . Verificar aplicaciones está habilitado de forma predeterminada en dispositivos con Google Mobile Services y es especialmente importante para los usuarios que instalan aplicaciones desde fuera de Google Play. Las herramientas de enraizamiento de dispositivos están prohibidas en Google Play, pero Verify Apps advierte a los usuarios cuando intentan instalar una aplicación de enraizamiento detectada, sin importar de dónde provenga. Además, Verify Apps intenta identificar y bloquear la instalación de aplicaciones maliciosas conocidas que explotan una vulnerabilidad de escalada de privilegios. Si ya se instaló una aplicación de este tipo, Verify Apps notificará al usuario e intentará eliminar la aplicación detectada.
  • Según corresponda, las aplicaciones Google Hangouts y Messenger no pasan automáticamente los medios a procesos como Mediaserver.

Agradecimientos

Nos gustaría agradecer a estos investigadores por sus contribuciones:

También nos gustaría agradecer a las siguientes personas por sus contribuciones a este boletín:

  • Pengfei Ding (丁鹏飞), Chenfu Bao (包沉浮) y Lenx Wei (韦韬) de Baidu X-Lab (百度安全实验室)

Nivel de parche de seguridad 2017-02-01: detalles de vulnerabilidad

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2017-02-01. Hay una descripción del problema, una justificación de la gravedad y una tabla con el CVE, las referencias asociadas, la gravedad, los dispositivos de Google actualizados, las versiones actualizadas de AOSP (cuando corresponda) y la fecha en que se informó. Cuando esté disponible, vincularemos el cambio público que abordó el problema con el ID del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

Vulnerabilidad de ejecución remota de código en Surfaceflinger

Una vulnerabilidad de ejecución remota de código en Surfaceflinger podría permitir que un atacante use un archivo especialmente diseñado para causar daños en la memoria durante el procesamiento de datos y archivos multimedia. Este problema se clasifica como Crítico debido a la posibilidad de ejecución remota de código en el contexto del proceso de Surfaceflinger.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0405 A-31960359 Crítico Todos 7.0, 7.1.1 4 de octubre de 2016

Vulnerabilidad de ejecución remota de código en Mediaserver

Una vulnerabilidad de ejecución remota de código en Mediaserver podría permitir que un atacante use un archivo especialmente diseñado para causar daños en la memoria durante el procesamiento de datos y archivos multimedia. Este problema se clasifica como Crítico debido a la posibilidad de ejecución remota de código en el contexto del proceso Mediaserver.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0406 A-32915871 [ 2 ] Crítico Todos 6.0, 6.0.1, 7.0, 7.1.1 14 de noviembre de 2016
CVE-2017-0407 A-32873375 Crítico Todos 6.0, 6.0.1, 7.0, 7.1.1 12 de noviembre de 2016

Vulnerabilidad de ejecución remota de código en libgdx

Una vulnerabilidad de ejecución remota de código en libgdx podría permitir que un atacante utilice un archivo especialmente diseñado para ejecutar código arbitrario en el contexto de un proceso sin privilegios. Este problema se califica como alto debido a la posibilidad de ejecución remota de código en una aplicación que usa esta biblioteca.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0408 A-32769670 Alto Todos 7.1.1 9 de noviembre de 2016

Vulnerabilidad de ejecución remota de código en libstagefright

Una vulnerabilidad de ejecución remota de código en libstagefright podría permitir que un atacante utilice un archivo especialmente diseñado para ejecutar código arbitrario en el contexto de un proceso sin privilegios. Este problema se califica como alto debido a la posibilidad de ejecución remota de código en una aplicación que usa esta biblioteca.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0409 A-31999646 Alto Todos 6.0, 6.0.1, 7.0, 7.1.1 interno de Google

Vulnerabilidad de elevación de privilegios en Java.Net

Una elevación de privilegios en la biblioteca Java.Net podría permitir que el contenido web malicioso redirija a un usuario a otro sitio web sin permiso explícito. Este problema se califica como alto porque es una omisión remota de los requisitos de interacción del usuario.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2016-5552 A-31858037 Alto Todos 7.0, 7.1.1 30 de septiembre de 2016

Vulnerabilidad de elevación de privilegios en las API de Framework

Una vulnerabilidad de elevación de privilegios en las API de Framework podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de un proceso privilegiado. Este problema se califica como Alto porque podría usarse para obtener acceso local a capacidades elevadas, que normalmente no son accesibles para una aplicación de terceros.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0410 A-31929765 Alto Todos 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2 de octubre de 2016
CVE-2017-0411 A-33042690 [ 2 ] Alto Todos 7.0, 7.1.1 21 de noviembre de 2016
CVE-2017-0412 A-33039926 [ 2 ] Alto Todos 7.0, 7.1.1 21 de noviembre de 2016

Vulnerabilidad de elevación de privilegios en Mediaserver

Una vulnerabilidad de elevación de privilegios en Mediaserver podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de un proceso privilegiado. Este problema se califica como Alto porque podría usarse para obtener acceso local a capacidades elevadas, que normalmente no son accesibles para una aplicación de terceros.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0415 A-32706020 Alto Todos 6.0, 6.0.1, 7.0, 7.1.1 4 de noviembre de 2016

Vulnerabilidad de elevación de privilegios en Audioserver

Una vulnerabilidad de elevación de privilegios en Audioserver podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de un proceso privilegiado. Este problema se califica como Alto porque podría usarse para obtener acceso local a capacidades elevadas, que normalmente no son accesibles para una aplicación de terceros.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0416 A-32886609 [ 2 ] Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 interno de Google
CVE-2017-0417 A-32705438 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7 de noviembre de 2016
CVE-2017-0418 A-32703959 [ 2 ] Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7 de noviembre de 2016
CVE-2017-0419 A-32220769 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 15 de octubre de 2016

Vulnerabilidad de divulgación de información en AOSP Mail

Una vulnerabilidad de divulgación de información en AOSP Mail podría permitir que una aplicación maliciosa local eluda las protecciones del sistema operativo que aíslan los datos de la aplicación de otras aplicaciones. Este problema se califica como Alto porque podría usarse para obtener acceso a datos a los que la aplicación no tiene acceso.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0420 A-32615212 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 12 de septiembre de 2016

Vulnerabilidad de divulgación de información en AOSP Messaging

Una vulnerabilidad de divulgación de información en AOSP Messaging podría permitir que una aplicación maliciosa local eluda las protecciones del sistema operativo que aíslan los datos de la aplicación de otras aplicaciones. Este problema se califica como Alto porque podría usarse para obtener acceso a datos a los que la aplicación no tiene acceso.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0413 A-32161610 Alto Todos 6.0, 6.0.1, 7.0, 7.1.1 13 de octubre de 2016
CVE-2017-0414 A-32807795 Alto Todos 6.0, 6.0.1, 7.0, 7.1.1 10 de noviembre de 2016

Vulnerabilidad de divulgación de información en las API de Framework

Una vulnerabilidad de divulgación de información en las API de Framework podría permitir que una aplicación maliciosa local eluda las protecciones del sistema operativo que aíslan los datos de la aplicación de otras aplicaciones. Este problema se califica como Alto porque podría usarse para obtener acceso a datos a los que la aplicación no tiene acceso.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0421 A-32555637 Alto Todos 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 interno de Google

Vulnerabilidad de denegación de servicio en Bionic DNS

Una vulnerabilidad de denegación de servicio en Bionic DNS podría permitir que un atacante remoto use un paquete de red especialmente diseñado para provocar que un dispositivo se cuelgue o se reinicie. Este problema está clasificado como Alto debido a la posibilidad de denegación de servicio remota.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0422 A-32322088 Alto Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 20 de octubre de 2016

Vulnerabilidad de elevación de privilegios en Bluetooth

Una vulnerabilidad de elevación de privilegios en Bluetooth podría permitir que un atacante cercano administre el acceso a los documentos en el dispositivo. Este problema se clasifica como moderado porque primero requiere la explotación de una vulnerabilidad separada en la pila de Bluetooth.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0423 A-32612586 Moderado Todos 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2 de noviembre de 2016

Vulnerabilidad de divulgación de información en AOSP Messaging

Una vulnerabilidad de divulgación de información en AOSP Messaging podría permitir que un atacante remoto use un archivo especialmente diseñado para acceder a datos fuera de sus niveles de permiso. Este problema se clasifica como Moderado porque es una omisión general para una defensa a nivel de usuario en profundidad o tecnología de mitigación de explotación en un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0424 A-32322450 Moderado Todos 6.0, 6.0.1, 7.0, 7.1.1 20 de octubre de 2016

Vulnerabilidad de divulgación de información en Audioserver

Una vulnerabilidad de divulgación de información en Audioserver podría permitir que una aplicación maliciosa local acceda a datos fuera de sus niveles de permiso. Este problema se clasifica como Moderado porque podría usarse para acceder a datos confidenciales sin permiso.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0425 A-32720785 Moderado Todos 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7 de noviembre de 2016

Vulnerabilidad de divulgación de información en el sistema de archivos

Una vulnerabilidad de divulgación de información en el sistema de archivos podría permitir que una aplicación local maliciosa acceda a datos fuera de sus niveles de permiso. Este problema se clasifica como Moderado porque podría usarse para acceder a datos confidenciales sin permiso.

CVE Referencias Gravedad Dispositivos de Google actualizados Versiones actualizadas de AOSP Fecha reportada
CVE-2017-0426 A-32799236 [ 2 ] Moderado Todos 7.0, 7.1.1 interno de Google

Nivel de parche de seguridad 2017-02-05: detalles de vulnerabilidad

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2017-02-05. Hay una descripción del problema, una justificación de la gravedad y una tabla con el CVE, las referencias asociadas, la gravedad, los dispositivos de Google actualizados, las versiones actualizadas de AOSP (cuando corresponda) y la fecha en que se informó. Cuando esté disponible, vincularemos el cambio público que abordó el problema con el ID del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

Vulnerabilidad de ejecución remota de código en el controlador criptográfico de Qualcomm

Una vulnerabilidad de ejecución remota de código en el controlador criptográfico de Qualcomm podría permitir que un atacante remoto ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de ejecución remota de código en el contexto del kernel.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8418 A-32652894
QC-CR#1077457
Crítico Ninguna* 10 de octubre de 2016

* Los dispositivos de Google compatibles con Android 7.0 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el sistema de archivos del kernel

Una vulnerabilidad de elevación de privilegios en el sistema de archivos del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0427 A-31495866* Crítico Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Píxel C, Nexus Player, Píxel, Píxel XL 13 de septiembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador de GPU NVIDIA

Una vulnerabilidad de elevación de privilegios en el controlador NVIDIA GPU podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0428 A-32401526*
N-CVE-2017-0428
Crítico nexo 9 25 de octubre de 2016
CVE-2017-0429 A-32636619*
N-CVE-2017-0429
Crítico nexo 9 3 de noviembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el subsistema de red del kernel

Una vulnerabilidad de elevación de privilegios en el subsistema de red del kernel podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2014-9914 A-32882659
Núcleo ascendente
Crítico Nexus 6, Nexus Player 9 de noviembre de 2016

Vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Broadcom

Una vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Broadcom podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como Crítico debido a la posibilidad de un compromiso local permanente del dispositivo, lo que puede requerir volver a actualizar el sistema operativo para reparar el dispositivo.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0430 A-32838767*
B-RB#107459
Crítico Nexus 6, Nexus 6P, Nexus 9, Píxel C, Nexus Player interno de Google

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidades en los componentes de Qualcomm

La siguiente vulnerabilidad afecta a los componentes de Qualcomm y se describe con más detalle en el boletín de seguridad de Qualcomm AMSS de septiembre de 2016.

CVE Referencias Gravedad* Dispositivos de Google actualizados Fecha reportada
CVE-2017-0431 A-32573899** Crítico Ninguna*** Qualcomm interno

* El proveedor determinó la clasificación de gravedad de estas vulnerabilidades.

** El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

*** Los dispositivos de Google compatibles con Android 7.0 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador MediaTek

Una vulnerabilidad de elevación de privilegios en el controlador MediaTek podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0432 A-28332719*
M-ALPS02708925
Alto Ninguna** 21 de abril de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

** Los dispositivos de Google compatibles con Android 7.0 o posterior que hayan instalado todas las actualizaciones disponibles no se ven afectados por esta vulnerabilidad.

Vulnerabilidad de elevación de privilegios en el controlador de pantalla táctil Synaptics

Una vulnerabilidad de elevación de privilegios en el controlador de pantalla táctil de Synaptics podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del conjunto de chips de pantalla táctil. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0433 A-31913571* Alto Nexus 6P, Nexus 9, Android One, Píxel, Píxel XL 8 de septiembre de 2016
CVE-2017-0434 A-33001936* Alto Píxel, Píxel XL 18 de noviembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador Qualcomm Secure Execution Environment Communicator

Una vulnerabilidad de elevación de privilegios en la unidad Qualcomm Secure Execution Environment Communicator podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8480 A-31804432
QC-CR#1086186 [ 2 ]
Alto Nexus 5X, Nexus 6, Nexus 6P, Android One, Píxel, Píxel XL 28 de septiembre de 2016

Vulnerabilidad de elevación de privilegios en el controlador de sonido de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador de sonido de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8481 A-31906415*
QC-CR#1078000
Alto Nexus 5X, Nexus 6P, Píxel, Píxel XL 1 de octubre de 2016
CVE-2017-0435 A-31906657*
QC-CR#1078000
Alto Nexus 5X, Nexus 6P, Píxel, Píxel XL 1 de octubre de 2016
CVE-2017-0436 A-32624661*
QC-CR#1078000
Alto Nexus 5X, Nexus 6P, Píxel, Píxel XL 2 de noviembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Qualcomm

Una vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Qualcomm podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0437 A-32402310
QC-CR#1092497
Alto Nexus 5X, píxel, píxel XL 25 de octubre de 2016
CVE-2017-0438 A-32402604
QC-CR#1092497
Alto Nexus 5X, píxel, píxel XL 25 de octubre de 2016
CVE-2017-0439 A-32450647
QC-CR#1092059
Alto Nexus 5X, píxel, píxel XL 25 de octubre de 2016
CVE-2016-8419 A-32454494
QC-CR#1087209
Alto Nexus 5X, píxel, píxel XL 26 de octubre de 2016
CVE-2016-8420 A-32451171
QC-CR#1087807
Alto Nexus 5X, píxel, píxel XL 26 de octubre de 2016
CVE-2016-8421 A-32451104
QC-CR#1087797
Alto Nexus 5X, píxel, píxel XL 26 de octubre de 2016
CVE-2017-0440 A-33252788
QC-CR#1095770
Alto Nexus 5X, píxel, píxel XL 11 de noviembre de 2016
CVE-2017-0441 A-32872662
QC-CR#1095009
Alto Nexus 5X, píxel, píxel XL 11 de noviembre de 2016
CVE-2017-0442 A-32871330
QC-CR#1092497
Alto Nexus 5X, píxel, píxel XL 13 de noviembre de 2016
CVE-2017-0443 A-32877494
QC-CR#1092497
Alto Nexus 5X, píxel, píxel XL 13 de noviembre de 2016
CVE-2016-8476 A-32879283
QC-CR#1091940
Alto Nexus 5X, píxel, píxel XL 14 de noviembre de 2016

Vulnerabilidad de elevación de privilegios en el controlador de sonido Realtek

Una vulnerabilidad de elevación de privilegios en el controlador de sonido Realtek podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0444 A-32705232* Alto nexo 9 7 de noviembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador de pantalla táctil de HTC

Una vulnerabilidad de elevación de privilegios en el controlador de pantalla táctil de HTC podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Alto porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0445 A-32769717* Alto Píxel, Píxel XL 9 de noviembre de 2016
CVE-2017-0446 A-32917445* Alto Píxel, Píxel XL 15 de noviembre de 2016
CVE-2017-0447 A-32919560* Alto Píxel, Píxel XL 15 de noviembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de divulgación de información en el controlador de video NVIDIA

Una vulnerabilidad de divulgación de información en el controlador de video NVIDIA podría permitir que una aplicación maliciosa local acceda a datos fuera de sus niveles de permiso. Este problema se califica como alto porque podría usarse para acceder a datos confidenciales sin el permiso explícito del usuario.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0448 A-32721029*
N-CVE-2017-0448
Alto nexo 9 7 de noviembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Broadcom

Una vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Broadcom podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se califica como Moderado porque primero requiere comprometer un proceso privilegiado y se mitiga con las configuraciones actuales de la plataforma.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0449 A-31707909*
B-RB#32094
Moderado Nexo 6, Nexo 6P 23 de septiembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en Audioserver

Una vulnerabilidad de elevación de privilegios en Audioserver podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de un proceso privilegiado. Este problema se califica como Moderado porque se mitiga con las configuraciones actuales de la plataforma.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0450 A-32917432* Moderado nexo 9 15 de noviembre de 2016

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el sistema de archivos del kernel

Una vulnerabilidad de elevación de privilegios en el sistema de archivos del kernel podría permitir que una aplicación local malintencionada eluda las protecciones que evitan una escalada de privilegios. Este problema se clasifica como Moderado porque es una omisión general para una defensa a nivel de usuario en profundidad o una tecnología de mitigación de vulnerabilidades.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-10044 A-31711619* Moderado Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Píxel C, Nexus Player, Píxel, Píxel XL interno de Google

* El parche para este problema no está disponible públicamente. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de divulgación de información en Qualcomm Secure Execution Environment Communicator

Una vulnerabilidad de divulgación de información en Qualcomm Secure Execution Environment Communicator podría permitir que una aplicación local maliciosa acceda a datos fuera de sus niveles de permiso. Este problema se clasifica como Moderado porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2016-8414 A-31704078
QC-CR#1076407
Moderado Nexus 5X, Nexus 6P, Android One, Píxel, Píxel XL 23 de septiembre de 2016

Vulnerabilidad de divulgación de información en el controlador de sonido de Qualcomm

Una vulnerabilidad de divulgación de información en el controlador de sonido de Qualcomm podría permitir que una aplicación local maliciosa acceda a datos fuera de sus niveles de permiso. Este problema se clasifica como Moderado porque primero requiere comprometer un proceso privilegiado.

CVE Referencias Gravedad Dispositivos de Google actualizados Fecha reportada
CVE-2017-0451 A-31796345
QC-CR#1073129 [ 2 ]
Moderado Nexus 5X, Nexus 6P, Android One, Píxel, Píxel XL 27 de septiembre de 2016

Preguntas y respuestas comunes

Esta sección responde preguntas comunes que pueden surgir después de leer este boletín.

1. ¿Cómo puedo determinar si mi dispositivo está actualizado para solucionar estos problemas?

Para obtener información sobre cómo verificar el nivel del parche de seguridad de un dispositivo, lea las instrucciones en el programa de actualización de Pixel y Nexus .

  • Los niveles de parche de seguridad de 2017-02-01 o posteriores abordan todos los problemas asociados con el nivel de parche de seguridad de 2017-02-01.
  • Los niveles de parches de seguridad de 2017-02-05 o posteriores abordan todos los problemas asociados con el nivel de parches de seguridad 2017-02-05 y todos los niveles de parches anteriores.

Los fabricantes de dispositivos que incluyen estas actualizaciones deben establecer el nivel de la cadena de parches en:

  • [ro.build.version.security_patch]:[2017-02-01]
  • [ro.build.version.security_patch]:[2017-02-05]

2. ¿Por qué este boletín tiene dos niveles de parches de seguridad?

Este boletín tiene dos niveles de parches de seguridad para que los socios de Android tengan la flexibilidad de corregir un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android con mayor rapidez. Se recomienda a los socios de Android que solucionen todos los problemas de este boletín y utilicen el nivel de parche de seguridad más reciente.

  • Los dispositivos que utilizan el nivel de parche de seguridad del 1 de febrero de 2017 deben incluir todos los problemas asociados con ese nivel de parche de seguridad, así como soluciones para todos los problemas informados en boletines de seguridad anteriores.
  • Los dispositivos que utilizan el nivel de parche de seguridad del 5 de febrero de 2017 o posterior deben incluir todos los parches aplicables en este (y en los anteriores) boletines de seguridad.

Se alienta a los socios a agrupar las soluciones para todos los problemas que están solucionando en una sola actualización.

3. ¿Cómo determino qué dispositivos de Google se ven afectados por cada problema?

En las secciones de detalles de vulnerabilidad de seguridad 2017-02-01 y 2017-02-05 , cada tabla tiene una columna de Dispositivos de Google actualizados que cubre el rango de dispositivos de Google afectados actualizados para cada problema. Esta columna tiene algunas opciones:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefijo Referencia
A- ID de error de Android
QC- Número de referencia de Qualcomm
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • February 06, 2017: Bulletin published.
  • February 08, 2017: Bulletin revised to include AOSP links.