Android 安全公告 - 2019 年 4 月

发布时间:2019 年 4 月 1 日 | 更新时间:2019 年 4 月 3 日

Android 安全公告详细介绍了会影响 Android 设备的安全漏洞。安全补丁程序级别为 2019-04-05 或更新的 Android 系统都已解决本公告中所述的所有问题。要了解如何查看设备的安全补丁程序级别,请参阅查看并更新 Android 版本

Android 合作伙伴在本公告发布前至少一个月就已收到关于所有问题的通知。我们已将针对这些问题的源代码补丁程序发布到 Android 开源项目 (AOSP) 代码库中,并在本公告中提供了相应链接。本公告中还提供了指向 AOSP 之外的补丁程序的链接。

这些问题中危险性最高的是媒体框架中的一个严重程度为“严重”的安全漏洞,该漏洞可让远程攻击者利用蓄意创建的文件在特权进程环境中执行任意代码。严重程度评估的依据是漏洞被利用后可能会对受影响的设备造成的影响(假设相关平台和服务缓解措施被成功规避或出于开发目的而被停用)。

尚未有人向我们举报过有用户主动利用或滥用这些新报告的问题。请参阅 Android 和 Google Play 保护机制提供的缓解措施部分,详细了解有助于提高 Android 平台安全性的 Android 安全平台防护功能和 Google Play 保护机制。

注意:如需了解适用于 Google 设备的最新无线下载更新 (OTA) 和固件映像,请参阅 2019 年 4 月的 Pixel 更新公告

Android 和 Google 服务缓解措施

这一部分总结了 Android 安全平台和服务防护功能(如 Google Play 保护机制)提供的缓解措施。这些功能有助于降低 Android 上的安全漏洞被成功利用的可能性。

  • 较高版本的 Android 平台中提供的增强功能让攻击者更加难以利用 Android 上存在的许多问题。我们建议所有用户都尽可能更新到最新版 Android。
  • Android 安全团队会积极利用 Google Play 保护机制监控滥用行为,并会在发现潜在有害应用时向用户发出警告。在安装有 Google 移动服务的设备上,Google Play 保护机制会默认处于启用状态,对于从 Google Play 以外的来源安装应用的用户来说,该功能尤为重要。

2019-04-01 安全补丁程序级别漏洞详情

我们在下面提供了 2019-04-01 补丁程序级别涵盖的每个安全漏洞的详细信息。漏洞列在所影响的组件下,内容包括问题描述和一个表,该表中包含 CVE、相关参考编号、漏洞类型严重程度和已更新的 AOSP 版本(若有)。如果有解决相应问题的公开更改记录(例如 AOSP 代码更改列表),我们会将 Bug ID 链接到该记录。如果某个 Bug 有多条相关的代码更改记录,我们还会通过 Bug ID 后面的数字链接到更多参考编号。

框架

这一部分中的漏洞可让本地攻击者绕过用户互动来获取额外的权限。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2019-2026 A-120866126* EoP 8.0

媒体框架

这一部分中最严重的漏洞可让远程攻击者利用蓄意创建的文件在特权进程环境中执行任意代码。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2019-2027 A-119120561 RCE 严重 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2019-2028 A-120644655 RCE 严重 7.0、7.1.1、7.1.2、8.0、8.1、9

系统

这一部分中最严重的漏洞可让本地恶意应用在特权进程环境中执行任意代码。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2019-2030 A-119496789 EoP 9
CVE-2019-2031 A-120502559 EoP 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2019-2033 A-121327565 [2] EoP 9
CVE-2019-2034 A-122035770 EoP 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2019-2035 A-122320256 EoP 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2019-2038 A-121259048 ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2019-2039 A-121260197 ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2019-2040 A-122316913 ID 9

2019-04-05 安全补丁程序级别漏洞详情

我们在下面提供了 2019-04-05 补丁程序级别涵盖的每个安全漏洞的详细信息。漏洞列在所影响的组件下,内容包括 CVE、相关参考编号、漏洞类型严重程度、组件(若有)和已更新的 AOSP 版本(若有)等详细信息。如果有解决相应问题的公开更改记录(例如 AOSP 代码更改列表),我们会将 Bug ID 链接到该记录。如果某个 Bug 有多条相关的代码更改记录,我们还会通过 Bug ID 后面的数字链接到更多参考编号。

系统

这一部分中最严重的漏洞可让远程攻击者利用蓄意创建的文件通过特权进程执行任意代码。

CVE 参考编号 类型 严重程度 已更新的 AOSP 版本
CVE-2019-2029 A-120612744 RCE 严重 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2019-2032 A-121145627 EoP 8.0、8.1、9
CVE-2019-2041 A-122034690 [2] [3] EoP 8.1、9
CVE-2019-2037 A-119870451 ID 7.0、7.1.1、7.1.2、8.0、8.1、9

Qualcomm 组件

以下漏洞会影响 Qualcomm 组件,相应的 Qualcomm 安全公告或安全提醒中对这些漏洞进行了详细说明。大多数修复程序都可以在 2018 年发布的 Qualcomm 安全公告中找到。这些漏洞的严重程度评估是由 Qualcomm 直接提供的。

CVE 参考编号 类型 严重程度 组件
CVE-2018-11940 A-79377832
QC-CR#2254946
N/A 严重 WLAN 主机
CVE-2017-17772 A-72957385
QC-CR#2153003 [2]
N/A WLAN 主机
CVE-2018-11294 A-109741680
QC-CR#2197481
N/A WLAN 主机
CVE-2018-5855 A-77527719
QC-CR#2193421
N/A WLAN 主机
CVE-2018-11299 A-109741946
QC-CR#2186953
N/A WLAN 主机
CVE-2018-11826 A-111127853
QC-CR#2205957
N/A WLAN 主机
CVE-2018-11827 A-111128575
QC-CR#2206569
N/A WLAN 主机
CVE-2018-11840 A-111126050
QC-CR#2215443
N/A WLAN 主机
CVE-2018-11851 A-111125792
QC-CR#2221902
N/A WLAN 主机
CVE-2018-11860 A-111128301
QC-CR#2225113
N/A WLAN 主机
CVE-2018-11868 A-111128420
QC-CR#2227248
N/A WLAN 主机
CVE-2018-11869 A-111128838
QC-CR#2227263
N/A WLAN 主机
CVE-2018-11878 A-111128797
QC-CR#2228608
N/A WLAN 主机
CVE-2018-11889 A-111128421
QC-CR#2230998
N/A WLAN 主机
CVE-2018-11891 A-111128578
QC-CR#2231767
N/A WLAN 主机
CVE-2018-11894 A-111127989
QC-CR#2232358
N/A WLAN 主机
CVE-2018-11895 A-111128877
QC-CR#2232542
N/A WLAN 主机
CVE-2018-11897 A-111128841
QC-CR#2233033
N/A WLAN 主机
CVE-2018-11902 A-111126532
QC-CR#2225604
N/A WLAN 主机
CVE-2018-11904 A-111125111
QC-CR#2215446
N/A WLAN 主机
CVE-2018-11905 A-112277221
QC-CR#2146878
N/A WLAN 主机
CVE-2018-11923 A-112276863
QC-CR#2224443
N/A WLAN 主机
CVE-2018-11924 A-112278150
QC-CR#2224451
N/A WLAN 主机
CVE-2018-11925 A-112277910
QC-CR#2226375 [2]
N/A WLAN 主机
CVE-2018-11927 A-112277186
QC-CR#2227076
N/A WLAN 主机
CVE-2018-11930 A-112278861
QC-CR#2231770
N/A WLAN 主机
CVE-2018-11937 A-112277891
QC-CR#2245944
N/A WLAN 主机
CVE-2018-11949 A-112278405
QC-CR#2249815
N/A WLAN 主机
CVE-2018-11953 A-112277852
QC-CR#2235576
N/A WLAN 主机
CVE-2018-13920 A-120487136*
QC-CR#2293841
N/A 内核

Qualcomm 闭源组件

以下漏洞会影响 Qualcomm 组件,相应的 Qualcomm 安全公告或安全提醒中对这些漏洞进行了详细说明。这些漏洞的严重程度评估是由 Qualcomm 直接提供的。

CVE 参考编号 类型 严重程度 组件
CVE-2018-11271 A-120487384* N/A 严重 闭源组件
CVE-2018-11976 A-117119000* N/A 严重 闭源组件
CVE-2018-12004 A-117118976* N/A 严重 闭源组件
CVE-2018-13886 A-117118295* N/A 严重 闭源组件
CVE-2018-13887 A-117119172* N/A 严重 闭源组件
CVE-2019-2250 A-122473270* N/A 严重 闭源组件
CVE-2018-11291 A-109678120* N/A 闭源组件
CVE-2018-11821 A-111093019* N/A 闭源组件
CVE-2018-11822 A-111092813* N/A 闭源组件
CVE-2018-11828 A-111089816* N/A 闭源组件
CVE-2018-11849 A-111092945* N/A 闭源组件
CVE-2018-11850 A-111092919* N/A 闭源组件
CVE-2018-11853 A-111091938* N/A 闭源组件
CVE-2018-11854 A-111093762* N/A 闭源组件
CVE-2018-11856 A-111093242* N/A 闭源组件
CVE-2018-11859 A-111090373* N/A 闭源组件
CVE-2018-11861 A-111092814* N/A 闭源组件
CVE-2018-11862 A-111093763* N/A 闭源组件
CVE-2018-11867 A-111093243* N/A 闭源组件
CVE-2018-11870 A-111089817* N/A 闭源组件
CVE-2018-11871 A-111092400* N/A 闭源组件
CVE-2018-11872 A-111090534* N/A 闭源组件
CVE-2018-11873 A-111091378* N/A 闭源组件
CVE-2018-11874 A-111092946* N/A 闭源组件
CVE-2018-11875 A-111093022* N/A 闭源组件
CVE-2018-11876 A-111093244* N/A 闭源组件
CVE-2018-11877 A-111092888* N/A 闭源组件
CVE-2018-11879 A-111093280* N/A 闭源组件
CVE-2018-11880 A-111092401* N/A 闭源组件
CVE-2018-11882 A-111093259* N/A 闭源组件
CVE-2018-11884 A-111090535* N/A 闭源组件
CVE-2018-11928 A-112279580* N/A 闭源组件
CVE-2018-11936 A-112279127* N/A 闭源组件
CVE-2018-11967 A-119049704* N/A 闭源组件
CVE-2018-11967 A-119052960* N/A 闭源组件
CVE-2018-11968 A-114042276* N/A 闭源组件
CVE-2018-12005 A-117118499* N/A 闭源组件
CVE-2018-12012 A-117119174* N/A 闭源组件
CVE-2018-12013 A-117119152* N/A 闭源组件
CVE-2018-13885 A-117118789* N/A 闭源组件
CVE-2018-13895 A-122472377* N/A 闭源组件
CVE-2018-13925 A-120483842* N/A 闭源组件
CVE-2019-2244 A-122472139* N/A 闭源组件
CVE-2019-2245 A-122473145* N/A 闭源组件

常见问题和解答

这一部分解答了用户在阅读本公告后可能会提出的常见问题。

1. 如何确定我的设备是否已通过更新解决这些问题?

要了解如何查看设备的安全补丁程序级别,请参阅查看并更新 Android 版本

  • 如果安全补丁程序级别是 2019-04-01 或更新,则意味着已解决 2019-04-01 安全补丁程序级别涵盖的所有问题。
  • 如果安全补丁程序级别是 2019-04-05 或更新,则意味着已解决 2019-04-05 以及之前的所有安全补丁程序级别涵盖的所有问题。

预装这些更新的设备制造商应将补丁程序字符串级别设为

  • [ro.build.version.security_patch]:[2019-04-01]
  • [ro.build.version.security_patch]:[2019-04-05]

2. 为何本公告有 2 个安全补丁程序级别?

本公告之所以有 2 个安全补丁程序级别,是为了让 Android 合作伙伴能够灵活地、更快速地修复在各种 Android 设备上类似的一系列漏洞。我们建议 Android 合作伙伴修复本公告中列出的所有问题并使用最新的安全补丁程序级别。

  • 如果设备使用的是 2019-04-01 这一安全补丁程序级别,则必须包含该安全补丁程序级别涵盖的所有问题以及之前的安全公告中报告的所有问题的修复程序。
  • 如果设备使用的是 2019-04-05 或更新的安全补丁程序级别,则必须包含本安全公告(以及之前的安全公告)中的所有适用补丁程序。

我们建议合作伙伴将要解决的全部问题的修复程序打包到一个更新中。

3.“类型”列中的条目表示什么意思?

在漏洞详情表内,“类型”列中的条目是安全漏洞的分类。

缩写词 定义
RCE 远程代码执行
EoP 提权
ID 信息披露
DoS 拒绝服务
N/A 没有分类

4.“参考编号”列中的条目表示什么意思?

在漏洞详情表内,“参考编号”列中的条目可能包含用于标识参考编号值所属组织的前缀。

前缀 参考编号
A- Android Bug ID
QC- Qualcomm 参考编号
M- MediaTek 参考编号
N- NVIDIA 参考编号
B- Broadcom 参考编号

5. 在“参考编号”列中,Android Bug ID 旁边的 * 表示什么意思?

如果问题尚未公开发布,则在“参考编号”列中,相应 Android Bug ID 旁边会显示 *。Google Developers 网站上针对 Pixel 设备提供的最新二进制驱动程序中通常包含用于解决相应问题的更新。

6. 为什么要将安全漏洞拆分到本公告和设备 / 合作伙伴安全公告(如 Pixel 公告)中?

要在 Android 设备上声明最新的安全补丁程序级别,必须修复本安全公告中记录的安全漏洞。但在声明安全补丁程序级别时,并不是必须要修复设备/合作伙伴安全公告中记录的其他安全漏洞。我们建议 Android 设备和芯片组制造商通过自己的安全网站(例如 SamsungLGEPixel 安全公告)记录其设备上存在的其他修复程序。

版本

版本 日期 备注
1.0 2019 年 4 月 1 日 发布了本公告
1.1 2019 年 4 月 3 日 在本公告中添加了 AOSP 链接