Google se compromete a impulsar la igualdad racial para las comunidades afrodescendientes. Obtén información al respecto.

Boletín de seguridad de Android: mayo de 2019

Organiza tus páginas con colecciones Guarda y categoriza el contenido según tus preferencias.

Publicado 6 de mayo de 2019 | Actualizado el 6 de mayo de 2019

El Boletín de seguridad de Android contiene detalles de las vulnerabilidades de seguridad que afectan a los dispositivos Android. Los niveles de parches de seguridad de 2019-05-05 o posteriores abordan todos estos problemas. Para obtener información sobre cómo verificar el nivel del parche de seguridad de un dispositivo, consulte Verifique y actualice su versión de Android .

Los socios de Android son notificados de todos los problemas al menos un mes antes de la publicación. Los parches de código fuente para estos problemas se publicaron en el repositorio del Proyecto de código abierto de Android (AOSP) y se vincularon desde este boletín. Este boletín también incluye enlaces a parches fuera de AOSP.

El más grave de estos problemas es una vulnerabilidad de seguridad crítica en el marco de medios que podría permitir que un atacante remoto utilice un archivo especialmente diseñado para ejecutar código arbitrario dentro del contexto de un proceso privilegiado. La evaluación de la gravedad se basa en el efecto que podría tener la explotación de la vulnerabilidad en un dispositivo afectado, suponiendo que las mitigaciones de la plataforma y el servicio estén desactivadas con fines de desarrollo o si se eluden con éxito.

No hemos recibido informes de explotación activa de clientes o abuso de estos problemas recientemente informados. Consulte la sección Mitigaciones de Android y Google Play Protect para obtener detalles sobre las protecciones de la plataforma de seguridad de Android y Google Play Protect, que mejoran la seguridad de la plataforma Android.

Nota: La información sobre la última actualización inalámbrica (OTA) y las imágenes de firmware para dispositivos de Google están disponibles en el boletín de actualización de píxeles de mayo de 2019 .

Mitigaciones de servicios de Android y Google

Este es un resumen de las mitigaciones proporcionadas por la plataforma de seguridad de Android y las protecciones de servicios como Google Play Protect . Estas capacidades reducen la probabilidad de que las vulnerabilidades de seguridad puedan explotarse con éxito en Android.

  • La explotación de muchos problemas en Android se hace más difícil debido a las mejoras en las versiones más recientes de la plataforma Android. Alentamos a todos los usuarios a actualizar a la última versión de Android siempre que sea posible.
  • El equipo de seguridad de Android monitorea activamente el abuso a través de Google Play Protect y advierte a los usuarios sobre aplicaciones potencialmente dañinas . Google Play Protect está habilitado de forma predeterminada en los dispositivos con Google Mobile Services y es especialmente importante para los usuarios que instalan aplicaciones desde fuera de Google Play.

Detalles de vulnerabilidad de nivel de parche de seguridad 2019-05-01

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2019-05-01. Las vulnerabilidades se agrupan según el componente al que afectan. Hay una descripción del problema y una tabla con el CVE, las referencias asociadas, el tipo de vulnerabilidad , la gravedad y las versiones actualizadas de AOSP (cuando corresponda). Cuando está disponible, vinculamos el cambio público que abordó el problema con la identificación del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

Estructura

La vulnerabilidad de esta sección podría permitir que una aplicación local malintencionada eluda los requisitos de interacción del usuario para obtener acceso a permisos adicionales.

CVE Referencias Escribe Gravedad Versiones actualizadas de AOSP
CVE-2019-2043 A-120484087 EoP Moderado 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9

Marco de medios

La vulnerabilidad de esta sección podría permitir que un atacante remoto utilice un archivo especialmente diseñado para ejecutar código arbitrario dentro del contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Versiones actualizadas de AOSP
CVE-2019-2044 A-123701862 RCE Crítico 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9

Sistema

La vulnerabilidad más grave de esta sección podría permitir que un atacante remoto utilice un archivo PAC especialmente diseñado para ejecutar código arbitrario dentro del contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Versiones actualizadas de AOSP
CVE-2019-2045 A-117554758 RCE Crítico 7.0, 7.1.1, 7.1.2, 8.1, 9
CVE-2019-2046 A-117556220 RCE Crítico 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2047 A-117607414 RCE Crítico 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2049 A-120445479 EoP Alto 9
CVE-2019-2050 A-121327323 EoP Alto 8.0, 8.1, 9
CVE-2019-2051 A-117555811 IDENTIFICACIÓN Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2052 A-117556606 IDENTIFICACIÓN Alto 7.0, 7.1.1, 7.1.2, 8.1, 9
CVE-2019-2053 A-122074159 IDENTIFICACIÓN Alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9

Detalles de vulnerabilidad de nivel de parche de seguridad 2019-05-05

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2019-05-05. Las vulnerabilidades se agrupan según el componente al que afectan e incluyen detalles como el CVE, las referencias asociadas, el tipo de vulnerabilidad , la gravedad , el componente (cuando corresponda) y las versiones actualizadas de AOSP (cuando corresponda). Cuando está disponible, vinculamos el cambio público que abordó el problema con la identificación del error, como la lista de cambios de AOSP. Cuando varios cambios se relacionan con un solo error, las referencias adicionales se vinculan a los números que siguen al ID del error.

Componentes del núcleo

La vulnerabilidad de esta sección podría permitir que un atacante local aumente los privilegios sin necesidad de privilegios de ejecución adicionales dentro del contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Componente
CVE-2019-2054 A-119769499 * EoP Moderado seccomp

Componentes NVIDIA

La vulnerabilidad de esta sección podría permitir que un atacante local aumente los privilegios (con la necesidad de privilegios de ejecución adicionales) y ejecute código arbitrario dentro del contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Componente
CVE-2018-6243 A-72315075 * EoP Alto Zona de confianza de Pixel C

Componentes de Broadcom

La vulnerabilidad de esta sección podría permitir que un atacante remoto utilice una transmisión especialmente diseñada para ejecutar código dentro del contexto de un proceso privilegiado.

CVE Referencias Escribe Gravedad Componente
CVE-2018-19860 A-122249979 * RCE Alto Firmware Bluetooth

Componentes Qualcomm

Estas vulnerabilidades afectan a los componentes de Qualcomm y se describen con más detalle en el boletín de seguridad o alerta de seguridad correspondiente de Qualcomm. Qualcomm proporciona directamente la evaluación de la gravedad de estos problemas.

CVE Referencias Escribe Gravedad Componente
CVE-2018-11955 A-78528839
QC-CR#2249768
N / A Alto controlador WLAN
CVE-2018-13919 A-120486022
QC-CR#2289598
N / A Alto Datos HLOS - LNX
CVE-2018-11819 A-112277301
QC-CR#2176354
N / A Moderado controlador WLAN

Componentes de código cerrado de Qualcomm

Estas vulnerabilidades afectan a los componentes de código cerrado de Qualcomm y se describen con más detalle en el boletín de seguridad o alerta de seguridad de Qualcomm correspondiente. Qualcomm proporciona directamente la evaluación de la gravedad de estos problemas.

CVE Referencias Escribe Gravedad Componente
CVE-2018-5912 A-114074547 * N / A Crítico Componente de código cerrado
CVE-2018-13898 A-119050181 * N / A Crítico Componente de código cerrado
CVE-2019-2255 A-122474428 * N / A Crítico Componente de código cerrado
CVE-2019-2256 A-114067283 * N / A Crítico Componente de código cerrado
CVE-2018-13901 A-119049466 * N / A Alto Componente de código cerrado
CVE-2018-13902 A-119050073 * N / A Alto Componente de código cerrado
CVE-2018-13906 A-119049388 * N / A Alto Componente de código cerrado
CVE-2018-13907 A-119050001 * N / A Alto Componente de código cerrado
CVE-2018-13908 A-119049623 * N / A Alto Componente de código cerrado
CVE-2018-13909 A-119051002 * N / A Alto Componente de código cerrado
CVE-2018-13910 A-119050182 * N / A Alto Componente de código cerrado
CVE-2018-13911 A-119052037 * N / A Alto Componente de código cerrado
CVE-2018-5913 A-122472140 * N / A Alto Componente de código cerrado
CVE-2019-2257 A-112303441 * N / A Alto Componente de código cerrado
CVE-2019-2259 A-123997497 * N / A Alto Componente de código cerrado

Preguntas y respuestas comunes

Esta sección responde preguntas comunes que pueden surgir después de leer este boletín.

1. ¿Cómo puedo determinar si mi dispositivo está actualizado para solucionar estos problemas?

Para obtener información sobre cómo verificar el nivel del parche de seguridad de un dispositivo, consulte Verifique y actualice su versión de Android .

  • Los niveles de parche de seguridad de 2019-05-01 o posteriores abordan todos los problemas asociados con el nivel de parche de seguridad de 2019-05-01.
  • Los niveles de parches de seguridad de 2019-05-05 o posteriores abordan todos los problemas asociados con el nivel de parches de seguridad 2019-05-05 y todos los niveles de parches anteriores.

Los fabricantes de dispositivos que incluyen estas actualizaciones deben establecer el nivel de la cadena de parches en:

  • [ro.build.version.security_patch]:[2019-05-01]
  • [ro.build.version.security_patch]:[2019-05-05]

2. ¿Por qué este boletín tiene dos niveles de parches de seguridad?

Este boletín tiene dos niveles de parches de seguridad para que los socios de Android tengan la flexibilidad de corregir un subconjunto de vulnerabilidades que son similares en todos los dispositivos Android con mayor rapidez. Se recomienda a los socios de Android que solucionen todos los problemas de este boletín y utilicen el nivel de parche de seguridad más reciente.

  • Los dispositivos que usan el nivel de parche de seguridad 2019-05-01 deben incluir todos los problemas asociados con ese nivel de parche de seguridad, así como soluciones para todos los problemas informados en boletines de seguridad anteriores.
  • Los dispositivos que usan el nivel de parche de seguridad de 2019-05-05 o posterior deben incluir todos los parches aplicables en este (y en los anteriores) boletines de seguridad.

Se alienta a los socios a agrupar las soluciones para todos los problemas que están solucionando en una sola actualización.

3. ¿Qué significan las entradas en la columna Tipo ?

Las entradas en la columna Tipo de la tabla de detalles de la vulnerabilidad hacen referencia a la clasificación de la vulnerabilidad de seguridad.

Abreviatura Definición
RCE Ejecución remota de código
EoP Elevación de privilegio
IDENTIFICACIÓN Divulgación de información
DoS Negación de servicio
N / A Clasificación no disponible

4. ¿Qué significan las entradas en la columna Referencias ?

Las entradas en la columna Referencias de la tabla de detalles de vulnerabilidad pueden contener un prefijo que identifique la organización a la que pertenece el valor de referencia.

Prefijo Referencia
A- ID de error de Android
QC- Número de referencia de Qualcomm
METRO- Número de referencia de MediaTek
NORTE- Número de referencia de NVIDIA
B- Número de referencia de Broadcom

5. ¿Qué significa un * junto al ID de error de Android en la columna Referencias ?

Los problemas que no están disponibles públicamente tienen un * junto al ID de error de Android en la columna Referencias . La actualización para ese problema generalmente se incluye en los controladores binarios más recientes para dispositivos Pixel disponibles en el sitio para desarrolladores de Google .

6. ¿Por qué las vulnerabilidades de seguridad se dividen entre este boletín y los boletines de seguridad de dispositivos/socios, como el boletín de Pixel?

Las vulnerabilidades de seguridad que se documentan en este boletín de seguridad deben declarar el último nivel de parche de seguridad en los dispositivos Android. Las vulnerabilidades de seguridad adicionales que están documentadas en los boletines de seguridad del dispositivo/socio no son necesarias para declarar un nivel de parche de seguridad. Se alienta a los fabricantes de chipsets y dispositivos Android a documentar la presencia de otras correcciones en sus dispositivos a través de sus propios sitios web de seguridad, como los boletines de seguridad de Samsung , LGE o Pixel .

Versiones

Versión Fecha notas
1.0 6 de mayo de 2019 Boletín publicado
1.1 6 de mayo de 2019 Boletín revisado para incluir enlaces AOSP