بولتن امنیتی اندروید - فوریه 2022

منتشر شده در 7 فوریه 2022 | به روز شده در 17 فوریه 2022

بولتن امنیتی اندروید حاوی جزئیاتی از آسیب پذیری های امنیتی است که بر دستگاه های اندرویدی تأثیر می گذارد. سطوح وصله امنیتی 2022-02-05 یا بالاتر همه این مشکلات را برطرف می کند. برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

شرکای Android حداقل یک ماه قبل از انتشار از همه مشکلات مطلع می شوند. وصله کد منبع برای این مشکلات در مخزن پروژه منبع باز Android (AOSP) منتشر شده و از این بولتن پیوند داده شده است. این بولتن همچنین شامل پیوندهایی به وصله های خارج از AOSP است

شدیدترین این مسائل یک آسیب‌پذیری امنیتی حیاتی در مؤلفه System است که می‌تواند منجر به افزایش از راه دور امتیاز بدون نیاز به مجوزهای اجرایی اضافی شود. ارزیابی شدت مبتنی بر تأثیری است که بهره‌برداری از آسیب‌پذیری احتمالاً روی دستگاه آسیب‌دیده می‌گذارد، با این فرض که پلت‌فرم و کاهش خدمات برای اهداف توسعه خاموش شده‌اند یا اگر با موفقیت دور زده شوند.

برای جزئیات بیشتر در مورد حفاظت های پلتفرم امنیتی اندروید و Google Play Protect که امنیت پلتفرم اندروید را بهبود می بخشد، به بخش کاهش دهنده های Android و Google Play Protect مراجعه کنید.

کاهش خدمات اندروید و گوگل

این خلاصه‌ای از کاهش‌های ارائه شده توسط پلتفرم امنیتی Android و محافظت‌های خدماتی مانند Google Play Protect است. این قابلیت ها احتمال سوء استفاده موفقیت آمیز از آسیب پذیری های امنیتی در اندروید را کاهش می دهد.

  • بهره برداری از بسیاری از مسائل در اندروید با بهبود نسخه های جدیدتر پلت فرم اندروید دشوارتر شده است. ما همه کاربران را تشویق می کنیم تا در صورت امکان به آخرین نسخه اندروید بروزرسانی کنند.
  • تیم امنیتی Android به طور فعال از طریق Google Play Protect برای سوء استفاده نظارت می کند و به کاربران در مورد برنامه های بالقوه مضر هشدار می دهد. Google Play Protect به طور پیش‌فرض در دستگاه‌های دارای سرویس‌های تلفن همراه Google فعال است و به ویژه برای کاربرانی که برنامه‌هایی را از خارج از Google Play نصب می‌کنند، مهم است.

جزئیات آسیب پذیری سطح وصله امنیتی 01/02/2022

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی که در سطح وصله ۲۰۲۲-۰۲-۰۱ اعمال می‌شوند، ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. مسائل در جداول زیر توضیح داده شده اند و شامل شناسه CVE، مراجع مرتبط، نوع آسیب پذیری ، شدت و نسخه های به روز شده AOSP (در صورت لزوم) می باشند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است، مانند لیست تغییرات AOSP، به شناسه اشکال مرتبط می کنیم. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعداد زیر شناسه اشکال مرتبط می شوند. دستگاه‌های دارای Android 10 و بالاتر ممکن است به‌روزرسانی‌های امنیتی و همچنین به‌روزرسانی‌های سیستم Google Play را دریافت کنند.

چارچوب

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افزایش محلی امتیاز بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2021-39619 الف-197399948 EoP بالا 11، 12
CVE-2021-39663 A-200682135 * EoP بالا 10
CVE-2021-39676 A-197228210 * EoP بالا 11
CVE-2021-39664 الف-203938029 شناسه بالا 12

چارچوب رسانه ای

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افزایش محلی امتیاز بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2020-13112 A-194342672 * EoP بالا 10، 11
CVE-2020-13113 A-196085005 * EoP بالا 10، 11
CVE-2021-39665 الف-204077881 شناسه بالا 12
CVE-2021-39666 A-204445255 [ 2 ] شناسه بالا 11، 12

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افزایش از راه دور امتیاز بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2021-39675 الف-205729183 EoP بحرانی 12
CVE-2021-39668 الف-193445603 EoP بالا 11، 12
CVE-2021-39669 الف-196969991 EoP بالا 11، 12
CVE-2021-39671 A-206718630 ​​[ 2 ] EoP بالا 12
CVE-2021-39674 الف-201083442 EoP بالا 10، 11، 12
CVE-2021-0706 A-193444889 * DoS بالا 10، 11

جزئیات آسیب پذیری سطح وصله امنیتی 05/02/2022

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی مربوط به سطح وصله 2022-02-05 را ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. مسائل در جداول زیر توضیح داده شده اند و شامل شناسه CVE، مراجع مرتبط، نوع آسیب پذیری ، شدت و نسخه های به روز شده AOSP (در صورت لزوم) می باشند. هنگامی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است، مانند لیست تغییرات AOSP، به شناسه اشکال مرتبط می کنیم. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعداد زیر شناسه اشکال مرتبط می شوند.

سیستم

آسیب‌پذیری در این بخش می‌تواند منجر به افشای اطلاعات محلی بدون نیاز به مجوزهای اجرایی اضافی شود.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2021-39631 A-193890833 [ 2 ] شناسه بالا 10، 11، 12

اجزای آملوژیک

این آسیب پذیری بر اجزای Amlogic تأثیر می گذارد و جزئیات بیشتر به طور مستقیم از Amlogic در دسترس است. ارزیابی شدت این موضوع به طور مستقیم توسط Amlogic ارائه شده است.

CVE منابع شدت مولفه
CVE-2021-39672
A-202018701 * بالا فست بوت

اجزای مدیاتک

این آسیب‌پذیری‌ها بر اجزای MediaTek تأثیر می‌گذارد و جزئیات بیشتر به‌طور مستقیم از MediaTek در دسترس است. ارزیابی شدت این مسائل به طور مستقیم توسط مدیاتک ارائه شده است.

CVE منابع شدت مولفه
CVE-2022-20024
الف-209705228
M-ALPS06219064 *
بالا سرویس سیستم
CVE-2022-20025 الف-209700749
M-ALPS06126832 *
بالا بلوتوث
CVE-2022-20026 الف-209705229
M-ALPS06126827 *
بالا بلوتوث
CVE-2022-20027 الف-209702508
M-ALPS06126826 *
بالا بلوتوث
CVE-2022-20028 الف-209702509
M-ALPS06198663 *
بالا بلوتوث

اجزای Unisoc

این آسیب‌پذیری‌ها بر اجزای Unisoc تأثیر می‌گذارند و جزئیات بیشتر مستقیماً از Unisoc در دسترس هستند. ارزیابی شدت این مسائل به طور مستقیم توسط Unisoc ارائه شده است.

CVE منابع شدت مولفه
CVE-2021-39616 الف-204686438
U-1704529 *
بالا sprd-vowifi
CVE-2021-39635 الف-206492634
U-1731024 *
بالا ims_ex
CVE-2021-39658 الف-207479207
U-1732729 *
بالا IsmsEx

قطعات کوالکام

این آسیب‌پذیری‌ها بر اجزای کوالکام تأثیر می‌گذارند و با جزئیات بیشتر در بولتن امنیتی یا هشدار امنیتی کوالکام توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه می شود.

CVE منابع شدت مولفه
CVE-2021-35068
A-202025798
QC-CR#2982971
بالا بلوتوث
CVE-2021-35069
الف-203032261
QC-CR#3001191
بالا WLAN
CVE-2021-35074 الف-204905255
QC-CR#2998013
بالا هسته
CVE-2021-35075
الف-204905325
QC-CR#2998149
بالا هسته
CVE-2021-35077 الف-204904989
QC-CR#3007135
بالا هسته

اجزای منبع بسته کوالکام

این آسیب‌پذیری‌ها بر اجزای منبع بسته کوالکام تأثیر می‌گذارند و با جزئیات بیشتر در بولتن امنیتی یا هشدار امنیتی کوالکام توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه می شود.

CVE منابع شدت مولفه
CVE-2021-30317 A-195750667 * بحرانی جزء منبع بسته
CVE-2021-30309 A-195750718 * بالا جزء منبع بسته
CVE-2021-30318 A-202025316 * بالا جزء منبع بسته
CVE-2021-30322 A-195751178 * بالا جزء منبع بسته
CVE-2021-30323 A-195750446 * بالا جزء منبع بسته
CVE-2021-30326 A-195751080 * بالا جزء منبع بسته

پرسش و پاسخ متداول

این بخش به سوالات رایجی که ممکن است پس از خواندن این بولتن رخ دهد پاسخ می دهد.

1. چگونه تشخیص دهم که آیا دستگاه من برای رفع این مشکلات به روز شده است؟

برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

  • سطوح وصله امنیتی 2022-02-01 یا جدیدتر تمام مسائل مرتبط با سطح وصله امنیتی 2022-02-01 را برطرف می کند.
  • سطوح وصله امنیتی 2022-02-05 یا جدیدتر، تمام مسائل مرتبط با سطح وصله امنیتی 2022-02-05 و تمام سطوح وصله قبلی را برطرف می کند.

سازندگان دستگاه‌هایی که شامل این به‌روزرسانی‌ها می‌شوند باید سطح رشته وصله را روی موارد زیر تنظیم کنند:

  • [ro.build.version.security_patch]:[01-02-2022]
  • [ro.build.version.security_patch]:[05-02-2022]

برای برخی از دستگاه‌های اندروید 10 یا جدیدتر، به‌روزرسانی سیستم Google Play دارای یک رشته تاریخی است که با سطح وصله امنیتی 01-02-2022 مطابقت دارد. لطفاً برای جزئیات بیشتر در مورد نحوه نصب به‌روزرسانی‌های امنیتی، این مقاله را ببینید.

2. چرا این بولتن دارای دو سطح وصله امنیتی است؟

این بولتن دارای دو سطح وصله امنیتی است تا شرکای Android انعطاف پذیری لازم را داشته باشند تا زیرمجموعه ای از آسیب پذیری ها را که در همه دستگاه های اندرویدی مشابه هستند با سرعت بیشتری برطرف کنند. شرکای Android تشویق می شوند تا همه مشکلات موجود در این بولتن را برطرف کنند و از آخرین سطح وصله امنیتی استفاده کنند.

  • دستگاه‌هایی که از سطح وصله امنیتی 2022-02-01 استفاده می‌کنند باید شامل تمام مشکلات مرتبط با آن سطح وصله امنیتی و همچنین رفع تمام مشکلات گزارش‌شده در بولتن‌های امنیتی قبلی باشند.
  • دستگاه‌هایی که از سطح وصله امنیتی 2022-02-05 یا جدیدتر استفاده می‌کنند، باید همه وصله‌های قابل‌اجرا در این (و قبلی) بولتن‌های امنیتی را شامل شوند.

شرکا تشویق می شوند تا اصلاحات مربوط به همه مشکلاتی را که در حال رفع آنها هستند در یک به روز رسانی واحد جمع کنند.

3. ورودی های ستون Type به چه معناست؟

ورودی های ستون نوع جدول جزئیات آسیب پذیری به طبقه بندی آسیب پذیری امنیتی اشاره دارد.

مخفف تعریف
RCE اجرای کد از راه دور
EoP بالا بردن امتیاز
شناسه افشای اطلاعات
DoS خود داری از خدمات
N/A طبقه بندی در دسترس نیست

4. ورودی های ستون References به چه معناست؟

ورودی‌های زیر ستون مراجع جدول جزئیات آسیب‌پذیری ممکن است حاوی پیشوندی باشد که سازمانی را که مقدار مرجع به آن تعلق دارد، مشخص می‌کند.

پیشوند ارجاع
آ- شناسه باگ اندروید
QC- شماره مرجع کوالکام
M- شماره مرجع مدیاتک
N- شماره مرجع NVIDIA
ب- شماره مرجع Broadcom
U- شماره مرجع UNISOC

5. یک * در کنار شناسه باگ اندروید در ستون References به چه معناست؟

مسائلی که به صورت عمومی در دسترس نیستند دارای علامت * در کنار شناسه مرجع مربوطه هستند. به‌روزرسانی برای آن مشکل عموماً در آخرین درایورهای باینری دستگاه‌های Pixel موجود در سایت Google Developer موجود است.

6. چرا آسیب‌پذیری‌های امنیتی بین این بولتن و بولتن‌های امنیتی دستگاه/شریک، مانند بولتن Pixel تقسیم شده است؟

آسیب پذیری های امنیتی که در این بولتن امنیتی مستند شده اند برای اعلام آخرین سطح وصله امنیتی در دستگاه های اندرویدی مورد نیاز هستند. آسیب‌پذیری‌های امنیتی اضافی که در بولتن‌های امنیتی دستگاه/شریک مستند شده‌اند، برای اعلام سطح وصله امنیتی لازم نیست. سازندگان دستگاه‌ها و چیپ‌ست‌های Android نیز ممکن است جزئیات آسیب‌پذیری امنیتی خاص محصولات خود را منتشر کنند، مانند Google ، Huawei ، LGE ، Motorola ، Nokia یا Samsung .

نسخه ها

نسخه تاریخ یادداشت
1.0 7 فوریه 2022 بولتن منتشر شد
1.1 8 فوریه 2022 بولتن اصلاح شد تا شامل پیوندهای AOSP باشد
1.2 17 فوریه 2022 جدول CVE اصلاح شده