Android 보안 게시판—2019년 3월

2019년 3월 4일 게시됨 | 2019년 3월 5일 업데이트됨

Android 보안 게시판은 Android 기기에 영향을 미치는 보안 취약성 세부정보를 다룹니다. 2019-03-05 보안 패치 수준 이상에서 관련 보안 문제가 모두 해결되었습니다. 기기의 보안 패치 수준을 확인하는 방법은 Android 버전 확인 및 업데이트를 참조하세요.

Android 파트너에게는 게시되기 최소 한 달 전에 모든 문제 관련 알림이 전달되었습니다. 이러한 문제의 해결을 위한 소스 코드 패치는 향후 48시간 동안 Android 오픈소스 프로젝트(AOSP) 저장소에 배포됩니다. 패치를 사용할 수 있게 되면 AOSP 링크와 함께 이 게시판을 수정하겠습니다.

이러한 문제 중 가장 심각한 것은 미디어 프레임워크의 심각한 보안 취약성으로, 특별히 제작된 파일을 사용하는 원격 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다. 심각도 평가는 개발 목적으로 플랫폼 및 서비스 완화를 사용할 수 없거나 우회에 성공한 경우 취약성 악용으로 인해 대상 기기가 받는 영향을 기준으로 합니다.

실제 고객이 새로 보고된 이러한 문제로 인해 악용당했다는 신고는 접수되지 않았습니다. Android 플랫폼의 보안을 개선하는 Android 보안 플랫폼 보호 및 Google Play 프로텍트에 관해 자세히 알아보려면 Android 및 Google Play 프로텍트 완화 섹션을 참조하세요.

참고: Google 기기의 최신 무선 업데이트(OTA) 및 펌웨어 이미지 관련 정보는 2019년 3월 Pixel 업데이트 게시판 을 참조하세요.

Android 및 Google 서비스 완화

다음은 Google Play 프로텍트와 같은 Android 보안 플랫폼 및 서비스 보호 기능에서 제공하는 완화에 관한 요약입니다. 다음과 같은 기능을 통해 Android에서 보안 취약성이 악용될 가능성을 줄입니다.

  • Android 플랫폼 최신 버전의 향상된 기능으로 Android의 여러 보안 문제를 악용하기가 더욱 어려워졌습니다. 가능하다면 모든 사용자는 최신 버전의 Android로 업데이트하는 것이 좋습니다.
  • Android 보안팀에서는 Google Play 프로텍트를 통해 악용사례를 적극적으로 모니터링하고 잠재적으로 위험한 애플리케이션 에 관해 사용자에게 경고를 보냅니다. Google Play 프로텍트는 Google 모바일 서비스가 적용된 기기에 기본적으로 사용 설정되어 있으며 Google Play 외부에서 가져온 앱을 설치하는 사용자에게 특히 중요합니다.

2019-03-01 보안 패치 수준 취약성 세부정보

다음 섹션에서는 2019-03-01 패치 수준에 적용되는 각 보안 취약성에 관해 자세히 알아볼 수 있습니다. 취약성은 영향을 받는 구성요소 아래에 분류되어 있습니다. 여기에는 문제 설명 및 CVE, 관련 참조, 취약성 유형, 심각도, 업데이트된 AOSP 버전(해당하는 경우)이 포함된 표가 제시됩니다. 가능한 경우 AOSP 변경사항 목록과 같이 문제를 해결한 공개 변경사항을 버그 ID에 연결합니다. 하나의 버그와 관련된 변경사항이 여러 개인 경우 추가 참조가 버그 ID 다음에 오는 번호에 연결됩니다.

프레임워크

이 섹션의 가장 심각한 취약성으로 인해 로컬 악성 애플리케이션이 권한이 설정된 프로세스 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2018-20346 A-121156452 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-1985 A-118694079* EoP 높음 7.0, 7.1.1, 7.1.2, 8.0
CVE-2019-2003 A-116321860 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2004 A-115739809 ID 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2005 A-68777217 EoP 보통 8.0, 8.1, 9

미디어 프레임워크

이 섹션의 가장 심각한 취약성으로 인해 특별히 제작된 파일을 사용하는 원격 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2019-1989 A-118399205 RCE 심각 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-1990 A-118453553 RCE 심각 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2006 A-116665972 EoP 높음 9
CVE-2019-2007 A-120789744 [2] EoP 높음 8.1, 9
CVE-2019-2008 A-122309228 EoP 높음 8.0, 8.1, 9

시스템

이 섹션의 가장 심각한 취약성으로 인해 특별히 제작된 전송을 사용하는 원격 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2019-2009 A-120665616 RCE 심각 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2010 A-118152591 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2011 A-120084106 [2] EoP 높음 8.0, 8.1, 9
CVE-2019-2012 A-120497437 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2013 A-120497583 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2014 A-120499324 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2015 A-120503926 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2016 A-120664978 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2017 A-121035711 EoP 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2018 A-110172241 [2] EoP 높음 8.1, 9
CVE-2018-9561 A-111660010 [2] ID 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2018-9563 A-114237888 [2] ID 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2018-9564 A-114238578 [2] ID 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2019 A-115635871 ID 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2020 A-116788646 ID 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2021 A-120428041 ID 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9
CVE-2019-2022 A-120506143 ID 높음 7.0, 7.1.1, 7.1.2, 8.0, 8.1, 9

2019-03-05 보안 패치 수준 취약성 세부정보

다음 섹션에서는 2019-03-05 패치 수준에 적용되는 각 보안 취약성에 관해 자세히 알아볼 수 있습니다. 취약성은 영향을 받는 구성요소 아래에 분류되어 있으며 CVE, 관련 참조, 취약성 유형, 심각도, 구성요소(해당하는 경우), 업데이트된 AOSP 버전(해당하는 경우)과 같은 세부정보가 포함되어 있습니다. 가능한 경우 AOSP 변경사항 목록과 같이 문제를 해결한 공개 변경사항을 버그 ID에 연결합니다. 하나의 버그와 관련된 변경사항이 여러 개인 경우 추가 참조가 버그 ID 다음에 오는 번호에 연결됩니다.

시스템

이 섹션의 취약성이 악용될 경우 로컬 악성 애플리케이션이 권한이 설정된 프로세스의 컨텍스트 내에서 임의의 코드를 실행할 수 있습니다.

CVE 참조 유형 심각도 업데이트된 AOSP 버전
CVE-2019-2023 A-121035042 [2] [3] [4] [5] [6] [7] EoP 높음 8.0, 8.1, 9

커널 구성요소

이 섹션의 취약성이 가장 심각하게 악용될 경우 로컬 공격자가 권한이 설정된 프로세스의 컨텍스트 내에서 특별히 제작된 파일로 임의의 코드를 실행할 수 있습니다.

CVE 참조 유형 심각도 구성요소
CVE-2018-10883 A-117311198
업스트림 커널 [2]
EoP 높음 ext4 파일 시스템
CVE-2019-2024 A-111761954
업스트림 커널
EoP 높음 em28xx 드라이버
CVE-2019-2025 A-116855682
업스트림 커널
EoP 높음 바인더 드라이버

Qualcomm 구성요소

다음 취약성은 Qualcomm 구성요소에 영향을 주며 해당 Qualcomm 보안 게시판 또는 보안 알림에 자세히 설명되어 있습니다. 이러한 문제의 심각도 평가는 Qualcomm에서 직접 제공합니다.

CVE 참조 유형 심각도 구성요소
CVE-2017-8252 A-112277630
QC-CR#2106159
N/A 심각 EcoSystem
CVE-2017-8252 A-114041175
QC-CR#2128529
N/A 심각 EcoSystem
CVE-2018-11817 A-114041192
QC-CR#2241830
N/A 심각 DSP_Services
CVE-2018-11817 A-114041747
QC-CR#2166542
N/A 심각 DSP_Services
CVE-2018-13899 A-119053086
QC-CR#2295915 [2]
N/A 높음 동영상
CVE-2018-13917 A-120487091
QC-CR#2251019
N/A 높음 WIN NSS Host

Qualcomm 비공개 소스 구성요소

다음 취약성은 Qualcomm 구성요소에 영향을 주며 해당 Qualcomm 보안 게시판 또는 보안 알림에 자세히 설명되어 있습니다. 이러한 문제의 심각도 평가는 Qualcomm에서 직접 제공합니다.

CVE 참조 유형 심각도 구성요소
CVE-2017-8252 A-79419898* N/A 심각 비공개 소스 구성요소
CVE-2017-8252 A-79420414* N/A 심각 비공개 소스 구성요소
CVE-2017-8252 A-112279542* N/A 심각 비공개 소스 구성요소
CVE-2018-11958 A-114042786* N/A 심각 비공개 소스 구성요소
CVE-2018-11966 A-114042484* N/A 높음 비공개 소스 구성요소
CVE-2018-11970 A-114042111* N/A 높음 비공개 소스 구성요소
CVE-2018-11971 A-114042829* N/A 높음 비공개 소스 구성요소
CVE-2018-13918 A-120486115* N/A 높음 비공개 소스 구성요소

일반적인 질문 및 답변

이 섹션에서는 게시판 내용에 관한 일반적인 질문의 답변을 제시합니다.

1. 내 기기가 업데이트되어 문제가 해결되었는지 어떻게 알 수 있나요?

기기의 보안 패치 수준을 확인하는 방법은 Android 버전 확인 및 업데이트를 참조하세요.

  • 2019-03-01 보안 패치 수준과 관련된 모든 문제는 2019-03-01 보안 패치 수준 이상에서 해결됩니다.
  • 2019-03-05 보안 패치 수준 및 그 이전의 모든 패치 수준과 관련된 모든 문제는 2019-03-05 보안 패치 수준 이상에서 모두 해결됩니다.

이 업데이트를 포함하는 기기 제조업체는 패치 문자열 수준을 다음과 같이 설정해야 합니다.

  • [ro.build.version.security_patch]:[2019-03-01]
  • [ro.build.version.security_patch]:[2019-03-05]

2. 이 게시판에 두 가지 보안 패치 수준이 있는 이유가 무엇인가요?

이 게시판에는 Android 파트너가 모든 Android 기기에서 유사하게 발생하는 취약성 문제의 일부를 더욱 빠르고 유연하게 해결할 수 있도록 두 가지 보안 패치 수준이 포함되어 있습니다. Android 파트너는 이 게시판에 언급된 문제를 모두 수정하고 최신 보안 패치 수준을 사용하는 것이 좋습니다.

  • 2019-03-01 보안 패치 수준을 사용하는 기기는 이 보안 패치 수준과 관련된 모든 문제와 이전 보안 게시판에 보고된 모든 문제의 수정사항을 포함해야 합니다.
  • 2019-03-05 이후의 보안 패치 수준을 사용하는 기기는 이 보안 게시판과 이전 게시판의 모든 관련 패치를 포함해야 합니다.

파트너는 해결하는 모든 문제의 수정사항을 단 한 번의 업데이트에서 번들로 묶는 것이 좋습니다.

3. 유형 열의 항목은 무엇을 의미하나요?

취약성 세부정보 표의 유형 열에 있는 항목은 보안 취약성 분류를 참조합니다.

약어 정의
RCE 원격 코드 실행
EoP 권한 승격
ID 정보 공개
DoS 서비스 거부
N/A 분류 없음

4. 참조 열의 항목은 무엇을 의미하나요?

취약성 세부정보 표의 참조 열에 있는 항목은 참조 값이 속한 조직을 나타내는 접두어를 포함할 수 있습니다.

접두어 참조
A- Android 버그 ID
QC- Qualcomm 참조 번호
M- MediaTek 참조 번호
N- NVIDIA 참조 번호
B- Broadcom 참조 번호

5 참조 열에서 Android 버그 ID 옆에 있는 * 표시는 무엇을 의미하나요?

공개되지 않은 문제에는 참조 열의 Android 버그 ID 옆에 * 표시가 있습니다. 일반적으로 이러한 문제에 관한 업데이트는 Google 개발자 사이트에서 제공되는 Pixel 기기용 최신 바이너리 드라이버에 포함되어 있습니다.

6. 보안 취약성이 이 게시판과 Pixel  게시판과 같은 기기 / 파트너 보안 게시판에 나뉘어져 있는 이유가 무엇인가요?

이 보안 게시판에 설명되어 있는 보안 취약성은 Android 기기의 최신 보안 패치 수준을 선언하는 데 필요합니다. 기기 / 파트너 보안 게시판에 설명된 추가 보안 취약성은 보안 패치 수준을 선언하는 데 필요하지 않습니다. Google은 Android 기기 및 칩셋 제조업체에 삼성, LGE 또는 Pixel 보안 게시판과 같은 자체 보안 웹사이트를 통해 기기와 관련된 기타 수정사항에 대해 기록하도록 권장하고 있습니다.

버전

버전 날짜 참고
1.0 2019년 3월 4일 게시판이 게시됨
1.1 2019년 3월 5일 게시판이 수정되어 AOSP 링크 포함됨