Google は、黒人コミュニティに対する人種平等の促進に取り組んでいます。取り組みを見る

Android のセキュリティに関する公開情報 - 2020 年 5 月

2020 年 5 月 4 日公開 | 2020 年 5 月 7 日更新

Android のセキュリティに関する公開情報には、Android デバイスに影響を与えるセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2020-05-05 以降では、下記のすべての問題に対処しています。デバイスのセキュリティ パッチレベルを確認するには、Android のバージョンを確認して更新する方法をご覧ください。

Android パートナーには、情報公開の 1 か月前までにすべての問題が通知されます。Android オープンソース プロジェクト(AOSP)リポジトリに、下記の問題に対するソースコードのパッチをリリースしています。また、この公開情報では、これらのパッチへのリンクに加え、AOSP 以外のパッチへのリンクも掲載しています。

下記の問題のうち最も重大度の高いものは、システム コンポーネントに重大なセキュリティの脆弱性があるため、リモートの攻撃者が特別に細工した通信を使用して、特権プロセス内で任意のコードを実行できるようになるおそれがあることです。重大度の評価は、攻撃対象のデバイスでその脆弱性が悪用された場合の影響に基づくもので、プラットフォームやサービスでのリスク軽減策が開発目的または不正な回避により無効となっていることを前提としています。

Android セキュリティ プラットフォームの保護や Google Play プロテクトについて詳しくは、Android と Google サービスでのリスク軽減策をご覧ください。こうした保護により、Android プラットフォームのセキュリティが改善されます。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームの保護と Google Play プロテクトのようなサービスの保護によるリスクの軽減について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を減らすものです。

  • Android プラットフォームの最新版での機能強化により、Android 上の多くの問題の悪用が困難になります。Google では、すべてのユーザーに対し、できる限り最新版の Android に更新することをおすすめしています。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、有害な可能性があるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載したデバイスではデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとっては特に重要です。

セキュリティ パッチレベル 2020-05-01 の脆弱性の詳細

以下に、パッチレベル 2020-05-01 に該当するセキュリティ脆弱性の各項目の詳細を示します。脆弱性は、影響を受けるコンポーネントごとに分類しています。下記の表に、問題の内容について説明し、CVE、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を示します。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクがあります。Android 10 以降を搭載したデバイスは、セキュリティ アップデートと Google Play システム アップデートを受信することがあります。

フレームワーク

カーネル コンポーネントの最も重大な脆弱性により、ローカルの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2020-0096 A-145669109 [2] EoP 重大 8.0、8.1、9
CVE-2020-0097 A-145981139 [2] [3] EoP 9、10
CVE-2020-0098 A-144285917 EoP 8.0、8.1、9、10

メディア フレームワーク

システムの最も重大な脆弱性により、ローカルの攻撃者が、追加権限の取得に必要なユーザー操作の要件を回避できるようになるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2020-0094 A-148223871 EoP 9、10
CVE-2020-0093 A-148705132 ID 8.0、8.1、9、10
CVE-2020-0100 A-150156584 ID 8.0、8.1
CVE-2020-0101 A-144767096 ID 8.0、8.1、9、10

システム

システムの最も重大な脆弱性により、リモートの攻撃者が特別に細工した通信を使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2020-0103 A-148107188 RCE 重大 9、10
CVE-2020-0102 A-143231677 EoP 8.0、8.1、9、10
CVE-2020-0109 A-148059175 EoP 9、10
CVE-2020-0105 A-144285084 EoP 9、10
CVE-2020-0024 A-137015265 [2] EoP 8.0、8.1、9、10
CVE-2020-0092 A-145135488 ID 10
CVE-2020-0106 A-148414207 ID 10
CVE-2020-0104 A-144430870 ID 9、10

Google Play システム アップデート

今月は Google Play システム アップデート(プロジェクト Mainline)で対処されたセキュリティ問題はありません。

セキュリティ パッチレベル 2020-05-05 の脆弱性の詳細

以下に、パッチレベル 2020-05-05 に該当するセキュリティ脆弱性の各項目の詳細を示します。影響を受けるコンポーネントごとに脆弱性を分類し、CVE、関連する参照先、脆弱性のタイプ重大度、コンポーネント(該当する場合)、更新対象の AOSP バージョン(該当する場合)などの詳細を記載しています。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に続く番号で、追加の参照先へのリンクを示します。

カーネル コンポーネント

カーネル コンポーネントの最も重大な脆弱性により、ローカルの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2020-0110 A-148159562
アップストリーム カーネル
EoP カーネル スケジューラ
CVE-2019-19536 A-146642883
アップストリーム カーネル
ID PCAN-USB ドライバ

MediaTek コンポーネント

システムの最も重大な脆弱性により、ローカルの攻撃者が特権アクセスで機密データにアクセスするおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2020-0064 A-149866855*
M-ALPS04737871
ID Omacp
CVE-2020-0065 A-149813448*
M-ALPS04886658
ID Android Suite Daemon
CVE-2020-0090 A-149813048*
M-ALPS04983879
ID メール
CVE-2020-0091 A-149808700*
M-ALPS04356368
ID mnld

Qualcomm コンポーネント

Qualcomm コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。これらの問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2019-14053 A-143902261
QC-CR#2317498
なし カーネル
CVE-2019-14087 A-145546454
QC-CR#2165928
なし ディスプレイ
CVE-2020-3610 A-148816869
QC-CR#2460844 [2]
なし ディスプレイ
CVE-2020-3615 A-148817147
QC-CR#2256679 [2]
QC-CR#2258844
なし WLAN
CVE-2020-3623 A-148815534*
QC-CR#2472080
なし セキュリティ
CVE-2020-3625 A-148816727*
QC-CR#2493825
なし セキュリティ
CVE-2020-3630 A-148816037
QC-CR#2534752 [2]
なし 動画
CVE-2020-3680 A-144350801
QC-CR#2597382
なし カーネル

Qualcomm クローズドソース コンポーネント

Qualcomm クローズドソース コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。これらの問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2020-3641 A-148816624* なし 重大 クローズドソース コンポーネント
CVE-2019-14054 A-143902264* なし クローズドソース コンポーネント
CVE-2019-14066 A-143903296* なし クローズドソース コンポーネント
CVE-2019-14067 A-143902707* なし クローズドソース コンポーネント
CVE-2019-14077 A-143903001* なし クローズドソース コンポーネント
CVE-2019-14078 A-143902885* なし クローズドソース コンポーネント
CVE-2020-3616 A-148816292* なし クローズドソース コンポーネント
CVE-2020-3618 A-148817245* なし クローズドソース コンポーネント
CVE-2020-3633 A-148816216* なし クローズドソース コンポーネント
CVE-2020-3645 A-148816217* なし クローズドソース コンポーネント

一般的な質問と回答

上記の公開情報に対する一般的な質問についての回答は以下のとおりです。

1. 上記の問題に対処するようにデバイスが更新されているかどうかを確かめるには、どうすればよいですか?

デバイスのセキュリティ パッチレベルを確認するには、Android のバージョンを確認して更新する方法をご覧ください。

  • セキュリティ パッチレベル 2020-05-01 以降では、セキュリティ パッチレベル 2020-05-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2020-05-05 以降では、セキュリティ パッチレベル 2020-05-05、およびそれ以前のすべてのパッチレベルに関連するすべての問題に対処しています。

デバイス メーカーは、こうしたアップデートを組み込む場合、パッチレベル文字列を以下のとおり設定する必要があります。

  • [ro.build.version.security_patch]:[2020-05-01]
  • [ro.build.version.security_patch]:[2020-05-05]

Android 10 以降を搭載した一部のデバイスでは、Google Play システム アップデートに、セキュリティ パッチレベル 2020-05-01 と一致する日付文字列が含まれます。セキュリティ アップデートのインストール方法について詳しくは、こちらの記事をご覧ください。

2. この公開情報に 2 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、2 つのセキュリティ パッチレベルを定義しています。これは、すべての Android デバイスで同様の問題が発生する一部の脆弱性をサブセットとし、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーは、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されています。

  • 2020-05-01 のセキュリティ パッチレベルを使用するデバイスには、そのセキュリティ パッチレベルに関連するすべての問題と、それ以前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2020-05-05 以降のセキュリティ パッチレベルを使用するデバイスには、今回(およびそれ以前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーには、対処するすべての問題の修正を 1 つのアップデートにまとめて提供することが推奨されています。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
なし 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属する組織を示す接頭辞が含まれる場合があります。

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、「参照」列の Android バグ ID の横に「*」を付けています。この問題のアップデートは、Google デベロッパー サイトから入手できる Pixel デバイス用最新バイナリ ドライバに通常含まれています。

6. セキュリティの脆弱性が、この公開情報とデバイスやパートナーのセキュリティに関する公開情報(Pixel のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android デバイスの最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要となります。それ以外の、デバイスやパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は必須ではありません。また、Android デバイスやチップセットのメーカー(GoogleHuaweiLGEMotorolaNokiaSamsung など)からも、各社製品に固有のセキュリティの脆弱性に関する詳細情報が公開される場合があります。

バージョン

バージョン 日付 メモ
1.0 2020 年 5 月 4 日 情報公開
1.1 2020 年 5 月 7 日 公開情報を改訂し AOSP リンクを追加