Google は、黒人コミュニティに対する人種平等の促進に取り組んでいます。取り組みを見る

Android のセキュリティに関する公開情報 - 2022 年 4 月

2022 年 4 月 4 日公開 | 2022 年 4 月 5 日更新

Android のセキュリティに関する公開情報には、Android デバイスに影響を与えるセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2022-04-05 以降では、下記のすべての問題に対処しています。デバイスのセキュリティ パッチレベルを確認するには、Android のバージョンを確認して更新する方法をご覧ください。

Android パートナーには、情報公開の 1 か月前までにすべての問題が通知されます。下記の問題に対するソースコードのパッチは、これから 48 時間の間に Android オープンソース プロジェクト(AOSP)リポジトリにリリースされます。AOSP リンクが利用可能になり次第、この公開情報を改訂します。

下記の問題のうち最も重大度の高いものは、フレームワーク コンポーネントに存在する重大度「高」のセキュリティ脆弱性です。これにより、追加の実行権限がなくてもローカルで権限を昇格されるおそれがあります。 重大度の評価は、攻撃対象のデバイスでその脆弱性が悪用された場合の影響に基づいています。プラットフォームやサービスでのリスク軽減策が、開発目的または不正な回避策により無効となっていると仮定しています。

Android セキュリティ プラットフォームの保護や Google Play プロテクトについて詳しくは、Android と Google サービスでのリスク軽減策をご覧ください。こうした保護により、Android プラットフォームのセキュリティが改善されます。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームGoogle Play プロテクトのようなサービスによる保護でリスクを軽減する手段について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を減らすものです。

  • Android プラットフォームの最新バージョンでの機能強化により、Android 上の多くの問題の悪用が困難になります。すべてのユーザーに対し、できる限り最新バージョンの Android にアップデートすることをおすすめします。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、有害な可能性があるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載したデバイスではデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとっては特に重要です。

セキュリティ パッチレベル 2022-04-01 の脆弱性の詳細

以下に、パッチレベル 2022-04-01 に該当するセキュリティ脆弱性の各項目の詳細を示します。脆弱性は、影響を受けるコンポーネントごとに分類しています。下の表に、問題の内容について説明し、CVE ID、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を示します。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載されている番号に、追加の参照へのリンクが設定されています。Android 10 以降を搭載したデバイスは、セキュリティ アップデートと Google Play システム アップデートを受信することがあります。

フレームワーク

このセクションの最も重大度の高い脆弱性により、追加の実行権限がなくてもローカルで権限を昇格されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2021-0694 A-183147114 EoP 11
CVE-2021-39794 A-205836329 EoP 11、12、12L
CVE-2021-39795 A-201667614 EoP 11、12、12L
CVE-2021-39796 A-205595291 EoP 10、11、12、12L
CVE-2021-39797 A-209607104 EoP 12、12L
CVE-2021-39798 A-213169612 EoP 12、12L
CVE-2021-39799 A-200288596 EoP 12、12L

メディア フレームワーク

このセクションの最も重大な脆弱性により、追加の実行権限がなくてもリモートで情報を開示されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2021-39803 A-193790350 ID 10、11、12、12L
CVE-2021-39804 A-215002587 DoS 11、12、12L

システム

このセクションの最も重大な脆弱性により、追加の実行権限を必要とすることなく、ローカルで権限を昇格されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2021-39808 A-209966086 EoP 10、11、12
CVE-2021-39805 A-212694559 ID 12、12L
CVE-2021-39809 A-205837191 ID 10、11、12、12L

Google Play システム アップデート

プロジェクト Mainline のコンポーネントには次の問題が含まれています。

コンポーネント CVE
MediaProvider CVE-2021-39795
メディア コーデック CVE-2021-39803

セキュリティ パッチレベル 2022-04-05 の脆弱性の詳細

以下に、パッチレベル 2022-04-05 に該当するセキュリティ脆弱性の各項目の詳細を示します。脆弱性は、影響を受けるコンポーネントごとに分類しています。下の表に、問題の内容について説明し、CVE ID、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を示します。該当する場合は、バグ ID の欄に、その問題に対処した一般公開されている変更(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載されている番号に、追加の参照へのリンクが設定されています。

システム

このセクションの最も重大な脆弱性により、追加の実行権限がなくてもゲスト アカウントからローカルで権限を昇格されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2021-39807 A-209446496 EoP 10、11、12、12L

カーネル コンポーネント

このセクションの最も重大な脆弱性により、追加の実行権限を必要とすることなく、ローカルで権限を昇格されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2021-0707 A-155756045
アップストリーム カーネル
EoP dma-buf
CVE-2021-39801 A-209791720
アップストリーム カーネル [2] [3]
EoP ION
CVE-2021-39802 A-213339151
アップストリーム カーネル [2] [3] [4]
EoP メモリ管理
CVE-2021-39800 A-208277166
アップストリーム カーネル [2] [3]
ID ION

MediaTek コンポーネント

これらの脆弱性は MediaTek コンポーネントに影響を与えます。詳細情報は MediaTek から直接入手できます。ここに示す問題の重大度の評価は、MediaTek から直接提供されたものです。

CVE 参照 重大度 コンポーネント
CVE-2022-20081
A-218242055
M-ALPS06461919 *
A-GPS
CVE-2021-25477
A-220262213
M-MOLY00684727 *
モデム LTE RRC

Qualcomm コンポーネント

Qualcomm コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。ここに示す問題の重大度は、Qualcomm から直接提供されたものです。

CVE 参照 重大度 コンポーネント
CVE-2021-35081
A-213239834
QC-CR#3028274
重大 WLAN
CVE-2021-35112
A-201574693
QC-CR#3049280
重大 ディスプレイ
CVE-2021-35123
A-213239948
QC-CR#3032290
重大 Bluetooth
CVE-2021-30334
A-213239835
QC-CR#2963049 [2]
QC-CR#3052789
ディスプレイ
CVE-2021-35091
A-204905109
QC-CR#3008877
ディスプレイ
CVE-2021-35095 A-204905206
QC-CR#2996895
カーネル
CVE-2021-35130
A-213240026
QC-CR#3057133
ディスプレイ

Qualcomm クローズドソース コンポーネント

Qualcomm クローズドソース コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。ここに示す問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 重大度 コンポーネント
CVE-2021-30339
A-202025975 * 重大 クローズドソース コンポーネント
CVE-2021-30341
A-202024969 * 重大 クローズドソース コンポーネント
CVE-2021-30342
A-202025860 * 重大 クローズドソース コンポーネント
CVE-2021-30343
A-202025978 * 重大 クローズドソース コンポーネント
CVE-2021-30347 A-202025598 * 重大 クローズドソース コンポーネント
CVE-2021-35104 A-213240044 * 重大 クローズドソース コンポーネント
CVE-2021-30281 A-202025858 * クローズドソース コンポーネント
CVE-2021-30338
A-202025859 * クローズドソース コンポーネント
CVE-2021-30340 A-202025736 * クローズドソース コンポーネント
CVE-2021-30344 A-192612963* クローズドソース コンポーネント
CVE-2021-30345 A-202025737* クローズドソース コンポーネント
CVE-2021-30346 A-202025862 * クローズドソース コンポーネント
CVE-2021-30349 A-202025797 * クローズドソース コンポーネント
CVE-2021-30350
A-202025979 * クローズドソース コンポーネント
CVE-2021-35070
A-202025864 * クローズドソース コンポーネント
CVE-2021-35100 A-213240046 * クローズドソース コンポーネント

一般的な質問と回答

上記の公開情報に対する一般的な質問とその回答は以下のとおりです。

1. 上記の問題に対処するようにデバイスが更新されているかどうかを確かめるには、どうすればよいですか?

デバイスのセキュリティ パッチレベルを確認するには、Android のバージョンを確認して更新する方法をご覧ください。

  • セキュリティ パッチレベル 2022-04-01 以降では、セキュリティ パッチレベル 2022-04-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2022-04-05 以降では、セキュリティ パッチレベル 2022-04-05 以前のすべてのパッチレベルに関連するすべての問題に対処しています。

デバイス メーカーは、こうしたアップデートを組み込む場合、パッチレベル文字列を以下のとおり設定する必要があります。

  • [ro.build.version.security_patch]:[2022-04-01]
  • [ro.build.version.security_patch]:[2022-04-05]

Android 10 以降を搭載した一部のデバイスでは、Google Play システム アップデートに、セキュリティ パッチレベル 2022-04-01 と一致する日付文字列が含まれます。セキュリティ アップデートのインストール方法について詳しくは、こちらの記事をご覧ください。

2. この公開情報に 2 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、2 つのセキュリティ パッチレベルを扱っています。これは、すべての Android デバイスにまたがる同様の脆弱性をひとまとめにして、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーは、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されます。

  • 2022-04-01 のセキュリティ パッチレベルを使用するデバイスには、そのセキュリティ パッチレベルに関連するすべての問題と、それより前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2022-04-05 以降のセキュリティ パッチレベルを使用するデバイスには、今回(およびそれより前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーは、対処するすべての問題の修正を 1 つのアップデートにまとめて提供することが推奨されます。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
なし 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属する組織を示す接頭辞が含まれる場合があります。

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号
U- UNISOC の参照番号

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、対応する参照 ID の横に「*」を付けています。この問題のアップデートは、Google デベロッパー サイトから入手できる Pixel デバイス用最新バイナリ ドライバに通常含まれています。

6. セキュリティの脆弱性が、この公開情報とデバイスやパートナーのセキュリティに関する公開情報(Pixel のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android デバイスの最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要となります。それ以外の、デバイスやパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は、セキュリティ パッチレベルを宣言するために必須ではありません。また、Android デバイスやチップセットのメーカー(GoogleHuaweiLGEMotorolaNokiaSamsung など)からも、各社製品に固有のセキュリティの脆弱性に関する詳細情報が公開される場合があります。

バージョン

バージョン 日付 メモ
1.0 2022 年 4 月 4 日 情報公開
1.1 2022 年 4 月 5 日 公開情報を改訂し AOSP リンクを追加