Google berkomitmen untuk memajukan ekuitas ras untuk komunitas kulit hitam. Lihat bagaimana.
Halaman ini diterjemahkan oleh Cloud Translation API.
Switch to English

Buletin Keamanan Android — Desember 2016

Diterbitkan 05 Desember 2016 | Diperbarui 21 Desember 2016

Buletin Keamanan Android berisi rincian kerentanan keamanan yang memengaruhi perangkat Android. Di samping buletin, kami telah merilis pembaruan keamanan untuk perangkat Google melalui pembaruan over-the-air (OTA). Gambar firmware perangkat Google juga telah dirilis ke situs Pengembang Google . Tingkat tambalan keamanan 05 Desember 2016 atau lebih baru mengatasi semua masalah ini. Lihat jadwal pembaruan Pixel dan Nexus untuk mempelajari cara memeriksa tingkat patch keamanan perangkat.

Mitra diberi tahu tentang masalah yang dijelaskan dalam buletin pada 07 November 2016 atau sebelumnya. Patch kode sumber untuk masalah ini telah dirilis ke repositori Android Open Source Project (AOSP) dan ditautkan dari buletin ini. Buletin ini juga menyertakan tautan ke tambalan di luar AOSP.

Yang paling parah dari masalah ini adalah kerentanan keamanan kritis dalam kode khusus perangkat yang dapat memungkinkan eksekusi kode arbitrer dalam konteks kernel, yang mengarah pada kemungkinan kompromi perangkat permanen lokal, yang mungkin memerlukan pencemaran ulang sistem operasi untuk memperbaiki perangkat . Penilaian tingkat permasalahan didasarkan pada efek bahwa mengeksploitasi kerentanan mungkin akan terjadi pada perangkat yang terpengaruh, dengan asumsi platform dan mitigasi layanan dinonaktifkan untuk tujuan pengembangan atau jika berhasil dilewati.

Kami belum memiliki laporan tentang eksploitasi pelanggan aktif atau penyalahgunaan masalah yang baru dilaporkan ini. Lihat bagian mitigasi layanan Android dan Google untuk perincian tentang perlindungan platform keamanan Android dan perlindungan layanan seperti SafetyNet , yang meningkatkan keamanan platform Android.

Kami mendorong semua pelanggan untuk menerima pembaruan ini ke perangkat mereka.

Pengumuman

  • Buletin ini memiliki dua rangkaian tingkat patch keamanan untuk memberikan fleksibilitas bagi mitra Android untuk lebih cepat memperbaiki subset kerentanan yang serupa di semua perangkat Android. Lihat Pertanyaan dan jawaban umum untuk informasi tambahan:
    • 2016-12-01 : String tingkat patch keamanan parsial. String tingkat patch keamanan ini menunjukkan bahwa semua masalah yang terkait dengan 2016-12-01 (dan semua string level patch keamanan sebelumnya) diatasi.
    • 2016-12-05 : Menyelesaikan string tingkat patch keamanan. String tingkat patch keamanan ini menunjukkan bahwa semua masalah yang terkait dengan 2016-12-01 dan 2016-12-05 (dan semua string level patch keamanan sebelumnya) ditangani.
  • Perangkat Google yang didukung akan menerima pembaruan OTA tunggal dengan tingkat patch keamanan 05 Desember 2016.

Android dan mitigasi layanan Google

Ini adalah ringkasan dari mitigasi yang disediakan oleh platform keamanan Android dan perlindungan layanan, seperti SafetyNet. Kemampuan ini mengurangi kemungkinan kerentanan keamanan dapat berhasil dieksploitasi di Android.

  • Eksploitasi untuk banyak masalah di Android menjadi lebih sulit dengan peningkatan versi Android yang lebih baru. Kami mendorong semua pengguna untuk memperbarui ke versi Android terbaru jika memungkinkan.
  • Tim Keamanan Android secara aktif memantau penyalahgunaan dengan Verifikasi Aplikasi dan SafetyNet , yang dirancang untuk memperingatkan pengguna tentang Aplikasi yang Berpotensi Berbahaya . Verifikasi Aplikasi diaktifkan secara default pada perangkat dengan Layanan Seluler Google dan sangat penting bagi pengguna yang menginstal aplikasi dari luar Google Play. Alat rooting perangkat dilarang di dalam Google Play, tetapi Verify Apps memperingatkan pengguna ketika mereka mencoba menginstal aplikasi rooting yang terdeteksi — dari mana pun asalnya. Selain itu, Verifikasi Aplikasi berupaya mengidentifikasi dan memblokir pemasangan aplikasi jahat yang diketahui yang mengeksploitasi kerentanan hak istimewa. Jika aplikasi semacam itu telah diinstal, Verifikasi Aplikasi akan memberi tahu pengguna dan berusaha menghapus aplikasi yang terdeteksi.
  • Jika sesuai, aplikasi Google Hangouts dan Messenger tidak secara otomatis mengirimkan media ke proses seperti Mediaserver.

Ucapan Terima Kasih

Kami ingin mengucapkan terima kasih kepada para peneliti ini atas kontribusi mereka:

  • Baozeng Ding, Chengming Yang, Peng Xiao, Ning You, Yang Dong, Chao Yang, Yi Zhang, dan Yang Song dari Alibaba Mobile Security Group: CVE-2016-6783, CVE-2016-6784, CVE-2016-6785
  • Chi Zhang , Mingjian Zhou ( @Mingjian_Zhou ), Chiachih Wu ( @chiachih_wu ), dan Xuxian Jiang dari C0RE Tim : CVE-2016-6789, CVE-2016-6790
  • Christian Seel: CVE-2016-6769
  • David Benjamin dan Kenny Root dari Google: CVE-2016-6767
  • Di Shen ( @returnsme ) dari KeenLab ( @keen_lab ), Tencent: CVE-2016-6776, CVE-2016-6787
  • En He ( @ heeeeen4x ) dari MS509Team : CVE-2016-6763
  • Gengjia Chen ( @ chengjia4574 ), pjf dari IceSword Lab, Qihoo 360 Technology Co. Ltd.: CVE-2016-6779, CVE-2016-6778, CVE-2016-8401, CVE-2016-8402, CVE-2016-8403, CVE-2016-8409, CVE-2016-8408, CVE-2016-8404
  • Jianqiang Zhao ( @jianqiangzhao ) dan pjf dari IceSword Lab, Qihoo 360 Technology Co. Ltd: CVE-2016-6788, CVE-2016-6781, CVE-2016-6782, CVE-2016-8396
  • Lubo Zhang , Tong Lin , Yuan-Tsung Lo , Chiachih Wu ( @chiachih_wu ), dan Xuxian Jiang dari C0RE Tim : CVE-2016-6791, CVE-2016-8391, CVE-2016-8392
  • Tandai Merek Project Zero: CVE-2016-6772
  • Michał Bednarski : CVE-2016-6770, CVE-2016-6774
  • Mingjian Zhou ( @Mingjian_Zhou ), Chi Zhang , Chiachih Wu ( @chiachih_wu ), dan Xuxian Jiang dari Tim C0RE : CVE-2016-6761, CVE-2016-6759, CVE-2016-8400, CVE-2016-8400
  • Mingjian Zhou ( @Mingjian_Zhou ), Chiachih Wu ( @chiachih_wu ), dan Xuxian Jiang dari C0RE Tim : CVE-2016-6760
  • Mingjian Zhou ( @Mingjian_Zhou ), Hanxiang Wen , Chiachih Wu ( @chiachih_wu ), dan Xuxian Jiang dari C0RE Tim : CVE-2016-6759
  • Nathan Crandall ( @natecray ) dari Tim Keamanan Produk Tesla Motors: CVE-2016-6915, CVE-2016-6916, CVE-2016-6917
  • Nightwatch Cybersecurity Research ( @nightwatchcyber ): CVE-2016-5341
  • Pengfei Ding (丁鹏飞), Chenfu Bao (包 沉浮), Lenx Wei (韦 韬) dari Baidu X-Lab: CVE-2016-6755, CVE-2016-6756
  • Peter Pi ( @heisecode ) dari Trend Micro: CVE-2016-8397, CVE-2016-8405, CVE-2016-8406, CVE-2016-8407
  • Qidan He (何 淇 丹) ( @flanker_hqd ) dari KeenLab, Tencent (腾讯 科恩 实验室): CVE-2016-8399, CVE-2016-8395
  • Qidan He (何 淇 丹) ( @flanker_hqd ) dan Marco Grassi ( @marcograss ) dari KeenLab, Tencent (腾讯 科恩 实验室): CVE-2016-6768
  • Richard Shupak: CVE-2016-5341
  • Sagi Kedmi dari IBM X-Force Research: CVE-2016-8393, CVE-2016-8394
  • Seven Shen ( @lingtongshen ) dari Tim Peneliti Ancaman Seluler, Trend Micro Inc .: CVE-2016-6757
  • Weichao Sun ( @sunblate ) dari Alibaba Inc .: CVE-2016-6773
  • Wenke Dou , Chi Zhang , Chiachih Wu ( @chiachih_wu ), dan Xuxian Jiang dari C0RE Tim : CVE-2016-6765
  • Wish Wu ( @wish_wu ) ( 吴 潍 浠 ) dari Tim Respons Ancaman Seluler , Trend Micro Inc .: CVE-2016-6704
  • Yuan-Tsung Lo , Tong Lin , Chiachih Wu ( @chiachih_wu ), dan Xuxian Jiang dari Tim C0RE : CVE-2016-6786, CVE-2016-6780, CVE-2016-6775
  • Yuan-Tsung Lo , Xiaodong Wang , Chiachih Wu ( @chiachih_wu ), dan Xuxian Jiang dari C0RE Tim : CVE-2016-6777
  • Yuxiang Li dari Departemen Platform Keamanan Tencent: CVE-2016-6771
  • Zhe Jin (金 哲) dari Pusat Respons Keamanan Chengdu, Qihoo 360 Technology Co. Ltd.: CVE-2016-6764, CVE-2016-6766
  • Zinuo Han dari Pusat Respons Keamanan Chengdu Qihoo 360 Technology Co. Ltd .: CVE-2016-6762

Terima kasih tambahan untuk berterima kasih kepada MengLuo Gou ( @ idhyt3r ) dari Bottle Tech, Yong Wang (王勇) ( @ ThomasKing2014 ), dan Zubin Mithra dari Google atas kontribusi mereka pada buletin keamanan ini.

Tingkat keamanan patch 2016-12-01 — Detail kerentanan

Di bagian di bawah ini, kami memberikan perincian untuk masing-masing kerentanan keamanan yang berlaku untuk tingkat tambalan 2016-12-01. Ada deskripsi masalah, alasan keparahan, dan tabel dengan CVE, referensi terkait, keparahan, perangkat Google yang diperbarui, versi AOSP yang diperbarui (jika berlaku), dan tanggal yang dilaporkan. Jika tersedia, kami akan menautkan perubahan publik yang menangani masalah ini ke ID bug, seperti daftar perubahan AOSP. Ketika beberapa perubahan terkait dengan satu bug, referensi tambahan ditautkan ke nomor setelah ID bug.

Kerentanan eksekusi kode jauh di CURL / LIBCURL

Tabel ini berisi kerentanan keamanan yang memengaruhi perpustakaan CURL dan LIBCURL. Masalah paling parah dapat memungkinkan penyerang man-in-the-middle menggunakan sertifikat palsu untuk mengeksekusi kode arbitrer dalam konteks proses istimewa. Masalah ini dinilai sebagai Tinggi karena penyerang membutuhkan sertifikat palsu.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-5419 A-31271247 Tinggi Semua 7.0 3 Agustus 2016
CVE-2016-5420 A-31271247 Tinggi Semua 7.0 3 Agustus 2016
CVE-2016-5421 A-31271247 Tinggi Semua 7.0 3 Agustus 2016

Peningkatan kerentanan hak istimewa di libziparchive

Peningkatan kerentanan hak istimewa di perpustakaan libziparchive dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks proses istimewa. Masalah ini dinilai Tinggi karena dapat digunakan untuk mendapatkan akses lokal ke kemampuan yang ditingkatkan, yang biasanya tidak dapat diakses oleh aplikasi pihak ketiga.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-6762 A-31251826 [ 2 ] Tinggi Semua 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 28 Agustus 2016

Penolakan kerentanan layanan di Telephony

Penolakan kerentanan layanan di Telephony dapat memungkinkan aplikasi jahat lokal menggunakan file yang dibuat khusus untuk menyebabkan perangkat hang atau reboot. Masalah ini dinilai Tinggi karena kemungkinan penolakan layanan permanen lokal.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-6763 A-31530456 Tinggi Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 12 Sep 2016

Penolakan kerentanan layanan di Mediaserver

Penolakan kerentanan layanan di Mediaserver dapat memungkinkan penyerang menggunakan file yang dibuat khusus untuk menyebabkan perangkat hang atau reboot. Masalah ini dinilai Tinggi karena kemungkinan penolakan layanan jarak jauh.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-6766 A-31318219 Tinggi Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 5 Sep 2016
CVE-2016-6765 A-31449945 Tinggi Semua 4.4.4, 5.0.2, 5.1.1, 7.0 13 Sep 2016
CVE-2016-6764 A-31681434 Tinggi Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 22 Sep 2016
CVE-2016-6767 A-31833604 Tinggi Tidak ada * 4.4.4 Google internal

* Perangkat Google yang didukung pada Android 7.0 atau yang lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Kerentanan Eksekusi Kode Jarak Jauh di perpustakaan Framesequence

Kerentanan eksekusi kode jauh di perpustakaan Framesequence dapat memungkinkan penyerang menggunakan file yang dibuat khusus untuk mengeksekusi kode sewenang-wenang dalam konteks proses yang tidak terprivasi. Masalah ini dinilai sebagai Tinggi karena kemungkinan eksekusi kode jauh dalam aplikasi yang menggunakan perpustakaan Framesequence.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-6768 A-31631842 Tinggi Semua 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 19 Sep 2016

Ketinggian kerentanan hak istimewa di Smart Lock

Peningkatan kerentanan hak istimewa di Smart Lock dapat memungkinkan pengguna jahat lokal untuk mengakses pengaturan Smart Lock tanpa PIN. Masalah ini dinilai sebagai Sedang karena pertama-tama memerlukan akses fisik ke perangkat yang tidak terkunci di mana Smart Lock adalah panel pengaturan terakhir yang diakses oleh pengguna.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-6769 A-29055171 Moderat Tidak ada * 5.0.2, 5.1.1, 6.0, 6.0.1 27 Mei 2016

* Perangkat Google yang didukung pada Android 7.0 atau yang lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa dalam API Kerangka

Peningkatan kerentanan hak istimewa dalam Framework API dapat mengaktifkan aplikasi jahat lokal untuk mengakses fungsi sistem di luar tingkat aksesnya. Masalah ini dinilai sebagai Sedang karena merupakan pintasan lokal pembatasan pada proses yang dibatasi.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-6770 A-30202228 Moderat Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 16 Jul 2016

Tingginya kerentanan hak istimewa di Telephony

Peningkatan kerentanan hak istimewa dalam Telephony dapat memungkinkan aplikasi jahat lokal mengakses fungsi sistem di luar tingkat aksesnya. Masalah ini dinilai sebagai Sedang karena merupakan pintasan lokal pembatasan pada proses yang dibatasi.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-6771 A-31566390 Moderat Semua 6.0, 6.0.1, 7.0 17 Sep 2016

Ketinggian kerentanan hak istimewa di Wi-Fi

Peningkatan kerentanan hak istimewa dalam Wi-Fi dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks proses istimewa. Masalah ini dinilai sebagai Sedang karena pertama-tama membutuhkan proses istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-6772 A-31856351 [ 2 ] Moderat Semua 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 30 Sep 2016

Kerentanan pengungkapan informasi dalam Mediaserver

Kerentanan pengungkapan informasi dalam Mediaserver dapat memungkinkan aplikasi jahat lokal untuk mengakses data di luar tingkat izinnya. Masalah ini dinilai sebagai Sedang karena dapat digunakan untuk mengakses data sensitif tanpa izin.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-6773 A-30481714 [ 2 ] Moderat Semua 6.0, 6.0.1, 7.0 27 Jul 2016

Kerentanan pengungkapan informasi dalam Package Manager

Kerentanan pengungkapan informasi dalam Package Manager dapat memungkinkan aplikasi jahat lokal untuk memintas perlindungan sistem operasi yang mengisolasi data aplikasi dari aplikasi lain. Masalah ini dinilai sebagai Sedang karena pertama-tama membutuhkan proses istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-6774 A-31251489 Moderat Semua 7.0 29 Agustus 2016

Tingkat keamanan patch 2016-12-05 — Detail kerentanan

Pada bagian di bawah ini, kami memberikan perincian untuk masing-masing kerentanan keamanan yang berlaku untuk tingkat patch 2016-12-05. Ada deskripsi masalah, alasan keparahan, dan tabel dengan CVE, referensi terkait, keparahan, perangkat Google yang diperbarui, versi AOSP yang diperbarui (jika berlaku), dan tanggal yang dilaporkan. Jika tersedia, kami akan menautkan perubahan publik yang menangani masalah ini ke ID bug, seperti daftar perubahan AOSP. Ketika beberapa perubahan terkait dengan satu bug, referensi tambahan ditautkan ke nomor setelah ID bug.

Peningkatan kerentanan hak istimewa dalam subsistem memori kernel

Peningkatan kerentanan hak istimewa dalam subsistem memori kernel dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Kritis karena kemungkinan kompromi perangkat permanen lokal, yang mungkin memerlukan reflashing sistem operasi untuk memperbaiki perangkat.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-4794 A-31596597
Kernel upstream [ 2 ]
Kritis Pixel C, Pixel, Pixel XL 17 Apr 2016
CVE-2016-5195 A-32141528
Kernel upstream [ 2 ]
Kritis Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Pemain Nexus, Pixel, Pixel XL 12 Okt 2016

Peningkatan kerentanan hak istimewa pada driver GPU NVIDIA

Peningkatan kerentanan hak istimewa pada driver GPU NVIDIA dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Kritis karena kemungkinan kompromi perangkat permanen lokal, yang mungkin memerlukan reflashing sistem operasi untuk memperbaiki perangkat.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-6775 A-31222873 *
N-CVE-2016-6775
Kritis Nexus 9 25 Agustus 2016
CVE-2016-6776 A-31680980 *
N-CVE-2016-6776
Kritis Nexus 9 22 Sep 2016
CVE-2016-6777 A-31910462 *
N-CVE-2016-6777
Kritis Nexus 9 3 Okt 2016

* Tambalan untuk masalah ini tidak tersedia untuk umum. Pembaruan terkandung dalam driver biner terbaru untuk perangkat Google yang tersedia dari situs Pengembang Google .

Peningkatan kerentanan hak istimewa di kernel

Peningkatan kerentanan hak istimewa di kernel dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Kritis karena kemungkinan kompromi perangkat permanen lokal, yang mungkin memerlukan reflashing sistem operasi untuk memperbaiki perangkat.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2015-8966 A-31435731
Kernel upstream
Kritis Tidak ada * 10 Sep 2016

* Perangkat Google yang didukung pada Android 7.0 atau yang lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa dalam driver video NVIDIA

Peningkatan kerentanan hak istimewa dalam driver video NVIDIA dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Kritis karena kemungkinan kompromi perangkat permanen lokal, yang mungkin memerlukan reflashing sistem operasi untuk memperbaiki perangkat.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-6915 A-31471161 *
N-CVE-2016-6915
Kritis Nexus 9 13 Sep 2016
CVE-2016-6916 A-32072350 *
N-CVE-2016-6916
Kritis Nexus 9, Pixel C 13 Sep 2016
CVE-2016-6917 A-32072253 *
N-CVE-2016-6917
Kritis Nexus 9 13 Sep 2016

* Tambalan untuk masalah ini tidak tersedia untuk umum. Pembaruan terkandung dalam driver biner terbaru untuk perangkat Google yang tersedia dari situs Pengembang Google .

Peningkatan kerentanan hak istimewa pada driver ION kernel

Peningkatan kerentanan hak istimewa pada driver ION kernel dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Kritis karena kemungkinan kompromi perangkat permanen lokal, yang mungkin memerlukan reflashing sistem operasi untuk memperbaiki perangkat.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-9120 A-31568617
Kernel upstream
Kritis Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel C, Nexus Player 16 Sep 2016

Kerentanan dalam komponen Qualcomm

Kerentanan berikut memengaruhi komponen Qualcomm dan dijelaskan lebih lanjut dalam buletin keamanan Qualcomm AMSS November 2015.

CVE Referensi Kerasnya* Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-8411 A-31805216 ** Kritis Nexus 6, Nexus 6P, Android One Qualcomm internal

* Tingkat keparahan untuk kerentanan ini ditentukan oleh vendor.

** Tambalan untuk masalah ini tidak tersedia untuk umum. Pembaruan terkandung dalam driver biner terbaru untuk perangkat Google yang tersedia dari situs Pengembang Google .

Peningkatan kerentanan hak istimewa dalam sistem file kernel

Peningkatan kerentanan hak istimewa dalam sistem file kernel dapat memungkinkan aplikasi jahat lokal untuk memintas perlindungan sistem operasi yang mengisolasi data aplikasi dari aplikasi lain. Masalah ini dinilai Tinggi karena dapat digunakan untuk mendapatkan akses lokal ke kapabilitas yang ditinggikan, yang biasanya tidak dapat diakses oleh aplikasi pihak ketiga.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2014-4014 A-31252187
Kernel upstream
Tinggi Nexus 6, Nexus Player 10 Juni 2014

Peningkatan kerentanan hak istimewa di kernel

Peningkatan kerentanan hak istimewa di kernel dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama membutuhkan eksploitasi kerentanan yang terpisah.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2015-8967 A-31703084
Kernel upstream
Tinggi Nexus 5X, Nexus 6P, Nexus 9, Pixel C, Pixel, Pixel XL 8 Januari 2015

Peningkatan kerentanan hak istimewa pada driver codec suara HTC

Peningkatan kerentanan hak istimewa pada driver codec suara HTC dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Tinggi karena pertama-tama membutuhkan kompromi proses yang istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-6778 A-31384646 * Tinggi Nexus 9 25 Feb 2016
CVE-2016-6779 A-31386004 * Tinggi Nexus 9 25 Feb 2016
CVE-2016-6780 A-31251496 * Tinggi Nexus 9 30 Agustus 2016

* Tambalan untuk masalah ini tidak tersedia untuk umum. Pembaruan terkandung dalam driver biner terbaru untuk perangkat Google yang tersedia dari situs Pengembang Google .

Peningkatan kerentanan hak istimewa pada driver MediaTek

Peningkatan kerentanan hak istimewa pada driver MediaTek dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Tinggi karena pertama-tama membutuhkan kompromi proses yang istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-6492 A-28175122
MT-ALPS02696413
Tinggi Tidak ada * 11 Apr 2016
CVE-2016-6781 A-31095175
MT-ALPS02943455
Tinggi Tidak ada * 22 Agustus 2016
CVE-2016-6782 A-31224389
MT-ALPS02943506
Tinggi Tidak ada * 24 Agustus 2016
CVE-2016-6783 A-31350044
MT-ALPS02943437
Tinggi Tidak ada * 6 Sep 2016
CVE-2016-6784 A-31350755
MT-ALPS02961424
Tinggi Tidak ada * 6 Sep 2016
CVE-2016-6785 A-31748056
MT-ALPS02961400
Tinggi Tidak ada * 25 Sep 2016

* Perangkat Google yang didukung pada Android 7.0 atau yang lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa dalam codec media Qualcomm

Peningkatan kerentanan hak istimewa dalam codec media Qualcomm dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks proses istimewa. Masalah ini dinilai Tinggi karena dapat digunakan untuk mendapatkan akses lokal ke kemampuan yang ditingkatkan, yang biasanya tidak dapat diakses oleh aplikasi pihak ketiga.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-6761 A-29421682 *
QC-CR # 1055792
Tinggi Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pemutar Nexus, Pixel, Pixel XL 16 Jun 2016
CVE-2016-6760 A-29617572 *
QC-CR # 1055783
Tinggi Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pemutar Nexus, Pixel, Pixel XL 23 Jun 2016
CVE-2016-6759 A-29982686 *
QC-CR # 1055766
Tinggi Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pemutar Nexus, Pixel, Pixel XL 4 Jul 2016
CVE-2016-6758 A-30148882 *
QC-CR # 1071731
Tinggi Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pemutar Nexus, Pixel, Pixel XL 13 Jul 2016

* Tambalan untuk masalah ini tidak tersedia untuk umum. Pembaruan terkandung dalam driver biner terbaru untuk perangkat Google yang tersedia dari situs Pengembang Google .

Ketinggian kerentanan hak istimewa pada driver kamera Qualcomm

Peningkatan kerentanan hak istimewa pada driver kamera Qualcomm dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Tinggi karena pertama-tama membutuhkan kompromi proses yang istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-6755 A-30740545
QC-CR # 1065916
Tinggi Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 3 Agustus 2016

Peningkatan kerentanan hak istimewa dalam subsistem kinerja kernel

Peningkatan kerentanan hak istimewa dalam subsistem kinerja kernel dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Tinggi karena pertama-tama membutuhkan kompromi proses yang istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-6786 A-30955111 Kernel upstream Tinggi Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Pemain Nexus, Pixel, Pixel XL 18 Agustus 2016
CVE-2016-6787 A-31095224 Kernel upstream Tinggi Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Pemain Nexus, Pixel, Pixel XL 22 Agustus 2016

Ketinggian kerentanan hak istimewa dalam driver MediaTek I2C

Peningkatan kerentanan hak istimewa pada driver MediaTek I2C dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Tinggi karena pertama-tama membutuhkan kompromi proses yang istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-6788 A-31224428
MT-ALPS02943467
Tinggi Tidak ada * 24 Agustus 2016

* Perangkat Google yang didukung pada Android 7.0 atau yang lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa di perpustakaan NVIDIA libomx

Peningkatan kerentanan hak istimewa di perpustakaan libomx NVIDIA (libnvomx) dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks proses istimewa. Masalah ini dinilai Tinggi karena dapat digunakan untuk mendapatkan akses lokal ke kemampuan yang ditingkatkan, yang biasanya tidak dapat diakses oleh aplikasi pihak ketiga.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-6789 A-31251973 *
N-CVE-2016-6789
Tinggi Pixel C 29 Agustus 2016
CVE-2016-6790 A-31251628 *
N-CVE-2016-6790
Tinggi Pixel C 28 Agustus 2016

* Tambalan untuk masalah ini tidak tersedia untuk umum. Pembaruan terkandung dalam driver biner terbaru untuk perangkat Google yang tersedia dari situs Pengembang Google .

Peningkatan kerentanan hak istimewa pada driver suara Qualcomm

Peningkatan kerentanan hak istimewa pada driver suara Qualcomm dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Tinggi karena pertama-tama membutuhkan kompromi proses yang istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-6791 A-31252384
QC-CR # 1071809
Tinggi Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 31 Agustus 2016
CVE-2016-8391 A-31253255
QC-CR # 1072166
Tinggi Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 31 Agustus 2016
CVE-2016-8392 A-31385862
QC-CR # 1073136
Tinggi Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 8 Sep 2016

Peningkatan kerentanan hak istimewa dalam subsistem keamanan kernel

Peningkatan kerentanan hak istimewa dalam subsistem keamanan kernel dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Tinggi karena pertama-tama membutuhkan kompromi proses yang istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2015-7872 A-31253168
Kernel upstream
Tinggi Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pemutar Nexus, Pixel, Pixel XL 31 Agustus 2016

Peningkatan kerentanan hak istimewa dalam driver layar sentuh Synaptics

Peningkatan kerentanan hak istimewa dalam driver layar sentuh Synaptics dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Tinggi karena pertama-tama membutuhkan kompromi proses yang istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-8393 A-31911920 * Tinggi Nexus 5X, Nexus 6P, Nexus 9, Android One, Pixel, Pixel XL 8 Sep 2016
CVE-2016-8394 A-31913197 * Tinggi Nexus 9, Android One 8 Sep 2016

* Tambalan untuk masalah ini tidak tersedia untuk umum. Pembaruan terkandung dalam driver biner terbaru untuk perangkat Google yang tersedia dari situs Pengembang Google .

Ketinggian kerentanan hak istimewa dalam driver Wi-Fi Broadcom

Peningkatan kerentanan hak istimewa dalam driver Wi-Fi Broadcom dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Tinggi karena pertama-tama membutuhkan kompromi proses yang istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2014-9909 A-31676542
B-RB # 26684
Tinggi Tidak ada * 21 Sep 2016
CVE-2014-9910 A-31746399
B-RB # 26710
Tinggi Tidak ada * 26 Sep 2016

* Perangkat Google yang didukung pada Android 7.0 atau yang lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Kerentanan pengungkapan informasi dalam driver video MediaTek

Kerentanan pengungkapan informasi dalam driver video MediaTek dapat memungkinkan aplikasi jahat lokal untuk mengakses data di luar tingkat izinnya. Masalah ini dinilai Tinggi karena dapat digunakan untuk mengakses data sensitif tanpa izin pengguna eksplisit.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-8396 A-31249105 Tinggi Tidak ada * 26 Agustus 2016

* Perangkat Google yang didukung pada Android 7.0 atau yang lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Kerentanan pengungkapan informasi dalam driver video NVIDIA

Kerentanan pengungkapan informasi dalam driver video NVIDIA dapat memungkinkan aplikasi jahat lokal untuk mengakses data di luar tingkat izinnya. Masalah ini dinilai Tinggi karena dapat digunakan untuk mengakses data sensitif tanpa izin pengguna eksplisit.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-8397 A-31385953 *
N-CVE-2016-8397
Tinggi Nexus 9 8 Sep 2016

* Tambalan untuk masalah ini tidak tersedia untuk umum. Pembaruan terkandung dalam driver biner terbaru untuk perangkat Google yang tersedia dari situs Pengembang Google .

Penolakan kerentanan layanan dalam GPS

Penolakan kerentanan layanan dalam komponen GPS Qualcomm dapat memungkinkan penyerang jarak jauh menyebabkan perangkat hang atau reboot. Masalah ini dinilai sebagai Tinggi karena kemungkinan penolakan layanan sementara jarak jauh.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-5341 A-31470303 * Tinggi Nexus 6, Nexus 5X, Nexus 6P, Nexus 9, Android One, Pixel, Pixel XL 21 Jun 2016

* Tambalan untuk masalah ini tidak tersedia untuk umum. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Denial of service vulnerability in NVIDIA camera driver

A denial of service vulnerability in the NVIDIA camera driver could enable an attacker to cause a local permanent denial of service, which may require reflashing the operating system to repair the device. This issue is rated as High due to the possibility of local permanent denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-8395 A-31403040*
N-CVE-2016-8395
High Pixel C Sep 9, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Elevation of privilege vulnerability in kernel networking subsystem

An elevation of privilege vulnerability in the kernel networking subsystem could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and current compiler optimizations restrict access to the vulnerable code.

CVE References Severity Updated Google devices Date reported
CVE-2016-8399 A-31349935* Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 5, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm components

An information disclosure vulnerability in Qualcomm components including the camera driver and video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-6756 A-29464815
QC-CR#1042068 [ 2 ]
Moderate Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL Jun 17, 2016
CVE-2016-6757 A-30148242
QC-CR#1052821
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL Jul 13, 2016

Information disclosure vulnerability in NVIDIA librm library

An information disclosure vulnerability in the NVIDIA librm library (libnvrm) could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it could be used to access sensitive data without permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-8400 A-31251599*
N-CVE-2016-8400
Moderate Pixel C Aug 29, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Information disclosure vulnerability in kernel components

An information disclosure vulnerability in kernel components including the ION subsystem, Binder, USB driver and networking subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8401 A-31494725* Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 13, 2016
CVE-2016-8402 A-31495231* Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 13, 2016
CVE-2016-8403 A-31495348* Moderate Nexus 9 Sep 13, 2016
CVE-2016-8404 A-31496950* Moderate Nexus 9 Sep 13, 2016
CVE-2016-8405 A-31651010* Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 21, 2016
CVE-2016-8406 A-31796940* Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 27, 2016
CVE-2016-8407 A-31802656* Moderate Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL Sep 28, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Information disclosure vulnerability in NVIDIA video driver

An information disclosure vulnerability in the NVIDIA video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8408 A-31496571*
N-CVE-2016-8408
Moderate Nexus 9 Sep 13, 2016
CVE-2016-8409 A-31495687*
N-CVE-2016-8409
Moderate Nexus 9 Sep 13, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8410 A-31498403
QC-CR#987010
Moderate Nexus 5X, Nexus 6, Nexus 6P, Android One Google internal

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2016-12-01 or later address all issues associated with the 2016-12-01 security patch level.
  • Security patch levels of 2016-12-05 or later address all issues associated with the 2016-12-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2016-12-01]
  • [ro.build.version.security_patch]:[2016-12-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the December 1, 2016 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of December 5, 2016 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2016-12-01 and 2016-12-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • December 05, 2016: Bulletin published.
  • December 07, 2016: Bulletin revised to include AOSP links and updated attribution for CVE-2016-6915, CVE-2016-6916 and CVE-2016-6917.
  • December 21, 2016: Corrected typos in CVE-2016-8411 description and Common Questions and Answers.