Google berkomitmen untuk mendorong terwujudnya keadilan ras bagi komunitas Kulit Hitam. Lihat caranya.

Buletin Keamanan Android — April 2017

Dipublikasikan pada 03 April 2017 | Diperbarui 17 Agustus 2017

Buletin Keamanan Android berisi detail kerentanan keamanan yang memengaruhi perangkat Android. Bersamaan dengan buletin tersebut, kami telah merilis pembaruan keamanan untuk perangkat Nexus melalui pembaruan melalui udara (OTA). Gambar firmware perangkat Google juga telah dirilis ke situs Pengembang Google . Tingkat patch keamanan pada 05 April 2017 atau yang lebih baru mengatasi semua masalah ini. Lihat jadwal pembaruan Pixel dan Nexus untuk mempelajari cara memeriksa tingkat patch keamanan perangkat.

Mitra diberi tahu tentang masalah yang dijelaskan dalam buletin pada 06 Maret 2017 atau sebelumnya. Patch kode sumber untuk masalah ini telah dirilis ke repositori Android Open Source Project (AOSP) dan ditautkan dari buletin ini. Buletin ini juga menyertakan tautan ke tambalan di luar AOSP.

Masalah yang paling parah dari masalah ini adalah kerentanan keamanan kritis yang dapat mengaktifkan eksekusi kode jarak jauh pada perangkat yang terpengaruh melalui beberapa metode seperti email, penjelajahan web, dan MMS saat memproses file media. Penilaian tingkat keparahan didasarkan pada efek yang mengeksploitasi kerentanan pada perangkat yang terpengaruh, dengan asumsi platform dan mitigasi layanan dinonaktifkan untuk tujuan pengembangan atau jika berhasil dilewati.

Kami tidak memiliki laporan tentang eksploitasi pelanggan aktif atau penyalahgunaan masalah yang baru dilaporkan ini. Lihat bagian mitigasi layanan Android dan Google untuk detail tentang perlindungan platform keamanan Android dan perlindungan layanan seperti SafetyNet , yang meningkatkan keamanan platform Android.

Kami mendorong semua pelanggan untuk menerima pembaruan ini ke perangkat mereka.

Pengumuman

  • Buletin ini memiliki dua string level patch keamanan untuk memberikan fleksibilitas kepada partner Android agar lebih cepat memperbaiki subset kerentanan yang serupa di semua perangkat Android. Lihat pertanyaan dan jawaban umum untuk informasi tambahan:
    • 01-04-2017 : String level patch keamanan parsial. String tingkat patch keamanan ini menunjukkan bahwa semua masalah yang terkait dengan 01-04-2017 (dan semua string tingkat patch keamanan sebelumnya) telah diatasi.
    • 2017-04-05 : String level patch keamanan lengkap. String level patch keamanan ini menunjukkan bahwa semua masalah yang terkait dengan 2017-04-01 dan 2017-04-05 (dan semua string level patch keamanan sebelumnya) telah diatasi.
  • Perangkat Google yang didukung akan menerima pembaruan OTA tunggal dengan level patch keamanan 05 April 2017.

Android dan Mitigasi Layanan Google

Ini adalah ringkasan mitigasi yang disediakan oleh platform keamanan Android dan perlindungan layanan seperti SafetyNet. Kemampuan ini mengurangi kemungkinan kerentanan keamanan berhasil dieksploitasi di Android.

  • Eksploitasi untuk banyak masalah di Android menjadi lebih sulit dengan peningkatan di versi platform Android yang lebih baru. Kami mendorong semua pengguna untuk memperbarui ke versi terbaru Android jika memungkinkan.
  • Tim Keamanan Android secara aktif memantau penyalahgunaan dengan Verify Apps dan SafetyNet , yang dirancang untuk memperingatkan pengguna tentang Aplikasi yang Berpotensi Berbahaya . Verifikasi Aplikasi diaktifkan secara default di perangkat dengan Layanan Seluler Google dan sangat penting bagi pengguna yang memasang aplikasi dari luar Google Play. Alat rooting perangkat dilarang di dalam Google Play, tetapi Verify Apps memperingatkan pengguna saat mereka mencoba memasang aplikasi rooting yang terdeteksi — dari mana pun asalnya. Selain itu, Verifikasi Aplikasi mencoba mengidentifikasi dan memblokir penginstalan aplikasi berbahaya yang diketahui yang mengeksploitasi kerentanan eskalasi hak istimewa. Jika aplikasi semacam itu telah diinstal, Verifikasi Aplikasi akan memberi tahu pengguna dan mencoba menghapus aplikasi yang terdeteksi.
  • Jika sesuai, aplikasi Google Hangouts dan Messenger tidak secara otomatis meneruskan media ke proses seperti Mediaserver.

Ucapan Terima Kasih

Kami ingin berterima kasih kepada para peneliti ini atas kontribusinya:

  • Aravind Machiry (donfos) dari Tim Shellphish Grill: CVE-2016-5349
  • Daxing Guo ( @ freener0 ) dari Xuanwu Lab, Tencent: CVE-2017-0585, CVE-2017-0553
  • Derrek ( @ derrekr6 ) dan Scott Bauer: CVE-2017-0576
  • Gal Beniamini dari Project Zero: CVE-2017-0571, CVE-2017-0570, CVE-2017-0572, CVE-2017-0569, CVE-2017-0561
  • Gengjia Chen ( @ chengjia4574 ) dan pjf dari IceSword Lab, Qihoo 360 Technology Co. Ltd .: CVE-2017-6426, CVE-2017-0581, CVE-2017-0329, CVE-2017-0332, CVE-2017-0566, CVE-2017-0573
  • Guang Gong (龚 广) ( @oldfresher ) dari Tim Alpha, Qihoo 360 Technology Co. Ltd .: CVE-2017-0547
  • Hao Chen dan Guang Gong dari Alpha Team, Qihoo 360 Technology Co. Ltd .: CVE-2017-6424, CVE-2017-0584, CVE-2017-0454, CVE-2017-0574, CVE-2017-0575, CVE-2017 -0567
  • Ian Foster ( @lanrat ): CVE-2017-0554
  • Jack Tang dari Trend Micro Inc.: CVE-2017-0579
  • Jianjun Dai ( @Jioun_dai ) dari Qihoo 360 Skyeye Labs : CVE-2017-0559, CVE-2017-0541
  • Jianqiang Zhao ( @jianqiangzhao ) dan pjf dari IceSword Lab, Qihoo 360: CVE-2017-6425, CVE-2016-5346
  • Lubo Zhang ( zlbzlb815@163.com ) dari Tim C0RE dan Yonggang Guo ( @guoygang ) dari IceSword Lab, Qihoo 360 Technology Co. Ltd .: CVE-2017-0564
  • Mark Salyzyn dari Google: CVE-2017-0558
  • Mike Andereson ( @manderbot ) dan Nathan Crandall ( @natecray ) dari Tim Keamanan Produk Tesla: CVE-2017-0327, CVE-2017-0328
  • Peng Xiao, Chengming Yang, Ning You, Chao Yang, dan Yang lagu Alibaba Mobile Security Group: CVE-2017-0565
  • Pengfei Ding (丁鹏飞), Chenfu Bao (包 沉浮), dan Lenx Wei (韦 韬) dari Baidu X-Lab (百度 安全 实验室): CVE-2016-10236
  • Qidan He (何 淇 丹 - @flanker_hqd ) dari KeenLab, Tencent: CVE-2017-0544, CVE-2017-0325
  • Roee Hay ( @roeehay ) dari Aleph Research, HCL Technologies: CVE-2017-0582, CVE-2017-0563
  • Scott Bauer ( @ ScottyBauer1 ): CVE-2017-0562, CVE-2017-0339
  • Seven Shen ( @lingtongshen ) dari TrendMicro Mobile Threat Research Team: CVE-2016-10231, CVE-2017-0578, CVE-2017-0586
  • Tim Becker: CVE-2017-0546
  • Uma Sankar Pradhan ( @umasankar_iitd ): CVE-2017-0560
  • VEO ( @VYSEa ) dari Tim Respons Ancaman Seluler , Trend Micro : CVE-2017-0555, CVE-2017-0538, CVE-2017-0539, CVE-2017-0557, CVE-2017-0556
  • Weichao Sun ( @sunblate ) dari Alibaba Inc: CVE-2017-0549
  • Wenlin Yang ( @wenlin_yang ), Guang Gong ( @oldfresher ), dan Hao Chen dari Alpha Team, Qihoo 360 Technology Co. Ltd .: CVE-2017-0580, CVE-2017-0577
  • Zinuo Han dari Pusat Respons Keamanan Chengdu di Qihoo 360 Technology Co. Ltd .: CVE-2017-0548
  • Zubin Mithra dari Google: CVE-2017-0462

Tanggal 01-04-2017 tingkat patch keamanan — Detail kerentanan

Pada bagian di bawah ini, kami memberikan detail untuk setiap kerentanan keamanan yang berlaku untuk tingkat patch 2017-04-01. Ada deskripsi masalah, alasan keparahan, dan tabel dengan CVE, referensi terkait, tingkat keparahan, perangkat Google yang diperbarui, versi AOSP yang diperbarui (jika berlaku), dan tanggal dilaporkan. Jika tersedia, kami akan menautkan perubahan publik yang membahas masalah tersebut ke ID bug, seperti daftar perubahan AOSP. Ketika beberapa perubahan terkait dengan satu bug, referensi tambahan ditautkan ke nomor setelah ID bug.

Kerentanan eksekusi kode jarak jauh di Mediaserver

Kerentanan eksekusi kode jarak jauh di Mediaserver dapat memungkinkan penyerang menggunakan file yang dibuat khusus untuk menyebabkan kerusakan memori selama file media dan pemrosesan data. Masalah ini dinilai sebagai Kritis karena kemungkinan eksekusi kode jarak jauh dalam konteks proses Mediaserver.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0538 A-33641588 Kritis Semua 6.0, 6.0.1, 7.0, 7.1.1 13 Desember 2016
CVE-2017-0539 A-33864300 Kritis Semua 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 23 Desember 2016
CVE-2017-0541 A-34031018 Kritis Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 1 Jan 2017
CVE-2017-0542 A-33934721 Kritis Semua 6.0, 6.0.1, 7.0, 7.1.1 Google internal
CVE-2017-0543 A-34097866 Kritis Semua 6.0, 6.0.1, 7.0, 7.1.1 Google internal

Peningkatan kerentanan hak istimewa di CameraBase

Peningkatan kerentanan hak istimewa di CameraBase dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer. Masalah ini dinilai Tinggi karena merupakan eksekusi kode arbitrer lokal dalam proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0544 A-31992879 Tinggi Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 6 Oktober 2016

Peningkatan kerentanan hak istimewa di Audioserver

Peningkatan kerentanan hak istimewa di Audioserver dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks proses yang memiliki hak istimewa. Masalah ini dinilai Tinggi karena dapat digunakan untuk mendapatkan akses lokal ke kapabilitas yang ditingkatkan, yang biasanya tidak dapat diakses oleh aplikasi pihak ketiga.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0545 A-32591350 Tinggi Semua 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 31 Oktober 2016

Peningkatan kerentanan hak istimewa di SurfaceFlinger

Peningkatan kerentanan hak istimewa di SurfaceFlinger dapat mengaktifkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks proses yang memiliki hak istimewa. Masalah ini dinilai Tinggi karena dapat digunakan untuk mendapatkan akses lokal ke kapabilitas yang ditingkatkan, yang biasanya tidak dapat diakses oleh aplikasi pihak ketiga.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0546 A-32628763 Tinggi Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2 November 2016

Kerentanan pengungkapan informasi di Mediaserver

Kerentanan pengungkapan informasi di Mediaserver dapat memungkinkan aplikasi berbahaya lokal untuk mengakses data di luar tingkat izinnya. Masalah ini dinilai Tinggi karena merupakan jalan pintas umum untuk perlindungan sistem operasi yang mengisolasi data aplikasi dari aplikasi lain.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0547 A-33861560 Tinggi Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 22 Desember 2016

Kerentanan penolakan layanan di libskia

Kerentanan penolakan layanan jarak jauh di libskia dapat memungkinkan penyerang menggunakan file yang dibuat khusus untuk menyebabkan perangkat hang atau reboot. Masalah ini dinilai sebagai Tingkat keseriusan tinggi karena kemungkinan penolakan layanan dari jarak jauh.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0548 A-33251605 Tinggi Semua 7.0, 7.1.1 29 November 2016

Kerentanan penolakan layanan di Mediaserver

Kerentanan penolakan layanan jarak jauh di Mediaserver dapat memungkinkan penyerang menggunakan file yang dibuat khusus untuk menyebabkan perangkat hang atau reboot. Masalah ini dinilai sebagai Tingkat keseriusan tinggi karena kemungkinan penolakan layanan dari jarak jauh.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0549 A-33818508 Tinggi Semua 6.0, 6.0.1, 7.0, 7.1.1 20 Desember 2016
CVE-2017-0550 A-33933140 Tinggi Semua 6.0, 6.0.1, 7.0, 7.1.1 Google internal
CVE-2017-0551 A-34097231 [ 2 ] Tinggi Semua 6.0, 6.0.1, 7.0, 7.1.1 Google internal
CVE-2017-0552 A-34097915 Tinggi Semua 6.0, 6.0.1, 7.0, 7.1.1 Google internal

Peningkatan kerentanan hak istimewa di libnl

Peningkatan kerentanan hak istimewa di libnl dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks layanan Wi-Fi. Masalah ini dinilai Sedang karena pertama-tama memerlukan kompromi proses yang memiliki hak istimewa dan diatasi oleh konfigurasi platform saat ini.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0553 A-32342065 Moderat Semua 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 21 Oktober 2016

Peningkatan kerentanan hak istimewa di Teleponi

Peningkatan kerentanan hak istimewa dalam komponen Telefoni dapat memungkinkan aplikasi jahat lokal mengakses kemampuan di luar tingkat izinnya. Masalah ini dinilai Sedang karena dapat digunakan untuk mendapatkan akses ke kemampuan yang ditingkatkan, yang biasanya tidak dapat diakses oleh aplikasi pihak ketiga.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0554 A-33815946 [ 2 ] Moderat Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 20 Desember 2016

Kerentanan pengungkapan informasi di Mediaserver

Kerentanan pengungkapan informasi di Mediaserver dapat memungkinkan aplikasi berbahaya lokal untuk mengakses data di luar tingkat izinnya. Masalah ini dinilai Sedang karena dapat digunakan untuk mengakses data tanpa izin.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0555 A-33551775 Moderat Semua 6.0, 6.0.1, 7.0, 7.1.1 12 Desember 2016
CVE-2017-0556 A-34093952 Moderat Semua 6.0, 6.0.1, 7.0, 7.1.1 4 Jan 2017
CVE-2017-0557 A-34093073 Moderat Semua 6.0, 6.0.1, 7.0, 7.1.1 4 Jan 2017
CVE-2017-0558 A-34056274 Moderat Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google internal

Kerentanan pengungkapan informasi di libskia

Kerentanan pengungkapan informasi di libskia dapat memungkinkan aplikasi jahat lokal mengakses data di luar tingkat izinnya. Masalah ini dinilai Sedang karena dapat digunakan untuk mengakses data tanpa izin.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0559 A-33897722 Moderat Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 Desember 2016

Kerentanan pengungkapan informasi di Factory Reset

Kerentanan pengungkapan informasi dalam proses pengaturan ulang pabrik dapat memungkinkan penyerang lokal untuk mengakses data dari pemilik sebelumnya. Masalah ini dinilai Sedang karena kemungkinan melewati perlindungan perangkat.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2017-0560 A-30681079 Moderat Semua 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google internal

05-04-2017 Tingkat patch keamanan — Detail kerentanan

Pada bagian di bawah ini, kami memberikan detail untuk setiap kerentanan keamanan yang berlaku untuk level patch 2017-04-05. Ada deskripsi masalah, alasan keparahan, dan tabel dengan CVE, referensi terkait, tingkat keparahan, perangkat Google yang diperbarui, versi AOSP yang diperbarui (jika ada), dan tanggal dilaporkan. Jika tersedia, kami akan menautkan perubahan publik yang membahas masalah tersebut ke ID bug, seperti daftar perubahan AOSP. Ketika beberapa perubahan terkait dengan satu bug, referensi tambahan ditautkan ke nomor setelah ID bug.

Kerentanan eksekusi kode jarak jauh di firmware Wi-Fi Broadcom

Kerentanan eksekusi kode jarak jauh dalam firmware Wi-Fi Broadcom dapat memungkinkan penyerang jarak jauh untuk mengeksekusi kode arbitrer dalam konteks SoC Wi-Fi. Masalah ini dinilai sebagai Kritis karena kemungkinan eksekusi kode jarak jauh dalam konteks SoC Wi-Fi.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0561 A-34199105 *
B-RB # 110814
Kritis Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 Jan 2017

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

Kerentanan eksekusi kode jarak jauh di driver mesin kripto Qualcomm

Kerentanan eksekusi kode jarak jauh dalam driver mesin kripto Qualcomm dapat memungkinkan penyerang jarak jauh untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Kritis karena kemungkinan eksekusi kode jarak jauh dalam konteks kernel.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-10230 A-34389927
QC-CR # 1091408
Kritis Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 10 Jan 2017

Kerentanan eksekusi kode jarak jauh di subsistem jaringan kernel

Kerentanan eksekusi kode jarak jauh dalam subsistem jaringan kernel dapat memungkinkan penyerang jarak jauh untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Kritis karena kemungkinan eksekusi kode jarak jauh dalam konteks kernel.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-10229 A-32813456
Kernel hulu
Kritis Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Google internal

Peningkatan kerentanan hak istimewa dalam driver layar sentuh MediaTek

Peningkatan kerentanan hak istimewa di driver layar sentuh MediaTek dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Kritis karena kemungkinan kompromi perangkat permanen lokal, yang mungkin memerlukan pemantulan ulang sistem operasi untuk memperbaiki perangkat.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0562 A-30202425 *
M-ALPS02898189
Kritis* Tidak ada ** 16 Juli 2016

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

** Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa pada driver layar sentuh HTC

Peningkatan kerentanan hak istimewa di driver layar sentuh HTC dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Kritis karena kemungkinan kompromi perangkat permanen lokal, yang mungkin memerlukan pemantulan ulang sistem operasi untuk memperbaiki perangkat.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0563 A-32089409 *
Kritis Nexus 9 9 Oktober 2016

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

Peningkatan kerentanan hak istimewa di subsistem kernel ION

Peningkatan kerentanan hak istimewa di subsistem kernel ION dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai sebagai Kritis karena kemungkinan kompromi perangkat permanen lokal, yang mungkin memerlukan pemantulan ulang sistem operasi untuk memperbaiki perangkat.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0564 A-34276203 *
Kritis Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player 12 Jan 2017

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

Kerentanan dalam komponen Qualcomm

Kerentanan ini memengaruhi komponen Qualcomm dan dijelaskan secara lebih rinci di buletin keamanan Qualcomm AMSS Oktober 2016.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-10237 A-31628601 **
QC-CR # 1046751
Kritis Tidak ada ** Qualcomm internal
CVE-2016-10238 A-35358527 **
QC-CR # 1042558
Kritis Tidak ada *** Qualcomm internal
CVE-2016-10239 A-31624618 **
QC-CR # 1032929
Tinggi Pixel, Pixel XL Qualcomm internal

* Tingkat keparahan kerentanan ini ditentukan oleh vendor.

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

*** Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Kerentanan eksekusi kode jarak jauh di v8

Kerentanan eksekusi kode jarak jauh di v8 dapat memungkinkan penyerang jarak jauh mengeksekusi kode arbitrer dalam konteks proses yang memiliki hak istimewa. Masalah ini dinilai Tinggi karena kemungkinan eksekusi kode jarak jauh di situs web.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-5129 A-29178923 Tinggi Tidak ada * 6.0, 6.0.1, 7.0 20 Juli 2016

* Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Kerentanan eksekusi kode jarak jauh di Freetype

Kerentanan eksekusi kode jarak jauh di Freetype dapat memungkinkan aplikasi jahat lokal memuat font yang dibuat khusus untuk menyebabkan kerusakan memori dalam proses yang tidak memiliki hak istimewa. Masalah ini dinilai Tinggi karena kemungkinan eksekusi kode jarak jauh dalam aplikasi yang menggunakan pustaka ini.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Versi AOSP yang diperbarui Tanggal dilaporkan
CVE-2016-10244 A-31470908 Tinggi Tidak ada * 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 13 Sep 2016

* Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa di subsistem suara kernel

Peningkatan kerentanan hak istimewa dalam subsistem suara kernel dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2014-4656 A-34464977
Kernel hulu
Tinggi Nexus 6, Nexus Player 26 Jun 2014

Peningkatan kerentanan hak istimewa di driver kripto NVIDIA

Peningkatan kerentanan hak istimewa di driver kripto NVIDIA dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0339 A-27930566 *
N-CVE-2017-0339
Tinggi Nexus 9 29 Maret 2016
CVE-2017-0332 A-33812508 *
N-CVE-2017-0332
Tinggi Nexus 9 21 Desember 2016
CVE-2017-0327 A-33893669 *
N-CVE-2017-0327
Tinggi Nexus 9 24 Desember 2016

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

Peningkatan kerentanan hak istimewa di driver termal MediaTek

Peningkatan kerentanan hak istimewa di driver termal MediaTek dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0565 A-28175904 *
M-ALPS02696516
Tinggi Tidak ada ** 11 April 2016

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

** Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa dalam driver kamera MediaTek

Peningkatan kerentanan hak istimewa di driver kamera MediaTek dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0566 A-28470975 *
M-ALPS02696367
Tinggi Tidak ada ** 29 April 2016

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

** Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa dalam driver Wi-Fi Broadcom

Peningkatan kerentanan hak istimewa di driver Wi-Fi Broadcom dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0567 A-32125310 *
B-RB # 112575
Tinggi Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 12 Oktober 2016
CVE-2017-0568 A-34197514 *
B-RB # 112600
Tinggi Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 Jan 2017
CVE-2017-0569 A-34198729 *
B-RB # 110666
Tinggi Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 Jan 2017
CVE-2017-0570 A-34199963 *
B-RB # 110688
Tinggi Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 Jan 2017
CVE-2017-0571 A-34203305 *
B-RB # 111541
Tinggi Nexus 6, Nexus 6P, Pixel C, Nexus Player 9 Jan 2017
CVE-2017-0572 A-34198931 *
B-RB # 112597
Tinggi Tidak ada ** 9 Jan 2017
CVE-2017-0573 A-34469904 *
B-RB # 91539
Tinggi Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 18 Jan 2017
CVE-2017-0574 A-34624457 *
B-RB # 113189
Tinggi Nexus 6, Nexus 6P, Nexus 9, Pixel C 22 Jan 2017

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

** Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa dalam driver Wi-Fi Qualcomm

Peningkatan kerentanan hak istimewa dalam driver Qualcomm Wi-Fi dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0575 A-32658595 *
QC-CR # 1103099
Tinggi Nexus 5X, Pixel, Pixel XL 3 November 2016

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

Peningkatan kerentanan hak istimewa di driver NVIDIA I2C HID

Peningkatan kerentanan hak istimewa di driver NVIDIA I2C HID dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0325 A-33040280 *
N-CVE-2017-0325
Tinggi Nexus 9, Pixel C 20 November 2016

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

Peningkatan kerentanan hak istimewa dalam driver audio Qualcomm

Peningkatan kerentanan hak istimewa di driver audio Qualcomm dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0454 A-33353700
QC-CR # 1104067
Tinggi Nexus 5X, Nexus 6P, Pixel, Pixel XL 5 Desember 2016

Peningkatan kerentanan hak istimewa dalam driver mesin kripto Qualcomm

Peningkatan kerentanan hak istimewa di driver mesin kripto Qualcomm dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0576 A-33544431
QC-CR # 1103089
Tinggi Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 9 Desember 2016

Peningkatan kerentanan hak istimewa pada driver layar sentuh HTC

Peningkatan kerentanan hak istimewa di driver layar sentuh HTC dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0577 A-33842951 *
Tinggi Tidak ada ** 21 Desember 2016

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

** Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa dalam driver suara DTS

Peningkatan kerentanan hak istimewa di pengandar suara DTS dapat mengaktifkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0578 A-33964406 *
Tinggi Tidak ada ** 28 Desember 2016

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

** Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa dalam driver codec suara Qualcomm

Peningkatan kerentanan hak istimewa dalam driver codec suara Qualcomm dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2016-10231 A-33966912
QC-CR # 1096799
Tinggi Pixel, Pixel XL 29 Desember 2016

Peningkatan kerentanan hak istimewa dalam driver video Qualcomm

Peningkatan kerentanan hak istimewa dalam driver video Qualcomm dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0579 A-34125463 *
QC-CR # 1115406
Tinggi Nexus 5X, Nexus 6P, Pixel, Pixel XL 5 Jan 2017
CVE-2016-10232 A-34386696
QC-CR # 1024872 [2]
Tinggi Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One 10 Jan 2017
CVE-2016-10233 A-34389926
QC-CR # 897452
Tinggi Tidak ada ** 10 Jan 2017

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

** Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa di boot NVIDIA dan driver prosesor manajemen daya

Peningkatan kerentanan hak istimewa di boot NVIDIA dan driver prosesor manajemen daya dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks booting dan prosesor manajemen daya. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0329 A-34115304 *
N-CVE-2017-0329
Tinggi Pixel C 5 Jan 2017

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

Peningkatan kerentanan hak istimewa dalam driver layar sentuh Synaptics

Peningkatan kerentanan hak istimewa di driver Synaptics Touchscreen dapat memungkinkan aplikasi berbahaya lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. Masalah ini dinilai Tinggi karena pertama-tama harus dikompromikan dengan proses yang memiliki hak istimewa.

CVE Referensi Kerasnya Perangkat Google yang diperbarui Tanggal dilaporkan
CVE-2017-0580 A-34325986 *
Tinggi Tidak ada ** 16 Jan 2017
CVE-2017-0581 A-34614485 *
Tinggi Tidak ada ** 22 Jan 2017

* Patch untuk masalah ini tidak tersedia untuk umum. Pembaruan terdapat dalam driver biner terbaru untuk perangkat Nexus yang tersedia dari situs Pengembang Google .

** Perangkat Google yang didukung di Android 7.0 atau lebih baru yang telah menginstal semua pembaruan yang tersedia tidak terpengaruh oleh kerentanan ini.

Peningkatan kerentanan hak istimewa di driver Qualcomm Seemp

Peningkatan kerentanan hak istimewa di driver Qualcomm Seemp dapat memungkinkan aplikasi jahat lokal untuk mengeksekusi kode arbitrer dalam konteks kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0462 A-33353601
QC-CR#1102288
High Pixel, Pixel XL Google internal

Elevation of privilege vulnerability in Qualcomm Kyro L2 driver

An elevation of privilege vulnerability in the Qualcomm Kyro L2 driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6423 A-32831370
QC-CR#1103158
High Pixel, Pixel XL Google internal

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-9922 A-32761463
Upstream kernel
High Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Oct 24, 2014

Information disclosure vulnerability in kernel memory subsystem

An information disclosure vulnerability in the kernel memory subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-0206 A-34465735
Upstream kernel
High Nexus 6, Nexus Player May 6, 2014

Information disclosure vulnerability in kernel networking subsystem

An information disclosure vulnerability in the kernel networking subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-3145 A-34469585
Upstream kernel [2]
High Nexus 6, Nexus Player May 9, 2014

Information disclosure vulnerability in Qualcomm TrustZone

An information disclosure vulnerability in the Qualcomm TrustZone could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-5349 A-29083830
QC-CR#1021945 [2] [3] [4]
High Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Jun 1, 2016

Information disclosure vulnerability in Qualcomm IPA driver

An information disclosure vulnerability in the Qualcomm IPA driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-10234 A-34390017
QC-CR#1069060 [2]
High Nexus 5X, Nexus 6P, Pixel, Pixel XL Jan 10, 2017

Denial of service vulnerability in kernel networking subsystem

A denial of service vulnerability in the kernel networking subsystem could enable a remote attacker to use a specially crafted network packet to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2014-2706 A-34160553
Upstream kernel
High Nexus Player Apr 1, 2014

Denial of service vulnerability in Qualcomm Wi-Fi driver

A denial of service vulnerability in the Qualcomm Wi-Fi driver could enable a proximate attacker to cause a denial of service in the Wi-Fi subsystem. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-10235 A-34390620
QC-CR#1046409
High None** Jan 10, 2017

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-7097 A-32458736
Upstream kernel
Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Nexus Player Aug 28, 2016

Elevation of privilege vulnerability in Qualcomm Wi-Fi driver

An elevation of privilege vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and because of vulnerability specific details which limit the impact of the issue.

CVE References Severity Updated Google devices Date reported
CVE-2017-6424 A-32086742
QC-CR#1102648
Moderate Nexus 5X, Pixel, Pixel XL, Android One Oct 9, 2016

Elevation of privilege vulnerability in Broadcom Wi-Fi driver

An elevation of privilege vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-8465 A-32474971*
B-RB#106053
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in HTC OEM fastboot command

An elevation of privilege vulnerability in the HTC OEM fastboot command could enable a local malicious application to execute arbitrary code within the context of the sensor hub. This issue is rated as Moderate because it first requires exploitation of separate vulnerabilities.

CVE References Severity Updated Google devices Date reported
CVE-2017-0582 A-33178836*
Moderate Nexus 9 Nov 28, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Qualcomm CP access driver

An elevation of privilege vulnerability in the Qualcomm CP access driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and because of vulnerability specific details which limit the impact of the issue.

CVE References Severity Updated Google devices Date reported
CVE-2017-0583 A-32068683
QC-CR#1103788
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Google internal

Information disclosure vulnerability in kernel media driver

An information disclosure vulnerability in the kernel media driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-1739 A-34460642
Upstream kernel
Moderate Nexus 6, Nexus 9, Nexus Player Jun 15, 2014

Information disclosure vulnerability in Qualcomm Wi-Fi driver

An information disclosure vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0584 A-32074353*
QC-CR#1104731
Moderate Nexus 5X, Pixel, Pixel XL Oct 9, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Broadcom Wi-Fi driver

An information disclosure vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0585 A-32475556*
B-RB#112953
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm Avtimer driver

An information disclosure vulnerability in the Qualcomm Avtimer driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5346 A-32551280
QC-CR#1097878
Moderate Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm video driver

An information disclosure vulnerability in the Qualcomm video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6425 A-32577085
QC-CR#1103689
Moderate Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm USB driver

An information disclosure vulnerability in the Qualcomm USB driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10236 A-33280689
QC-CR#1102418
Moderate Pixel, Pixel XL Nov 30, 2016

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0586 A-33649808
QC-CR#1097569
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Dec 13, 2016

Information disclosure vulnerability in Qualcomm SPMI driver

An information disclosure vulnerability in the Qualcomm SPMI driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6426 A-33644474
QC-CR#1106842
Moderate Pixel, Pixel XL Dec 14, 2016

Information disclosure vulnerability in NVIDIA crypto driver

An information disclosure vulnerability in the NVIDIA crypto driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0328 A-33898322*
N-CVE-2017-0328
Moderate None** Dec 24, 2016
CVE-2017-0330 A-33899858*
N-CVE-2017-0330
Moderate None** Dec 24, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Vulnerabilities in Qualcomm components

These vulnerabilities affecting Qualcomm components were released as part of Qualcomm AMSS security bulletins between 2014–2016. They are included in this Android security bulletin to associate their fixes with an Android security patch level.

CVE References Severity Updated Google devices Date reported
CVE-2014-9931 A-35445101** Critical None** Qualcomm internal
CVE-2014-9932 A-35434683** Critical Pixel, Pixel XL Qualcomm internal
CVE-2014-9933 A-35442512** Critical None** Qualcomm internal
CVE-2014-9934 A-35439275** Critical None** Qualcomm internal
CVE-2014-9935 A-35444951** Critical None** Qualcomm internal
CVE-2014-9936 A-35442420** Critical None** Qualcomm internal
CVE-2014-9937 A-35445102** Critical None** Qualcomm internal
CVE-2015-8995 A-35445002** Critical None** Qualcomm internal
CVE-2015-8996 A-35444658** Critical None** Qualcomm internal
CVE-2015-8997 A-35432947** Critical None** Qualcomm internal
CVE-2015-8998 A-35441175** Critical None** Qualcomm internal
CVE-2015-8999 A-35445401** Critical None** Qualcomm internal
CVE-2015-9000 A-35441076** Critical None** Qualcomm internal
CVE-2015-9001 A-35445400** Critical None** Qualcomm internal
CVE-2015-9002 A-35442421** Critical None** Qualcomm internal
CVE-2015-9003 A-35440626** Critical None** Qualcomm internal
CVE-2016-10242 A-35434643** Critical None** Qualcomm internal

* The severity rating for these vulnerabilities was determined by the vendor.

** The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

*** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-04-01 or later address all issues associated with the 2017-04-01 security patch level.
  • Security patch levels of 2017-04-05 or later address all issues associated with the 2017-04-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-04-01]
  • [ro.build.version.security_patch]:[2017-04-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the April 01, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of April 05, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-04-01 and 2017-04-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • April 03, 2017: Bulletin published.
  • April 05, 2017: Bulletin revised to include AOSP links.
  • April 21, 2017: Attribution for CVE-2016-10231 and CVE-2017-0586 corrected.
  • April 27, 2017: CVE-2017-0540 removed from bulletin.
  • August 17, 2017: Bulletin revised to update reference numbers.