Android のセキュリティに関する公開情報 - 2018 年 10 月

2018 年 10 月 1 日公開 | 2018 年 10 月 1 日更新

Android のセキュリティに関する公開情報には、Android デバイスに影響を与えるセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2018-10-05 以降では、下記のすべての問題に対処しています。デバイスのセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新するをご覧ください。

Android パートナーには、情報公開の 1 か月前までにすべての問題が通知されます。Android オープンソース プロジェクト(AOSP)リポジトリに、下記の問題に対するソースコードのパッチをリリースしています。また、この公開情報では、これらのパッチへのリンクに加え、AOSP 以外のパッチへのリンクも掲載しています。

下記の問題のうち最も重大度が高いものは、フレームワークに重大なセキュリティの脆弱性があるため、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行できるようになるおそれがあることです。重大度の評価は、攻撃対象のデバイスでその脆弱性が悪用された場合の影響に基づくもので、プラットフォームやサービスでのリスク軽減策が開発目的または不正な回避により無効となっていることを前提としています。

この新たに報告された問題によってユーザーのデバイスが実際に不正使用された報告はありません。Android セキュリティ プラットフォームの保護や Google Play プロテクトについて詳しくは、Android と Google サービスでのリスク軽減策をご覧ください。こうした保護により、Android プラットフォームのセキュリティが改善されます。

注: 最新の無線(OTA)アップデートと Google デバイスのファームウェア イメージについての情報は、2018 年 10 月の Pixel / Nexus のセキュリティに関する公開情報でご覧いただけます。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームGoogle Play プロテクトのようなサービスによる保護でリスクを軽減する手段について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を減らすものです。

  • Android 上の多くの問題の悪用は、Android プラットフォームの最新版で機能が強化されるほど困難になります。Google では、すべてのユーザーに対し、できる限り最新バージョンの Android に更新することをおすすめしています。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、害を及ぼすおそれのあるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載したデバイスでデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとっては特に重要です。

セキュリティ パッチレベル 2018-10-01 の脆弱性の詳細

ここでは、パッチレベル 2018-10-01 に該当するセキュリティ脆弱性の各項目の詳細を説明します。脆弱性は、影響を受けるコンポーネントごとに分類しています。問題の内容について説明し、CVE、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を表にまとめています。該当する場合は、バグ ID の欄に、その問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクを設定しています。

フレームワーク

フレームワークの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9490 A-111274046 [2] EoP 重大 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9491 A-111603051 RCE 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9492 A-111934948 EoP 8.0、8.1、9
CVE-2018-9493 A-111085900 [2] [3] ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9452 A-78464361 [2] DoS 7.0、7.1.1、7.1.2、8.0、8.1、9

メディア フレームワーク

メディア フレームワークの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9473 A-65484460 RCE 重大 8.0
CVE-2018-9496 A-110769924 RCE 重大 9
CVE-2018-9497 A-74078669 RCE 重大 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9498 A-78354855 RCE 重大 7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9499 A-79218474 ID 7.0、7.1.1、7.1.2、8.0、8.1、9

システム

システムの最も重大な脆弱性により、近くにいる攻撃者が特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2017-13283 A-78526423 RCE 重大 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9476 A-109699112 EoP 重大 8.0、8.1
CVE-2018-9504 A-110216176 RCE 重大 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9501 A-110034419 EoP 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9502 A-111936792 [2] [3] ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9503 A-80432928 [2] [3] ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9505 A-110791536 ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9506 A-111803925 ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9507 A-111893951 ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9508 A-111936834 ID 7.0、7.1.1、7.1.2、8.0、8.1
CVE-2018-9509 A-111937027 ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9510 A-111937065 ID 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9511 A-111650288 DoS 9

セキュリティ パッチレベル 2018-10-05 の脆弱性の詳細

ここでは、パッチレベル 2018-10-05 に該当するセキュリティ脆弱性の各項目の詳細を説明します。影響を受けるコンポーネントごとに脆弱性を分類し、CVE、関連する参照先、脆弱性のタイプ重大度、コンポーネント(該当する場合)、更新対象の AOSP バージョン(該当する場合)などの詳細を記載しています。該当する場合は、バグ ID の欄に、その問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に続く番号で、追加の参照先へのリンクを示します。

カーネル コンポーネント

フレームワークの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-9513 A-111081202* EoP Fork
CVE-2018-9514 A-111642636* EoP sdcardfs
CVE-2018-9515 A-111641492* EoP sdcardfs

一般的な質問と回答

上記の公開情報に対する一般的な質問についての回答は以下のとおりです。

1. 上記の問題に対処するようにデバイスが更新されているかどうかを確かめるには、どうすればよいですか?

デバイスのセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新するをご覧ください。

  • セキュリティ パッチレベル 2018-10-01 以降では、セキュリティ パッチレベル 2018-10-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2018-10-05 以降では、セキュリティ パッチレベル 2018-10-05、およびそれ以前のすべてのパッチレベルに関連するすべての問題に対処しています。

このアップデートを組み込んだデバイス メーカーは、パッチレベル文字列を以下に設定する必要があります。

  • [ro.build.version.security_patch]:[2018-10-01]
  • [ro.build.version.security_patch]:[2018-10-05]

2. この公開情報に 2 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、2 つのセキュリティ パッチレベルを定義しています。これは、すべての Android デバイスにまたがる同様の脆弱性をひとまとめにして、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーは、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されています。

  • 2018-10-01 のセキュリティ パッチレベルを使用するデバイスでは、そのセキュリティ パッチレベルに関連するすべての問題と、それ以前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2018-10-05 以降のセキュリティ パッチレベルを使用するデバイスには、今回(およびそれ以前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーは、対処する問題すべてについて、修正を 1 つのアップデートにまとめて提供することが推奨されます。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
N/A 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属す組織を示す接頭辞が含まれる場合があります。

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、「参照」列の Android バグ ID の横に「*」を付けています。この問題のアップデートは、Google デベロッパー サイトから入手できる Pixel / Nexus デバイス用最新バイナリ ドライバに通常含まれています。

6. セキュリティの脆弱性が、この公開情報とデバイスやパートナーのセキュリティに関する公開情報(Pixel / Nexus のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android デバイスの最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要となります。それ以外の、デバイスやパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は必要ありません。SamsungLGE などの Android デバイスやチップセットのメーカーは、自社のデバイスに関して他にも修正がある場合、その情報を自社のセキュリティ関連のウェブサイトや Pixel / Nexus のセキュリティに関する公開情報に掲載することが推奨されています。

バージョン

バージョン 日付 メモ
1.0 2018 年 10 月 1 日 情報公開
1.1 2018 年 10 月 1 日 公開情報を改訂し AOSP リンクを追加