Android のセキュリティに関する公開情報 - 2018 年 12 月

2018 年 12 月 3 日公開 | 2018 年 12 月 5 日更新

Android のセキュリティに関する公開情報には、Android デバイスに影響を及ぼすセキュリティの脆弱性の詳細を掲載しています。セキュリティ パッチレベル 2018-12-05 以降では、下記のすべての問題に対処しています。デバイスのセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新する方法についての記事をご覧ください。

Android パートナーには、情報公開の少なくとも 1 か月前にすべての問題が通知されます。Android オープンソース プロジェクト(AOSP)リポジトリに、下記の問題に対するソースコードのパッチをリリースしています。また、この公開情報では、これらのパッチへのリンクに加え、AOSP 以外のパッチへのリンクも掲載しています。

下記の問題のうち最も重大度の高いものは、メディア フレームワークに重大なセキュリティの脆弱性があるため、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあることです。重大度の評価は、攻撃対象のデバイスでその脆弱性が悪用された場合の影響に基づくもので、プラットフォームやサービスでのリスク軽減策が開発目的または不正な回避により無効となっていることを前提としています。

この新たに報告された問題によってユーザーのデバイスが実際に不正使用された報告はありません。Android プラットフォームのセキュリティの向上に役立つ Android セキュリティ プラットフォームでの保護や Google Play プロテクトについて詳しくは、Android と Google サービスでのリスク軽減策をご覧ください。

注: 最新の無線(OTA)アップデートと Google デバイスのファームウェア イメージについての情報は、2018 年 12 月の Pixel / Nexus のセキュリティに関する公開情報のページでご覧いただけます。

Android と Google サービスでのリスク軽減策

ここでは、Android セキュリティ プラットフォームGoogle Play プロテクトのようなサービスでの保護によってリスクを軽減する手段について概説します。こうした機能は、Android でセキュリティの脆弱性が悪用される可能性を減らすものです。

  • Android 上の多くの問題の悪用は、Android プラットフォームの最新版で機能が強化されるほど困難になります。Google では、すべてのユーザーに対し、できる限り最新バージョンの Android に更新することをおすすめしています。
  • Android セキュリティ チームは、Google Play プロテクトによって脆弱性の悪用を積極的に監視しており、害を及ぼすおそれのあるアプリについてユーザーに警告しています。Google Play プロテクトは、Google モバイル サービスを搭載したデバイスではデフォルトで有効になっており、Google Play 以外からアプリをインストールするユーザーにとっては特に重要です。

セキュリティ パッチレベル 2018-12-01 の脆弱性の詳細

パッチレベル 2018-12-01 に該当するセキュリティ脆弱性の各項目について、下記で詳しく説明します。脆弱性は、影響を受けるコンポーネントごとに分類しています。問題の内容について説明し、CVE、関連する参照先、脆弱性のタイプ重大度、更新対象の AOSP バージョン(該当する場合)を表にまとめています。該当する場合は、バグ ID の欄に、その問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクを設定しています。

フレームワーク

フレームワークの最も重大な脆弱性により、悪意のあるローカルアプリによって特権プロセス内で任意のコードが実行されるおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9547 A-114223584 EoP 8.1、9
CVE-2018-9548 A-112555574 ID 7.0、7.1.1、7.1.2、8.0、8.1、9

メディア フレームワーク

メディア フレームワークの最も重大な脆弱性により、リモートの攻撃者が特別に細工したファイルを使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9549 A-112160868 RCE 重大 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9550 A-112660981 RCE 重大 9
CVE-2018-9551 A-112891548 RCE 重大 9
CVE-2018-9552 A-113260892 ID 重大 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9553 A-116615297 RCE 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9538 A-112181526 EoP 8.1、9
CVE-2018-9554 A-114770654 ID 7.0、7.1.1、7.1.2、8.0、8.1

システム

システムの最も重大な脆弱性により、リモートの攻撃者が特別に細工した通信を使用して、特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 更新対象の AOSP バージョン
CVE-2018-9555 A-112321180 RCE 重大 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9556 A-113118184 RCE 重大 9
CVE-2018-9557 A-35385357* EoP 7.0、7.1.1、7.1.2
CVE-2018-9558 A-112161557 EoP 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9559 A-112731440 EoP 7.0、7.1.1、7.1.2、8.0、8.1、9
CVE-2018-9560 A-79946737 EoP 9
CVE-2018-9562 A-113164621 ID 9
CVE-2018-9566 A-74249842 ID 7.0、7.1.1、7.1.2、8.0、8.1、9

セキュリティ パッチレベル 2018-12-05 の脆弱性の詳細

パッチレベル 2018-12-05 に該当するセキュリティ脆弱性の各項目について、下記で詳しく説明します。影響を受けるコンポーネントごとに脆弱性を分類し、CVE、関連する参照先、脆弱性のタイプ重大度、コンポーネント(該当する場合)、更新対象の AOSP バージョン(該当する場合)などの詳細を記載しています。該当する場合は、バグ ID の欄に、その問題の対処法として一般公開されている変更内容(AOSP の変更の一覧など)へのリンクがあります。複数の変更が同じバグに関係する場合は、バグ ID の後に記載した番号に、追加の参照へのリンクを設定しています。

システム

システムの最も重大な脆弱性により、追加の実行権限を必要とすることなく、リモートで情報が漏えいするおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-9565 A-16680558* ID OMA-DM

HTC コンポーネント

HTC コンポーネントの最も重大な脆弱性により、ローカルの攻撃者によって、追加権限を取得するためのユーザー操作の要件が回避されるおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-9567 A-65543936* EoP ブートローダー

カーネル コンポーネント

カーネル コンポーネントの最も重大な脆弱性により、ローカルの攻撃者が特権プロセス内で任意のコードを実行するおそれがあります。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-10840 A-116406508
アップストリーム カーネル
EoP ext4 ファイル システム
CVE-2018-9568 A-113509306
アップストリーム カーネル
EoP ネットワーク

Qualcomm コンポーネント

Qualcomm コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。これらの問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2018-11960 A-114042002
QC-CR#2264832
なし HWEngines
CVE-2018-11961 A-114040881
QC-CR#2261813
なし GPS_AP_LINUX
CVE-2018-11963 A-114041685
QC-CR#2220770
なし 車載マルチメディア

Qualcomm クローズドソース コンポーネント

Qualcomm コンポーネントに影響する脆弱性は次のとおりです。詳細については、該当する Qualcomm のセキュリティに関する公開情報やセキュリティ アラートをご覧ください。これらの問題の重大度の評価は、Qualcomm から直接提供されたものです。

CVE 参照 タイプ 重大度 コンポーネント
CVE-2017-8248 A-78135902* なし 重大 クローズドソース コンポーネント
CVE-2017-11004 A-66913713* なし 重大 クローズドソース コンポーネント
CVE-2017-18141 A-67712316* なし 重大 クローズドソース コンポーネント
CVE-2018-5913 A-79419833* なし 重大 クローズドソース コンポーネント
CVE-2018-11279 A-109678200* なし 重大 クローズドソース コンポーネント
CVE-2017-18319 A-78284753* なし クローズドソース コンポーネント
CVE-2017-18321 A-78283451* なし クローズドソース コンポーネント
CVE-2017-18322 A-78285196* なし クローズドソース コンポーネント
CVE-2017-18323 A-78284194* なし クローズドソース コンポーネント
CVE-2017-18324 A-78284517* なし クローズドソース コンポーネント
CVE-2017-18327 A-78240177* なし クローズドソース コンポーネント
CVE-2017-18331 A-78239686* なし クローズドソース コンポーネント
CVE-2017-18332 A-78284545* なし クローズドソース コンポーネント
CVE-2017-18160 A-109660689* なし クローズドソース コンポーネント
CVE-2017-18326 A-78240324* なし クローズドソース コンポーネント
CVE-2017-8276 A-68141338* なし クローズドソース コンポーネント
CVE-2017-18328 A-78286046* なし クローズドソース コンポーネント
CVE-2017-18329 A-73539037* なし クローズドソース コンポーネント
CVE-2017-18330 A-73539235* なし クローズドソース コンポーネント
CVE-2018-3595 A-71501115* なし クローズドソース コンポーネント
CVE-2017-18320 A-33757308* なし クローズドソース コンポーネント
CVE-2018-11999 A-74236942* なし クローズドソース コンポーネント
CVE-2018-5867 A-77485184* なし クローズドソース コンポーネント
CVE-2018-5868 A-77484529* なし クローズドソース コンポーネント
CVE-2018-5869 A-33385206* なし クローズドソース コンポーネント
CVE-2017-5754 A-79419639* なし クローズドソース コンポーネント
CVE-2018-5915 A-79420511* なし クローズドソース コンポーネント
CVE-2018-11267 A-109678338* なし クローズドソース コンポーネント
CVE-2018-11922 A-112279564* なし クローズドソース コンポーネント

一般的な質問と回答

上記の公開情報に対する一般的な質問についての回答は以下のとおりです。

1. 上記の問題に対処するようにデバイスが更新されているかどうかを確かめるには、どうすればよいですか?

デバイスのセキュリティ パッチレベルを確認する方法については、Android のバージョンを確認して更新するをご覧ください。

  • セキュリティ パッチレベル 2018-12-01 以降では、セキュリティ パッチレベル 2018-12-01 に関連するすべての問題に対処しています。
  • セキュリティ パッチレベル 2018-12-05 以降では、セキュリティ パッチレベル 2018-12-05、およびそれ以前のすべてのパッチレベルに関連するすべての問題に対処しています。

デバイス メーカーは、こうしたアップデートを組み込む場合、パッチレベル文字列を以下のとおり設定する必要があります。

  • [ro.build.version.security_patch]:[2018-12-01]
  • [ro.build.version.security_patch]:[2018-12-05]

2. この公開情報に 2 つのセキュリティ パッチレベルがあるのはなぜですか?

この公開情報では、2 つのセキュリティ パッチレベルを定義しています。これは、すべての Android デバイスにまたがる同様の脆弱性をひとまとめにして、Android パートナーが迅速かつ柔軟に修正できるようにするためです。Android パートナーは、この公開情報に掲載されている問題をすべて修正し、最新のセキュリティ パッチレベルを使用することが推奨されています。

  • 2018-12-01 のセキュリティ パッチレベルを使用するデバイスでは、そのセキュリティ パッチレベルに関連するすべての問題と、それ以前のセキュリティに関する公開情報で報告されたすべての問題の修正を含める必要があります。
  • 2018-12-05 以降のセキュリティ パッチレベルを使用するデバイスには、今回(およびそれ以前)のセキュリティに関する公開情報に掲載された、該当するすべてのパッチを組み込む必要があります。

パートナーは、対処する問題すべてについて、修正を 1 つのアップデートにまとめて提供することが推奨されます。

3. 「タイプ」列の項目はどういう意味ですか?

脆弱性の詳細の表で「タイプ」列に記載した項目は、セキュリティの脆弱性の分類を示しています。

略語 定義
RCE リモートコード実行
EoP 権限昇格
ID 情報開示
DoS サービス拒否
N/A 該当する分類なし

4. 「参照」列の項目はどういう意味ですか?

脆弱性の詳細の表で「参照」列に記載した項目には、その参照番号が属す組織を示す接頭辞が含まれる場合があります。

接頭辞 参照
A- Android バグ ID
QC- Qualcomm の参照番号
M- MediaTek の参照番号
N- NVIDIA の参照番号
B- Broadcom の参照番号

5. 「参照」列の Android バグ ID の横にある「*」はどういう意味ですか?

公開されていない問題には、「参照」列の Android バグ ID の横に「*」を付けています。この問題のアップデートは、Google デベロッパー サイトから入手できる Pixel / Nexus デバイス用最新バイナリ ドライバに通常含まれています。

6. セキュリティの脆弱性が、この公開情報とデバイスやパートナーのセキュリティに関する公開情報(Pixel / Nexus のセキュリティに関する公開情報など)に分けられているのはなぜですか?

Android デバイスの最新のセキュリティ パッチレベルを宣言するためには、このセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処が必要となります。それ以外の、デバイスやパートナーのセキュリティに関する公開情報に掲載されているセキュリティの脆弱性への対処は必要ありません。SamsungLGE などの Android デバイスやチップセットのメーカーは、自社のデバイスに関して他にも修正がある場合、その情報を自社のセキュリティ関連のウェブサイトや Pixel / Nexus のセキュリティに関する公開情報に掲載することが推奨されています。

バージョン

バージョン 日付 メモ
1.0 2018 年 12 月 3 日 情報公開
1.1 2018 年 12 月 5 日 公開情報を改訂し AOSP リンクを追加