Google si impegna a promuovere l'equità razziale per le comunità nere. Vedi come.
Questa pagina è stata tradotta dall'API Cloud Translation.
Switch to English

Bollettino sulla sicurezza Android — luglio 2016

Pubblicato il 06 luglio 2016 | Aggiornato il 1 aprile 2019

Il Bollettino sulla sicurezza di Android contiene i dettagli delle vulnerabilità di sicurezza che interessano i dispositivi Android. Oltre al bollettino, abbiamo rilasciato un aggiornamento di sicurezza per i dispositivi Nexus attraverso un aggiornamento over-the-air (OTA). Le immagini del firmware Nexus sono state anche rilasciate sul sito per sviluppatori Google . I livelli di patch di sicurezza del 05 luglio 2016 o successivi risolvono tutti i problemi applicabili in questo bollettino. Fare riferimento alla documentazione per informazioni su come controllare il livello della patch di sicurezza.

I partner sono stati informati dei problemi descritti nel bollettino il 06 giugno 2016 o precedenti. Laddove applicabile, le patch di codice sorgente per questi problemi sono state rilasciate nel repository AOSP (Android Open Source Project). Questo bollettino include anche collegamenti a patch al di fuori di AOSP.

Il più grave di questi problemi è una vulnerabilità di sicurezza critica che potrebbe consentire l'esecuzione di codice in modalità remota su un dispositivo interessato attraverso più metodi come e-mail, navigazione Web e MMS durante l'elaborazione dei file multimediali. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, presupponendo che le mitigazioni della piattaforma e del servizio siano disabilitate a fini di sviluppo o se vengano aggirate correttamente.

Non abbiamo avuto notizie di sfruttamento attivo dei clienti o abuso di questi problemi appena segnalati. Fare riferimento alla sezione Mitigazioni dei servizi Android e Google per i dettagli sulle protezioni della piattaforma di sicurezza Android e le protezioni dei servizi come SafetyNet, che migliorano la sicurezza della piattaforma Android.

Incoraggiamo tutti i clienti ad accettare questi aggiornamenti per i loro dispositivi.

Annunci

  • Questo bollettino definisce due stringhe a livello di patch di sicurezza per offrire ai partner Android la flessibilità di spostarsi più rapidamente per correggere un sottoinsieme di vulnerabilità simili a tutti i dispositivi Android. Consulta Domande e risposte comuni per ulteriori informazioni:
    • 01/07/2016 : stringa di livello di patch di sicurezza parziale. Questa stringa a livello di patch di sicurezza indica che tutti i problemi associati a 01/07/2016 sono stati risolti.
    • 05/07/2016 : stringa di livello di patch di sicurezza completa. Questa stringa a livello di patch di sicurezza indica che sono stati risolti tutti i problemi associati a 2016-07-01 e 2016-07-05.
  • I dispositivi Nexus supportati riceveranno un singolo aggiornamento OTA con il livello di patch di sicurezza del 05 luglio 2016.

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle mitigazioni fornite dalla piattaforma di sicurezza Android e delle protezioni del servizio come SafetyNet. Queste funzionalità riducono la probabilità che le vulnerabilità di sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento per molti problemi su Android è reso più difficile dai miglioramenti nelle nuove versioni della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android ove possibile.
  • Il team di sicurezza di Android monitora attivamente gli abusi con Verify Apps e SafetyNet , progettati per avvisare gli utenti di applicazioni potenzialmente dannose . Verifica che le app siano abilitate per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano applicazioni al di fuori di Google Play. Gli strumenti di rooting dei dispositivi sono vietati in Google Play, ma Verifica App avvisa gli utenti quando tentano di installare un'applicazione di rooting rilevata, indipendentemente da dove provenga. Inoltre, Verifica App tenta di identificare e bloccare l'installazione di applicazioni dannose note che sfruttano una vulnerabilità di escalation di privilegi. Se tale applicazione è già stata installata, Verifica App avviserà l'utente e tenterà di rimuovere l'applicazione rilevata.
  • Se del caso, le applicazioni di Google Hangouts e Messenger non trasmettono automaticamente i media a processi come Mediaserver.

Ringraziamenti

Vorremmo ringraziare questi ricercatori per il loro contributo:

  • Abhishek Arya, Oliver Chang e Martin Barbella del team di sicurezza di Google Chrome: CVE-2016-3756, CVE-2016-3741, CVE-2016-3743, CVE-2016-3742
  • Adam Donenfeld et al. di Check Point Software Technologies Ltd .: CVE-2016-2503
  • Adam Powell di Google: CVE-2016-3752
  • Alex Chapman e Paul Stone of Context Information Security: CVE-2016-3763
  • Andy Tyler ( @ticarpi ) di e2e -assure: CVE-2016-2457
  • Ben Hawkes di Google Project Zero: CVE-2016-3775
  • Chiachih Wu ( @chiachih_wu ), Yuan-Tsung Lo ( computernik@gmail.com ) e Xuxian Jiang del team C0RE : CVE-2016-3770, CVE-2016-3771, CVE-2016-3772, CVE-2016-3773, CVE-2016-3774
  • Christopher Tate di Google: CVE-2016-3759
  • Di Shen ( @returnsme ) di KeenLab ( @keen_lab ), Tencent: CVE-2016-3762
  • Gengjia Chen ( @ chengjia4574 ), pjf ( weibo.com/jfpan ) di IceSword Lab, Qihoo 360 Technology Co. Ltd .: CVE-2016-3806, CVE-2016-3816, CVE-2016-3805, CVE-2016-3804 , CVE-2016-3767, CVE-2016-3810, CVE-2016-3795, CVE-2016-3796
  • Greg Kaiser del team di Google Android: CVE-2016-3758
  • Guang Gong (龚 广) ( @oldfresher ) del Mobile Safe Team, Qihoo 360 Technology Co. Ltd .: CVE-2016-3764
  • Hao Chen e Guang Gong del team Alpha, Qihoo 360 Technology Co. Ltd .: CVE-2016-3792, CVE-2016-3768
  • Hao Qin del Security Research Lab, Cheetah Mobile : CVE-2016-3754, CVE-2016-3766
  • Jianqiang Zhao ( @jianqiangzhao ) e pjf ( weibo.com/jfpan ) di IceSword Lab, Qihoo 360 Technology Co. Ltd : CVE-2016-3814, CVE-2016-3802, CVE-2016-3769, CVE-2016-3807, CVE-2016-3808
  • Marco Nelissen di Google: CVE-2016-3818
  • Contrassegna il marchio di Google Project Zero: CVE-2016-3757
  • Michał Bednarski : CVE-2016-3750
  • Mingjian Zhou ( @Mingjian_Zhou ), Chiachih Wu ( @chiachih_wu ) e Xuxian Jiang del team C0RE : CVE-2016-3747, CVE-2016-3746, CVE-2016-3765
  • Peng Xiao, Chengming Yang, Ning You, Chao Yang e Yang Ssong di Alibaba Mobile Security Group: CVE-2016-3800, CVE-2016-3799, CVE-2016-3801, CVE-2016-3812, CVE-2016-3798
  • Peter Pi ( @heisecode ) di Trend Micro: CVE-2016-3793
  • Ricky Wai di Google: CVE-2016-3749
  • Roeland Krak: CVE-2016-3753
  • Scott Bauer ( @ ScottyBauer1 ): CVE-2016-3797, CVE-2016-3813, CVE-2016-3815, CVE-2016-2501, CVE-2016-2502
  • Vasily Vasilev: CVE-2016-2507
  • Weichao Sun ( @sunblate ) di Alibaba Inc .: CVE-2016-2508, CVE-2016-3755
  • Wen Niu ( @NWMonster ) di KeenLab ( @keen_lab ), Tencent: CVE-2016-3809
  • Dipartimento di piattaforma di sicurezza Xiling Gong di Tencent: CVE-2016-3745
  • Yacong Gu del TCA Lab, Institute of Software, Chinese Academy of Sciences: CVE-2016-3761
  • Yongke Wang ( @Rudykewang ) di Xuanwu LAB, Tencent: CVE-2016-2505
  • Yongke Wang ( @Rudykewang ) e Wei Wei ( @Danny__Wei ) di Xuanwu LAB, Tencent: CVE-2016-2506
  • Yulong Zhang e Tao (Lenx) Wei di Baidu X-Lab: CVE-2016-3744

01/07/2016 livello di patch di sicurezza: dettagli sulla vulnerabilità di sicurezza

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2016-07-01. C'è una descrizione del problema, una logica di gravità e una tabella con CVE, riferimenti associati, gravità, dispositivi Nexus aggiornati, versioni AOSP aggiornate (ove applicabile) e data riportata. Se disponibile, collegheremo la modifica pubblica che ha risolto il problema con l'ID bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID bug.

Vulnerabilità legata all'esecuzione di codice in modalità remota in Mediaserver

Una vulnerabilità legata all'esecuzione di codice in modalità remota in Mediaserver potrebbe consentire a un utente malintenzionato che utilizza un file appositamente predisposto di causare danni alla memoria durante l'elaborazione di file multimediali e dati. Questo problema è classificato come critico a causa della possibilità di esecuzione di codice in modalità remota nel contesto del processo Mediaserver. Il processo Mediaserver ha accesso a flussi audio e video, nonché l'accesso ai privilegi a cui le app di terze parti non potevano normalmente accedere.

La funzionalità interessata viene fornita come parte principale del sistema operativo e ci sono più applicazioni che ne consentono il raggiungimento con contenuti remoti, in particolare MMS e riproduzione del browser da parte dei media.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2506 A-28175045 critico Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 11 aprile 2016
CVE-2016-2505 A-28333006 critico Tutti i Nexus 6.0, 6.0.1 21 aprile 2016
CVE-2016-2507 A-28532266 critico Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2 maggio 2016
CVE-2016-2508 A-28799341 [ 2 ] critico Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 16 maggio 2016
CVE-2016-3741 A-28165661 [ 2 ] critico Tutti i Nexus 6.0, 6.0.1 Google interno
CVE-2016-3742 A-28165659 critico Tutti i Nexus 6.0, 6.0.1 Google interno
CVE-2016-3743 A-27907656 critico Tutti i Nexus 6.0, 6.0.1 Google interno

Vulnerabilità legata all'esecuzione di codice in modalità remota in OpenSSL e BoringSSL

Una vulnerabilità legata all'esecuzione di codice in modalità remota in OpenSSL e BoringSSL potrebbe consentire a un utente malintenzionato che utilizza un file appositamente predisposto di causare danni alla memoria durante l'elaborazione di file e dati. Questo problema è classificato come critico a causa della possibilità di esecuzione di codice in modalità remota nel contesto di un processo interessato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2108 A-28175332 critico Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 3 maggio 2016

Vulnerabilità legata all'esecuzione di codice in modalità remota in Bluetooth

Una vulnerabilità legata all'esecuzione di codice in modalità remota in Bluetooth potrebbe consentire a un utente malintenzionato prossimale di eseguire codice arbitrario durante il processo di associazione. Questo problema è considerato elevato a causa della possibilità di eseguire codice in modalità remota durante l'inizializzazione di un dispositivo Bluetooth.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3744 A-27930580 alto Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 30-mar-2016

Elevazione della vulnerabilità dei privilegi in libpng

Una vulnerabilità legata all'acquisizione di privilegi più elevati in libpng potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un'applicazione di sistema elevata. Questo problema è considerato alto perché potrebbe essere utilizzato per ottenere l'accesso locale a funzionalità elevate, come i privilegi di autorizzazione Signature o SignatureOrSystem , che non sono accessibili a un'applicazione di terze parti.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3751 A-23265085 alto Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 3 dicembre 2015

Elevazione della vulnerabilità dei privilegi in Mediaserver

Un'elevata vulnerabilità dei privilegi in Mediaserver potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un'applicazione di sistema elevata. Questo problema è considerato alto perché potrebbe essere utilizzato per ottenere l'accesso locale a funzionalità elevate, come i privilegi di autorizzazione Signature o SignatureOrSystem , che non sono accessibili a un'applicazione di terze parti.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3745 A-28173666 alto Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 10 aprile 2016
CVE-2016-3746 A-27890802 alto Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 27-mar-2016
CVE-2016-3747 A-27903498 alto Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 28-mar-2016

Elevazione della vulnerabilità dei privilegi nei socket

Un'elevata vulnerabilità dei privilegi nei socket potrebbe consentire a un'applicazione dannosa locale di accedere alle chiamate di sistema al di fuori del suo livello di autorizzazione. Questo problema è considerato alto perché potrebbe consentire un bypass delle misure di sicurezza in atto per aumentare la difficoltà degli aggressori che sfruttano la piattaforma.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3748 A-28171804 alto Tutti i Nexus 6.0, 6.0.1 13 aprile 2016

Elevazione della vulnerabilità dei privilegi in LockSettingsService

Una vulnerabilità legata all'acquisizione di privilegi più elevati in LockSettingsService potrebbe consentire a un'applicazione dannosa di reimpostare la password di blocco dello schermo senza autorizzazione da parte dell'utente. Questo problema è considerato alto perché è un bypass locale dei requisiti di interazione dell'utente per eventuali modifiche alle impostazioni di sicurezza o degli sviluppatori.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3749 A-28163930 alto Tutti i Nexus 6.0, 6.0.1 Google interno

Elevazione della vulnerabilità dei privilegi nelle API Framework

Un'elevata vulnerabilità dei privilegi nelle API di Parcels Framework potrebbe consentire a un'applicazione locale dannosa di eludere le protezioni del sistema operativo che isolano i dati dell'applicazione da altre applicazioni. Questo problema è considerato alto perché potrebbe essere utilizzato per ottenere l'accesso ai dati a cui l'applicazione non ha accesso.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3750 A-28395952 alto Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 16 dic 2015

Elevata vulnerabilità dei privilegi nel servizio SceltaTarget

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel servizio ChooserTarget potrebbe consentire a un'applicazione dannosa locale di eseguire codice nel contesto di un'altra applicazione. Questo problema è considerato alto perché potrebbe essere utilizzato per accedere alle attività appartenenti a un'altra applicazione senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3752 A-28384423 alto Tutti i Nexus 6.0, 6.0.1 Google interno

Vulnerabilità legata alla divulgazione di informazioni in Mediaserver

Una vulnerabilità legata alla divulgazione di informazioni in Mediaserver potrebbe consentire a un utente malintenzionato remoto di accedere a dati protetti normalmente accessibili solo alle app installate localmente che richiedono l'autorizzazione. Questo problema è considerato alto perché potrebbe essere utilizzato per accedere ai dati senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3753 A-27210135 alto Nessuna* 4.4.4 15 febbraio 2016

* I dispositivi Nexus supportati che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Vulnerabilità legata alla divulgazione di informazioni in OpenSSL

Una vulnerabilità legata alla divulgazione di informazioni in OpenSSL potrebbe consentire a un utente malintenzionato remoto di accedere a dati protetti normalmente accessibili solo alle app installate localmente che richiedono l'autorizzazione. Questo problema è considerato alto perché potrebbe essere utilizzato per accedere ai dati senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-2107 A-28550804 alto Nessuna* 4.4.4, 5.0.2, 5.1.1 13 aprile 2016

* I dispositivi Nexus supportati che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Vulnerabilità di tipo Denial of Service in Mediaserver

Una vulnerabilità di negazione del servizio in Mediaserver potrebbe consentire a un utente malintenzionato di utilizzare un file appositamente predisposto per causare il blocco o il riavvio del dispositivo. Questo problema è considerato elevato a causa della possibilità di un rifiuto temporaneo del servizio remoto.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3754 A-28615448 [ 2 ] alto Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 5 maggio 2016
CVE-2016-3755 A-28470138 alto Tutti i Nexus 6.0, 6.0.1 29 aprile 2016
CVE-2016-3756 A-28556125 alto Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Vulnerabilità di tipo Denial of Service in libc

Una vulnerabilità di negazione del servizio in libc potrebbe consentire a un utente malintenzionato di utilizzare un file appositamente predisposto per causare il blocco o il riavvio del dispositivo. Questo problema è valutato come elevato a causa della possibilità di Denial of Service remoto.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3818 A-28740702 [ 2 ] alto Nessuna* 4.4.4 Google interno

* I dispositivi Nexus supportati che hanno installato tutti gli aggiornamenti disponibili non sono interessati da questa vulnerabilità.

Elevazione della vulnerabilità dei privilegi in lsof

Una vulnerabilità legata all'acquisizione di privilegi più elevati in lsof potrebbe consentire a un'applicazione locale dannosa di eseguire codice arbitrario che potrebbe portare a una compromissione permanente del dispositivo. Questo problema è classificato come moderato perché richiede passaggi manuali non comuni.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3757 A-28175237 Moderare Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 11 aprile 2016

Elevazione della vulnerabilità dei privilegi in DexClassLoader

Una vulnerabilità legata all'acquisizione di privilegi più elevati in DexClassLoader potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato. Questo problema è classificato come moderato perché richiede passaggi manuali non comuni.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3758 A-27840771 Moderare Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Elevazione della vulnerabilità dei privilegi nelle API Framework

Una vulnerabilità legata all'acquisizione di privilegi più elevati nelle API Framework potrebbe consentire a un'applicazione locale dannosa di richiedere autorizzazioni di backup e intercettare tutti i dati di backup. Questo problema è classificato come moderato perché richiede autorizzazioni specifiche per bypassare le protezioni del sistema operativo che isolano i dati delle applicazioni da altre applicazioni.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3759 A-28406080 Moderare Tutti i Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 Google interno

Elevazione della vulnerabilità dei privilegi in Bluetooth

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel componente Bluetooth potrebbe consentire a un utente malintenzionato locale di aggiungere un dispositivo Bluetooth autenticato che persiste per l'utente principale. Questo problema è considerato moderato perché potrebbe essere utilizzato per ottenere capacità elevate senza l'autorizzazione esplicita dell'utente.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3760 A-27410683 [ 2 ] [ 3 ] Moderare Tutti i Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 29 febbraio 2016

Elevazione della vulnerabilità dei privilegi in NFC

Una vulnerabilità legata all'acquisizione di privilegi più elevati in NFC potrebbe consentire a un'applicazione locale di sfondo dannoso di accedere alle informazioni da un'applicazione in primo piano. Questo problema è considerato moderato perché potrebbe essere utilizzato per ottenere capacità elevate senza l'autorizzazione esplicita dell'utente.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3761 A-28300969 Moderare Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 20 aprile 2016

Elevazione della vulnerabilità dei privilegi nei socket

Un'elevata vulnerabilità dei privilegi nei socket potrebbe consentire a un'applicazione dannosa locale di ottenere l'accesso a determinati tipi di socket non comuni che potrebbero portare a un'esecuzione arbitraria di codice nel contesto del kernel. Questo problema è classificato come moderato perché potrebbe consentire un bypass delle misure di sicurezza in atto per aumentare la difficoltà degli aggressori che sfruttano la piattaforma.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3762 A-28612709 Moderare Tutti i Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 21 aprile 2016

Vulnerabilità legata alla divulgazione di informazioni in Configurazione automatica proxy

Una vulnerabilità legata alla divulgazione di informazioni nel componente Configurazione automatica proxy potrebbe consentire a un'applicazione di accedere a informazioni riservate. Questo problema è considerato moderato perché potrebbe essere utilizzato per accedere ai dati senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3763 A-27593919 Moderare Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 10-mar-2016

Vulnerabilità legata alla divulgazione di informazioni in Mediaserver

Una vulnerabilità legata alla divulgazione di informazioni in Mediaserver potrebbe consentire a un'applicazione dannosa locale di accedere a informazioni riservate. Questo problema è considerato moderato perché potrebbe essere utilizzato per accedere ai dati senza autorizzazione.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3764 A-28377502 Moderare Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 25 aprile 2016
CVE-2016-3765 A-28168413 Moderare Tutti i Nexus 6.0, 6.0.1 8 aprile 2016

Vulnerabilità di tipo Denial of Service in Mediaserver

Una vulnerabilità di negazione del servizio in Mediaserver potrebbe consentire a un utente malintenzionato di utilizzare un file appositamente predisposto per causare il blocco o il riavvio del dispositivo. Questo problema è classificato come moderato a causa della possibilità di denial of service remoto.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Versioni AOSP aggiornate Data riportata
CVE-2016-3766 A-28471206 [ 2 ] Moderare Tutti i Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 29 aprile 2016

05/07/2016 Livello di patch di sicurezza: dettagli della vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2016-07-05. C'è una descrizione del problema, una logica di gravità e una tabella con CVE, riferimenti associati, gravità, dispositivi Nexus aggiornati, versioni AOSP aggiornate (ove applicabile) e data riportata. Se disponibile, collegheremo la modifica pubblica che ha risolto il problema con l'ID bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID bug.

Elevata vulnerabilità dei privilegi nel driver GPU Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver GPU Qualcomm potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il reflashing del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2503 A-28084795 * QC-CR1006067 critico Nexus 5X, Nexus 6P 5 aprile 2016
CVE-2016-2067 A-28305757 QC-CR988993 critico Nexus 5X, Nexus 6, Nexus 6P 20 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevata vulnerabilità dei privilegi nel driver Wi-Fi MediaTek

Un'elevata vulnerabilità dei privilegi nel driver Wi-Fi MediaTek potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il reflashing del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3767 A-28169363 *
M-ALPS02689526
critico Android One 6 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevazione della vulnerabilità dei privilegi nel componente delle prestazioni Qualcomm

Un'elevata vulnerabilità dei privilegi nel componente delle prestazioni Qualcomm potrebbe consentire a un'applicazione locale dannosa di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come gravità critica a causa della possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il reflashing del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3768 A-28172137 * QC-CR1010644 critico Nexus 5, Nexus 6, Nexus 5X, Nexus 6P, Nexus 7 (2013) 9 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevata vulnerabilità dei privilegi nel driver video NVIDIA

Un'elevata vulnerabilità dei privilegi nel driver video NVIDIA potrebbe consentire a un'applicazione locale dannosa di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il reflashing del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3769 A-28376656 *
N-CVE20163769
critico Nexus 9 18 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevazione della vulnerabilità dei privilegi nei driver MediaTek (specifica del dispositivo)

Un'elevata vulnerabilità dei privilegi in più driver MediaTek potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il reflashing del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3770 A-28346752 *
M-ALPS02703102
critico Android One 22 aprile 2016
CVE-2016-3771 A-29007611 *
M-ALPS02703102
critico Android One 22 aprile 2016
CVE-2016-3772 A-29008188 *
M-ALPS02703102
critico Android One 22 aprile 2016
CVE-2016-3773 A-29008363 *
M-ALPS02703102
critico Android One 22 aprile 2016
CVE-2016-3774 A-29008609 *
M-ALPS02703102
critico Android One 22 aprile 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevata vulnerabilità dei privilegi nel file system del kernel

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel file system del kernel potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come critico a causa della possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il reflashing del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3775 A-28588279 * critico Nexus 5X, Nexus 6, Nexus 6P e Nexus Player, Pixel C 4 maggio 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevazione della vulnerabilità dei privilegi nel driver USB

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver USB potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è classificato come gravità critica a causa della possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il reflashing del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2015-8816 A-28712303 * critico Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013), Nexus 9, Nexus Player, Pixel C 4 maggio 2016

* La patch per questo problema non è disponibile pubblicamente. L'aggiornamento è contenuto negli ultimi driver binari per i dispositivi Nexus disponibili sul sito di Google Developer .

Elevazione della vulnerabilità dei privilegi nei componenti Qualcomm

La tabella seguente contiene le vulnerabilità di sicurezza che interessano i componenti di Qualcomm tra cui bootloader, driver della fotocamera, driver dei caratteri, rete, driver audio e driver video.

Il più grave di questi problemi è classificato come Critico a causa della possibilità di esecuzione di codice arbitrario che porta alla possibilità di un compromesso permanente del dispositivo locale, che potrebbe richiedere il rifacimento del sistema operativo per riparare il dispositivo.

CVE Riferimenti Gravità* Dispositivi Nexus aggiornati Data riportata
CVE-2014-9795 A-28820720
QC-CR681957 [ 2 ]
critico Nexus 5 8 agosto 2014
CVE-2014-9794 A-28821172
QC-CR646385
critico Nexus 7 (2013) 8 agosto 2014
CVE-2015-8892 A-28822807
QC-CR902998
critico Nexus 5X, Nexus 6P 30 dicembre 2015
CVE-2014-9781 A-28410333
QC-CR556471
alto Nexus 7 (2013) 6 febbraio 2014
CVE-2014-9786 A-28557260
QC-CR545979
alto Nexus 5, Nexus 7 (2013) 13-mar-2014
CVE-2014-9788 A-28573112
QC-CR548872
alto Nexus 5 13-mar-2014
CVE-2014-9779 A-28598347
QC-CR548679
alto Nexus 5 13-mar-2014
CVE-2014-9780 A-28602014
QC-CR542222
alto Nexus 5, Nexus 5X, Nexus 6P 13-mar-2014
CVE-2014-9789 A-28749392
QC-CR556425
alto Nexus 5 13-mar-2014
CVE-2014-9793 A-28821253
QC-CR580567
alto Nexus 7 (2013) 13-mar-2014
CVE-2014-9782 A-28431531
QC-CR511349
alto Nexus 5, Nexus 7 (2013) 31-mar-2014
CVE-2014-9783 A-28441831
QC-CR511382 [ 2 ]
alto Nexus 7 (2013) 31-mar-2014
CVE-2014-9785 A-28469042
QC-CR545747
alto Nexus 7 (2013) 31-mar-2014
CVE-2014-9787 A-28571496
QC-CR545764
alto Nexus 7 (2013) 31-mar-2014
CVE-2014-9784 A-28442449
QC-CR585147
alto Nexus 5, Nexus 7 (2013) 30 aprile 2014
CVE-2014-9777 A-28598501
QC-CR563654
alto Nexus 5, Nexus 7 (2013) 30 aprile 2014
CVE-2014-9778 A-28598515
QC-CR563694
alto Nexus 5, Nexus 7 (2013) 30 aprile 2014
CVE-2014-9790 A-28769136
QC-CR545716 [ 2 ]
alto Nexus 5, Nexus 7 (2013) 30 aprile 2014
CVE-2014-9792 A-28769399
QC-CR550606
alto Nexus 5 30 aprile 2014
CVE-2014-9797 A-28821090
QC-CR674071
alto Nexus 5 3 lug 2014
CVE-2014-9791 A-28803396
QC-CR659364
alto Nexus 7 (2013) 29 agosto 2014
CVE-2014-9796 A-28820722
QC-CR684756
alto Nexus 5, Nexus 7 (2013) 30 settembre 2014
CVE-2014-9800 A-28822150
QC-CR692478
alto Nexus 5, Nexus 7 (2013) 31 ottobre 2014
CVE-2014-9799 A-28821731
QC-CR691916
alto Nexus 5, Nexus 7 (2013) 31 ottobre 2014
CVE-2014-9801 A-28822060
QC-CR705078
alto Nexus 5 28 nov 2014
CVE-2014-9802 A-28821965
QC-CR705108
alto Nexus 5, Nexus 7 (2013) 31 dicembre 2014
CVE-2015-8891 A-28842418
QC-CR813930
alto Nexus 5, Nexus 7 (2013) 29 maggio 2015
CVE-2015-8888 A-28822465
QC-CR813933
alto Nexus 5 30-giu-2015
CVE-2015-8889 A-28822677
QC-CR804067
alto Nexus 6P 30-giu-2015
CVE-2015-8890 A-28822878
QC-CR823461
alto Nexus 5, Nexus 7 (2013) 19-ago-2015

* Il livello di gravità per questi problemi è fornito direttamente da Qualcomm.

Elevata vulnerabilità dei privilegi nel driver USB Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver Qualcomm USB potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato elevato perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-2502 A-27657963 QC-CR997044 alto Nexus 5X, Nexus 6P 11-mar-2016

Elevata vulnerabilità dei privilegi nel driver Wi-Fi Qualcomm

Una vulnerabilità legata all'acquisizione di privilegi più elevati nel driver Wi-Fi Qualcomm potrebbe consentire a un'applicazione locale dannosa di eseguire codice arbitrario nel contesto del kernel. Questo problema è considerato alto perché richiede innanzitutto di compromettere un processo privilegiato.

CVE Riferimenti Gravità Dispositivi Nexus aggiornati Data riportata
CVE-2016-3792 A-27725204 QC-CR561022 alto Nexus 7 (2013) 17-mar-2016

Elevata vulnerabilità dei privilegi nel driver della fotocamera Qualcomm

An elevation of privilege vulnerability in the Qualcomm camera driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-2501 A-27890772* QC-CR1001092 High Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013) Mar 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in NVIDIA camera driver

An elevation of privilege vulnerability in the NVIDIA camera driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3793 A-28026625*
N-CVE20163793
High Nexus 9 Apr 5, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in MediaTek power driver

An elevation of privilege in the MediaTek power driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3795 A-28085222*
M-ALPS02677244
High Android One Apr 7, 2016
CVE-2016-3796 A-29008443*
M-ALPS02677244
High Android One Apr 7, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Qualcomm Wi-Fi driver

An elevation of privilege vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3797 A-28085680* QC-CR1001450 High Nexus 5X Apr 7, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in MediaTek hardware sensor driver

An elevation of privilege vulnerability in the MediaTek hardware sensor driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3798 A-28174490*
M-ALPS02703105
High Android One Apr 11, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in MediaTek video driver

An elevation of privilege vulnerability in the MediaTek video driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3799 A-28175025*
M-ALPS02693738
High Android One Apr 11, 2016
CVE-2016-3800 A-28175027*
M-ALPS02693739
High Android One Apr 11, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in MediaTek GPS driver

An elevation of privilege vulnerability in the MediaTek GPS driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3801 A-28174914*
M-ALPS02688853
High Android One Apr 11, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3802 A-28271368* High Nexus 9 Apr 19, 2016
CVE-2016-3803 A-28588434* High Nexus 5X, Nexus 6P May 4, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in MediaTek power management driver

An elevation of privilege in the MediaTek power management driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3804 A-28332766*
M-ALPS02694410
High Android One Apr 20, 2016
CVE-2016-3805 A-28333002*
M-ALPS02694412
High Android One Apr 21, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in MediaTek display driver

An elevation of privilege vulnerability in the MediaTek display driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3806 A-28402341*
M-ALPS02715341
High Android One Apr 26, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in serial peripheral interface driver

An elevation of privilege vulnerability in the serial peripheral interface driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3807 A-28402196* High Nexus 5X, Nexus 6P Apr 26, 2016
CVE-2016-3808 A-28430009* High Pixel C Apr 26, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Qualcomm sound driver

An elevation of privilege vulnerability in the Qualcomm sound driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High severity because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-2068 A-28470967 QC-CR1006609 High Nexus 5, Nexus 5X, Nexus 6, Nexus 6P Apr 28, 2016

Elevation of privilege vulnerability in kernel

An elevation of privilege vulnerability in the kernel could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2014-9803 A-28557020
Upstream kernel
High Nexus 5X, Nexus 6P Google internal

Information disclosure vulnerability in networking component

An information disclosure vulnerability in the networking component could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3809 A-27532522* High All Nexus Mar 5, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in MediaTek Wi-Fi driver

An information disclosure vulnerability in the MediaTek Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3810 A-28175522*
M-ALPS02694389
High Android One Apr 12, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in kernel video driver

An elevation of privilege vulnerability in the kernel video driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3811 A-28447556* Moderate Nexus 9 Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in MediaTek video codec driver

An information disclosure vulnerability in the MediaTek video codec driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3812 A-28174833*
M-ALPS02688832
Moderate Android One Apr 11, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm USB driver

An information disclosure vulnerability in the Qualcomm USB driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3813 A-28172322* QC-CR1010222 Moderate Nexus 5, Nexus 5X, Nexus 6, Nexus 6P Apr 11, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in NVIDIA camera driver

An information disclosure vulnerability in the NVIDIA camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3814 A-28193342*
N-CVE20163814
Moderate Nexus 9 Apr 14, 2016
CVE-2016-3815 A-28522274*
N-CVE20163815
Moderate Nexus 9 May 1, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in MediaTek display driver

An information disclosure vulnerability in the MediaTek display driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3816 A-28402240* Moderate Android One Apr 26, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in kernel teletype driver

An information disclosure vulnerability in the teletype driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-0723 A-28409131
Upstream kernel
Moderate Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013), Nexus 9, Nexus Player, Pixel C Apr 26, 2016

Denial of service vulnerability in Qualcomm bootloader

A denial of service vulnerability in the Qualcomm bootloader could enable a local malicious application to cause a local permanent device compromise, which may require reflashing the operating system to repair the device. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2014-9798 A-28821448 QC-CR681965 Moderate Nexus 5 Oct 31, 2014
CVE-2015-8893 A-28822690 QC-CR822275 Moderate Nexus 5, Nexus 7 (2013) Aug 19, 2015

Common questions and answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

Security Patch Levels of 2016-07-01 or later address all issues associated with the 2016-7-01 security patch string level. Security Patch Levels of 2016-07-05 or later address all issues associated with the 2016-07-05 security patch string level. Refer to the help center for instructions on how to check the security patch level. Device manufacturers that include these updates should set the patch string level to: [ro.build.version.security_patch]:[2016-07-01] or [ro.build.version.security_patch]:[2016-07-05].

2. Why does this bulletin have two security patch level strings?

This bulletin has two security patch level strings in order to provide Android partners with the flexibility to move more quickly to fix a subset of vulnerabilities that are similar across all Android devices. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level string.

Devices that use the security patch level of July 5, 2016 or newer must include all applicable patches in this (and previous) security bulletins.

Devices that use the July 1, 2016 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins. Devices that use July 1, 2016 security patch level may also include a subset of fixes associated with the July 5, 2016 security patch level.

3. How do I determine which Nexus devices are affected by each issue?

In the 2016-07-01 and 2016-07-05 security vulnerability details sections, each table has an Updated Nexus devices column that covers the range of affected Nexus devices updated for each issue. This column has a few options:

  • All Nexus devices : If an issue affects all Nexus devices, the table will have “All Nexus” in the Updated Nexus devices column. “All Nexus” encapsulates the following supported devices : Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013), Nexus 9, Android One, Nexus Player, and Pixel C.
  • Some Nexus devices : If an issue doesn't affect all Nexus devices, the affected Nexus devices are listed in the Updated Nexus devices column.
  • No Nexus devices : If no Nexus devices are affected by the issue, the table will have “None” in the Updated Nexus devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number

Revisions

  • July 06, 2016: Bulletin published.
  • July 07, 2016:
    • Added AOSP links.
    • Removed CVE-2016-3794 because it is a duplicate of CVE-2016-3814
    • Added attribution for CVE-2016-2501 and CVE-2016-2502
  • July 11, 2016: Updated attribution for CVE-2016-3750
  • July 14, 2016: Updated attribution for CVE-2016-2503
  • April 1, 2019: Updated patch links for CVE-2016-3818