Бюллетень по безопасности Android — май 2022 г.

Опубликовано 2 мая 2022 г. | Обновлено 3 мая 2022 г.

Бюллетень по безопасности Android содержит подробную информацию об уязвимостях безопасности, затрагивающих устройства Android. Уровни исправлений безопасности от 5 мая 2022 г. или более поздние версии решают все эти проблемы. Чтобы узнать, как проверить уровень исправления безопасности устройства, см. раздел Проверка и обновление версии Android .

Партнеры Android уведомляются обо всех проблемах как минимум за месяц до публикации. Исправления исходного кода для этих проблем будут выпущены в репозиторий Android Open Source Project (AOSP) в течение следующих 48 часов. Мы переработаем этот бюллетень со ссылками на AOSP, когда они станут доступны.

Наиболее серьезной из этих проблем является уязвимость с высоким уровнем безопасности в компоненте Framework, которая может привести к локальному повышению привилегий с необходимыми привилегиями пользователя. Оценка серьезности основывается на возможном воздействии, которое может оказать использование уязвимости на уязвимом устройстве, при условии, что средства защиты платформы и служб отключены в целях разработки или успешно обойдены.

Подробные сведения о средствах защиты платформы безопасности Android и Google Play Protect, улучшающих безопасность платформы Android, см. в разделе « Смягчение последствий для Android и Google Play Protect».

Устранение последствий для Android и сервисов Google

Это сводка по смягчению последствий, предоставляемых платформой безопасности Android и средствами защиты сервисов, такими как Google Play Protect . Эти возможности снижают вероятность того, что уязвимости системы безопасности могут быть успешно использованы на Android.

  • Эксплуатация многих проблем на Android усложняется улучшениями в новых версиях платформы Android. Мы рекомендуем всем пользователям по возможности обновиться до последней версии Android.
  • Команда безопасности Android активно отслеживает злоупотребления с помощью Google Play Protect и предупреждает пользователей о потенциально опасных приложениях . Google Play Protect включен по умолчанию на устройствах с Google Mobile Services и особенно важен для пользователей, которые устанавливают приложения не из Google Play.

Сведения об уязвимости на уровне исправления безопасности от 01 мая 2022 г.

В разделах ниже мы приводим подробные сведения о каждой уязвимости системы безопасности, применимой к уровню исправления 2022-05-01. Уязвимости сгруппированы по компонентам, на которые они влияют. Проблемы описаны в таблицах ниже и включают идентификатор CVE, связанные ссылки, тип уязвимости , серьезность и обновленные версии AOSP (где применимо). Если доступно, мы связываем общедоступное изменение, устраняющее проблему, с идентификатором ошибки, например, со списком изменений AOSP. Когда несколько изменений относятся к одной ошибке, дополнительные ссылки привязываются к номерам, следующим за идентификатором ошибки. Устройства с Android 10 и более поздних версий могут получать обновления безопасности, а также системные обновления Google Play .

Рамки

Самая серьезная уязвимость в этом разделе может привести к локальному повышению привилегий с необходимыми привилегиями пользователя.

CVE использованная литература Тип Строгость Обновленные версии AOSP
CVE-2021-39662 А-197302116 окончание срока действия Высокая 11, 12
CVE-2022-20004 А-179699767 окончание срока действия Высокая 10, 11, 12, 12л
CVE-2022-20005 А-219044664 окончание срока действия Высокая 10, 11, 12, 12л
CVE-2022-20007 А-211481342 окончание срока действия Высокая 10, 11, 12, 12л
CVE-2021-39700 А-201645790 Я БЫ Умеренный 10, 11, 12

Система

Самая серьезная уязвимость в этом разделе может привести к локальному повышению привилегий без необходимости дополнительных привилегий на выполнение.

CVE использованная литература Тип Строгость Обновленные версии AOSP
CVE-2022-20113 А-205996517 окончание срока действия Высокая 12, 12л
CVE-2022-20114 А-211114016 окончание срока действия Высокая 10, 11, 12, 12л
CVE-2022-20116 А-212467440 окончание срока действия Высокая 12, 12л
CVE-2022-20010 А-213519176 Я БЫ Высокая 12, 12л
CVE-2022-20011 А-214999128 Я БЫ Высокая 10, 11, 12, 12л
CVE-2022-20115 А-210118427 Я БЫ Высокая 12, 12л
CVE-2021-39670 А-204087139 DoS Высокая 12, 12л
CVE-2022-20112 А-206987762 DoS Высокая 10, 11, 12, 12л

Системные обновления Google Play

Следующие проблемы включены в компоненты Project Mainline.

Составная часть CVE
МедиаПровайдер CVE-2021-39662

Сведения об уязвимости уровня исправления безопасности 05.05.2022

В разделах ниже мы приводим подробные сведения о каждой уязвимости системы безопасности, применимой к уровню исправления 2022-05-05. Уязвимости сгруппированы по компонентам, на которые они влияют. Проблемы описаны в таблицах ниже и включают идентификатор CVE, связанные ссылки, тип уязвимости , серьезность и обновленные версии AOSP (где применимо). Если доступно, мы связываем общедоступное изменение, устраняющее проблему, с идентификатором ошибки, например, со списком изменений AOSP. Когда несколько изменений относятся к одной ошибке, дополнительные ссылки привязываются к номерам, следующим за идентификатором ошибки.

Компоненты ядра

Наиболее серьезная уязвимость в этом разделе может привести к локальному повышению привилегий в системных библиотеках без необходимости дополнительных привилегий на выполнение.

CVE использованная литература Тип Строгость Составная часть
CVE-2022-0847 А-220741611
Верхнее ядро ​​[ 2 ] [ 3 ]
окончание срока действия Высокая трубы
CVE-2022-20009 А-213172319
Ядро восходящей ветки [ 2 ]
окончание срока действия Высокая линукс
CVE-2022-20008 А-216481035
Верхнее ядро ​​[ 2 ] [ 3 ]
Я БЫ Высокая СД ММС
CVE-2021-22600 А-213464034
Ядро восходящего потока
окончание срока действия Умеренный ядро

Компоненты MediaTek

Эти уязвимости затрагивают компоненты MediaTek, и дополнительную информацию можно получить непосредственно в MediaTek. Оценка серьезности этих проблем предоставляется непосредственно MediaTek.

CVE использованная литература Строгость Составная часть
CVE-2022-20084 А-223071148
М-АЛПС06498874 *
Высокая телефония
CVE-2022-20109 А-223072269
М-АЛПС06399915 *
Высокая ион
CVE-2022-20110 А-223071150
М-АЛПС06399915 *
Высокая ион

Компоненты Qualcomm

Эти уязвимости затрагивают компоненты Qualcomm и более подробно описаны в соответствующем бюллетене по безопасности Qualcomm или предупреждении о безопасности. Оценка серьезности этих проблем предоставляется непосредственно Qualcomm.

CVE использованная литература Строгость Составная часть
CVE-2022-22057 А-218337595
КК-CR#3077687
Высокая Отображать
CVE-2022-22064 А-218338071
КК-CR#3042282
КК-CR#3048959
КК-CR#3056532
QC-CR#3049158 [ 2 ]
Высокая беспроводная сеть
CVE-2022-22065 А-218337597
КК-CR#3042293
КК-CR#3064612
Высокая беспроводная сеть
CVE-2022-22068 А-218337596
QC-CR#3084983 [ 2 ]
Высокая ядро
CVE-2022-22072 А-218339149
QC-CR#3073345 [ 2 ]
Высокая беспроводная сеть

Компоненты Qualcomm с закрытым исходным кодом

Эти уязвимости затрагивают компоненты Qualcomm с закрытым исходным кодом и более подробно описаны в соответствующем бюллетене по безопасности Qualcomm или предупреждении о безопасности. Оценка серьезности этих проблем предоставляется непосредственно Qualcomm.

CVE использованная литература Строгость Составная часть
CVE-2021-35090 А-204905205 ​​* Критический Компонент с закрытым исходным кодом
CVE-2021-35072 А-204905110 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35073 А-204905209 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35076 А-204905151 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35078 А-204905326 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35080 А-204905287 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35086 А-204905289 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35087 А-204905111 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35094 А-204905838 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35096 А-204905290 * Высокая Компонент с закрытым исходным кодом
CVE-2021-35116 А-209469826 * Высокая Компонент с закрытым исходным кодом

Ядро LTS

В следующей таблице описаны минимальные требования к версии ядра для соответствия уровню исправлений безопасности. Версия запуска Android относится к версии ОС Android, которая была на устройстве при запуске, а версия ядра относится к версии ядра Linux, которая в настоящее время установлена ​​на устройстве.

использованная литература Стартовая версия ОС Android Версия ядра Минимальная версия обновления
А-202441831 11 5.4 5.4.147
А-204345773 12 5.4 5.4.147

Общие вопросы и ответы

В этом разделе даны ответы на распространенные вопросы, которые могут возникнуть после прочтения этого бюллетеня.

1. Как определить, обновлено ли мое устройство для решения этих проблем?

Чтобы узнать, как проверить уровень исправления безопасности устройства, см. раздел Проверка и обновление версии Android .

  • Уровни исправлений безопасности 2022-05-01 или более поздние устраняют все проблемы, связанные с уровнем исправлений безопасности 2022-05-01.
  • Уровни исправлений безопасности 2022-05-05 или более поздние устраняют все проблемы, связанные с уровнем исправлений безопасности 2022-05-05 и всеми предыдущими уровнями исправлений.

Производители устройств, которые включают эти обновления, должны установить уровень строки исправления следующим образом:

  • [ro.build.version.security_patch]:[2022-05-01]
  • [ro.build.version.security_patch]:[2022-05-05]

Для некоторых устройств на Android 10 или более поздней версии системное обновление Google Play будет иметь строку даты, соответствующую уровню исправления безопасности 2022-05-01. Подробнее об установке обновлений безопасности см. в этой статье .

2. Почему в этом бюллетене два уровня исправлений безопасности?

В этом бюллетене есть два уровня исправлений безопасности, чтобы партнеры Android могли быстрее устранять подмножество уязвимостей, одинаковых для всех устройств Android. Партнерам Android рекомендуется исправить все проблемы, описанные в этом бюллетене, и использовать последний уровень исправлений безопасности.

  • Устройства, использующие уровень исправления безопасности 2022-05-01, должны содержать все проблемы, связанные с этим уровнем исправления безопасности, а также исправления для всех проблем, о которых сообщалось в предыдущих бюллетенях по безопасности.
  • Устройства, использующие уровень исправлений безопасности от 2022-05-05 или более поздних версий, должны включать все применимые исправления в этом (и предыдущих) бюллетенях по безопасности.

Партнерам рекомендуется объединять исправления для всех проблем, которые они решают, в одном обновлении.

3. Что означают записи в столбце Тип ?

Записи в столбце « Тип » таблицы сведений об уязвимостях ссылаются на классификацию уязвимости системы безопасности.

Сокращенное название Определение
РЦЭ Удаленное выполнение кода
окончание срока действия Повышение привилегий
Я БЫ Раскрытие информации
DoS Отказ в обслуживании
Н/Д Классификация недоступна

4. Что означают записи в столбце « Ссылки »?

Записи в столбце « Ссылки » таблицы сведений об уязвимостях могут содержать префикс, идентифицирующий организацию, которой принадлежит эталонное значение.

Префикс Ссылка
А- Идентификатор ошибки Android
КК- Ссылочный номер Qualcomm
М- Справочный номер MediaTek
Н- Справочный номер NVIDIA
Б- Ссылочный номер Broadcom
У- Справочный номер ЮНИСОК

5. Что означает * рядом с идентификатором ошибки Android в столбце « Ссылки »?

Проблемы, которые не являются общедоступными, отмечены * рядом с соответствующим идентификатором ссылки. Обновление для этой проблемы обычно содержится в последних двоичных драйверах для устройств Pixel, доступных на сайте Google Developer .

6. Почему уязвимости безопасности разделены между этим бюллетенем и бюллетенями по безопасности устройств/партнеров, такими как бюллетень Pixel?

Уязвимости безопасности, описанные в этом бюллетене по безопасности, необходимы для объявления последнего уровня исправления безопасности на устройствах Android. Дополнительные уязвимости безопасности, задокументированные в бюллетенях по безопасности устройств/партнеров, не требуются для объявления уровня исправления безопасности. Производители устройств Android и наборов микросхем также могут публиковать сведения об уязвимостях безопасности, характерных для их продуктов, таких как Google , Huawei , LGE , Motorola , Nokia или Samsung .

Версии

Версия Свидание Заметки
1,0 2 мая 2022 г. Бюллетень опубликован
1.1 3 мая 2022 г. В бюллетень добавлены ссылки на AOSP