Google se compromete a impulsar la igualdad racial para las comunidades afrodescendientes. Obtén información al respecto.

Boletín de seguridad de Nexus: febrero de 2016

Organiza tus páginas con colecciones Guarda y categoriza el contenido según tus preferencias.

Publicado 01 de febrero de 2016 | Actualizado el 7 de marzo de 2016

Hemos lanzado una actualización de seguridad para los dispositivos Nexus a través de una actualización inalámbrica (OTA) como parte de nuestro proceso de publicación mensual del boletín de seguridad de Android. Las imágenes del firmware de Nexus también se han publicado en el sitio de desarrolladores de Google . Las compilaciones LMY49G o posteriores y Android M con nivel de parche de seguridad del 1 de febrero de 2016 o posterior solucionan estos problemas. Consulte la documentación de Nexus para obtener instrucciones sobre cómo verificar el nivel del parche de seguridad.

Los socios fueron notificados sobre los problemas descritos en el boletín el 4 de enero de 2016 o antes. Donde corresponde, los parches de código fuente para estos problemas se han publicado en el repositorio del Proyecto de código abierto de Android (AOSP).

El más grave de estos problemas es una vulnerabilidad de seguridad crítica que podría permitir la ejecución remota de código en un dispositivo afectado a través de múltiples métodos, como correo electrónico, navegación web y MMS al procesar archivos multimedia. La vulnerabilidad de ejecución remota de código en el controlador Wi-Fi de Broadcom también es de gravedad crítica, ya que podría permitir la ejecución remota de código en un dispositivo afectado mientras está conectado a la misma red que el atacante. La evaluación de la gravedad se basa en el efecto que podría tener la explotación de la vulnerabilidad en un dispositivo afectado, suponiendo que las mitigaciones de la plataforma y el servicio estén deshabilitadas para fines de desarrollo o si se eluden con éxito.

No hemos recibido informes de explotación activa por parte de los clientes de estos problemas recientemente informados. Consulte la sección Mitigaciones para obtener detalles sobre las protecciones de la plataforma de seguridad de Android y las protecciones de servicios como SafetyNet, que mejoran la seguridad de la plataforma Android. Alentamos a todos los clientes a aceptar estas actualizaciones en sus dispositivos.

Mitigaciones

Este es un resumen de las mitigaciones proporcionadas por la plataforma de seguridad de Android y las protecciones de servicios como SafetyNet. Estas capacidades reducen la probabilidad de que las vulnerabilidades de seguridad puedan explotarse con éxito en Android.

  • La explotación de muchos problemas en Android se hace más difícil debido a las mejoras en las versiones más recientes de la plataforma Android. Alentamos a todos los usuarios a actualizar a la última versión de Android siempre que sea posible.
  • El equipo de seguridad de Android está monitoreando activamente el abuso con Verify Apps y SafetyNet, que advertirá sobre aplicaciones potencialmente dañinas que están a punto de instalarse. Las herramientas de rooteo de dispositivos están prohibidas en Google Play. Para proteger a los usuarios que instalan aplicaciones desde fuera de Google Play, Verificar aplicaciones está habilitado de forma predeterminada y advertirá a los usuarios sobre aplicaciones de enraizamiento conocidas. Verificar aplicaciones intenta identificar y bloquear la instalación de aplicaciones maliciosas conocidas que explotan una vulnerabilidad de escalada de privilegios. Si ya se instaló dicha aplicación, Verify Apps notificará al usuario e intentará eliminar dichas aplicaciones.
  • Según corresponda, las aplicaciones Google Hangouts y Messenger no pasan automáticamente los medios a procesos como el servidor de medios.

Agradecimientos

Nos gustaría agradecer a estos investigadores por sus contribuciones:

  • Equipo de seguridad de Android y Chrome: CVE-2016-0809, CVE-2016-0810
  • Equipo Broadgate: CVE-2016-0801, CVE-2015-0802
  • Chiachih Wu ( @chiachih_wu ), Mingjian Zhou ( @Mingjian_Zhou ) y Xuxian Jiang del equipo C0RE , Qihoo 360 : CVE-2016-0804
  • David Riley del equipo Google Pixel C: CVE-2016-0812
  • Gengjia Chen ( @chengjia4574 ) de Lab IceSword, Qihoo 360: CVE-2016-0805
  • Qidan He ( @Flanker_hqd ) de KeenLab ( @keen_lab ), Tencent: CVE-2016-0811
  • Seven Shen ( @lingtongshen ) de Trend Micro ( www.trendmicro.com ): CVE-2016-0803
  • Weichao Sun ( @sunblate ) de Alibaba Inc: CVE-2016-0808
  • Zach Riggle ( @ebeip90 ) del equipo de seguridad de Android: CVE-2016-0807

Detalles de vulnerabilidad de seguridad

En las secciones a continuación, proporcionamos detalles para cada una de las vulnerabilidades de seguridad que se aplican al nivel de parche 2016-02-01. Hay una descripción del problema, una justificación de la gravedad y una tabla con el CVE, el error asociado, la gravedad, las versiones afectadas y la fecha del informe. Cuando esté disponible, vincularemos la confirmación de AOSP que solucionó el problema con el ID del error. Cuando varios cambios se relacionan con un solo error, las referencias adicionales de AOSP se vinculan a los números que siguen al ID del error.

Vulnerabilidad de ejecución remota de código en el controlador Wi-Fi de Broadcom

Múltiples vulnerabilidades de ejecución remota en el controlador Wi-Fi de Broadcom podrían permitir que un atacante remoto use paquetes de mensajes de control inalámbrico especialmente diseñados para corromper la memoria del kernel de una manera que conduzca a la ejecución remota de código en el contexto del kernel. Estas vulnerabilidades pueden desencadenarse cuando el atacante y la víctima están asociados a la misma red. Este problema se clasifica como de gravedad crítica debido a la posibilidad de ejecución remota de código en el contexto del kernel sin necesidad de interacción del usuario.

CVE Insectos Gravedad Versiones actualizadas Fecha reportada
CVE-2016-0801 ANDROID-25662029
ANDROID-25662233
Crítico 4.4.4, 5.0, 5.1.1, 6.0, 6.0.1 25 de octubre de 2015
CVE-2016-0802 ANDROID-25306181 Crítico 4.4.4, 5.0, 5.1.1, 6.0, 6.0.1 26 de octubre de 2015

Vulnerabilidad de ejecución remota de código en Mediaserver

Durante el procesamiento de archivos multimedia y datos de un archivo especialmente diseñado, las vulnerabilidades en el servidor de medios podrían permitir que un atacante provoque daños en la memoria y la ejecución remota de código como el proceso del servidor de medios.

La funcionalidad afectada se proporciona como una parte central del sistema operativo y existen múltiples aplicaciones que permiten acceder a ella con contenido remoto, sobre todo MMS y reproducción de medios mediante el navegador.

Este problema tiene una gravedad crítica debido a la posibilidad de ejecución remota de código en el contexto del servicio del servidor de medios. El servicio de servidor de medios tiene acceso a transmisiones de audio y video, así como acceso a privilegios a los que las aplicaciones de terceros normalmente no pueden acceder.

CVE Errores con enlaces AOSP Gravedad Versiones actualizadas Fecha reportada
CVE-2016-0803 ANDROID-25812794 Crítico 4.4.4, 5.0, 5.1.1, 6.0, 6.0.1 19 de noviembre de 2015
CVE-2016-0804 ANDROID-25070434 Crítico 5.0, 5.1.1, 6.0, 6.0.1 12 de octubre de 2015

Vulnerabilidad de elevación de privilegios en el módulo de rendimiento de Qualcomm

Una vulnerabilidad de elevación de privilegios en el componente del administrador de eventos de rendimiento para los procesadores ARM de Qualcomm podría permitir que una aplicación maliciosa local ejecute código arbitrario dentro del kernel. Este problema se clasifica como de gravedad crítica debido a la posibilidad de un compromiso local permanente del dispositivo y el dispositivo posiblemente deba repararse volviendo a actualizar el sistema operativo.

CVE Insecto Gravedad Versiones actualizadas Fecha reportada
CVE-2016-0805 ANDROID-25773204* Crítico 4.4.4, 5.0, 5.1.1, 6.0, 6.0.1 15 de noviembre de 2015

* El parche para este problema no está en AOSP. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el controlador Wi-Fi de Qualcomm

Existe una vulnerabilidad en el controlador Wi-Fi de Qualcomm que podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del kernel. Este problema se clasifica como de gravedad crítica debido a la posibilidad de un compromiso local permanente del dispositivo y el dispositivo posiblemente deba repararse volviendo a actualizar el sistema operativo.

CVE Insecto Gravedad Versiones actualizadas Fecha reportada
CVE-2016-0806 ANDROID-25344453* Crítico 4.4.4, 5.0, 5.1.1, 6.0, 6.0.1 15 de noviembre de 2015

* El parche para este problema no está en AOSP. La actualización está incluida en los controladores binarios más recientes para dispositivos Nexus disponibles en el sitio para desarrolladores de Google .

Vulnerabilidad de elevación de privilegios en el depurador

Una vulnerabilidad de elevación de privilegios en el componente Debuggerd podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto raíz del dispositivo. Este problema se clasifica como de gravedad crítica debido a la posibilidad de un compromiso local permanente del dispositivo y el dispositivo posiblemente deba repararse volviendo a actualizar el sistema operativo.

CVE Error con enlace AOSP Gravedad Versiones actualizadas Fecha reportada
CVE-2016-0807 ANDROID-25187394 Crítico 6.0 y 6.0.1 interno de Google

Vulnerabilidad de denegación de servicio en Minikin

Una vulnerabilidad de denegación de servicio en la biblioteca Minikin podría permitir que un atacante local bloquee temporalmente el acceso a un dispositivo afectado. Un atacante podría hacer que se cargue una fuente que no sea de confianza y provocar un desbordamiento en el componente Minikin que provoque un bloqueo. Esto se clasifica como de gravedad alta porque la denegación de servicio genera un bucle de reinicio continuo.

CVE Error con enlace AOSP Gravedad Versiones actualizadas Fecha reportada
CVE-2016-0808 ANDROID-25645298 Alto 5.0, 5.1.1, 6.0, 6.0.1 3 de noviembre de 2015

Vulnerabilidad de elevación de privilegios en Wi-Fi

Una vulnerabilidad de elevación de privilegios en el componente Wi-Fi podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto del sistema. Un dispositivo solo es vulnerable a este problema mientras se encuentra en proximidad local. Este problema se clasifica como de gravedad alta porque podría usarse para obtener capacidades " normales " de forma remota. Por lo general, estos permisos solo son accesibles para aplicaciones de terceros instaladas localmente.

CVE Error con enlace AOSP Gravedad Versiones actualizadas Fecha reportada
CVE-2016-0809 ANDROID-25753768 Alto 6.0, 6.0.1 interno de Google

Vulnerabilidad de elevación de privilegios en Mediaserver

Una vulnerabilidad de elevación de privilegios en mediaserver podría permitir que una aplicación local maliciosa ejecute código arbitrario dentro del contexto de una aplicación de sistema elevada. Este problema se clasifica como de gravedad alta porque podría usarse para obtener capacidades elevadas, como privilegios de permisos Signature o SignatureOrSystem , a los que no puede acceder una aplicación de terceros.

CVE Error con enlace AOSP Gravedad Versiones actualizadas Fecha reportada
CVE-2016-0810 ANDROID-25781119 Alto 4.4.4, 5.0, 5.1.1, 6.0, 6.0.1 interno de Google

Vulnerabilidad de divulgación de información en libmediaplayerservice

Una vulnerabilidad de divulgación de información en libmediaplayerservice podría permitir eludir las medidas de seguridad existentes para aumentar la dificultad de los atacantes para explotar la plataforma. Estos problemas se clasifican como de gravedad alta porque también se pueden usar para obtener capacidades elevadas, como los privilegios de permisos Signature o SignatureOrSystem , a los que no pueden acceder las aplicaciones de terceros.

CVE Error con enlace AOSP Gravedad Versiones actualizadas Fecha reportada
CVE-2016-0811 ANDROID-25800375 Alto 6.0, 6.0.1 16 de noviembre de 2015

Vulnerabilidad de elevación de privilegios en el asistente de configuración

Una vulnerabilidad en el asistente de configuración podría permitir que un atacante malicioso eluda la protección de restablecimiento de fábrica y obtenga acceso al dispositivo. Esto se clasifica como una gravedad moderada porque potencialmente permite que alguien con acceso físico a un dispositivo eluda la protección de restablecimiento de fábrica, lo que permite que un atacante restablezca con éxito un dispositivo, borrando todos los datos.

CVE Errores con enlaces AOSP Gravedad Versiones actualizadas Fecha reportada
CVE-2016-0812 ANDROID-25229538 Moderado 5.1.1, 6.0 interno de Google
CVE-2016-0813 ANDROID-25476219 Moderado 5.1.1, 6.0, 6.0.1 interno de Google

Preguntas y respuestas comunes

Esta sección revisa las respuestas a preguntas comunes que pueden surgir después de leer este boletín.

1. ¿Cómo puedo determinar si mi dispositivo está actualizado para solucionar estos problemas?

Las compilaciones LMY49G o posteriores y Android 6.0 con nivel de parche de seguridad del 1 de febrero de 2016 o posterior solucionan estos problemas. Consulte la documentación de Nexus para obtener instrucciones sobre cómo verificar el nivel del parche de seguridad. Los fabricantes de dispositivos que incluyen estas actualizaciones deben establecer el nivel de la cadena del parche en: [ro.build.version.security_patch]:[2016-02-01]

Revisiones

  • 01 de febrero de 2016: Boletín publicado.
  • 02 de febrero de 2016: Boletín revisado para incluir enlaces AOSP.
  • 7 de marzo de 2016: Boletín revisado para incluir enlaces AOSP adicionales.