Android Güvenlik Bülteni - Nisan 2017

03 Nisan 2017 Yayınlandı | Yayım tarihi 17 August 2017

Android Güvenlik Bülteni, Android cihazları etkileyen güvenlik açıklarının ayrıntılarını içerir. Bültenle birlikte, kablosuz (OTA) güncellemesiyle Nexus cihazlarına bir güvenlik güncellemesi yayınladık. Google cihaz donanım yazılımı görüntüleri de Google Geliştirici sitesinde yayınlanmıştır . 05 Nisan 2017 veya daha sonraki güvenlik yaması seviyeleri tüm bu sorunları ele almaktadır. Bir cihazın güvenlik yaması düzeyini nasıl kontrol edeceğinizi öğrenmek için Pixel ve Nexus güncelleme programına bakın.

Ortaklara, 06 Mart 2017 veya daha önceki tarihli bültende açıklanan sorunlar bildirildi. Bu sorunlar için kaynak kod yamaları, Android Açık Kaynak Projesi (AOSP) havuzunda yayınlanmış ve bu bültenden bağlanmıştır. Bu bülten ayrıca AOSP dışındaki yamalara bağlantılar içerir.

Bu sorunların en önemlisi, medya dosyalarını işlerken e-posta, web'de gezinme ve MMS gibi birden çok yöntemle etkilenen bir cihazda uzaktan kod yürütülmesine olanak verebilecek Kritik bir güvenlik açığıdır. Önem değerlendirmesi , güvenlik açığından yararlanmanın muhtemelen etkilenen bir cihaz üzerinde yaratacağı etkiye dayanır ve platform ve hizmet azaltımlarının geliştirme amacıyla devre dışı bırakıldığı veya başarılı bir şekilde atlanması durumunda devre dışı bırakıldığı varsayılır.

Yeni bildirilen bu sorunların aktif olarak istismar edildiğine veya kötüye kullanıldığına dair hiçbir bildirim almadık. Android platformunun güvenliğini artıran SafetyNet gibi Android güvenlik platformu korumaları ve hizmet korumaları hakkında ayrıntılar için Android ve Google hizmet azaltıcı etkenler bölümüne bakın.

Tüm müşterilerimizi cihazlarında bu güncellemeleri kabul etmeye davet ediyoruz.

Duyurular

  • Bu bülten, Android iş ortaklarına tüm Android cihazlarda benzer bir güvenlik açıkları alt kümesini daha hızlı bir şekilde düzeltme esnekliği sağlamak için iki güvenlik yaması düzeyi dizesine sahiptir. Ek bilgi için Yaygın sorular ve yanıtlar bölümüne bakın:
    • 2017-04-01 : Kısmi güvenlik yaması düzeyi dizesi. Bu güvenlik yaması düzeyi dizesi, 2017-04-01 (ve önceki tüm güvenlik yaması düzeyi dizeleri) ile ilişkili tüm sorunların ele alındığını gösterir.
    • 2017-04-05 : Tam güvenlik yaması düzeyi dizesi. Bu güvenlik yaması düzeyi dizesi, 2017-04-01 ve 2017-04-05 (ve önceki tüm güvenlik yaması düzeyi dizeleri) ile ilişkili tüm sorunların ele alındığını gösterir.
  • Desteklenen Google cihazları, 05 Nisan 2017 güvenlik yaması düzeyiyle tek bir OTA güncellemesi alacak.

Android ve Google Hizmeti Hafifletmeleri

Bu, Android güvenlik platformu tarafından sağlanan azaltma önlemlerinin ve SafetyNet gibi hizmet korumalarının bir özetidir. Bu yetenekler, güvenlik açıklarından Android'de başarıyla yararlanma olasılığını azaltır.

  • Android platformunun daha yeni sürümlerindeki geliştirmeler, Android'deki birçok sorundan yararlanmayı daha da zorlaştırıyor. Mümkünse tüm kullanıcıları en son Android sürümüne güncelleme yapmaya teşvik ediyoruz.
  • Android Güvenlik ekibi, kullanıcıları Zararlı Olabilecek Uygulamalar konusunda uyarmak için tasarlanan Verify Apps ve SafetyNet ile kötüye kullanımı aktif olarak izler. Uygulamaları Doğrula, Google Mobil Hizmetleri bulunan cihazlarda varsayılan olarak etkindir ve özellikle Google Play dışından uygulama yükleyen kullanıcılar için önemlidir. Google Play'de cihaz köklendirme araçları yasaktır, ancak Uygulamaları Doğrula, nereden gelirse gelsin algılanan bir köklendirme uygulamasını yüklemeye çalıştıklarında kullanıcıları uyarır. Ek olarak, Uygulamaları Doğrula, bir ayrıcalık yükseltme güvenlik açığından yararlanan bilinen kötü amaçlı uygulamaların kurulumunu belirlemeye ve engellemeye çalışır. Böyle bir uygulama zaten kuruluysa, Uygulamaları Doğrula kullanıcıyı bilgilendirecek ve tespit edilen uygulamayı kaldırmaya çalışacaktır.
  • Uygun olduğu şekilde, Google Hangouts ve Messenger uygulamaları, medyayı Mediaserver gibi işlemlere otomatik olarak geçirmez.

Teşekkürler

Bu araştırmacılara katkılarından dolayı teşekkür ederiz:

  • Shellphish Grill Ekibinden Aravind Machiry (donfos): CVE-2016-5349
  • Xuanwu Lab'den Daxing Guo ( @ freener0 ), Tencent: CVE-2017-0585, CVE-2017-0553
  • Derrek ( @ derrekr6 ) ve Scott Bauer: CVE-2017-0576
  • Project Zero'dan Gal Beniamini: CVE-2017-0571, CVE-2017-0570, CVE-2017-0572, CVE-2017-0569, CVE-2017-0561
  • Gengjia Chen ( @ chengjia4574 ) ve Qihoo 360 Technology Co. Ltd, IceSword Lab'den pjf : CVE-2017-6426, CVE-2017-0581, CVE-2017-0329, CVE-2017-0332, CVE-2017-0566, CVE-2017-0573
  • Guang Gong (龚 广) ( @oldfresher ) Alpha Team, Qihoo 360 Technology Co.Ltd .: CVE-2017-0547
  • Alpha Team'den Hao Chen ve Guang Gong, Qihoo 360 Technology Co. Ltd .: CVE-2017-6424, CVE-2017-0584, CVE-2017-0454, CVE-2017-0574, CVE-2017-0575, CVE-2017 -0567
  • Ian Foster ( @lanrat ): CVE-2017-0554
  • Trend Micro Inc. şirketinden Jack Tang: CVE-2017-0579
  • Qihoo 360 Skyeye Labs'ten Jianjun Dai ( @Jioun_dai ): CVE-2017-0559, CVE-2017-0541
  • Jianqiang Zhao ( @jianqiangzhao ) ve IceSword Lab'den pjf , Qihoo 360: CVE-2017-6425, CVE-2016-5346
  • C0RE Ekibinden Lubo Zhang ( zlbzlb815@163.com ) ve IceSword Lab, Qihoo 360 Technology Co.Ltd'den Yonggang Guo ( @guoygang ): CVE-2017-0564
  • Google'dan Mark Salyzyn : CVE-2017-0558
  • Tesla'nın Ürün Güvenliği Ekibinden Mike Andereson ( @manderbot ) ve Nathan Crandall ( @natecray ): CVE-2017-0327, CVE-2017-0328
  • Alibaba Mobile Security Group'tan Peng Xiao, Chengming Yang, Ning You, Chao Yang ve Yang şarkısı: CVE-2017-0565
  • Baidu X-Lab'den (百度 安全 实验室) Pengfei Ding (丁鹏飞), Chenfu Bao (包 沉浮) ve Lenx Wei (韦 韬): CVE-2016-10236
  • KeenLab'den Qidan He (何 淇 丹 - @flanker_hqd ), Tencent: CVE-2017-0544, CVE-2017-0325
  • Aleph Research'ten Roee Hay ( @roeehay ), HCL Technologies: CVE-2017-0582, CVE-2017-0563
  • Scott Bauer ( @ ScottyBauer1 ): CVE-2017-0562, CVE-2017-0339
  • TrendMicro Mobil Tehdit Araştırma Ekibinden Seven Shen ( @lingtongshen ): CVE-2016-10231, CVE-2017-0578, CVE-2017-0586
  • Tim Becker: CVE-2017-0546
  • Uma Sankar Pradhan ( @umasankar_iitd ): CVE-2017-0560
  • Mobil Tehdit Müdahale Ekibi'nden VEO ( @VYSEa ), Trend Micro : CVE-2017-0555, CVE-2017-0538, CVE-2017-0539, CVE-2017-0557, CVE-2017-0556
  • Alibaba Inc'den Weichao Sun ( @sunblate ): CVE-2017-0549
  • Wenlin Yang ( @wenlin_yang ), Guang Gong ( @oldfresher ) ve Alpha Team'den Hao Chen, Qihoo 360 Technology Co. Ltd .: CVE-2017-0580, CVE-2017-0577
  • Zinuo Han Qihoo 360 Technology Co Ltd Chengdu Güvenlik Yanıt Merkezi .: CVE-2017-0548 den
  • Google'dan Zubin Mithra: CVE-2017-0462

2017-04-01 güvenlik yaması düzeyi — Güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2017-04-01 yama seviyesi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sunuyoruz. Sorunun bir açıklaması, bir önem derecesi ve CVE, ilişkili referanslar, önem derecesi, güncellenmiş Google cihazları, güncellenmiş AOSP sürümleri (varsa) ve bildirilen tarih. Mümkün olduğunda, sorunu ele alan genel değişikliği, AOSP değişiklik listesi gibi hata kimliğine bağlayacağız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen numaralara ek referanslar bağlanır.

Mediaserver'da uzaktan kod yürütme güvenlik açığı

Mediaserver'daki bir uzaktan kod yürütme güvenlik açığı, özel hazırlanmış bir dosya kullanan bir saldırganın medya dosyası ve veri işleme sırasında bellek bozulmasına neden olmasına olanak verebilir. Mediaserver işlemi bağlamında uzaktan kod çalıştırma olasılığı nedeniyle bu sorun Kritik olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0538 A-33641588 Kritik Herşey 6.0, 6.0.1, 7.0, 7.1.1 13 Aralık 2016
CVE-2017-0539 A-33864300 Kritik Herşey 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 23 Aralık 2016
CVE-2017-0541 A-34031018 Kritik Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 1 Ocak 2017
CVE-2017-0542 A-33934721 Kritik Herşey 6.0, 6.0.1, 7.0, 7.1.1 Google dahili
CVE-2017-0543 A-34097866 Kritik Herşey 6.0, 6.0.1, 7.0, 7.1.1 Google dahili

CameraBase'de ayrıcalık yükselmesi güvenlik açığı

CameraBase'deki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın rastgele kod yürütmesine olanak sağlayabilir. Bu sorun, ayrıcalıklı bir işlemde yerel bir keyfi kod yürütme olduğu için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0544 A-31992879 Yüksek Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 6 Ekim 2016

Audioserver'da ayrıcalık yükselmesi güvenlik açığı

Audioserver'daki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın ayrıcalıklı bir işlem bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, bir üçüncü taraf uygulamasının normalde erişemediği yükseltilmiş yeteneklere yerel erişim elde etmek için kullanılabileceğinden Yüksek olarak derecelendirilmiştir.

CVE Referanslar Önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0545 A-32591350 Yüksek Herşey 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 31 Ekim 2016

SurfaceFlinger'da ayrıcalık yükselmesi güvenlik açığı

SurfaceFlinger'daki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın ayrıcalıklı bir işlem bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, bir üçüncü taraf uygulamasının normalde erişemediği yükseltilmiş yeteneklere yerel erişim elde etmek için kullanılabileceğinden Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0546 A-32628763 Yüksek Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2 Kasım 2016

Mediaserver'da bilgi ifşası güvenlik açığı

Mediaserver'daki bir bilginin açığa çıkması güvenlik açığı, yerel bir kötü amaçlı uygulamanın izin düzeylerinin dışındaki verilere erişmesine olanak sağlayabilir. Bu sorun, uygulama verilerini diğer uygulamalardan ayıran işletim sistemi korumaları için genel bir atlama olduğu için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0547 A-33861560 Yüksek Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 22 Aralık 2016

Libskia'da hizmet reddi güvenlik açığı

Libskia'daki uzaktan hizmet reddi güvenlik açığı, bir saldırganın aygıtın askıda kalmasına veya yeniden başlatılmasına neden olmak için özel hazırlanmış bir dosya kullanmasına olanak verebilir. Uzaktan hizmet reddi olasılığı nedeniyle bu sorun Yüksek önem derecesi olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0548 A-33251605 Yüksek Herşey 7.0, 7.1.1 29 Kasım 2016

Mediaserver'da hizmet reddi güvenlik açığı

Mediaserver'daki uzaktan hizmet reddi güvenlik açığı, bir saldırganın aygıtın askıda kalmasına veya yeniden başlatılmasına neden olmak için özel hazırlanmış bir dosya kullanmasına olanak verebilir. Uzaktan hizmet reddi olasılığı nedeniyle bu sorun Yüksek önem derecesi olarak derecelendirilmiştir.

CVE Referanslar Önem Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0549 A-33818508 Yüksek Herşey 6.0, 6.0.1, 7.0, 7.1.1 20 Aralık 2016
CVE-2017-0550 A-33933140 Yüksek Herşey 6.0, 6.0.1, 7.0, 7.1.1 Google dahili
CVE-2017-0551 A-34097231 [ 2 ] Yüksek Herşey 6.0, 6.0.1, 7.0, 7.1.1 Google dahili
CVE-2017-0552 A-34097915 Yüksek Herşey 6.0, 6.0.1, 7.0, 7.1.1 Google dahili

Libnl'de ayrıcalık yükselmesi savunmasızlığı

Libbnl'deki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın Wi-Fi hizmeti bağlamında rastgele kod yürütmesine olanak sağlayabilir. Bu sorun Orta olarak derecelendirilmiştir çünkü öncelikle ayrıcalıklı bir işlemden ödün vermeyi gerektirir ve mevcut platform yapılandırmaları tarafından hafifletilir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0553 A-32342065 Orta Herşey 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 21 Ekim 2016

Telefonda ayrıcalık yükselmesi güvenlik açığı

Telefon bileşenindeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın izin düzeylerinin dışındaki yeteneklere erişmesine olanak sağlayabilir. Bu sorun, bir üçüncü taraf uygulamasının normalde erişemediği yükseltilmiş yeteneklere erişim sağlamak için kullanılabileceğinden Orta olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0554 A-33815946 [ 2 ] Orta Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 20 Aralık 2016

Mediaserver'da bilgi ifşası güvenlik açığı

Mediaserver'daki bir bilginin açığa çıkması güvenlik açığı, yerel bir kötü amaçlı uygulamanın izin düzeylerinin dışındaki verilere erişmesine olanak sağlayabilir. Bu sorun, izinsiz verilere erişmek için kullanılabileceğinden Orta olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0555 A-33551775 Orta Herşey 6.0, 6.0.1, 7.0, 7.1.1 Aralık 12, 2016
CVE-2017-0556 A-34093952 Orta Herşey 6.0, 6.0.1, 7.0, 7.1.1 4 Ocak 2017
CVE-2017-0557 A-34093073 Orta Herşey 6.0, 6.0.1, 7.0, 7.1.1 4 Ocak 2017
CVE-2017-0558 A-34056274 Orta Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google dahili

Libskia'da bilgi ifşa güvenlik açığı

Libskia'daki bir bilginin açığa çıkması güvenlik açığı, yerel bir kötü amaçlı uygulamanın izin düzeylerinin dışındaki verilere erişmesine olanak sağlayabilir. Bu sorun, izinsiz verilere erişmek için kullanılabileceğinden Orta olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0559 A-33897722 Orta Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 Aralık 2016

Fabrika Ayarlarına Sıfırlamada bilgi ifşası güvenlik açığı

Fabrika ayarlarına sıfırlama sürecindeki bilginin açığa çıkması güvenlik açığı, kötü niyetli yerel bir saldırganın önceki sahibin verilerine erişmesine olanak verebilir. Cihaz korumasını atlama olasılığı nedeniyle bu sorun Orta olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2017-0560 A-30681079 Orta Herşey 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google dahili

2017-04-05 güvenlik yaması düzeyi — Güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2017-04-05 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sunuyoruz. Sorunun bir açıklaması, önem derecesi gerekçesinin yanı sıra CVE, ilişkili referanslar, önem derecesi, güncellenmiş Google cihazları, güncellenmiş AOSP sürümleri (varsa) ve bildirilen tarihi içeren bir tablo bulunmaktadır. Mümkün olduğunda, sorunu ele alan genel değişikliği, AOSP değişiklik listesi gibi hata kimliğine bağlayacağız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen numaralara ek referanslar bağlanır.

Broadcom Wi-Fi ürün yazılımında uzaktan kod yürütme güvenlik açığı

Broadcom Wi-Fi ürün yazılımındaki bir uzaktan kod yürütme güvenlik açığı, uzaktaki bir saldırganın Wi-Fi SoC bağlamında rastgele kod yürütmesine olanak sağlayabilir. Wi-Fi SoC bağlamında uzaktan kod çalıştırma olasılığı nedeniyle bu sorun Kritik olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0561 A-34199105 *
B-RB # 110814
Kritik Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 Ocak 2017

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

Qualcomm şifreleme motoru sürücüsünde uzaktan kod yürütme güvenlik açığı

Qualcomm şifreleme motoru sürücüsündeki bir uzaktan kod yürütme güvenlik açığı, uzaktaki bir saldırganın çekirdek bağlamında rasgele kod yürütmesini sağlayabilir. Çekirdek bağlamında uzaktan kod çalıştırma olasılığı nedeniyle bu sorun Kritik olarak derecelendirilmiştir.

CVE Referanslar Önem Google cihazları güncellendi Rapor tarihi
CVE-2016-10230 A-34389927
QC-CR # 1091408
Kritik Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 10 Ocak 2017

Çekirdek ağ alt sistemindeki uzaktan kod yürütme güvenlik açığı

Çekirdek ağ iletişimi alt sistemindeki bir uzaktan kod yürütme güvenlik açığı, uzaktaki bir saldırganın çekirdek bağlamında rasgele kod yürütmesini sağlayabilir. Çekirdek bağlamında uzaktan kod çalıştırma olasılığı nedeniyle bu sorun Kritik olarak derecelendirilmiştir.

CVE Referanslar Önem Google cihazları güncellendi Rapor tarihi
CVE-2016-10229 A-32813456
Yukarı akış çekirdek
Kritik Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Google dahili

MediaTek dokunmatik ekran sürücüsünde ayrıcalık yükselmesi güvenlik açığı

MediaTek dokunmatik ekran sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, aygıtın onarılması için işletim sisteminin yeniden başlatılmasını gerektirebilecek yerel bir kalıcı aygıt tehlikesi olasılığı nedeniyle Kritik olarak derecelendirilmiştir.

CVE Referanslar Önem Google cihazları güncellendi Rapor tarihi
CVE-2017-0562 A-30202425 *
M-ALPS02898189
Kritik * Yok** 16 Temmuz 2016

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

HTC dokunmatik ekran sürücüsünde ayrıcalık yükselmesi güvenlik açığı

HTC dokunmatik ekran sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, aygıtın onarılması için işletim sisteminin yeniden başlatılmasını gerektirebilecek yerel bir kalıcı aygıt tehlikesi olasılığı nedeniyle Kritik olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0563 A-32089409 *
Kritik Nexus 9 9 Ekim 2016

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

Çekirdek ION alt sisteminde ayrıcalık yükselmesi güvenlik açığı

Çekirdek ION alt sistemindeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, aygıtın onarılması için işletim sisteminin yeniden başlatılmasını gerektirebilecek yerel bir kalıcı aygıt tehlikesi olasılığı nedeniyle Kritik olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0564 A-34276203 *
Kritik Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player 12 Ocak 2017

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

Qualcomm bileşenlerindeki güvenlik açıkları

Bu güvenlik açıkları Qualcomm bileşenlerini etkiler ve Qualcomm AMSS Ekim 2016 güvenlik bülteninde daha ayrıntılı olarak açıklanmıştır.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2016-10237 A-31628601 **
QC-CR # 1046751
Kritik Yok** Qualcomm dahili
CVE-2016-10238 A-35358527 **
QC-CR # 1042558
Kritik Yok*** Qualcomm dahili
CVE-2016-10239 A-31624618 **
QC-CR # 1032929
Yüksek Pixel, Pixel XL Qualcomm dahili

* Bu güvenlik açıklarının önem derecesi satıcı tarafından belirlendi.

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

*** Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

V8'de uzaktan kod yürütme güvenlik açığı

V8'deki bir uzaktan kod yürütme güvenlik açığı, uzak saldırganların ayrıcalıklı bir işlem bağlamında rastgele kod yürütmesine olanak sağlayabilir. Web sitelerinde uzaktan kod çalıştırma olasılığı nedeniyle bu sorun Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2016-5129 A-29178923 Yüksek Yok* 6.0, 6.0.1, 7.0 20 Temmuz 2016

* Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Freetype'ta uzaktan kod yürütme güvenlik açığı

Freetype'taki bir uzaktan kod yürütme güvenlik açığı, yerel bir kötü amaçlı uygulamanın ayrıcalıksız bir işlemde bellek bozulmasına neden olacak şekilde özel hazırlanmış bir yazı tipini yüklemesine olanak verebilir. Bu kitaplığı kullanan bir uygulamada uzaktan kod yürütülmesi olasılığı nedeniyle bu sorun Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Güncellenmiş AOSP sürümleri Rapor tarihi
CVE-2016-10244 A-31470908 Yüksek Yok* 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 13 Eyl 2016

* Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Çekirdek ses alt sisteminde ayrıcalık yükselmesi güvenlik açığı

Çekirdek sesi alt sistemindeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2014-4656 A-34464977
Yukarı akış çekirdek
Yüksek Nexus 6, Nexus Player 26 Haziran 2014

NVIDIA kripto sürücüsünde ayrıcalık yükselmesi güvenlik açığı

NVIDIA şifreleme sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0339 A-27930566 *
N-CVE-2017-0339
Yüksek Nexus 9 29 Mart 2016
CVE-2017-0332 A-33812508 *
N-CVE-2017-0332
Yüksek Nexus 9 21 Aralık 2016
CVE-2017-0327 A-33893669 *
N-CVE-2017-0327
Yüksek Nexus 9 24 Aralık 2016

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

MediaTek termal sürücüsünde ayrıcalık yükselmesi güvenlik açığı

MediaTek termal sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0565 A-28175904 *
M-ALPS02696516
Yüksek Yok** 11 Nisan 2016

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

MediaTek kamera sürücüsünde ayrıcalık yükselmesi güvenlik açığı

MediaTek kamera sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0566 A-28470975 *
M-ALPS02696367
Yüksek Yok** Nisan 29, 2016

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Broadcom Wi-Fi sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Broadcom Wi-Fi sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0567 A-32125310 *
B-RB # 112575
Yüksek Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Ekim 12, 2016
CVE-2017-0568 A-34197514 *
B-RB # 112600
Yüksek Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 Ocak 2017
CVE-2017-0569 A-34198729 *
B-RB # 110666
Yüksek Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 Ocak 2017
CVE-2017-0570 A-34199963 *
B-RB # 110688
Yüksek Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 Ocak 2017
CVE-2017-0571 A-34203305 *
B-RB # 111541
Yüksek Nexus 6, Nexus 6P, Pixel C, Nexus Player 9 Ocak 2017
CVE-2017-0572 A-34198931 *
B-RB # 112597
Yüksek Yok** 9 Ocak 2017
CVE-2017-0573 A-34469904 *
B-RB # 91539
Yüksek Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 18 Ocak 2017
CVE-2017-0574 A-34624457 *
B-RB # 113189
Yüksek Nexus 6, Nexus 6P, Nexus 9, Pixel C 22 Ocak 2017

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Qualcomm Wi-Fi sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm Wi-Fi sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0575 A-32658595 *
QC-CR # 1103099
Yüksek Nexus 5X, Pixel, Pixel XL 3 Kasım 2016

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

NVIDIA I2C HID sürücüsünde ayrıcalık yükselmesi güvenlik açığı

NVIDIA I2C HID sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Önem Google cihazları güncellendi Rapor tarihi
CVE-2017-0325 A-33040280 *
N-CVE-2017-0325
Yüksek Nexus 9, Pixel C 20 Kasım 2016

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

Qualcomm ses sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm ses sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0454 A-33353700
QC-CR # 1104067
Yüksek Nexus 5X, Nexus 6P, Pixel, Pixel XL 5 Aralık 2016

Qualcomm kripto motoru sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm şifreleme motoru sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Önem Google cihazları güncellendi Rapor tarihi
CVE-2017-0576 A-33544431
QC-CR # 1103089
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 9 Aralık 2016

HTC dokunmatik ekran sürücüsünde ayrıcalık yükselmesi güvenlik açığı

HTC dokunmatik ekran sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0577 A-33842951 *
Yüksek Yok** 21 Aralık 2016

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

DTS ses sürücüsünde ayrıcalık yükselmesi güvenlik açığı

DTS ses sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak verebilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Önem Google cihazları güncellendi Rapor tarihi
CVE-2017-0578 A-33964406 *
Yüksek Yok** 28 Aralık 2016

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Qualcomm ses codec sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm ses codec sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2016-10231 A-33966912
QC-CR # 1096799
Yüksek Pixel, Pixel XL 29 Aralık 2016

Qualcomm video sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm video sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0579 A-34125463 *
QC-CR # 1115406
Yüksek Nexus 5X, Nexus 6P, Pixel, Pixel XL 5 Ocak 2017
CVE-2016-10232 A-34386696
QC-CR # 1024872 [2]
Yüksek Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One 10 Ocak 2017
CVE-2016-10233 A-34389926
QC-CR # 897452
Yüksek Yok** 10 Ocak 2017

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

NVIDIA önyükleme ve güç yönetimi işlemci sürücüsünde ayrıcalık yükselmesi güvenlik açığı

NVIDIA önyükleme ve güç yönetimi işlemci sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın önyükleme ve güç yönetimi işlemcisi bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Ciddiyet Google cihazları güncellendi Rapor tarihi
CVE-2017-0329 A-34115304 *
N-CVE-2017-0329
Yüksek Piksel C 5 Ocak 2017

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

Synaptics dokunmatik ekran sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Synaptics Dokunmatik Ekran sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Önem Google cihazları güncellendi Rapor tarihi
CVE-2017-0580 A-34325986 *
Yüksek Yok** 16 Ocak 2017
CVE-2017-0581 A-34614485 *
Yüksek Yok** 22 Ocak 2017

* Bu sayı için yama kamuya açık değildir. Güncelleme, Google Geliştirici sitesinde bulunan Nexus cihazları için en son ikili sürücülerde bulunur.

** Mevcut tüm güncellemeleri yükleyen, Android 7.0 veya sonraki sürümlerde desteklenen Google cihazları bu güvenlik açığından etkilenmez.

Qualcomm Seemp sürücüsünde ayrıcalık yükselmesi güvenlik açığı

Qualcomm Seemp sürücüsündeki bir ayrıcalık yükselmesi güvenlik açığı, yerel bir kötü amaçlı uygulamanın çekirdek bağlamında rasgele kod yürütmesine olanak sağlayabilir. Bu sorun, öncelikle ayrıcalıklı bir süreçten ödün verilmesini gerektirdiği için Yüksek olarak derecelendirilmiştir.

CVE Referanslar Önem Google cihazları güncellendi Rapor tarihi
CVE-2017-0462 A-33353601
QC-CR # 1102288
Yüksek Pixel, Pixel XL Google dahili

Elevation of privilege vulnerability in Qualcomm Kyro L2 driver

An elevation of privilege vulnerability in the Qualcomm Kyro L2 driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6423 A-32831370
QC-CR#1103158
Yüksek Pixel, Pixel XL Google internal

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-9922 A-32761463
Upstream kernel
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Oct 24, 2014

Information disclosure vulnerability in kernel memory subsystem

An information disclosure vulnerability in the kernel memory subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-0206 A-34465735
Upstream kernel
Yüksek Nexus 6, Nexus Player May 6, 2014

Information disclosure vulnerability in kernel networking subsystem

An information disclosure vulnerability in the kernel networking subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-3145 A-34469585
Upstream kernel [2]
Yüksek Nexus 6, Nexus Player May 9, 2014

Information disclosure vulnerability in Qualcomm TrustZone

An information disclosure vulnerability in the Qualcomm TrustZone could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-5349 A-29083830
QC-CR#1021945 [2] [3] [4]
Yüksek Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Jun 1, 2016

Information disclosure vulnerability in Qualcomm IPA driver

An information disclosure vulnerability in the Qualcomm IPA driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-10234 A-34390017
QC-CR#1069060 [2]
Yüksek Nexus 5X, Nexus 6P, Pixel, Pixel XL Jan 10, 2017

Denial of service vulnerability in kernel networking subsystem

A denial of service vulnerability in the kernel networking subsystem could enable a remote attacker to use a specially crafted network packet to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2014-2706 A-34160553
Upstream kernel
Yüksek Nexus Player Apr 1, 2014

Denial of service vulnerability in Qualcomm Wi-Fi driver

A denial of service vulnerability in the Qualcomm Wi-Fi driver could enable a proximate attacker to cause a denial of service in the Wi-Fi subsystem. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-10235 A-34390620
QC-CR#1046409
Yüksek None** Jan 10, 2017

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-7097 A-32458736
Upstream kernel
Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Nexus Player Aug 28, 2016

Elevation of privilege vulnerability in Qualcomm Wi-Fi driver

An elevation of privilege vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and because of vulnerability specific details which limit the impact of the issue.

CVE References Severity Updated Google devices Date reported
CVE-2017-6424 A-32086742
QC-CR#1102648
Moderate Nexus 5X, Pixel, Pixel XL, Android One Oct 9, 2016

Elevation of privilege vulnerability in Broadcom Wi-Fi driver

An elevation of privilege vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-8465 A-32474971*
B-RB#106053
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in HTC OEM fastboot command

An elevation of privilege vulnerability in the HTC OEM fastboot command could enable a local malicious application to execute arbitrary code within the context of the sensor hub. This issue is rated as Moderate because it first requires exploitation of separate vulnerabilities.

CVE References Severity Updated Google devices Date reported
CVE-2017-0582 A-33178836*
Moderate Nexus 9 Nov 28, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Qualcomm CP access driver

An elevation of privilege vulnerability in the Qualcomm CP access driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and because of vulnerability specific details which limit the impact of the issue.

CVE References Severity Updated Google devices Date reported
CVE-2017-0583 A-32068683
QC-CR#1103788
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Google internal

Information disclosure vulnerability in kernel media driver

An information disclosure vulnerability in the kernel media driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-1739 A-34460642
Upstream kernel
Moderate Nexus 6, Nexus 9, Nexus Player Jun 15, 2014

Information disclosure vulnerability in Qualcomm Wi-Fi driver

An information disclosure vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0584 A-32074353*
QC-CR#1104731
Moderate Nexus 5X, Pixel, Pixel XL Oct 9, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Broadcom Wi-Fi driver

An information disclosure vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0585 A-32475556*
B-RB#112953
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm Avtimer driver

An information disclosure vulnerability in the Qualcomm Avtimer driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5346 A-32551280
QC-CR#1097878
Moderate Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm video driver

An information disclosure vulnerability in the Qualcomm video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6425 A-32577085
QC-CR#1103689
Moderate Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm USB driver

An information disclosure vulnerability in the Qualcomm USB driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10236 A-33280689
QC-CR#1102418
Moderate Pixel, Pixel XL Nov 30, 2016

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0586 A-33649808
QC-CR#1097569
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Dec 13, 2016

Information disclosure vulnerability in Qualcomm SPMI driver

An information disclosure vulnerability in the Qualcomm SPMI driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6426 A-33644474
QC-CR#1106842
Moderate Pixel, Pixel XL Dec 14, 2016

Information disclosure vulnerability in NVIDIA crypto driver

An information disclosure vulnerability in the NVIDIA crypto driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0328 A-33898322*
N-CVE-2017-0328
Moderate None** Dec 24, 2016
CVE-2017-0330 A-33899858*
N-CVE-2017-0330
Moderate None** Dec 24, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Vulnerabilities in Qualcomm components

These vulnerabilities affecting Qualcomm components were released as part of Qualcomm AMSS security bulletins between 2014–2016. They are included in this Android security bulletin to associate their fixes with an Android security patch level.

CVE References Severity Updated Google devices Date reported
CVE-2014-9931 A-35445101** Kritik None** Qualcomm internal
CVE-2014-9932 A-35434683** Kritik Pixel, Pixel XL Qualcomm internal
CVE-2014-9933 A-35442512** Kritik None** Qualcomm internal
CVE-2014-9934 A-35439275** Kritik None** Qualcomm internal
CVE-2014-9935 A-35444951** Kritik None** Qualcomm internal
CVE-2014-9936 A-35442420** Kritik None** Qualcomm internal
CVE-2014-9937 A-35445102** Kritik None** Qualcomm internal
CVE-2015-8995 A-35445002** Kritik None** Qualcomm internal
CVE-2015-8996 A-35444658** Kritik None** Qualcomm internal
CVE-2015-8997 A-35432947** Kritik None** Qualcomm internal
CVE-2015-8998 A-35441175** Kritik None** Qualcomm internal
CVE-2015-8999 A-35445401** Kritik None** Qualcomm internal
CVE-2015-9000 A-35441076** Kritik None** Qualcomm internal
CVE-2015-9001 A-35445400** Kritik None** Qualcomm internal
CVE-2015-9002 A-35442421** Kritik None** Qualcomm internal
CVE-2015-9003 A-35440626** Kritik None** Qualcomm internal
CVE-2016-10242 A-35434643** Kritik None** Qualcomm internal

* The severity rating for these vulnerabilities was determined by the vendor.

** The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

*** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-04-01 or later address all issues associated with the 2017-04-01 security patch level.
  • Security patch levels of 2017-04-05 or later address all issues associated with the 2017-04-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-04-01]
  • [ro.build.version.security_patch]:[2017-04-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the April 01, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of April 05, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-04-01 and 2017-04-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • April 03, 2017: Bulletin published.
  • April 05, 2017: Bulletin revised to include AOSP links.
  • April 21, 2017: Attribution for CVE-2016-10231 and CVE-2017-0586 corrected.
  • April 27, 2017: CVE-2017-0540 removed from bulletin.
  • August 17, 2017: Bulletin revised to update reference numbers.