Google is committed to advancing racial equity for Black communities. See how.
This page was translated by the Cloud Translation API.
Switch to English

Android Security Bulletin—April 2017

เผยแพร่เมื่อ 03 เมษายน 2017 | อัปเดตเมื่อ 17 สิงหาคม 2017

กระดานข่าวความปลอดภัยของ Android มีรายละเอียดของช่องโหว่ด้านความปลอดภัยที่ส่งผลต่ออุปกรณ์ Android นอกเหนือจากกระดานข่าวเราได้เปิดตัวการอัปเดตความปลอดภัยสำหรับอุปกรณ์ Nexus ผ่านการอัปเดตแบบ over-the-air (OTA) นอกจากนี้อิมเมจเฟิร์มแวร์อุปกรณ์ Google ได้เผยแพร่ไปยัง ไซต์ Google Developer ระดับแพตช์ความปลอดภัยตั้งแต่วันที่ 5 เมษายน 2017 ขึ้นไปจะช่วยแก้ปัญหาเหล่านี้ทั้งหมด โปรดดู ตารางการอัปเดต Pixel และ Nexus เพื่อเรียนรู้วิธีตรวจสอบระดับแพตช์ความปลอดภัยของอุปกรณ์

พาร์ทเนอร์ได้รับแจ้งเกี่ยวกับปัญหาที่อธิบายไว้ในกระดานข่าวเมื่อวันที่ 6 มีนาคม 2017 หรือก่อนหน้านั้น แพตช์ซอร์สโค้ดสำหรับปัญหาเหล่านี้ได้รับการเผยแพร่ไปยังที่เก็บ Android Open Source Project (AOSP) และลิงก์จากกระดานข่าวสารนี้ กระดานข่าวสารนี้ยังมีลิงก์ไปยังแพตช์ภายนอก AOSP

ปัญหาที่รุนแรงที่สุดคือช่องโหว่ด้านความปลอดภัยที่สำคัญซึ่งอาจเปิดใช้งานการเรียกใช้โค้ดจากระยะไกลบนอุปกรณ์ที่ได้รับผลกระทบผ่านวิธีการต่างๆเช่นอีเมลการท่องเว็บและ MMS เมื่อประมวลผลไฟล์สื่อ การ ประเมินความรุนแรง จะขึ้นอยู่กับผลกระทบของการใช้ประโยชน์จากช่องโหว่ที่อาจเกิดขึ้นกับอุปกรณ์ที่ได้รับผลกระทบโดยสมมติว่าแพลตฟอร์มและการลดการให้บริการถูกปิดใช้งานเพื่อวัตถุประสงค์ในการพัฒนาหรือหากข้ามได้สำเร็จ

เราไม่มีรายงานเกี่ยวกับการแสวงหาประโยชน์จากลูกค้าหรือการละเมิดปัญหาที่รายงานใหม่เหล่านี้ โปรดดูส่วนการ ลดการให้บริการของ Android และ Google สำหรับรายละเอียดเกี่ยวกับการ ป้องกันแพลตฟอร์มความปลอดภัยของ Android และการป้องกันบริการเช่น SafetyNet ซึ่งปรับปรุงความปลอดภัยของแพลตฟอร์ม Android

เราขอแนะนำให้ลูกค้าทุกคนยอมรับการอัปเดตเหล่านี้ในอุปกรณ์ของตน

ประกาศ

  • กระดานข่าวนี้มีสตริงระดับแพตช์ความปลอดภัยสองรายการเพื่อให้พันธมิตร Android มีความยืดหยุ่นในการแก้ไขช่องโหว่ย่อยที่คล้ายกันในอุปกรณ์ Android ทั้งหมดได้รวดเร็วขึ้น ดู คำถามและคำตอบทั่วไป สำหรับข้อมูลเพิ่มเติม:
    • 2017-04-01 : สตริงระดับแพตช์ความปลอดภัยบางส่วน สตริงระดับแพตช์ความปลอดภัยนี้บ่งชี้ว่าปัญหาทั้งหมดที่เกี่ยวข้องกับ 2017-04-01 (และสตริงระดับแพตช์ความปลอดภัยก่อนหน้าทั้งหมด) ได้รับการแก้ไขแล้ว
    • 2017-04-05 : กรอกสตริงระดับแพตช์ความปลอดภัย สตริงระดับแพตช์ความปลอดภัยนี้บ่งชี้ว่าปัญหาทั้งหมดที่เกี่ยวข้องกับ 2017-04-01 และ 2017-04-05 (และสตริงระดับแพตช์ความปลอดภัยก่อนหน้าทั้งหมด) ได้รับการแก้ไขแล้ว
  • อุปกรณ์ Google ที่รองรับจะได้รับการอัปเดต OTA เพียงครั้งเดียวพร้อมด้วยระดับแพตช์ความปลอดภัยวันที่ 5 เมษายน 2017

การลดขนาดบริการ Android และ Google

นี่คือบทสรุปของการบรรเทาผลกระทบจาก แพลตฟอร์มความปลอดภัยของ Android และการป้องกันบริการเช่น SafetyNet ความสามารถเหล่านี้ช่วยลดโอกาสที่ช่องโหว่ด้านความปลอดภัยอาจถูกใช้ประโยชน์บน Android ได้สำเร็จ

  • การแสวงหาประโยชน์จากปัญหาต่างๆบน Android ทำได้ยากขึ้นโดยการปรับปรุงในแพลตฟอร์ม Android เวอร์ชันใหม่กว่า เราขอแนะนำให้ผู้ใช้ทุกคนอัปเดตเป็น Android เวอร์ชันล่าสุดหากเป็นไปได้
  • ทีมรักษาความปลอดภัยของ Android คอยตรวจสอบการละเมิดด้วย Verify Apps และ SafetyNet ซึ่งออกแบบมาเพื่อเตือนผู้ใช้เกี่ยวกับ แอปพลิเคชันที่อาจเป็นอันตราย ตรวจสอบว่าแอปเปิดใช้งานโดยค่าเริ่มต้นบนอุปกรณ์ที่มี บริการมือถือของ Google และมีความสำคัญอย่างยิ่งสำหรับผู้ใช้ที่ติดตั้งแอปพลิเคชันจากภายนอก Google Play ห้ามใช้เครื่องมือรูทอุปกรณ์ใน Google Play แต่ Verify Apps จะเตือนผู้ใช้เมื่อพยายามติดตั้งแอปพลิเคชันการรูทที่ตรวจพบไม่ว่าจะมาจากที่ใดก็ตาม นอกจากนี้ Verify Apps ยังพยายามระบุและบล็อกการติดตั้งแอปพลิเคชันที่เป็นอันตรายซึ่งเป็นที่รู้จักซึ่งใช้ช่องโหว่ในการเพิ่มสิทธิ์ หากแอปพลิเคชันดังกล่าวได้รับการติดตั้งแล้ว Verify Apps จะแจ้งให้ผู้ใช้ทราบและพยายามลบแอปพลิเคชันที่ตรวจพบ
  • ตามความเหมาะสมแอปพลิเคชัน Google Hangouts และ Messenger จะไม่ส่งผ่านสื่อไปยังกระบวนการต่างๆเช่น Mediaserver โดยอัตโนมัติ

กิตติกรรมประกาศ

เราขอขอบคุณนักวิจัยเหล่านี้สำหรับผลงาน:

  • Aravind Machiry (donfos) จาก Shellphish Grill Team: CVE-2016-5349
  • Daxing Guo ( @ freener0 ) จาก Xuanwu Lab, Tencent: CVE-2017-0585, CVE-2017-0553
  • Derrek ( @ derrekr6 ) และ Scott Bauer: CVE-2017-0576
  • Gal Beniamini จาก Project Zero: CVE-2017-0571, CVE-2017-0570, CVE-2017-0572, CVE-2017-0569, CVE-2017-0561
  • Gengjia Chen ( @ chengjia4574 ) และ pjf จาก IceSword Lab, Qihoo 360 Technology Co. Ltd. : CVE-2017-6426, CVE-2017-0581, CVE-2017-0329, CVE-2017-0332, CVE-2017-0566, CVE-2017-0573
  • Guang Gong (龚广) ( @oldfresher ) จาก Alpha Team, Qihoo 360 Technology Co. Ltd. : CVE-2017-0547
  • Hao Chen และ Guang Gong จาก Alpha Team, Qihoo 360 Technology Co. Ltd. : CVE-2017-6424, CVE-2017-0584, CVE-2017-0454, CVE-2017-0574, CVE-2017-0575, CVE-2017 -0567
  • Ian Foster ( @lanrat ): CVE-2017-0554
  • Jack Tang จาก Trend Micro Inc. : CVE-2017-0579
  • Jianjun Dai ( @Jioun_dai ) จาก Qihoo 360 Skyeye Labs : CVE-2017-0559, CVE-2017-0541
  • Jianqiang Zhao ( @jianqiangzhao ) และ pjf จาก IceSword Lab, Qihoo 360: CVE-2017-6425, CVE-2016-5346
  • Lubo Zhang ( zlbzlb815@163.com ) จาก C0RE Team และ Yonggang Guo ( @guoygang ) จาก IceSword Lab, Qihoo 360 Technology Co. Ltd. : CVE-2017-0564
  • Mark Salyzyn จาก Google: CVE-2017-0558
  • Mike Andereson ( @manderbot ) และ Nathan Crandall ( @natecray ) จากทีมรักษาความปลอดภัยผลิตภัณฑ์ของ Tesla: CVE-2017-0327, CVE-2017-0328
  • Peng Xiao, Chengming Yang, Ning You, Chao Yang และ Yang song จาก Alibaba Mobile Security Group: CVE-2017-0565
  • Pengfei Ding (丁鹏飞), Chenfu Bao (包沉浮) และ Lenx Wei (韦韬) จาก Baidu X-Lab (百度安全实验室): CVE-2016-10236
  • Qidan He (何淇丹 - @flanker_hqd ) จาก KeenLab, Tencent: CVE-2017-0544, CVE-2017-0325
  • Roee Hay ( @roeehay ) จาก Aleph Research, HCL Technologies: CVE-2017-0582, CVE-2017-0563
  • Scott Bauer ( @ ScottyBauer1 ): CVE-2017-0562, CVE-2017-0339
  • Seven Shen ( @lingtongshen ) จากทีมวิจัยภัยคุกคามของ TrendMicro Mobile: CVE-2016-10231, CVE-2017-0578, CVE-2017-0586
  • ทิมเบ็กเกอร์: CVE-2017-0546
  • Uma Sankar Pradhan ( @umasankar_iitd ): CVE-2017-0560
  • VEO ( @VYSEa ) ของ Mobile Threat Response Team , Trend Micro : CVE-2017-0555, CVE-2017-0538, CVE-2017-0539, CVE-2017-0557, CVE-2017-0556
  • Weichao Sun ( @sunblate ) จาก Alibaba Inc: CVE-2017-0549
  • Wenlin Yang ( @wenlin_yang ), Guang Gong ( @oldfresher ) และ Hao Chen จาก Alpha Team, Qihoo 360 Technology Co. Ltd. : CVE-2017-0580, CVE-2017-0577
  • Zinuo Han จาก Chengdu Security Response Center ของ Qihoo 360 Technology Co. Ltd. : CVE-2017-0548
  • Zubin Mithra จาก Google: CVE-2017-0462

2017-04-01 ระดับแพตช์ความปลอดภัย - รายละเอียดช่องโหว่

ในส่วนด้านล่างเราให้รายละเอียดสำหรับช่องโหว่ด้านความปลอดภัยแต่ละรายการที่ใช้กับระดับแพตช์ 2017-04-01 มีคำอธิบายของปัญหาเหตุผลความรุนแรงและตารางที่มี CVE การอ้างอิงที่เกี่ยวข้องความรุนแรง อุปกรณ์ Google ที่อัปเดตเวอร์ชัน AOSP ที่อัปเดต (หากมี) และวันที่รายงาน เมื่อพร้อมใช้งานเราจะเชื่อมโยงการเปลี่ยนแปลงสาธารณะที่แก้ไขปัญหากับรหัสข้อบกพร่องเช่นรายการการเปลี่ยนแปลง AOSP เมื่อการเปลี่ยนแปลงหลายอย่างเกี่ยวข้องกับจุดบกพร่องเดียวการอ้างอิงเพิ่มเติมจะเชื่อมโยงกับตัวเลขตามรหัสข้อบกพร่อง

ช่องโหว่การเรียกใช้รหัสระยะไกลใน Mediaserver

ช่องโหว่การเรียกใช้โค้ดจากระยะไกลใน Mediaserver สามารถเปิดใช้งานผู้โจมตีโดยใช้ไฟล์ที่สร้างขึ้นมาเป็นพิเศษเพื่อทำให้หน่วยความจำเสียหายระหว่างไฟล์สื่อและการประมวลผลข้อมูล ปัญหานี้ได้รับการจัดอันดับว่าเป็นวิกฤตเนื่องจากความเป็นไปได้ของการเรียกใช้รหัสระยะไกลภายในบริบทของกระบวนการ Mediaserver

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0538 A-33641588 สำคัญ ทั้งหมด 6.0, 6.0.1, 7.0, 7.1.1 13 ธ.ค. 2559
CVE-2017-0539 A-33864300 สำคัญ ทั้งหมด 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 23 ธ.ค. 2559
CVE-2017-0541 A-34031018 สำคัญ ทั้งหมด 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 1 ม.ค. 2017
CVE-2017-0542 A-33934721 สำคัญ ทั้งหมด 6.0, 6.0.1, 7.0, 7.1.1 ภายในของ Google
CVE-2017-0543 A-34097866 สำคัญ ทั้งหมด 6.0, 6.0.1, 7.0, 7.1.1 ภายในของ Google

การเพิ่มช่องโหว่ของสิทธิ์ใน CameraBase

การเพิ่มช่องโหว่ของสิทธิ์พิเศษใน CameraBase อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยอำเภอใจได้ ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากเป็นการใช้รหัสโดยอำเภอใจในกระบวนการที่มีสิทธิพิเศษ

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0544 A-31992879 สูง ทั้งหมด 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 6 ต.ค. 2559

การเพิ่มช่องโหว่ของสิทธิ์ใน Audioserver

การเพิ่มช่องโหว่ของสิทธิพิเศษใน Audioserver อาจทำให้แอปพลิเคชันที่เป็นอันตรายในระบบสามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของกระบวนการที่มีสิทธิพิเศษ ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากสามารถใช้เพื่อเข้าถึงความสามารถที่ยกระดับในพื้นที่ซึ่งโดยปกติแอปพลิเคชันของบุคคลที่สามไม่สามารถเข้าถึงได้

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0545 A-32591350 สูง ทั้งหมด 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 31 ต.ค. 2559

การยกระดับช่องโหว่ของสิทธิ์ใน SurfaceFlinger

การยกระดับช่องโหว่ของสิทธิ์ใน SurfaceFlinger อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของกระบวนการที่มีสิทธิพิเศษ ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากสามารถใช้เพื่อเข้าถึงความสามารถที่ยกระดับในพื้นที่ซึ่งโดยปกติแอปพลิเคชันของบุคคลที่สามไม่สามารถเข้าถึงได้

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0546 A-32628763 สูง ทั้งหมด 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2 พ.ย. 2559

ช่องโหว่ในการเปิดเผยข้อมูลใน Mediaserver

ช่องโหว่ในการเปิดเผยข้อมูลใน Mediaserver อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเข้าถึงข้อมูลนอกระดับสิทธิ์ได้ ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากเป็นการเลี่ยงผ่านทั่วไปสำหรับการป้องกันระบบปฏิบัติการที่แยกข้อมูลแอปพลิเคชันออกจากแอปพลิเคชันอื่น

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0547 A-33861560 สูง ทั้งหมด 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 22 ธ.ค. 2559

การปฏิเสธช่องโหว่ของบริการในลิเบีย

ช่องโหว่การปฏิเสธบริการจากระยะไกลใน libskia อาจทำให้ผู้โจมตีสามารถใช้ไฟล์ที่สร้างขึ้นมาเป็นพิเศษเพื่อทำให้อุปกรณ์ค้างหรือรีบูตได้ ปัญหานี้ได้รับการจัดอันดับว่ามีความรุนแรงสูงเนื่องจากมีความเป็นไปได้ของการปฏิเสธการให้บริการจากระยะไกล

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0548 A-33251605 สูง ทั้งหมด 7.0, 7.1.1 29 พ.ย. 2559

การปฏิเสธช่องโหว่ของบริการใน Mediaserver

ช่องโหว่การปฏิเสธบริการจากระยะไกลใน Mediaserver อาจทำให้ผู้โจมตีสามารถใช้ไฟล์ที่สร้างขึ้นมาเป็นพิเศษเพื่อทำให้อุปกรณ์ค้างหรือรีบูตได้ ปัญหานี้ได้รับการจัดอันดับว่ามีความรุนแรงสูงเนื่องจากมีความเป็นไปได้ของการปฏิเสธการให้บริการจากระยะไกล

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0549 A-33818508 สูง ทั้งหมด 6.0, 6.0.1, 7.0, 7.1.1 20 ธ.ค. 2559
CVE-2017-0550 A-33933140 สูง ทั้งหมด 6.0, 6.0.1, 7.0, 7.1.1 ภายในของ Google
CVE-2017-0551 A-34097231 [ 2 ] สูง ทั้งหมด 6.0, 6.0.1, 7.0, 7.1.1 ภายในของ Google
CVE-2017-0552 A-34097915 สูง ทั้งหมด 6.0, 6.0.1, 7.0, 7.1.1 ภายในของ Google

การเพิ่มช่องโหว่ของสิทธิ์ใน libnl

การเพิ่มช่องโหว่ของสิทธิพิเศษใน libnl อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของบริการ Wi-Fi ปัญหานี้ได้รับการจัดอันดับให้อยู่ในระดับปานกลางเนื่องจากก่อนอื่นต้องมีการประนีประนอมกับกระบวนการที่มีสิทธิพิเศษและได้รับการบรรเทาโดยการกำหนดค่าแพลตฟอร์มปัจจุบัน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0553 A-32342065 ปานกลาง ทั้งหมด 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 21 ต.ค. 2559

การยกระดับช่องโหว่ของสิทธิ์ในระบบโทรศัพท์

การยกระดับช่องโหว่ของสิทธิพิเศษในคอมโพเนนต์ Telephony อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเข้าถึงความสามารถภายนอกระดับสิทธิ์ได้ ปัญหานี้ได้รับการจัดอันดับให้อยู่ในระดับปานกลางเนื่องจากสามารถใช้เพื่อเข้าถึงความสามารถที่ยกระดับซึ่งโดยปกติแอปพลิเคชันของบุคคลที่สามไม่สามารถเข้าถึงได้

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0554 A-33815946 [ 2 ] ปานกลาง ทั้งหมด 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 20 ธ.ค. 2559

ช่องโหว่ในการเปิดเผยข้อมูลใน Mediaserver

ช่องโหว่ในการเปิดเผยข้อมูลใน Mediaserver อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเข้าถึงข้อมูลนอกระดับการอนุญาตได้ ปัญหานี้ได้รับการจัดอันดับให้อยู่ในระดับปานกลางเนื่องจากสามารถใช้เพื่อเข้าถึงข้อมูลโดยไม่ได้รับอนุญาต

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0555 A-33551775 ปานกลาง ทั้งหมด 6.0, 6.0.1, 7.0, 7.1.1 12 ธ.ค. 2559
CVE-2017-0556 A-34093952 ปานกลาง ทั้งหมด 6.0, 6.0.1, 7.0, 7.1.1 4 ม.ค. 2560
CVE-2017-0557 A-34093073 ปานกลาง ทั้งหมด 6.0, 6.0.1, 7.0, 7.1.1 4 ม.ค. 2560
CVE-2017-0558 A-34056274 ปานกลาง ทั้งหมด 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 ภายในของ Google

ช่องโหว่ในการเปิดเผยข้อมูลใน Libskia

ช่องโหว่ในการเปิดเผยข้อมูลใน libskia อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเข้าถึงข้อมูลนอกระดับการอนุญาตได้ ปัญหานี้ได้รับการจัดอันดับให้อยู่ในระดับปานกลางเนื่องจากสามารถใช้เพื่อเข้าถึงข้อมูลโดยไม่ได้รับอนุญาต

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0559 A-33897722 ปานกลาง ทั้งหมด 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25 ธ.ค. 2559

ช่องโหว่ในการเปิดเผยข้อมูลในการรีเซ็ตเป็นค่าเริ่มต้นจากโรงงาน

ช่องโหว่ในการเปิดเผยข้อมูลในกระบวนการรีเซ็ตเป็นค่าเริ่มต้นจากโรงงานอาจทำให้ผู้โจมตีที่เป็นอันตรายในพื้นที่สามารถเข้าถึงข้อมูลจากเจ้าของเดิมได้ ปัญหานี้ได้รับการจัดอันดับให้อยู่ในระดับปานกลางเนื่องจากความเป็นไปได้ที่จะข้ามการป้องกันอุปกรณ์

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2017-0560 A-30681079 ปานกลาง ทั้งหมด 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 ภายในของ Google

2017-04-05 ระดับแพตช์ความปลอดภัย - รายละเอียดช่องโหว่

ในส่วนด้านล่างนี้เราจะให้รายละเอียดสำหรับช่องโหว่ด้านความปลอดภัยแต่ละรายการที่ใช้กับระดับแพตช์ 2017-04-05 มีคำอธิบายของปัญหาเหตุผลความรุนแรงและตารางที่มี CVE การอ้างอิงที่เกี่ยวข้องความรุนแรงอุปกรณ์ Google ที่อัปเดตเวอร์ชัน AOSP ที่อัปเดต (หากมี) และวันที่ที่รายงาน เมื่อพร้อมใช้งานเราจะเชื่อมโยงการเปลี่ยนแปลงสาธารณะที่แก้ไขปัญหากับรหัสข้อบกพร่องเช่นรายการการเปลี่ยนแปลง AOSP เมื่อการเปลี่ยนแปลงหลายอย่างเกี่ยวข้องกับจุดบกพร่องเดียวการอ้างอิงเพิ่มเติมจะเชื่อมโยงกับตัวเลขตามรหัสข้อบกพร่อง

ช่องโหว่การเรียกใช้รหัสระยะไกลในเฟิร์มแวร์ Broadcom Wi-Fi

ช่องโหว่ในการเรียกใช้โค้ดจากระยะไกลในเฟิร์มแวร์ Broadcom Wi-Fi อาจทำให้ผู้โจมตีระยะไกลสามารถเรียกใช้รหัสโดยพลการภายในบริบทของ Wi-Fi SoC ปัญหานี้ได้รับการจัดอันดับให้เป็นวิกฤตเนื่องจากความเป็นไปได้ของการเรียกใช้รหัสระยะไกลในบริบทของ Wi-Fi SoC

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0561 A-34199105 *
B-RB # 110814
สำคัญ Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 ม.ค. 2560

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

ช่องโหว่การเรียกใช้โค้ดจากระยะไกลในโปรแกรมควบคุมเครื่องมือเข้ารหัสลับของ Qualcomm

ช่องโหว่การเรียกใช้รหัสจากระยะไกลในโปรแกรมควบคุมเครื่องมือเข้ารหัสลับของ Qualcomm อาจทำให้ผู้โจมตีระยะไกลสามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับเป็นวิกฤตเนื่องจากความเป็นไปได้ของการเรียกใช้โค้ดระยะไกลในบริบทของเคอร์เนล

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2016-10230 A-34389927
QC-CR # 1091408
สำคัญ Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 10 ม.ค. 2560

ช่องโหว่การเรียกใช้รหัสระยะไกลในระบบย่อยเครือข่ายเคอร์เนล

ช่องโหว่การเรียกใช้รหัสระยะไกลในระบบย่อยเครือข่ายเคอร์เนลอาจทำให้ผู้โจมตีระยะไกลสามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับเป็นวิกฤตเนื่องจากความเป็นไปได้ของการเรียกใช้โค้ดระยะไกลในบริบทของเคอร์เนล

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2016-10229 A-32813456
เคอร์เนลต้นน้ำ
สำคัญ Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player ภายในของ Google

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์หน้าจอสัมผัส MediaTek

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในโปรแกรมควบคุมหน้าจอสัมผัส MediaTek อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าเป็นวิกฤตเนื่องจากมีความเป็นไปได้ที่อุปกรณ์ถาวรในเครื่องอาจถูกบุกรุกซึ่งอาจต้องมีการรีแฟลชระบบปฏิบัติการเพื่อซ่อมแซมอุปกรณ์

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0562 ก -30202425 *
M-ALPS02898189
วิกฤต * ไม่มี** 16 ก.ค. 2559

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

** อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์หน้าจอสัมผัส HTC

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในไดรเวอร์หน้าจอสัมผัสของ HTC อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าเป็นวิกฤตเนื่องจากมีความเป็นไปได้ที่อุปกรณ์ถาวรในเครื่องอาจถูกบุกรุกซึ่งอาจต้องมีการรีแฟลชระบบปฏิบัติการเพื่อซ่อมแซมอุปกรณ์

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0563 A-32089409 *
สำคัญ Nexus 9 9 ต.ค. 2559

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

การเพิ่มช่องโหว่ของสิทธิพิเศษในระบบย่อยเคอร์เนล ION

การยกระดับช่องโหว่ของสิทธิพิเศษในระบบย่อยของเคอร์เนล ION อาจทำให้แอปพลิเคชันที่เป็นอันตรายในระบบสามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าเป็นวิกฤตเนื่องจากมีความเป็นไปได้ที่อุปกรณ์ถาวรในเครื่องอาจถูกบุกรุกซึ่งอาจต้องมีการรีแฟลชระบบปฏิบัติการเพื่อซ่อมแซมอุปกรณ์

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0564 A-34276203 *
สำคัญ Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player 12 ม.ค. 2560

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

ช่องโหว่ในส่วนประกอบของ Qualcomm

ช่องโหว่เหล่านี้ส่งผลกระทบต่อส่วนประกอบของ Qualcomm และมีการอธิบายรายละเอียดเพิ่มเติมในประกาศความปลอดภัยของ Qualcomm AMSS ตุลาคม 2016

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2016-10237 A-31628601 **
QC-CR # 1046751
สำคัญ ไม่มี** Qualcomm ภายใน
CVE-2016-10238 A-35358527 **
QC-CR # 1042558
สำคัญ ไม่มี*** Qualcomm ภายใน
CVE-2016-10239 A-31624618 **
QC-CR # 1032929
สูง Pixel, Pixel XL Qualcomm ภายใน

* ผู้ให้บริการกำหนดระดับความรุนแรงของช่องโหว่เหล่านี้

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

*** อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

ช่องโหว่การเรียกใช้รหัสระยะไกลใน v8

ช่องโหว่การเรียกใช้โค้ดจากระยะไกลใน v8 อาจทำให้ผู้โจมตีจากระยะไกลสามารถเรียกใช้รหัสโดยอำเภอใจได้ภายในบริบทของกระบวนการที่มีสิทธิพิเศษ ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากความเป็นไปได้ของการเรียกใช้รหัสระยะไกลในเว็บไซต์

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2016-5129 A-29178923 สูง ไม่มี* 6.0, 6.0.1, 7.0 20 ก.ค. 2559

* อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งการอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

ช่องโหว่การเรียกใช้รหัสระยะไกลใน Freetype

ช่องโหว่ในการเรียกใช้โค้ดจากระยะไกลใน Freetype อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่โหลดแบบอักษรที่ออกแบบมาเป็นพิเศษเพื่อทำให้หน่วยความจำเสียหายในกระบวนการที่ไม่มีสิทธิ์ ปัญหานี้ได้รับการจัดอันดับเป็นสูงเนื่องจากความเป็นไปได้ของการเรียกใช้รหัสระยะไกลในแอปพลิเคชันที่ใช้ไลบรารีนี้

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google อัปเดตเวอร์ชัน AOSP วันที่รายงาน
CVE-2016-10244 A-31470908 สูง ไม่มี* 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 13 ก.ย. 2559

* อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งการอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

การเพิ่มช่องโหว่สิทธิ์ในระบบย่อยเสียงเคอร์เนล

การยกระดับช่องโหว่ของสิทธิพิเศษในระบบย่อยเสียงของเคอร์เนลอาจทำให้แอปพลิเคชันที่เป็นอันตรายในระบบสามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2014-4656 A-34464977
เคอร์เนลต้นน้ำ
สูง Nexus 6, Nexus Player 26 มิ.ย. 2557

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในไดรเวอร์การเข้ารหัสลับของ NVIDIA

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในไดรเวอร์การเข้ารหัสลับของ NVIDIA อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0339 A-27930566 *
N-CVE-2017-0339
สูง Nexus 9 29 มี.ค. 2559
CVE-2017-0332 A-33812508 *
N-CVE-2017-0332
สูง Nexus 9 21 ธ.ค. 2559
CVE-2017-0327 A-33893669 *
N-CVE-2017-0327
สูง Nexus 9 24 ธันวาคม 2559

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในโปรแกรมควบคุมความร้อน MediaTek

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในโปรแกรมควบคุมความร้อน MediaTek อาจทำให้แอปพลิเคชันที่เป็นอันตรายในระบบสามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0565 A-28175904 *
M-ALPS02696516
สูง ไม่มี** 11 เม.ย. 2559

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

** อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์กล้อง MediaTek

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์กล้อง MediaTek อาจทำให้แอปพลิเคชันที่เป็นอันตรายในระบบสามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0566 A-28470975 *
M-ALPS02696367
สูง ไม่มี** 29 เม.ย. 2559

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

** อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์ Broadcom Wi-Fi

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์ Broadcom Wi-Fi อาจทำให้แอปพลิเคชันที่เป็นอันตรายในระบบสามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0567 A-32125310 *
B-RB # 112575
สูง Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 12 ต.ค. 2559
CVE-2017-0568 A-34197514 *
B-RB # 112600
สูง Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 ม.ค. 2560
CVE-2017-0569 A-34198729 *
B-RB # 110666
สูง Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 ม.ค. 2560
CVE-2017-0570 A-34199963 *
B-RB # 110688
สูง Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9 ม.ค. 2560
CVE-2017-0571 A-34203305 *
B-RB # 111541
สูง Nexus 6, Nexus 6P, Pixel C, Nexus Player 9 ม.ค. 2560
CVE-2017-0572 A-34198931 *
B-RB # 112597
สูง ไม่มี** 9 ม.ค. 2560
CVE-2017-0573 A-34469904 *
B-RB # 91539
สูง Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 18 ม.ค. 2560
CVE-2017-0574 A-34624457 *
B-RB # 113189
สูง Nexus 6, Nexus 6P, Nexus 9 พิกเซล C 22 ม.ค. 2560

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

** อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์ Qualcomm Wi-Fi

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในไดรเวอร์ Qualcomm Wi-Fi อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0575 A-32658595 *
QC-CR # 1103099
สูง Nexus 5X, Pixel, Pixel XL 3 พ.ย. 2559

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์ NVIDIA I2C HID

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์ NVIDIA I2C HID อาจทำให้แอปพลิเคชันที่เป็นอันตรายในระบบสามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0325 A-33040280 *
N-CVE-2017-0325
สูง Nexus 9 พิกเซล C 20 พ.ย. 2559

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์เสียง Qualcomm

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในไดรเวอร์เสียงของ Qualcomm อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0454 A-33353700
QC-CR # 1104067
สูง Nexus 5X, Nexus 6P, Pixel, Pixel XL 5 ธ.ค. 2559

การเพิ่มช่องโหว่ของสิทธิ์ในโปรแกรมควบคุมเครื่องมือเข้ารหัสลับของ Qualcomm

การเพิ่มช่องโหว่ของสิทธิพิเศษในโปรแกรมควบคุมเครื่องมือเข้ารหัสลับของ Qualcomm อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0576 A-33544431
QC-CR # 1103089
สูง Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 9 ธ.ค. 2559

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์หน้าจอสัมผัส HTC

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในไดรเวอร์หน้าจอสัมผัสของ HTC อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0577 A-33842951 *
สูง ไม่มี** 21 ธ.ค. 2559

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

** อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์เสียง DTS

การเพิ่มช่องโหว่ของสิทธิพิเศษในโปรแกรมควบคุมเสียง DTS อาจทำให้แอปพลิเคชันที่เป็นอันตรายในระบบสามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0578 A-33964406 *
สูง ไม่มี** 28 ธ.ค. 2559

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

** อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์ตัวแปลงสัญญาณเสียง Qualcomm

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์ตัวแปลงสัญญาณเสียงของ Qualcomm อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2016-10231 A-33966912
QC-CR # 1096799
สูง Pixel, Pixel XL 29 ธ.ค. 2559

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในไดรเวอร์วิดีโอ Qualcomm

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในไดรเวอร์วิดีโอ Qualcomm อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0579 A-34125463 *
QC-CR # 1115406
สูง Nexus 5X, Nexus 6P, Pixel, Pixel XL 5 ม.ค. 2560
CVE-2016-10232 A-34386696
QC-CR # 1024872 [2]
สูง Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One 10 ม.ค. 2560
CVE-2016-10233 A-34389926
QC-CR # 897452
สูง ไม่มี** 10 ม.ค. 2560

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

** อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในการบูต NVIDIA และไดรเวอร์โปรเซสเซอร์การจัดการพลังงาน

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในการบูต NVIDIA และไดรเวอร์โปรเซสเซอร์การจัดการพลังงานอาจทำให้แอปพลิเคชันที่เป็นอันตรายในระบบสามารถเรียกใช้รหัสโดยพลการภายในบริบทของการบูตและโปรเซสเซอร์การจัดการพลังงาน ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0329 A-34115304 *
N-CVE-2017-0329
สูง พิกเซลค 5 ม.ค. 2560

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในไดรเวอร์หน้าจอสัมผัส Synaptics

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์ Synaptics Touchscreen อาจทำให้แอปพลิเคชันที่เป็นอันตรายในระบบสามารถเรียกใช้รหัสโดยอำเภอใจภายในบริบทของเคอร์เนล ปัญหานี้ได้รับการจัดอันดับว่าสูงเนื่องจากต้องมีการประนีประนอมกระบวนการที่มีสิทธิพิเศษก่อน

CVE อ้างอิง ความรุนแรง อัปเดตอุปกรณ์ Google วันที่รายงาน
CVE-2017-0580 A-34325986 *
สูง ไม่มี** 16 ม.ค. 2560
CVE-2017-0581 A-34614485 *
สูง ไม่มี** 22 ม.ค. 2560

* แพตช์สำหรับปัญหานี้ไม่สามารถใช้ได้แบบสาธารณะ การอัปเดตนี้มีอยู่ในไดรเวอร์ไบนารีล่าสุดสำหรับอุปกรณ์ Nexus ที่มีให้จาก ไซต์ Google Developer

** อุปกรณ์ Google ที่รองรับบน Android 7.0 หรือใหม่กว่าที่ติดตั้งอัปเดตที่มีอยู่ทั้งหมดจะไม่ได้รับผลกระทบจากช่องโหว่นี้

การเพิ่มช่องโหว่ของสิทธิพิเศษในไดรเวอร์ Qualcomm Seemp

การเพิ่มช่องโหว่ของสิทธิ์พิเศษในไดรเวอร์ Qualcomm Seemp อาจทำให้แอปพลิเคชันที่เป็นอันตรายในพื้นที่สามารถเรียกใช้รหัสโดยพลการภายในบริบทของเคอร์เนล This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0462 A-33353601
QC-CR#1102288
High Pixel, Pixel XL Google internal

Elevation of privilege vulnerability in Qualcomm Kyro L2 driver

An elevation of privilege vulnerability in the Qualcomm Kyro L2 driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6423 A-32831370
QC-CR#1103158
High Pixel, Pixel XL Google internal

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-9922 A-32761463
Upstream kernel
High Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Oct 24, 2014

Information disclosure vulnerability in kernel memory subsystem

An information disclosure vulnerability in the kernel memory subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-0206 A-34465735
Upstream kernel
High Nexus 6, Nexus Player May 6, 2014

Information disclosure vulnerability in kernel networking subsystem

An information disclosure vulnerability in the kernel networking subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-3145 A-34469585
Upstream kernel [2]
High Nexus 6, Nexus Player May 9, 2014

Information disclosure vulnerability in Qualcomm TrustZone

An information disclosure vulnerability in the Qualcomm TrustZone could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-5349 A-29083830
QC-CR#1021945 [2] [3] [4]
High Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Jun 1, 2016

Information disclosure vulnerability in Qualcomm IPA driver

An information disclosure vulnerability in the Qualcomm IPA driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-10234 A-34390017
QC-CR#1069060 [2]
High Nexus 5X, Nexus 6P, Pixel, Pixel XL Jan 10, 2017

Denial of service vulnerability in kernel networking subsystem

A denial of service vulnerability in the kernel networking subsystem could enable a remote attacker to use a specially crafted network packet to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2014-2706 A-34160553
Upstream kernel
High Nexus Player Apr 1, 2014

Denial of service vulnerability in Qualcomm Wi-Fi driver

A denial of service vulnerability in the Qualcomm Wi-Fi driver could enable a proximate attacker to cause a denial of service in the Wi-Fi subsystem. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-10235 A-34390620
QC-CR#1046409
High None** Jan 10, 2017

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-7097 A-32458736
Upstream kernel
Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Nexus Player Aug 28, 2016

Elevation of privilege vulnerability in Qualcomm Wi-Fi driver

An elevation of privilege vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and because of vulnerability specific details which limit the impact of the issue.

CVE References Severity Updated Google devices Date reported
CVE-2017-6424 A-32086742
QC-CR#1102648
Moderate Nexus 5X, Pixel, Pixel XL, Android One Oct 9, 2016

Elevation of privilege vulnerability in Broadcom Wi-Fi driver

An elevation of privilege vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-8465 A-32474971*
B-RB#106053
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in HTC OEM fastboot command

An elevation of privilege vulnerability in the HTC OEM fastboot command could enable a local malicious application to execute arbitrary code within the context of the sensor hub. This issue is rated as Moderate because it first requires exploitation of separate vulnerabilities.

CVE References Severity Updated Google devices Date reported
CVE-2017-0582 A-33178836*
Moderate Nexus 9 Nov 28, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Qualcomm CP access driver

An elevation of privilege vulnerability in the Qualcomm CP access driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and because of vulnerability specific details which limit the impact of the issue.

CVE References Severity Updated Google devices Date reported
CVE-2017-0583 A-32068683
QC-CR#1103788
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Google internal

Information disclosure vulnerability in kernel media driver

An information disclosure vulnerability in the kernel media driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-1739 A-34460642
Upstream kernel
Moderate Nexus 6, Nexus 9, Nexus Player Jun 15, 2014

Information disclosure vulnerability in Qualcomm Wi-Fi driver

An information disclosure vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0584 A-32074353*
QC-CR#1104731
Moderate Nexus 5X, Pixel, Pixel XL Oct 9, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Broadcom Wi-Fi driver

An information disclosure vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0585 A-32475556*
B-RB#112953
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm Avtimer driver

An information disclosure vulnerability in the Qualcomm Avtimer driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5346 A-32551280
QC-CR#1097878
Moderate Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm video driver

An information disclosure vulnerability in the Qualcomm video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6425 A-32577085
QC-CR#1103689
Moderate Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm USB driver

An information disclosure vulnerability in the Qualcomm USB driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10236 A-33280689
QC-CR#1102418
Moderate Pixel, Pixel XL Nov 30, 2016

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0586 A-33649808
QC-CR#1097569
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Dec 13, 2016

Information disclosure vulnerability in Qualcomm SPMI driver

An information disclosure vulnerability in the Qualcomm SPMI driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6426 A-33644474
QC-CR#1106842
Moderate Pixel, Pixel XL Dec 14, 2016

Information disclosure vulnerability in NVIDIA crypto driver

An information disclosure vulnerability in the NVIDIA crypto driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0328 A-33898322*
N-CVE-2017-0328
Moderate None** Dec 24, 2016
CVE-2017-0330 A-33899858*
N-CVE-2017-0330
Moderate None** Dec 24, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Vulnerabilities in Qualcomm components

These vulnerabilities affecting Qualcomm components were released as part of Qualcomm AMSS security bulletins between 2014–2016. They are included in this Android security bulletin to associate their fixes with an Android security patch level.

CVE References Severity Updated Google devices Date reported
CVE-2014-9931 A-35445101** Critical None** Qualcomm internal
CVE-2014-9932 A-35434683** Critical Pixel, Pixel XL Qualcomm internal
CVE-2014-9933 A-35442512** Critical None** Qualcomm internal
CVE-2014-9934 A-35439275** Critical None** Qualcomm internal
CVE-2014-9935 A-35444951** Critical None** Qualcomm internal
CVE-2014-9936 A-35442420** Critical None** Qualcomm internal
CVE-2014-9937 A-35445102** Critical None** Qualcomm internal
CVE-2015-8995 A-35445002** Critical None** Qualcomm internal
CVE-2015-8996 A-35444658** Critical None** Qualcomm internal
CVE-2015-8997 A-35432947** Critical None** Qualcomm internal
CVE-2015-8998 A-35441175** Critical None** Qualcomm internal
CVE-2015-8999 A-35445401** Critical None** Qualcomm internal
CVE-2015-9000 A-35441076** Critical None** Qualcomm internal
CVE-2015-9001 A-35445400** Critical None** Qualcomm internal
CVE-2015-9002 A-35442421** Critical None** Qualcomm internal
CVE-2015-9003 A-35440626** Critical None** Qualcomm internal
CVE-2016-10242 A-35434643** Critical None** Qualcomm internal

* The severity rating for these vulnerabilities was determined by the vendor.

** The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

*** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-04-01 or later address all issues associated with the 2017-04-01 security patch level.
  • Security patch levels of 2017-04-05 or later address all issues associated with the 2017-04-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-04-01]
  • [ro.build.version.security_patch]:[2017-04-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the April 01, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of April 05, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-04-01 and 2017-04-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • April 03, 2017: Bulletin published.
  • April 05, 2017: Bulletin revised to include AOSP links.
  • April 21, 2017: Attribution for CVE-2016-10231 and CVE-2017-0586 corrected.
  • April 27, 2017: CVE-2017-0540 removed from bulletin.
  • August 17, 2017: Bulletin revised to update reference numbers.