Android Güvenlik Bülteni—Mayıs 2021

3 Mayıs 2021 tarihinde yayınlandı | 4 Mayıs 2021'de güncellendi

Android Güvenlik Bülteni, Android cihazlarını etkileyen güvenlik açıklarının ayrıntılarını içerir. 2021-05-05 veya sonraki güvenlik yaması seviyeleri, tüm bu sorunları giderir. Bir aygıtın güvenlik yaması seviyesini kontrol görmeyi öğrenmek için kontrol ve Android sürümünü güncellemek .

Android iş ortaklarına, tüm sorunlar yayınlanmadan en az bir ay önce bildirilir. Bu sorunlar için kaynak kodu yamaları Android Açık Kaynak Projesi (AOSP) deposunda yayınlandı ve bu bültenden bağlantı verildi. Bu bülten ayrıca AOSP dışındaki yamalara bağlantılar içerir.

Bu sorunların en şiddetlisi, özel hazırlanmış bir dosya kullanan uzak bir saldırganın ayrıcalıklı bir işlem bağlamında rasgele kod yürütmesine olanak verebilecek Sistem bileşenindeki kritik bir güvenlik açığıdır. Ciddi değerlendirmeler açığı kullanarak muhtemelen platformu ve servis azaltıcı etkenler geliştirme amacıyla kapalı veya başarılı baypas eğer varsayarak, etkilenen bir cihazda olacağını etkisi dayanmaktadır.

Bakınız , Android ve Google Koru hafifletilmesi Çal ilgili ayrıntılar için bölüm Android güvenlik platformu korumaları ve Google Android platformunun güvenliğini artırmak olan Koru oyna.

Android ve Google hizmeti azaltmaları

Bu tarafından sağlanan azaltıcı etkenleri bir özetidir Android güvenlik platformu gibi ve servis korumaları koru Google Play . Bu yetenekler, güvenlik açıklarından Android'de başarıyla yararlanma olasılığını azaltır.

  • Android platformunun daha yeni sürümlerinde yapılan geliştirmeler sayesinde Android'deki birçok sorundan yararlanma daha zor hale getirilmiştir. Tüm kullanıcıları, mümkün olduğunda Android'in en son sürümüne güncellemeye teşvik ediyoruz.
  • Yoluyla istismar için Android güvenlik ekibi aktif olarak izler Google Koru oyna ve hakkında kullanıcıları uyarıyor Potansiyel Zararlı Uygulamalar . Google ile cihazlarda varsayılan olarak etkindir Koru oyna Google Mobil Hizmetleri ve Google Play dışından uygulama yükleyebilmek kullanıcılar için özellikle önemlidir.

2021-05-01 güvenlik yaması düzeyinde güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2021-05-01 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sağlıyoruz. Güvenlik açıkları, etkiledikleri bileşen altında gruplandırılmıştır. Sorunlar aşağıdaki tablolarda tarif edilen ve CVE numarası, ilişkili referanslar içerir savunma türünü , şiddeti , ve güncel AOSP sürümlerini (uygun olduğu yerde). Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır. Daha sonra Android 10 ve sahip cihazlar güvenlik güncellemelerini yanı sıra alabilirsiniz Google Play sistem güncellemelerini .

çerçeve

Bu bölümdeki en ciddi güvenlik açığı, yerel bir kötü amaçlı uygulamanın ek izinlere erişmek için kullanıcı etkileşimi gereksinimlerini atlamasına olanak verebilir.

CVE Referanslar Tür önem Güncellenmiş AOSP sürümleri
CVE-2021-0472 A-176801033 EoP Yüksek 9, 10, 11
CVE-2021-0485 A-174302616 EoP Yüksek 11
CVE-2021-0487 A-174046397 EoP Yüksek 11

Medya Çerçevesi

Bu bölümdeki en ciddi güvenlik açığı, yerel bir kötü amaçlı uygulamanın ek izinlere erişmek için kullanıcı etkileşimi gereksinimlerini atlamasına olanak verebilir.

CVE Referanslar Tür önem Güncellenmiş AOSP sürümleri
CVE-2021-0482 A-173791720 EoP Yüksek 11
CVE-2021-0484 A-173720767 İD Yüksek 8.1, 9, 10, 11

sistem

Bu bölümdeki en ciddi güvenlik açığı, uzaktaki bir saldırganın özel hazırlanmış bir dosya kullanarak ayrıcalıklı bir işlem bağlamında rasgele kod yürütmesine olanak verebilir.

CVE Referanslar Tür önem Güncellenmiş AOSP sürümleri
CVE-2021-0473 A-179687208 RCE kritik 8.1, 9, 10, 11
CVE-2021-0474 A-177611958 RCE kritik 8.1, 9, 10, 11
CVE-2021-0475 A-175686168 RCE kritik 10, 11
CVE-2021-0476 A-169252501 EoP Yüksek 9, 10, 11
CVE-2021-0477 A-178189250 EoP Yüksek 8.1, 9, 10, 11
CVE-2021-0481 A-172939189 EoP Yüksek 8.1, 9, 10, 11
CVE-2021-0466 A-154114734 İD Yüksek 10
CVE-2021-0480 A-174493336 İD Yüksek 8.1, 9, 10, 11

Google Play sistem güncellemeleri

Bu ay Google Play sistem güncellemelerinde (Project Mainline) ele alınan herhangi bir güvenlik sorunu yok.

2021-05-05 güvenlik yaması düzeyinde güvenlik açığı ayrıntıları

Aşağıdaki bölümlerde, 2021-05-05 yama düzeyi için geçerli olan güvenlik açıklarının her biri için ayrıntılar sunuyoruz. Güvenlik açıkları, etkiledikleri bileşen altında gruplandırılmıştır. Sorunlar aşağıdaki tablolarda tarif edilen ve CVE numarası, ilişkili referanslar içerir savunma türünü , şiddeti , ve güncel AOSP sürümlerini (uygun olduğu yerde). Mevcut olduğunda, sorunu ele alan genel değişikliği AOSP değişiklik listesi gibi hata kimliğine bağlarız. Birden fazla değişiklik tek bir hatayla ilgili olduğunda, hata kimliğini izleyen sayılara ek referanslar bağlanır.

çerçeve

Bu bölümdeki güvenlik açığı, yerel bir kötü amaçlı uygulamanın, uygulama verilerini diğer uygulamalardan izole eden işletim sistemi korumalarını atlamasını sağlayabilir.

CVE Referanslar Tür önem Güncellenmiş AOSP sürümleri
CVE-2019-2219 A-119041698 İD Yüksek 11

Çekirdek bileşenleri

Bu bölümdeki güvenlik açığı, yerel bir saldırganın ek izinlere erişmek için kullanıcı etkileşimi gereksinimlerini atlamasını sağlayabilir.

CVE Referanslar Tür önem Bileşen
CVE-2020-29661 A-175451802
yukarı akış çekirdeği
EoP Yüksek TTY

AMLojik

Bu güvenlik açığı AMLogic bileşenlerini etkiler ve daha fazla ayrıntı doğrudan AMLogic'ten edinilebilir. Bu sorunun önem derecesi değerlendirmesi doğrudan AMLogic tarafından sağlanır.

CVE Referanslar önem Bileşen
CVE-2021-0467 A-174490700 * kritik önyükleme ROM'u

ARM bileşenleri

Bu güvenlik açıkları ARM bileşenlerini etkiler ve daha fazla ayrıntı doğrudan ARM'den edinilebilir. Bu sorunların önem derecesi değerlendirmesi doğrudan ARM tarafından sağlanmaktadır.

CVE Referanslar önem Bileşen
CVE-2021-28663
A-174259860 * Yüksek Mali
CVE-2021-28664
A-174588870 * Yüksek Mali

MediaTek bileşenleri

Bu güvenlik açıkları MediaTek bileşenlerini etkiler ve daha fazla ayrıntı doğrudan MediaTek'ten edinilebilir. Bu sorunların önem derecesi değerlendirmesi doğrudan MediaTek tarafından sağlanır.

CVE Referanslar önem Bileşen
CVE-2021-0489 A-183464866
M-ALPS05403499 *
Yüksek bellek yönetimi sürücüsü
CVE-2021-0490
A-183464868
M-ALPS05403499 *
Yüksek bellek yönetimi sürücüsü
CVE-2021-0491 A-183461315
M-ALPS05403499 *
Yüksek bellek yönetimi sürücüsü
CVE-2021-0492 A-183459078
M-ALPS05403499 *
Yüksek bellek yönetimi sürücüsü
CVE-2021-0493
A-183461317
M-ALPS05403499 *
Yüksek bellek yönetimi sürücüsü
CVE-2021-0494 A-183461318
M-ALPS05403499 *
Yüksek bellek yönetimi sürücüsü
CVE-2021-0495 A-183459083
M-ALPS05403499 *
Yüksek bellek yönetimi sürücüsü
CVE-2021-0496 A-183467912
M-ALPS05403499 *
Yüksek bellek yönetimi sürücüsü
CVE-2021-0497 A-183461320
M-ALPS05403499 *
Yüksek bellek yönetimi sürücüsü
CVE-2021-0498 A-183461321
M-ALPS05403499 *
Yüksek bellek yönetimi sürücüsü

Unisoc bileşenleri

Bu güvenlik açığı Unisoc bileşenlerini etkiler ve daha fazla ayrıntı doğrudan Unisoc'tan edinilebilir. Bu sorunun önem derecesi değerlendirmesi doğrudan Unisoc tarafından sağlanmaktadır.

CVE Referanslar önem Bileşen
CVE-2021-0324 A-175402462 * Yüksek çerçeve

Qualcomm bileşenleri

Bu güvenlik açıkları Qualcomm bileşenlerini etkiler ve uygun Qualcomm güvenlik bülteninde veya güvenlik uyarısında daha ayrıntılı olarak açıklanmıştır. Bu sorunların önem derecesi değerlendirmesi doğrudan Qualcomm tarafından sağlanır.

CVE Referanslar önem Bileşen
CVE-2021-1891 A-179039763
QC-CR # 2766242 [ 2 ]
Yüksek Ses
CVE-2021-1905 A-178809945
QC-CR#2826864
Yüksek Görüntüle
CVE-2021-1927 A-179040600
QC-CR#2827356
Yüksek Çekirdek
CVE-2021-1906 A-178810049
QC-CR#2835082
orta Görüntüle

Qualcomm kapalı kaynak bileşenleri

Bu güvenlik açıkları Qualcomm kapalı kaynak bileşenlerini etkiler ve uygun Qualcomm güvenlik bülteninde veya güvenlik uyarısında daha ayrıntılı olarak açıklanmıştır. Bu sorunların önem derecesi değerlendirmesi doğrudan Qualcomm tarafından sağlanır.

CVE Referanslar önem Bileşen
CVE-2020-11273 A-172348952 * Yüksek Kapalı kaynak bileşeni
CVE-2020-11274
A-172348993 * Yüksek Kapalı kaynak bileşeni
CVE-2020-11279 A-172348857 * Yüksek Kapalı kaynak bileşeni
CVE-2020-11284 A-172348929 * Yüksek Kapalı kaynak bileşeni
CVE-2020-11285 A-172349029 * Yüksek Kapalı kaynak bileşeni
CVE-2020-11288 A-172348722 * Yüksek Kapalı kaynak bileşeni
CVE-2020-11289 A-172348852 * Yüksek Kapalı kaynak bileşeni
CVE-2021-1910 A-179039901 * Yüksek Kapalı kaynak bileşeni
CVE-2021-1915 A-172944461 * Yüksek Kapalı kaynak bileşeni

Sık sorulan sorular ve cevaplar

Bu bölüm, bu bülteni okuduktan sonra ortaya çıkabilecek genel soruları yanıtlamaktadır.

1. Cihazımın bu sorunları gidermek için güncellenip güncellenmediğini nasıl belirleyebilirim?

Bir aygıtın güvenlik yaması seviyesini kontrol görmeyi öğrenmek için kontrol ve Android sürümünü güncellemek .

  • 2021-05-01 veya sonraki güvenlik yaması seviyeleri, 2021-05-01 güvenlik yaması seviyesiyle ilişkili tüm sorunları ele alır.
  • 2021-05-05 veya sonraki güvenlik yaması seviyeleri, 2021-05-05 güvenlik yaması seviyesi ve önceki tüm yama seviyeleri ile ilgili tüm sorunları ele alır.

Bu güncellemeleri içeren cihaz üreticileri, yama dizesi düzeyini şu şekilde ayarlamalıdır:

  • [ro.build.version.security_patch]:[2021-05-01]
  • [ro.build.version.security_patch]:[2021-05-05]

Android 10 veya sonraki sürümlerdeki bazı cihazlar için Google Play sistem güncellemesi, 2021-05-01 güvenlik yaması düzeyiyle eşleşen bir tarih dizisine sahip olacaktır. Bakınız bu yazıyı güvenlik güncelleştirmelerini yükleme hakkında daha fazla ayrıntı için.

2. Bu bültende neden iki güvenlik düzeltme eki düzeyi var?

Bu bültende, Android iş ortaklarının tüm Android cihazlarda benzer olan bir dizi güvenlik açığını daha hızlı düzeltme esnekliğine sahip olması için iki güvenlik düzeltme eki düzeyi vardır. Android iş ortaklarının bu bültendeki tüm sorunları düzeltmeleri ve en son güvenlik düzeltme eki düzeyini kullanmaları önerilir.

  • 2021-05-01 güvenlik yaması düzeyini kullanan cihazlar, bu güvenlik yaması düzeyiyle ilişkili tüm sorunları ve önceki güvenlik bültenlerinde bildirilen tüm sorunların düzeltmelerini içermelidir.
  • 2021-05-05 veya daha yeni güvenlik yaması düzeyini kullanan cihazlar, bu (ve önceki) güvenlik bültenlerinde geçerli tüm yamaları içermelidir.

İş ortaklarının, ele aldıkları tüm sorunlara yönelik düzeltmeleri tek bir güncellemede toplamaları önerilir.

Tür sütunu ortalama girişleri ne yapıyoruz 3.?

Güvenlik açığının Tür sütununda Girişler masa referansı güvenlik açığına sınıflandırma ayrıntıları.

Kısaltma Tanım
RCE Uzaktan kod yürütme
EoP Ayrıcalığın yükseltilmesi
İD Bilgi ifşası
DoS hizmet reddi
Yok Sınıflandırma mevcut değil

Başvurular sütun ortalama girişleri ne yapıyoruz 4.?

Savunma bilgilerini tablonun Referanslar sütunu altındaki verileri referans değeri ait olduğu organizasyonu tanımlayan bir ön ek içerebilir.

Önek Referans
bir Android hata kimliği
KK- Qualcomm referans numarası
M- MediaTek referans numarası
N- NVIDIA referans numarası
B- Broadcom referans numarası

5. Başvurular sütun ortalama Android hata kimliği yanında * özü nedir?

Herkese açık olmayan sorunlarda, ilgili referans kimliğinin yanında * bulunur. Bu sorunla ilgili güncelleştirme genellikle temin Piksel cihazlar için en son ikili sürücüleri bulunan Google Geliştirici sitesinde .

6. Güvenlik açıkları neden bu bülten ile Pixel bülteni gibi cihaz/iş ortağı güvenlik bültenleri arasında bölünmüştür?

Bu güvenlik bülteninde belgelenen güvenlik açıkları, Android cihazlarda en son güvenlik düzeltme eki düzeyini bildirmek için gereklidir. Cihaz/ortak güvenlik bültenlerinde belgelenen ek güvenlik açıkları, bir güvenlik düzeltme eki düzeyi bildirmek için gerekli değildir. Android cihazı ve yonga seti üreticileri de gibi kendi ürünlerinin, güvenlik açığı bilgilerini özgü yayınlayabilir Google , Huawei , LGE , Motorola , Nokia , veya Samsung .

Sürümler

Sürüm Tarih Notlar
1.0 3 Mayıs 2021 Bülten yayınlandı.
1.1 4 Mayıs 2021 Bülten, AOSP bağlantılarını içerecek şekilde revize edildi