Google setzt sich dafür ein, die Rassengerechtigkeit für schwarze Gemeinschaften zu fördern. Siehe wie.
Diese Seite wurde von der Cloud Translation API übersetzt.
Switch to English

Android Security Bulletin - August 2016

Veröffentlicht am 01. August 2016 | Aktualisiert am 21. Oktober 2016

Das Android Security Bulletin enthält Details zu Sicherheitslücken, die Android-Geräte betreffen. Neben dem Bulletin haben wir ein Sicherheitsupdate für Nexus-Geräte über ein OTA-Update (Over-the-Air) veröffentlicht. Die Nexus-Firmware-Images wurden auch auf der Google Developer-Website veröffentlicht . Sicherheits-Patch-Levels vom 05. August 2016 oder höher beheben diese Probleme. In der Dokumentation erfahren Sie, wie Sie die Sicherheits-Patch-Stufe überprüfen.

Die Partner wurden am 06. Juli 2016 oder früher über die im Bulletin beschriebenen Probleme informiert. Gegebenenfalls wurden Quellcode-Patches für diese Probleme im AOSP-Repository (Android Open Source Project) veröffentlicht. Dieses Bulletin enthält auch Links zu Patches außerhalb von AOSP.

Das schwerwiegendste dieser Probleme ist eine kritische Sicherheitslücke, die die Remotecodeausführung auf einem betroffenen Gerät über mehrere Methoden wie E-Mail, Surfen im Internet und MMS bei der Verarbeitung von Mediendateien ermöglichen kann. Die Bewertung des Schweregrads basiert auf den Auswirkungen, die das Ausnutzen der Sicherheitsanfälligkeit möglicherweise auf ein betroffenes Gerät haben würde, vorausgesetzt, die Plattform- und Dienstminderungen sind für Entwicklungszwecke deaktiviert oder werden erfolgreich umgangen.

Wir haben keine Berichte über die aktive Ausbeutung oder den Missbrauch dieser neu gemeldeten Probleme durch Kunden erhalten. Weitere Informationen zum Schutz der Android-Sicherheitsplattform und zum Schutz von Diensten wie SafetyNet, die die Sicherheit der Android-Plattform verbessern, finden Sie im Abschnitt zur Minderung von Android- und Google-Diensten .

Wir empfehlen allen Kunden, diese Updates für ihre Geräte zu akzeptieren.

Ankündigungen

  • Bulletin überarbeitet, um CVE-2016-3856 auf CVE-2016-2060 zu korrigieren.
  • Dieses Bulletin enthält zwei Sicherheits-Patch-Level-Zeichenfolgen, mit denen Android-Partner flexibler vorgehen können, um eine Teilmenge von Schwachstellen zu beheben, die auf allen Android-Geräten ähnlich sind. Weitere Informationen finden Sie unter Allgemeine Fragen und Antworten :
    • 2016-08-01 : Teilweise Sicherheits-Patch-Level-Zeichenfolge. Diese Zeichenfolge auf Sicherheits-Patch-Ebene gibt an, dass alle mit dem 01.08.2016 verbundenen Probleme (und alle vorherigen Zeichenfolgen auf Sicherheits-Patch-Ebene) behoben sind.
    • 05.08.2016 : Vollständige Sicherheits-Patch-Level-Zeichenfolge. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle mit dem 01.08.2016 und dem 05.08.2016 verbundenen Probleme (und alle vorherigen Sicherheits-Patch-Level-Zeichenfolgen) behoben sind.
  • Unterstützte Nexus-Geräte erhalten ein einzelnes OTA-Update mit der Sicherheits-Patch-Stufe vom 05. August 2016.

Minderung von Android- und Google-Diensten

Dies ist eine Zusammenfassung der von der Android-Sicherheitsplattform bereitgestellten Maßnahmen und des Schutzes von Diensten wie SafetyNet. Diese Funktionen verringern die Wahrscheinlichkeit, dass Sicherheitslücken unter Android erfolgreich ausgenutzt werden können.

  • Die Nutzung vieler Probleme unter Android wird durch Verbesserungen in neueren Versionen der Android-Plattform erschwert. Wir empfehlen allen Benutzern, nach Möglichkeit auf die neueste Version von Android zu aktualisieren.
  • Das Android-Sicherheitsteam überwacht mit Verify Apps und SafetyNet aktiv auf Missbrauch, um Benutzer vor potenziell schädlichen Anwendungen zu warnen. Überprüfen Sie, ob Apps auf Geräten mit Google Mobile Services standardmäßig aktiviert sind. Dies ist besonders wichtig für Benutzer, die Anwendungen von außerhalb von Google Play installieren. Geräte-Rooting-Tools sind in Google Play verboten. Verify Apps warnt Benutzer jedoch, wenn sie versuchen, eine erkannte Rooting-Anwendung zu installieren - unabhängig davon, woher sie stammt. Darüber hinaus versucht Verify Apps, die Installation bekannter schädlicher Anwendungen zu identifizieren und zu blockieren, die eine Sicherheitsanfälligkeit bezüglich der Eskalation von Berechtigungen ausnutzen. Wenn eine solche Anwendung bereits installiert wurde, benachrichtigt Verify Apps den Benutzer und versucht, die erkannte Anwendung zu entfernen.
  • Gegebenenfalls übergeben Google Hangouts- und Messenger-Anwendungen Medien nicht automatisch an Prozesse wie Mediaserver.

Danksagung

Wir möchten diesen Forschern für ihre Beiträge danken:

Wir möchten Daniel Micay von Copperhead Security, Jeff Vander Stoep und Yabin Cui von Google für ihren Beitrag zu Updates auf Plattformebene zur Minderung einer Klasse von Schwachstellen wie CVE-2016-3843 danken. Diese Minderung basiert auf Arbeiten von Brad Spengler von Grsecurity.

2016-08-01 Sicherheits-Patch-Level - Details zu Sicherheitslücken

In den folgenden Abschnitten finden Sie Details zu den Sicherheitslücken, die für die Patch-Version 2016-08-01 gelten. Es gibt eine Beschreibung des Problems, eine Begründung des Schweregrads und eine Tabelle mit dem CVE, den zugehörigen Referenzen, dem Schweregrad, den aktualisierten Nexus-Geräten, den aktualisierten AOSP-Versionen (falls zutreffend) und dem gemeldeten Datum. Wenn verfügbar, verknüpfen wir die öffentliche Änderung, mit der das Problem behoben wurde, mit der Fehler-ID, z. B. der AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern verknüpft, die auf die Fehler-ID folgen.

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Mediaserver kann es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei Speicherbeschädigungen während der Verarbeitung von Mediendateien und Daten zu verursachen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext des Mediaserver-Prozesses als kritisch eingestuft. Der Mediaserver-Prozess hat Zugriff auf Audio- und Videostreams sowie auf Berechtigungen, auf die Apps von Drittanbietern normalerweise nicht zugreifen können.

Die betroffene Funktionalität wird als Kernbestandteil des Betriebssystems bereitgestellt, und es gibt mehrere Anwendungen, mit denen sie mit Remote-Inhalten erreicht werden kann, insbesondere mit MMS und der Browser-Wiedergabe von Medien.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3819 A-28533562 Kritisch Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 2. Mai 2016
CVE-2016-3820 A-28673410 Kritisch Alles Nexus 6.0, 6.0.1 6. Mai 2016
CVE-2016-3821 A-28166152 Kritisch Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google intern

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in libjhead

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in libjhead kann es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei beliebigen Code im Kontext eines nicht privilegierten Prozesses auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung in Anwendungen, die diese Bibliothek verwenden, als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3822 A-28868315 Hoch Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google intern

Erhöhung der Sicherheitsanfälligkeit in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in Mediaserver kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als hoch eingestuft, da es verwendet werden kann, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die normalerweise keine Drittanbieteranwendung zugreifen kann.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3823 A-28815329 Hoch Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 17. Mai 2016
CVE-2016-3824 A-28816827 Hoch Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 17. Mai 2016
CVE-2016-3825 A-28816964 Hoch Alles Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 17. Mai 2016
CVE-2016-3826 A-29251553 Hoch Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 9. Juni 2016

Denial-of-Service-Sicherheitsanfälligkeit in Mediaserver

Eine Denial-of-Service-Sicherheitsanfälligkeit in Mediaserver kann es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei ein Gerät hängen zu lassen oder neu zu starten. Dieses Problem wird aufgrund der Möglichkeit eines vorübergehenden Remote-Denial-of-Service als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3827 A-28816956 Hoch Alles Nexus 6.0.1 16. Mai 2016
CVE-2016-3828 A-28835995 Hoch Alles Nexus 6.0, 6.0.1 17. Mai 2016
CVE-2016-3829 A-29023649 Hoch Alles Nexus 6.0, 6.0.1 27. Mai 2016
CVE-2016-3830 A-29153599 Hoch Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google intern

Denial-of-Service-Sicherheitsanfälligkeit in der Systemuhr

Eine Denial-of-Service-Sicherheitsanfälligkeit in der Systemuhr kann es einem Remoteangreifer ermöglichen, das Gerät zum Absturz zu bringen. Dieses Problem wird aufgrund der Möglichkeit eines vorübergehenden Remote-Denial-of-Service als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3831 A-29083635 Hoch Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 31. Mai 2016

Erhöhung der Sicherheitsanfälligkeit in Framework-APIs

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in den Framework-APIs kann es einer lokalen bösartigen Anwendung ermöglichen, den Betriebssystemschutz zu umgehen, der Anwendungsdaten von anderen Anwendungen isoliert. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um Zugriff auf Daten zu erhalten, die außerhalb der Berechtigungsstufen der Anwendung liegen.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3832 A-28795098 Mäßig Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 15. Mai 2016

Erhöhung der Sicherheitsanfälligkeit in Shell

Eine Erhöhung der Berechtigungen in der Shell kann es einer lokalen böswilligen Anwendung ermöglichen, Geräteeinschränkungen wie Benutzereinschränkungen zu umgehen. Dieses Problem wird als mittel eingestuft, da es sich um eine lokale Umgehung von Benutzerberechtigungen handelt.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3833 A-29189712 [ 2 ] Mäßig Alles Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 Google intern

Sicherheitsanfälligkeit in OpenSSL zur Offenlegung von Informationen

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in OpenSSL kann es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um ohne Erlaubnis auf vertrauliche Daten zuzugreifen.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-2842 A-29060514 Keiner* Alles Nexus 4.4.4, 5.0.2, 5.1.1 29. März 2016

* Unterstützte Nexus-Geräte, auf denen alle verfügbaren Updates installiert sind, sind von dieser Sicherheitsanfälligkeit nicht betroffen

Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in Kamera-APIs

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in den Kamera-APIs kann es einer lokalen bösartigen Anwendung ermöglichen, auf Datenstrukturen außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um ohne Erlaubnis auf vertrauliche Daten zuzugreifen.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3834 A-28466701 Mäßig Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 28. April 2016

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in Mediaserver kann es einer lokalen böswilligen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um ohne Erlaubnis auf vertrauliche Daten zuzugreifen.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3835 A-28920116 Mäßig Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 23. Mai 2016

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen in SurfaceFlinger

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen im SurfaceFlinger-Dienst kann es einer lokalen böswilligen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es ohne ausdrückliche Benutzerberechtigung für den Zugriff auf vertrauliche Daten verwendet werden kann.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3836 A-28592402 Mäßig Alles Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 4. Mai 2016

Sicherheitslücke bei der Offenlegung von Informationen in Wi-Fi

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in Wi-Fi kann es einer lokalen böswilligen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um ohne Erlaubnis auf vertrauliche Daten zuzugreifen.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3837 A-28164077 Mäßig Alles Nexus 5.0.2, 5.1.1, 6.0, 6.0.1 Google intern

Denial-of-Service-Sicherheitsanfälligkeit in der Systembenutzeroberfläche

Eine Denial-of-Service-Sicherheitsanfälligkeit in der Benutzeroberfläche des Systems kann es einer lokalen bösartigen Anwendung ermöglichen, 911-Anrufe von einem gesperrten Bildschirm aus zu verhindern. Dieses Problem wird aufgrund der Möglichkeit eines Denial-of-Service für eine kritische Funktion als mittel eingestuft.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3838 A-28761672 Mäßig Alles Nexus 6.0, 6.0.1 Google intern

Denial-of-Service-Sicherheitslücke in Bluetooth

Eine Denial-of-Service-Sicherheitsanfälligkeit in Bluetooth kann es einer lokalen bösartigen Anwendung ermöglichen, 911-Anrufe von einem Bluetooth-Gerät zu verhindern. Dieses Problem wird aufgrund der Möglichkeit eines Denial-of-Service für eine kritische Funktion als mittel eingestuft.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3839 A-28885210 Mäßig Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google intern

Sicherheits-Patch-Stufe 2016-08-05 - Details zur Sicherheitsanfälligkeit

In den folgenden Abschnitten finden Sie Details zu den Sicherheitslücken, die für die Patch-Version 2016-08-05 gelten. Es gibt eine Beschreibung des Problems, eine Begründung des Schweregrads und eine Tabelle mit dem CVE, den zugehörigen Referenzen, dem Schweregrad, den aktualisierten Nexus-Geräten, den aktualisierten AOSP-Versionen (falls zutreffend) und dem gemeldeten Datum. Sofern verfügbar, verknüpfen wir die öffentliche Änderung, mit der das Problem behoben wurde, mit der Fehler-ID, z. B. der AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern verknüpft, die auf die Fehler-ID folgen.

Sicherheitsanfälligkeit bezüglich Remotecodeausführung im Qualcomm Wi-Fi-Treiber

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung im Qualcomm Wi-Fi-Treiber kann es einem Remoteangreifer ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2014-9902 A-28668638

QC-CR # 553937
QC-CR # 553941

Kritisch Nexus 7 (2013) 31. März 2014

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Conscrypt

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Conscrypt kann es einem Remoteangreifer ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3840 A-28751153 Kritisch Alles Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google intern

Erhöhung der Sicherheitsanfälligkeit in Qualcomm-Komponenten

Die folgende Tabelle enthält Sicherheitslücken, die sich auf Qualcomm-Komponenten auswirken, einschließlich Bootloader, Kameratreiber, Charakterlaufwerk, Netzwerk, Soundtreiber und Videotreiber.

Das schwerwiegendste dieser Probleme wird als kritisch eingestuft, da die Möglichkeit besteht, dass eine lokale bösartige Anwendung beliebigen Code im Kontext des Kernels ausführt, was zu einem lokalen permanenten Gerätekompromiss führt, bei dem das Betriebssystem möglicherweise neu gestartet werden muss, um das Gerät zu reparieren.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2014-9863 A-28768146

QC-CR # 549470

Kritisch Nexus 5, Nexus 7 (2013) 30. April 2014
CVE-2014-9864 A-28747998

QC-CR # 561841

Hoch Nexus 5, Nexus 7 (2013) 27. März 2014
CVE-2014-9865 A-28748271

QC-CR # 550013

Hoch Nexus 5, Nexus 7 (2013) 27. März 2014
CVE-2014-9866 A-28747684

QC-CR # 511358

Hoch Nexus 5, Nexus 7 (2013) 31. März 2014
CVE-2014-9867 A-28749629

QC-CR # 514702

Hoch Nexus 5, Nexus 7 (2013) 31. März 2014
CVE-2014-9868 A-28749721

QC-CR # 511976

Hoch Nexus 5, Nexus 7 (2013) 31. März 2014
CVE-2014-9869 A-28749728

QC-CR # 514711 [ 2 ]

Hoch Nexus 5, Nexus 7 (2013) 31. März 2014
CVE-2014-9870 A-28749743

QC-CR # 561044

Hoch Nexus 5, Nexus 7 (2013) 31. März 2014
CVE-2014-9871 A-28749803

QC-CR # 514717

Hoch Nexus 5, Nexus 7 (2013) 31. März 2014
CVE-2014-9872 A-28750155

QC-CR # 590721

Hoch Nexus 5 31. März 2014
CVE-2014-9873 A-28750726

QC-CR # 556860

Hoch Nexus 5, Nexus 7 (2013) 31. März 2014
CVE-2014-9874 A-28751152

QC-CR # 563086

Hoch Nexus 5, Nexus 5X, Nexus 6P, Nexus 7 (2013) 31. März 2014
CVE-2014-9875 A-28767589

QC-CR # 483310

Hoch Nexus 7 (2013) 30. April 2014
CVE-2014-9876 A-28767796

QC-CR # 483408

Hoch Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013) 30. April 2014
CVE-2014-9877 A-28768281

QC-CR # 547231

Hoch Nexus 5, Nexus 7 (2013) 30. April 2014
CVE-2014-9878 A-28769208

QC-CR # 547479

Hoch Nexus 5 30. April 2014
CVE-2014-9879 A-28769221

QC-CR # 524490

Hoch Nexus 5 30. April 2014
CVE-2014-9880 A-28769352

QC-CR # 556356

Hoch Nexus 7 (2013) 30. April 2014
CVE-2014-9881 A-28769368

QC-CR # 539008

Hoch Nexus 7 (2013) 30. April 2014
CVE-2014-9882 A-28769546

QC-CR # 552329 [ 2 ]

Hoch Nexus 7 (2013) 30. April 2014
CVE-2014-9883 A-28769912

QC-CR # 565160

Hoch Nexus 5, Nexus 7 (2013) 30. April 2014
CVE-2014-9884 A-28769920

QC-CR # 580740

Hoch Nexus 5, Nexus 7 (2013) 30. April 2014
CVE-2014-9885 A-28769959

QC-CR # 562261

Hoch Nexus 5 30. April 2014
CVE-2014-9886 A-28815575

QC-CR # 555030

Hoch Nexus 5, Nexus 7 (2013) 30. April 2014
CVE-2014-9887 A-28804057

QC-CR # 636633

Hoch Nexus 5, Nexus 7 (2013) 3. Juli 2014
CVE-2014-9888 A-28803642

QC-CR # 642735

Hoch Nexus 5, Nexus 7 (2013) 29. August 2014
CVE-2014-9889 A-28803645

QC-CR # 674712

Hoch Nexus 5 31. Oktober 2014
CVE-2015-8937 A-28803962

QC-CR # 770548

Hoch Nexus 5, Nexus 6, Nexus 7 (2013) 31. März 2015
CVE-2015-8938 A-28804030

QC-CR # 766022

Hoch Nexus 6 31. März 2015
CVE-2015-8939 A-28398884

QC-CR # 779021

Hoch Nexus 7 (2013) 30. April 2015
CVE-2015-8940 A-28813987

QC-CR # 792367

Hoch Nexus 6 30. April 2015
CVE-2015-8941 A-28814502

QC-CR # 792473

Hoch Nexus 6, Nexus 7 (2013) 29. Mai 2015
CVE-2015-8942 A-28814652

QC-CR # 803246

Hoch Nexus 6 30. Juni 2015
CVE-2015-8943 A-28815158

QC-CR # 794217

QC-CR # 836226

Hoch Nexus 5 11. September 2015
CVE-2014-9891 A-28749283

QC-CR # 550061

Mäßig Nexus 5 13. März 2014
CVE-2014-9890 A-28770207

QC-CR # 529177

Mäßig Nexus 5, Nexus 7 (2013) 2. Juni 2014

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen in der Kernel-Netzwerkkomponente

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in der Kernel-Netzwerkkomponente kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2015-2686 A-28759139

Upstream-Kernel

Kritisch Alles Nexus 23. März 2015
CVE-2016-3841 A-28746669

Upstream-Kernel

Kritisch Alles Nexus 3. Dezember 2015

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im Qualcomm-GPU-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm-GPU-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-2504 A-28026365

QC-CR # 1002974

Kritisch Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013) 5. April 2016
CVE-2016-3842 A-28377352

QC-CR # 1002974

Kritisch Nexus 5X, Nexus 6, Nexus 6P 25. April 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Berechtigungsanfälligkeit in der Qualcomm-Leistungskomponente

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in der Qualcomm-Leistungskomponente kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

Hinweis: In diesem Bulletin unter A-29119870 finden Sie auch ein Update auf Plattformebene, mit dem diese Schwachstellenklasse gemindert werden soll.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-3843 A-28086229 *

QC-CR # 1011071

Kritisch Nexus 5X, Nexus 6P 7. April 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit im Kernel

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-3857 A-28522518 * Kritisch Nexus 7 (2013) 2. Mai 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit in Bezug auf Berechtigungen im Kernel-Speichersystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-Speichersystem könnte es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2015-1593 A-29577822

Upstream-Kernel

Hoch Nexus-Spieler 13. Februar 2015
CVE-2016-3672 A-28763575

Upstream-Kernel

Hoch Nexus-Spieler 25. März 2016

Erhöhung der Berechtigungsanfälligkeit in der Kernel-Soundkomponente

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in der Kernel-Soundkomponente kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-2544 A-28695438

Upstream-Kernel

Hoch Alles Nexus 19. Januar 2016
CVE-2016-2546 A-28694392

Upstream-Kernel

Hoch Pixel C. 19. Januar 2016
CVE-2014-9904 A-28592007

Upstream-Kernel

Hoch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Nexus Player 4. Mai 2016

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen im Kernel-Dateisystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-Dateisystem kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2012-6701 A-28939037

Upstream-Kernel

Hoch Nexus 5, Nexus 7 (2013) 2. März 2016

Erhöhung der Sicherheitsanfälligkeit in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in Mediaserver kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als hoch eingestuft, da es verwendet werden kann, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die eine Drittanbieteranwendung nicht zugreifen kann.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-3844 A-28299517 *

N-CVE-2016-3844

Hoch Nexus 9, Pixel C. 19. April 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im Kernel-Videotreiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-Videotreiber könnte es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-3845 A-28399876 * Hoch Nexus 5 20. April 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im Treiber für die serielle Peripherieschnittstelle

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Treiber für die serielle Peripherieschnittstelle kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-3846 A-28817378 * Hoch Nexus 5X, Nexus 6P 17. Mai 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im NVIDIA-Medientreiber

Eine Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im NVIDIA-Medientreiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-3847 A-28871433 *

N-CVE-2016-3847

Hoch Nexus 9 19. Mai 2016
CVE-2016-3848 A-28919417 *

N-CVE-2016-3848

Hoch Nexus 9 19. Mai 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit in ION-Treibern

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im ION-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-3849 A-28939740 Hoch Pixel C. 24. Mai 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen im Qualcomm-Bootloader

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm-Bootloader kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-3850 A-27917291

QC-CR # 945164

Hoch Nexus 5, Nexus 5X, Nexus 6P, Nexus 7 (2013) 28. März 2016

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Kernel-Leistungssubsystem

Durch das Erhöhen von Sicherheitslücken in Bezug auf Berechtigungen im Kernel-Leistungssubsystem kann eine lokale böswillige Anwendung beliebigen Code im Kontext des Kernels ausführen. Dieses Problem wird aufgrund der Kernel-Angriffsfläche, die Angreifer ausnutzen können, als hoch eingestuft.

Hinweis: Dies ist ein Update auf Plattformebene, mit dem eine Reihe von Sicherheitslücken wie CVE-2016-3843 (A-28086229) gemindert werden sollen.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-3843 A-29119870 * Hoch Alles Nexus 6.0, 6.1 Google intern

* Ein Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit in LG Electronics Bootloader

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im LG Electronics-Bootloader kann es einem Angreifer ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Nexus-Geräte Datum der Meldung
CVE-2016-3851 A-29189941 * Hoch Nexus 5X Google intern

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in Qualcomm-Komponenten

Die folgende Tabelle enthält Sicherheitslücken, die sich auf Qualcomm-Komponenten auswirken, einschließlich Bootloader, Kameratreiber, Charaktertreiber, Netzwerk, Soundtreiber und Videotreiber.

The most severe of these issues is rated as High due to the possibility that a local malicious application could access data outside of its permission levels such as sensitive data without explicit user permission.

CVE References Severity Updated Nexus devices Date reported
CVE-2014-9892 A-28770164

QC-CR#568717

High Nexus 5, Nexus 7 (2013) Jun 2, 2014
CVE-2015-8944 A-28814213

QC-CR#786116

High Nexus 6, Nexus 7 (2013) Apr 30, 2015
CVE-2014-9893 A-28747914

QC-CR#542223

Moderate Nexus 5 Mar 27, 2014
CVE-2014-9894 A-28749708

QC-CR#545736

Moderate Nexus 7 (2013) Mar 31, 2014
CVE-2014-9895 A-28750150

QC-CR#570757

Moderate Nexus 5, Nexus 7 (2013) Mar 31, 2014
CVE-2014-9896 A-28767593

QC-CR#551795

Moderate Nexus 5, Nexus 7 (2013) Apr 30, 2014
CVE-2014-9897 A-28769856

QC-CR#563752

Moderate Nexus 5 Apr 30, 2014
CVE-2014-9898 A-28814690

QC-CR#554575

Moderate Nexus 5, Nexus 7 (2013) Apr 30, 2014
CVE-2014-9899 A-28803909

QC-CR#547910

Moderate Nexus 5 Jul 3, 2014
CVE-2014-9900 A-28803952

QC-CR#570754

Moderate Nexus 5, Nexus 7 (2013) Aug 8, 2014

Information disclosure vulnerability in kernel scheduler

An information disclosure vulnerability in the kernel scheduler could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Nexus devices Date reported
CVE-2014-9903 A-28731691

Upstream kernel

High Nexus 5X, Nexus 6P Feb 21, 2014

Information disclosure vulnerability in MediaTek Wi-Fi driver (device specific)

An information disclosure vulnerability in the MediaTek Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3852 A-29141147*

M-ALPS02751738

High Android One Apr 12, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in USB driver

An information disclosure vulnerability in the USB driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-4482 A-28619695

Upstream kernel

High All Nexus May 3, 2016

Denial of service vulnerability in Qualcomm components

The table below contains security vulnerabilities affecting Qualcomm components, potentially including the Wi-Fi driver.

The most severe of these issues is rated as High due to the possibility that an attacker could cause a temporary remote denial of service resulting in a device hang or reboot.

CVE References Severity Updated Nexus devices Date reported
CVE-2014-9901 A-28670333

QC-CR#548711

High Nexus 7 (2013) Mar 31, 2014

Elevation of privilege vulnerability in Google Play services

An elevation of privilege vulnerability in Google Play services could allow a local attacker to bypass the Factory Reset Protection and gain access to the device. This is rated as Moderate due to the possibility of bypassing Factory Reset Protection, which could lead to successfully resetting the device and erasing all its data.

CVE References Severity Updated Nexus devices Updated AOSP versions Date reported
CVE-2016-3853 A-26803208* Moderate All Nexus None May 4, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Framework APIs

An elevation of privilege vulnerability in the framework APIs could enable a pre-installed application to increase its intent filter priority when the application is being updated without the user being notified. This issue is rated as Moderate because it could be used to gain elevated capabilities without explicit user permission.

CVE References Severity Updated Nexus devices Updated AOSP versions Date reported
CVE-2016-2497 A-27450489 Moderate All Nexus 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1 Google internal

Information disclosure vulnerability in kernel networking component

An information disclosure vulnerability in the kernel networking component could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-4486 A-28620102

Upstream kernel

Moderate All Nexus May 3, 2016

Information disclosure vulnerability in kernel sound component

An information disclosure vulnerability in the kernel sound component could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-4569 A-28980557

Upstream kernel

Moderate All Nexus May 9, 2016
CVE-2016-4578 A-28980217

Upstream kernel [ 2 ]

Moderate All Nexus May 11, 2016

Vulnerabilities in Qualcomm components

The table below contains security vulnerabilities affecting Qualcomm components, potentially including the bootloader, camera driver, character driver, networking, sound driver, and video driver.

CVE References Severity Updated Nexus devices Date reported
CVE-2016-3854 QC-CR#897326 High None Feb 2016
CVE-2016-3855 QC-CR#990824 High None May 2016
CVE-2016-2060 QC-CR#959631 Moderate None Apr 2016

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

Security Patch Levels of 2016-08-01 or later address all issues associated with the 2016-08-01 security patch string level. Security Patch Levels of 2016-08-05 or later address all issues associated with the 2016-08-05 security patch string level. Refer to the help center for instructions on how to check the security patch level. Device manufacturers that include these updates should set the patch string level to: [ro.build.version.security_patch]:[2016-08-01] or [ro.build.version.security_patch]:[2016-08-05].

2. Why does this bulletin have two security patch level strings?

This bulletin has two security patch level strings in order to provide Android partners with the flexibility to move more quickly to fix a subset of vulnerabilities that are similar across all Android devices. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level string.

Devices that use the security patch level of August 5, 2016 or newer must include all applicable patches in this (and previous) security bulletins.

Devices that use the August 1, 2016 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins. Devices that use August 1, 2016 security patch level may also include a subset of fixes associated with the August 5, 2016 security patch level.

3 . How do I determine which Nexus devices are affected by each issue?

In the 2016-08-01 and 2016-08-05 security vulnerability details sections, each table has an Updated Nexus devices column that covers the range of affected Nexus devices updated for each issue. This column has a few options:

  • All Nexus devices : If an issue affects all Nexus devices, the table will have “All Nexus” in the Updated Nexus devices column. “All Nexus” encapsulates the following supported devices : Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7 (2013), Nexus 9, Android One, Nexus Player, and Pixel C.
  • Some Nexus devices : If an issue doesn't affect all Nexus devices, the affected Nexus devices are listed in the Updated Nexus devices column.
  • No Nexus devices : If no Nexus devices are affected by the issue, the table will have “None” in the Updated Nexus devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number

Revisions

  • August 01, 2016: Bulletin published.
  • August 02, 2016: Bulletin revised to include AOSP links.
  • August 16, 2016: CVE-2016-3856 corrected to CVE-2016-2060 and updated the reference URL.
  • October 21, 2016: Corrected typo in CVE-2016-4486.