Google setzt sich dafür ein, die Rassengerechtigkeit für schwarze Gemeinschaften zu fördern. Siehe wie.
Diese Seite wurde von der Cloud Translation API übersetzt.
Switch to English

Android Security Bulletin - Dezember 2016

Veröffentlicht am 05. Dezember 2016 | Aktualisiert am 21. Dezember 2016

Das Android Security Bulletin enthält Details zu Sicherheitslücken, die Android-Geräte betreffen. Neben dem Bulletin haben wir ein Sicherheitsupdate für Google-Geräte über ein drahtloses Update (OTA) veröffentlicht. Die Firmware-Bilder des Google-Geräts wurden auch auf der Google Developer-Website veröffentlicht . Sicherheits-Patch-Levels vom 05. Dezember 2016 oder höher beheben all diese Probleme. Informationen zum Überprüfen der Sicherheits-Patch-Stufe eines Geräts finden Sie im Update-Zeitplan für Pixel und Nexus .

Die Partner wurden am 07. November 2016 oder früher über die im Bulletin beschriebenen Probleme informiert. Quellcode-Patches für diese Probleme wurden im AOSP-Repository (Android Open Source Project) veröffentlicht und über dieses Bulletin verlinkt. Dieses Bulletin enthält auch Links zu Patches außerhalb von AOSP.

Das schwerwiegendste dieser Probleme sind kritische Sicherheitslücken in gerätespezifischem Code, die eine beliebige Codeausführung im Kontext des Kernels ermöglichen können. Dies kann zu einem lokalen permanenten Gerätekompromiss führen, bei dem das Betriebssystem möglicherweise neu gestartet werden muss, um das Gerät zu reparieren . Die Bewertung des Schweregrads basiert auf den Auswirkungen, die das Ausnutzen der Sicherheitsanfälligkeit möglicherweise auf ein betroffenes Gerät haben würde, vorausgesetzt, die Plattform- und Dienstminderungen sind für Entwicklungszwecke deaktiviert oder werden erfolgreich umgangen.

Wir haben keine Berichte über die aktive Ausbeutung oder den Missbrauch dieser neu gemeldeten Probleme durch Kunden erhalten. Weitere Informationen zum Schutz der Android-Sicherheitsplattform und zum Schutz von Diensten wie SafetyNet , die die Sicherheit der Android-Plattform verbessern, finden Sie im Abschnitt zur Minderung von Android- und Google-Diensten .

Wir empfehlen allen Kunden, diese Updates für ihre Geräte zu akzeptieren.

Ankündigungen

  • Dieses Bulletin enthält zwei Sicherheits-Patch-Level-Zeichenfolgen, die Android-Partnern die Flexibilität bieten, eine Teilmenge von Schwachstellen, die auf allen Android-Geräten ähnlich sind, schneller zu beheben. Weitere Informationen finden Sie unter Allgemeine Fragen und Antworten :
    • 2016-12-01 : Teilweise Sicherheits-Patch-Level-Zeichenfolge. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle mit dem 01.12.2016 verbundenen Probleme (und alle vorherigen Sicherheits-Patch-Level-Zeichenfolgen) behoben sind.
    • 2016-12-05 : Vollständige Sicherheits-Patch-Level-Zeichenfolge. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle mit dem 01.12.2016 und dem 05.12.2016 verbundenen Probleme (und alle vorherigen String-Level-Sicherheitszeichenfolgen) behoben sind.
  • Unterstützte Google-Geräte erhalten ein einzelnes OTA-Update mit der Sicherheits-Patch-Stufe vom 05. Dezember 2016.

Minderung von Android- und Google-Diensten

Dies ist eine Zusammenfassung der Maßnahmen, die von der Android-Sicherheitsplattform und dem Schutz von Diensten wie SafetyNet bereitgestellt werden. Diese Funktionen verringern die Wahrscheinlichkeit, dass Sicherheitslücken unter Android erfolgreich ausgenutzt werden können.

  • Die Nutzung vieler Probleme unter Android wird durch Verbesserungen in neueren Versionen der Android-Plattform erschwert. Wir empfehlen allen Benutzern, nach Möglichkeit auf die neueste Version von Android zu aktualisieren.
  • Das Android-Sicherheitsteam überwacht mit Verify Apps und SafetyNet aktiv auf Missbrauch, um Benutzer vor potenziell schädlichen Anwendungen zu warnen. "Apps überprüfen" ist auf Geräten mit Google Mobile Services standardmäßig aktiviert und besonders wichtig für Benutzer, die Anwendungen von außerhalb von Google Play installieren. Geräte-Rooting-Tools sind in Google Play verboten. Verify Apps warnt Benutzer jedoch, wenn sie versuchen, eine erkannte Rooting-Anwendung zu installieren - unabhängig davon, woher sie stammt. Darüber hinaus versucht Verify Apps, die Installation bekannter schädlicher Anwendungen zu identifizieren und zu blockieren, die eine Sicherheitsanfälligkeit bezüglich der Eskalation von Berechtigungen ausnutzen. Wenn eine solche Anwendung bereits installiert wurde, benachrichtigt Verify Apps den Benutzer und versucht, die erkannte Anwendung zu entfernen.
  • Gegebenenfalls übergeben Google Hangouts- und Messenger-Anwendungen Medien nicht automatisch an Prozesse wie Mediaserver.

Danksagung

Wir möchten diesen Forschern für ihre Beiträge danken:

  • Baozeng Ding, Chengming Yang, Peng Xiao, Ning You, Yang Dong, Chao Yang, Yi Zhang und Yang Song der Alibaba Mobile Security Group: CVE-2016-6783, CVE-2016-6784, CVE-2016-6785
  • Chi Zhang , Mingjian Zhou ( @Mingjian_Zhou ), Chiachih Wu ( @chiachih_wu ) und Xuxian Jiang vom C0RE-Team : CVE-2016-6789, CVE-2016-6790
  • Christian Seel: CVE-2016-6769
  • David Benjamin und Kenny Root von Google: CVE-2016-6767
  • Di Shen ( @returnsme ) von KeenLab ( @keen_lab ), Tencent: CVE-2016-6776, CVE-2016-6787
  • En He ( @ heeeeen4x ) von MS509Team : CVE-2016-6763
  • Gengjia Chen ( @ chengjia4574 ), pjf von IceSword Lab, Qihoo 360 Technology Co. Ltd.: CVE-2016-6779, CVE-2016-6778, CVE-2016-8401, CVE-2016-8402, CVE-2016-8403, CVE-2016-8409, CVE-2016-8408, CVE-2016-8404
  • Jianqiang Zhao ( @jianqiangzhao ) und pjf von IceSword Lab, Qihoo 360 Technology Co. Ltd .: CVE-2016-6788, CVE-2016-6781, CVE-2016-6782, CVE-2016-8396
  • Lubo Zhang , Tong Lin , Yuan-Tsung Lo , Chiachih Wu ( @chiachih_wu ) und Xuxian Jiang vom C0RE-Team : CVE-2016-6791, CVE-2016-8391, CVE-2016-8392
  • Mark Brand von Project Zero: CVE-2016-6772
  • Michał Bednarski : CVE-2016-6770, CVE-2016-6774
  • Mingjian Zhou ( @Mingjian_Zhou ), Chi Zhang , Chiachih Wu ( @chiachih_wu ) und Xuxian Jiang vom C0RE-Team : CVE-2016-6761, CVE-2016-6759, CVE-2016-8400
  • Mingjian Zhou ( @Mingjian_Zhou ), Chiachih Wu ( @chiachih_wu ) und Xuxian Jiang vom C0RE-Team : CVE-2016-6760
  • Mingjian Zhou ( @Mingjian_Zhou ), Hanxiang Wen , Chiachih Wu ( @chiachih_wu ) und Xuxian Jiang vom C0RE-Team : CVE-2016-6759
  • Nathan Crandall ( @natecray ) vom Produktsicherheitsteam von Tesla Motors: CVE-2016-6915, CVE-2016-6916, CVE-2016-6917
  • Nightsec Cybersecurity Research ( @nightwatchcyber ): CVE-2016-5341
  • Pengfei Ding (丁鹏飞), Chenfu Bao (包 沉浮), Lenx Wei (韦 韬) von Baidu X-Lab: CVE-2016-6755, CVE-2016-6756
  • Peter Pi ( @heisecode ) von Trend Micro: CVE-2016-8397, CVE-2016-8405, CVE-2016-8406, CVE-2016-8407
  • Qidan He (何 淇 丹) ( @flanker_hqd ) von KeenLab, Tencent (腾讯 科恩 实验室): CVE-2016-8399, CVE-2016-8395
  • Qidan He (何 淇 丹) ( @flanker_hqd ) und Marco Grassi ( @marcograss ) von KeenLab, Tencent (腾讯 科恩 实验室): CVE-2016-6768
  • Richard Shupak: CVE-2016-5341
  • Sagi Kedmi von IBM X-Force Research: CVE-2016-8393, CVE-2016-8394
  • Sieben Shen ( @lingtongshen ) vom Mobile Threat Research Team, Trend Micro Inc.: CVE-2016-6757
  • Weichao Sun ( @sunblate ) von Alibaba Inc.: CVE-2016-6773
  • Wenke Dou , Chi Zhang , Chiachih Wu ( @chiachih_wu ) und Xuxian Jiang vom C0RE-Team : CVE-2016-6765
  • Wish Wu ( @wish_wu ) ( 吴 潍 浠 ) vom Mobile Threat Response Team von Trend Micro Inc . : CVE-2016-6704
  • Yuan-Tsung Lo , Tong Lin , Chiachih Wu ( @chiachih_wu ) und Xuxian Jiang vom C0RE-Team : CVE-2016-6786, CVE-2016-6780, CVE-2016-6775
  • Yuan-Tsung Lo , Xiaodong Wang , Chiachih Wu ( @chiachih_wu ) und Xuxian Jiang vom C0RE-Team : CVE-2016-6777
  • Yuxiang Li von der Abteilung Tencent Security Platform: CVE-2016-6771
  • Zhe Jin (金 哲) vom Chengdu Security Response Center, Qihoo 360 Technology Co. Ltd.: CVE-2016-6764, CVE-2016-6766
  • Zinuo Han vom Chengdu Security Response Center der Qihoo 360 Technology Co. Ltd.: CVE-2016-6762

Zusätzlicher Dank geht an MengLuo Gou ( @ idhyt3r ) von Bottle Tech, Yong Wang (王勇) ( @ ThomasKing2014 ) und Zubin Mithra von Google für ihre Beiträge zu diesem Sicherheitsbulletin.

01.12.2016 Sicherheits-Patch-Stufe - Details zur Sicherheitsanfälligkeit

In den folgenden Abschnitten finden Sie Details zu den Sicherheitslücken, die für die Patch-Version 2016-12-01 gelten. Es gibt eine Beschreibung des Problems, eine Begründung des Schweregrads und eine Tabelle mit dem CVE, den zugehörigen Referenzen, dem Schweregrad, aktualisierten Google-Geräten, aktualisierten AOSP-Versionen (falls zutreffend) und dem gemeldeten Datum. Sofern verfügbar, verknüpfen wir die öffentliche Änderung, mit der das Problem behoben wurde, mit der Fehler-ID, z. B. der AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern verknüpft, die auf die Fehler-ID folgen.

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in CURL / LIBCURL

Die Tabelle enthält Sicherheitslücken, die sich auf die Bibliotheken CURL und LIBCURL auswirken. Das schwerwiegendste Problem könnte es einem Man-in-the-Middle-Angreifer ermöglichen, mithilfe eines gefälschten Zertifikats beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als hoch eingestuft, da der Angreifer ein gefälschtes Zertifikat benötigt.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-5419 A-31271247 Hoch Alles 7.0 3. August 2016
CVE-2016-5420 A-31271247 Hoch Alles 7.0 3. August 2016
CVE-2016-5421 A-31271247 Hoch Alles 7.0 3. August 2016

Erhöhung der Sicherheitsanfälligkeit in libziparchive

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in der libziparchive-Bibliothek kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als hoch eingestuft, da es verwendet werden kann, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die normalerweise keine Drittanbieteranwendung zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-6762 A-31251826 [ 2 ] Hoch Alles 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 28. August 2016

Denial-of-Service-Sicherheitslücke in der Telefonie

Eine Denial-of-Service-Sicherheitsanfälligkeit in Telephony kann es einer lokalen bösartigen Anwendung ermöglichen, eine speziell gestaltete Datei zu verwenden, um ein Gerät hängen zu lassen oder neu zu starten. Dieses Problem wird aufgrund der Möglichkeit einer dauerhaften Dienstverweigerung vor Ort als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-6763 A-31530456 Hoch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 12. September 2016

Denial-of-Service-Sicherheitsanfälligkeit in Mediaserver

Eine Denial-of-Service-Sicherheitsanfälligkeit in Mediaserver kann es einem Angreifer ermöglichen, eine speziell gestaltete Datei zu verwenden, um ein Gerät hängen zu lassen oder neu zu starten. Dieses Problem wird aufgrund der Möglichkeit eines Remote-Denial-of-Service als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-6766 A-31318219 Hoch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 5. September 2016
CVE-2016-6765 A-31449945 Hoch Alles 4.4.4, 5.0.2, 5.1.1, 7.0 13. September 2016
CVE-2016-6764 A-31681434 Hoch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 22. September 2016
CVE-2016-6767 A-31833604 Hoch Keiner* 4.4.4 Google intern

* Unterstützte Google-Geräte unter Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert wurden, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in der Framesequence-Bibliothek

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in der Framesequence-Bibliothek kann es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei beliebigen Code im Kontext eines nicht privilegierten Prozesses auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung in einer Anwendung, die die Framesequence-Bibliothek verwendet, als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-6768 A-31631842 Hoch Alles 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 19. September 2016

Erhöhung der Sicherheitsanfälligkeit in Smart Lock

Durch eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in Smart Lock kann ein lokaler böswilliger Benutzer ohne PIN auf die Smart Lock-Einstellungen zugreifen. Dieses Problem wird als mittel eingestuft, da zunächst physischer Zugriff auf ein entsperrtes Gerät erforderlich ist, auf das Smart Lock als letzter Einstellungsbereich für den Benutzer zugegriffen hat.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-6769 A-29055171 Mäßig Keiner* 5.0.2, 5.1.1, 6.0, 6.0.1 27. Mai 2016

* Unterstützte Google-Geräte unter Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert wurden, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Erhöhung der Sicherheitsanfälligkeit in Framework-APIs

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in der Framework-API kann es einer lokalen bösartigen Anwendung ermöglichen, über ihre Zugriffsebene hinaus auf Systemfunktionen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es sich um eine lokale Umgehung von Einschränkungen für einen eingeschränkten Prozess handelt.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-6770 A-30202228 Mäßig Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 16. Juli 2016

Erhöhung der Sicherheitslücke in der Telefonie

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in der Telefonie kann es einer lokalen böswilligen Anwendung ermöglichen, über ihre Zugriffsebene hinaus auf Systemfunktionen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es sich um eine lokale Umgehung von Einschränkungen für einen eingeschränkten Prozess handelt.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-6771 A-31566390 Mäßig Alles 6.0, 6.0.1, 7.0 17. September 2016

Erhöhung der Sicherheitsanfälligkeit in Wi-Fi

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in Wi-Fi kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als mittel eingestuft, da zunächst ein privilegierter Prozess gefährdet werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-6772 A-31856351 [ 2 ] Mäßig Alles 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 30. September 2016

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in Mediaserver kann es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um ohne Erlaubnis auf vertrauliche Daten zuzugreifen.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-6773 A-30481714 [ 2 ] Mäßig Alles 6.0, 6.0.1, 7.0 27. Juli 2016

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen in Package Manager

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in Package Manager kann es einer lokalen bösartigen Anwendung ermöglichen, den Schutz des Betriebssystems zu umgehen, der Anwendungsdaten von anderen Anwendungen isoliert. Dieses Problem wird als mittel eingestuft, da zunächst ein privilegierter Prozess gefährdet werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-6774 A-31251489 Mäßig Alles 7.0 29. August 2016

Sicherheits-Patch-Stufe 2016-12-05 - Details zur Sicherheitsanfälligkeit

In den folgenden Abschnitten finden Sie Details zu den Sicherheitslücken, die für die Patch-Version 2016-12-05 gelten. Es gibt eine Beschreibung des Problems, eine Begründung des Schweregrads und eine Tabelle mit dem CVE, den zugehörigen Referenzen, dem Schweregrad, aktualisierten Google-Geräten, aktualisierten AOSP-Versionen (falls zutreffend) und dem gemeldeten Datum. Sofern verfügbar, verknüpfen wir die öffentliche Änderung, mit der das Problem behoben wurde, mit der Fehler-ID, z. B. der AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern verknüpft, die auf die Fehler-ID folgen.

Erhöhung der Berechtigungsanfälligkeit im Kernel-Speichersubsystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-Speichersubsystem könnte es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-4794 A-31596597
Upstream-Kernel [ 2 ]
Kritisch Pixel C, Pixel, Pixel XL 17. April 2016
CVE-2016-5195 A-32141528
Upstream-Kernel [ 2 ]
Kritisch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus-Player, Pixel, Pixel XL 12. Oktober 2016

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im NVIDIA-GPU-Treiber

Eine Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im NVIDIA-GPU-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-6775 A-31222873 *
N-CVE-2016-6775
Kritisch Nexus 9 25. August 2016
CVE-2016-6776 A-31680980 *
N-CVE-2016-6776
Kritisch Nexus 9 22. September 2016
CVE-2016-6777 A-31910462 *
N-CVE-2016-6777
Kritisch Nexus 9 3. Oktober 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Google-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit im Kernel

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2015-8966 A-31435731
Upstream-Kernel
Kritisch Keiner* 10. September 2016

* Unterstützte Google-Geräte unter Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert wurden, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im NVIDIA-Grafiktreiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im NVIDIA-Grafiktreiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-6915 A-31471161 *
N-CVE-2016-6915
Kritisch Nexus 9 13. September 2016
CVE-2016-6916 A-32072350 *
N-CVE-2016-6916
Kritisch Nexus 9, Pixel C. 13. September 2016
CVE-2016-6917 A-32072253 *
N-CVE-2016-6917
Kritisch Nexus 9 13. September 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Google-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Kernel-ION-Treiber

Eine Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im Kernel-ION-Treiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-9120 A-31568617
Upstream-Kernel
Kritisch Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel C, Nexus Player 16. September 2016

Sicherheitslücken in Qualcomm-Komponenten

Die folgenden Sicherheitsanfälligkeiten betreffen Qualcomm-Komponenten und werden im Qualcomm AMSS-Sicherheitsbulletin vom November 2015 ausführlicher beschrieben.

CVE Verweise Schwere* Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-8411 A-31805216 ** Kritisch Nexus 6, Nexus 6P, Android One Qualcomm intern

* Der Schweregrad für diese Sicherheitsanfälligkeiten wurde vom Anbieter festgelegt.

** Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Google-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen im Kernel-Dateisystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-Dateisystem kann es einer lokalen böswilligen Anwendung ermöglichen, den Schutz des Betriebssystems zu umgehen, der Anwendungsdaten von anderen Anwendungen isoliert. Dieses Problem wird als hoch eingestuft, da es verwendet werden kann, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die normalerweise keine Drittanbieteranwendung zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2014-4014 A-31252187
Upstream-Kernel
Hoch Nexus 6, Nexus-Spieler 10. Juni 2014

Erhöhung der Sicherheitsanfälligkeit im Kernel

Eine Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im Kernel kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst eine separate Sicherheitsanfälligkeit ausgenutzt werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2015-8967 A-31703084
Upstream-Kernel
Hoch Nexus 5X, Nexus 6P, Nexus 9, Pixel C, Pixel, Pixel XL 8. Januar 2015

Erhöhung der Sicherheitsanfälligkeit im HTC-Soundcodec-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im HTC-Soundcodec-Treiber könnte es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-6778 A-31384646 * Hoch Nexus 9 25. Februar 2016
CVE-2016-6779 A-31386004 * Hoch Nexus 9 25. Februar 2016
CVE-2016-6780 A-31251496 * Hoch Nexus 9 30. August 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Google-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen im MediaTek-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im MediaTek-Treiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-6492 A-28175122
MT-ALPS02696413
Hoch Keiner* 11. April 2016
CVE-2016-6781 A-31095175
MT-ALPS02943455
Hoch Keiner* 22. August 2016
CVE-2016-6782 A-31224389
MT-ALPS02943506
Hoch Keiner* 24. August 2016
CVE-2016-6783 A-31350044
MT-ALPS02943437
Hoch Keiner* 6. September 2016
CVE-2016-6784 A-31350755
MT-ALPS02961424
Hoch Keiner* 6. September 2016
CVE-2016-6785 A-31748056
MT-ALPS02961400
Hoch Keiner* 25. September 2016

* Unterstützte Google-Geräte unter Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert wurden, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Erhöhung der Sicherheitsanfälligkeit in Berechtigungen in Qualcomm-Mediencodecs

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in Qualcomm-Mediencodecs kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als hoch eingestuft, da es verwendet werden kann, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die normalerweise keine Drittanbieteranwendung zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-6761 A-29421682 *
QC-CR # 1055792
Hoch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus-Player, Pixel, Pixel XL 16. Juni 2016
CVE-2016-6760 A-29617572 *
QC-CR # 1055783
Hoch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus-Player, Pixel, Pixel XL 23. Juni 2016
CVE-2016-6759 A-29982686 *
QC-CR # 1055766
Hoch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus-Player, Pixel, Pixel XL 4. Juli 2016
CVE-2016-6758 A-30148882 *
QC-CR # 1071731
Hoch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus-Player, Pixel, Pixel XL 13. Juli 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Google-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit in Qualcomm-Kameratreibern

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm-Kameratreiber könnte es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-6755 A-30740545
QC-CR # 1065916
Hoch Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 3. August 2016

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Kernel-Leistungssubsystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-Leistungssubsystem kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-6786 A-30955111 Upstream-Kernel Hoch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus-Player, Pixel, Pixel XL 18. August 2016
CVE-2016-6787 A-31095224 Upstream-Kernel Hoch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus-Player, Pixel, Pixel XL 22. August 2016

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen im MediaTek I2C-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im MediaTek I2C-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-6788 A-31224428
MT-ALPS02943467
Hoch Keiner* 24. August 2016

* Unterstützte Google-Geräte unter Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert wurden, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen in der NVIDIA libomx-Bibliothek

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in der NVIDIA libomx-Bibliothek (libnvomx) kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als hoch eingestuft, da es verwendet werden kann, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die normalerweise keine Drittanbieteranwendung zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-6789 A-31251973 *
N-CVE-2016-6789
Hoch Pixel C. 29. August 2016
CVE-2016-6790 A-31251628 *
N-CVE-2016-6790
Hoch Pixel C. 28. August 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Google-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit in Qualcomm-Soundtreibern

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm-Soundtreiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-6791 A-31252384
QC-CR # 1071809
Hoch Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 31. August 2016
CVE-2016-8391 A-31253255
QC-CR # 1072166
Hoch Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 31. August 2016
CVE-2016-8392 A-31385862
QC-CR # 1073136
Hoch Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL 8. September 2016

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Kernel-Sicherheitssubsystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-Sicherheitssubsystem kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2015-7872 A-31253168
Upstream-Kernel
Hoch Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus-Player, Pixel, Pixel XL 31. August 2016

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen im Synaptics-Touchscreen-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Synaptics-Touchscreen-Treiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-8393 A-31911920 * Hoch Nexus 5X, Nexus 6P, Nexus 9, Android One, Pixel, Pixel XL 8. September 2016
CVE-2016-8394 A-31913197 * Hoch Nexus 9, Android One 8. September 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Google-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit in Broadcom Wi-Fi-Treibern

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Broadcom Wi-Fi-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2014-9909 A-31676542
B-RB # 26684
Hoch Keiner* 21. September 2016
CVE-2014-9910 A-31746399
B-RB # 26710
Hoch Keiner* 26. September 2016

* Unterstützte Google-Geräte unter Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert wurden, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen im MediaTek-Grafiktreiber

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen im MediaTek-Grafiktreiber kann es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als hoch eingestuft, da es ohne ausdrückliche Benutzerberechtigung für den Zugriff auf vertrauliche Daten verwendet werden kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-8396 A-31249105 Hoch Keiner* 26. August 2016

* Unterstützte Google-Geräte unter Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert wurden, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen im NVIDIA-Grafiktreiber

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen im NVIDIA-Grafiktreiber kann es einer lokalen böswilligen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als hoch eingestuft, da es ohne ausdrückliche Benutzerberechtigung für den Zugriff auf vertrauliche Daten verwendet werden kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-8397 A-31385953 *
N-CVE-2016-8397
Hoch Nexus 9 8. September 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Google-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Denial-of-Service-Sicherheitslücke in GPS

Eine Denial-of-Service-Sicherheitsanfälligkeit in der Qualcomm-GPS-Komponente kann es einem Remoteangreifer ermöglichen, ein Gerät hängen zu lassen oder neu zu starten. Dieses Problem wird aufgrund der Möglichkeit eines vorübergehenden Remote-Denial-of-Service als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-5341 A-31470303 * Hoch Nexus 6, Nexus 5X, Nexus 6P, Nexus 9, Android One, Pixel, Pixel XL 21. Juni 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Denial of service vulnerability in NVIDIA camera driver

A denial of service vulnerability in the NVIDIA camera driver could enable an attacker to cause a local permanent denial of service, which may require reflashing the operating system to repair the device. This issue is rated as High due to the possibility of local permanent denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-8395 A-31403040*
N-CVE-2016-8395
High Pixel C Sep 9, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Elevation of privilege vulnerability in kernel networking subsystem

An elevation of privilege vulnerability in the kernel networking subsystem could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and current compiler optimizations restrict access to the vulnerable code.

CVE References Severity Updated Google devices Date reported
CVE-2016-8399 A-31349935* Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 5, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm components

An information disclosure vulnerability in Qualcomm components including the camera driver and video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-6756 A-29464815
QC-CR#1042068 [ 2 ]
Moderate Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL Jun 17, 2016
CVE-2016-6757 A-30148242
QC-CR#1052821
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL Jul 13, 2016

Information disclosure vulnerability in NVIDIA librm library

An information disclosure vulnerability in the NVIDIA librm library (libnvrm) could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it could be used to access sensitive data without permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-8400 A-31251599*
N-CVE-2016-8400
Moderate Pixel C Aug 29, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Information disclosure vulnerability in kernel components

An information disclosure vulnerability in kernel components including the ION subsystem, Binder, USB driver and networking subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8401 A-31494725* Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 13, 2016
CVE-2016-8402 A-31495231* Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 13, 2016
CVE-2016-8403 A-31495348* Moderate Nexus 9 Sep 13, 2016
CVE-2016-8404 A-31496950* Moderate Nexus 9 Sep 13, 2016
CVE-2016-8405 A-31651010* Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 21, 2016
CVE-2016-8406 A-31796940* Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel C, Nexus Player, Pixel, Pixel XL Sep 27, 2016
CVE-2016-8407 A-31802656* Moderate Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL Sep 28, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Information disclosure vulnerability in NVIDIA video driver

An information disclosure vulnerability in the NVIDIA video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8408 A-31496571*
N-CVE-2016-8408
Moderate Nexus 9 Sep 13, 2016
CVE-2016-8409 A-31495687*
N-CVE-2016-8409
Moderate Nexus 9 Sep 13, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Google devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8410 A-31498403
QC-CR#987010
Moderate Nexus 5X, Nexus 6, Nexus 6P, Android One Google internal

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2016-12-01 or later address all issues associated with the 2016-12-01 security patch level.
  • Security patch levels of 2016-12-05 or later address all issues associated with the 2016-12-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2016-12-01]
  • [ro.build.version.security_patch]:[2016-12-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the December 1, 2016 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of December 5, 2016 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2016-12-01 and 2016-12-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • December 05, 2016: Bulletin published.
  • December 07, 2016: Bulletin revised to include AOSP links and updated attribution for CVE-2016-6915, CVE-2016-6916 and CVE-2016-6917.
  • December 21, 2016: Corrected typos in CVE-2016-8411 description and Common Questions and Answers.