Google setzt sich dafür ein, die Rassengerechtigkeit für schwarze Gemeinschaften zu fördern. Siehe wie.
Diese Seite wurde von der Cloud Translation API übersetzt.
Switch to English

Android Security Bulletin - März 2017

Veröffentlicht am 06. März 2017 | Aktualisiert am 07. März 2017

Das Android Security Bulletin enthält Details zu Sicherheitslücken, die Android-Geräte betreffen. Neben dem Bulletin haben wir ein Sicherheitsupdate für Google-Geräte über ein drahtloses Update (OTA) veröffentlicht. Die Firmware-Bilder des Google-Geräts wurden auch auf der Google Developer-Website veröffentlicht . Sicherheits-Patch-Levels vom 05. März 2017 oder höher beheben all diese Probleme. Informationen zum Überprüfen der Sicherheits-Patch-Stufe eines Geräts finden Sie im Update-Zeitplan für Pixel und Nexus .

Die Partner wurden am 06. Februar 2017 oder früher über die im Bulletin beschriebenen Probleme informiert. Quellcode-Patches für diese Probleme wurden im AOSP-Repository (Android Open Source Project) veröffentlicht und über dieses Bulletin verlinkt. Dieses Bulletin enthält auch Links zu Patches außerhalb von AOSP.

Das schwerwiegendste dieser Probleme ist eine kritische Sicherheitslücke, die die Remotecodeausführung auf einem betroffenen Gerät über mehrere Methoden wie E-Mail, Surfen im Internet und MMS bei der Verarbeitung von Mediendateien ermöglichen kann. Die Bewertung des Schweregrads basiert auf den Auswirkungen, die das Ausnutzen der Sicherheitsanfälligkeit möglicherweise auf ein betroffenes Gerät haben würde, vorausgesetzt, die Plattform- und Dienstminderungen sind für Entwicklungszwecke deaktiviert oder werden erfolgreich umgangen.

Wir haben keine Berichte über die aktive Ausbeutung oder den Missbrauch dieser neu gemeldeten Probleme durch Kunden erhalten. Weitere Informationen zum Schutz der Android-Sicherheitsplattform und zum Schutz von Diensten wie SafetyNet , die die Sicherheit der Android-Plattform verbessern, finden Sie im Abschnitt zur Minderung von Android- und Google-Diensten .

Wir empfehlen allen Kunden, diese Updates für ihre Geräte zu akzeptieren.

Ankündigungen

  • Dieses Bulletin enthält zwei Sicherheits-Patch-Level-Zeichenfolgen, die Android-Partnern die Flexibilität bieten, eine Teilmenge von Schwachstellen, die auf allen Android-Geräten ähnlich sind, schneller zu beheben. Weitere Informationen finden Sie unter Allgemeine Fragen und Antworten :
    • 2017-03-01 : Teilweise Sicherheits-Patch-Level-Zeichenfolge. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle mit dem 01.03.2017 verbundenen Probleme (und alle vorherigen Sicherheits-Patch-Level-Zeichenfolgen) behoben sind.
    • 2017-03-05 : Vollständige Zeichenfolge für die Sicherheits-Patch-Ebene. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle mit dem 01.03.2017 und dem 05.03.2017 verbundenen Probleme (und alle vorherigen Sicherheits-Patch-Level-Zeichenfolgen) behoben sind.
  • Unterstützte Google-Geräte erhalten ein einzelnes OTA-Update mit der Sicherheits-Patch-Stufe vom 05. März 2017.

Minderung von Android- und Google-Diensten

Dies ist eine Zusammenfassung der von der Android-Sicherheitsplattform bereitgestellten Maßnahmen und des Schutzes von Diensten wie SafetyNet. Diese Funktionen verringern die Wahrscheinlichkeit, dass Sicherheitslücken unter Android erfolgreich ausgenutzt werden können.

  • Die Nutzung vieler Probleme unter Android wird durch Verbesserungen in neueren Versionen der Android-Plattform erschwert. Wir empfehlen allen Benutzern, nach Möglichkeit auf die neueste Version von Android zu aktualisieren.
  • Das Android-Sicherheitsteam überwacht mit Verify Apps und SafetyNet aktiv auf Missbrauch, um Benutzer vor potenziell schädlichen Anwendungen zu warnen. Überprüfen Sie, ob Apps auf Geräten mit Google Mobile Services standardmäßig aktiviert sind. Dies ist besonders wichtig für Benutzer, die Anwendungen von außerhalb von Google Play installieren. Geräte-Rooting-Tools sind in Google Play verboten. Verify Apps warnt Benutzer jedoch, wenn sie versuchen, eine erkannte Rooting-Anwendung zu installieren - unabhängig davon, woher sie stammt. Darüber hinaus versucht Verify Apps, die Installation bekannter schädlicher Anwendungen zu identifizieren und zu blockieren, die eine Sicherheitsanfälligkeit bezüglich der Eskalation von Berechtigungen ausnutzen. Wenn eine solche Anwendung bereits installiert wurde, benachrichtigt Verify Apps den Benutzer und versucht, die erkannte Anwendung zu entfernen.
  • Gegebenenfalls übergeben Google Hangouts- und Messenger-Anwendungen Medien nicht automatisch an Prozesse wie Mediaserver.

Danksagung

Wir möchten diesen Forschern für ihre Beiträge danken:

  • Alexander Potapenko vom Google Dynamic Tools-Team: CVE-2017-0537
  • Baozeng Ding, Chengming Yang, Peng Xiao und Yang Song der Alibaba Mobile Security Group: CVE-2017-0506
  • Baozeng Ding, Ning You, Chengming Yang, Peng Xiao und Yang Song der Alibaba Mobile Security Group: CVE-2017-0463
  • Billy Lau von Android Security: CVE-2017-0335, CVE-2017-0336, CVE-2017-0338, CVE-2017-0460
  • derrek ( @ derrekr6 ): CVE-2016-8413, CVE-2016-8477, CVE-2017-0531
  • derrek ( @ derrekr6 ) und Scott Bauer ( @ ScottyBauer1 ): CVE-2017-0521
  • Di Shen ( @returnsme ) von KeenLab ( @keen_lab ), Tencent: CVE-2017-0334, CVE-2017-0456, CVE-2017-0457, CVE-2017-0525
  • En He ( @ heeeeen4x ) und Bo Liu von MS509Team : CVE-2017-0490
  • Gengjia Chen ( @ chengjia4574 ) und pjf von IceSword Lab, Qihoo 360 Technology Co. Ltd.: CVE-2017-0500, CVE-2017-0501, CVE-2017-0502, CVE-2017-0503, CVE-2017-0509, CVE-2017-0524, CVE-2017-0529, CVE-2017-0536
  • Hao Chen und Guang Gong vom Alpha-Team, Qihoo 360 Technology Co. Ltd.: CVE-2017-0453, CVE-2017-0461, CVE-2017-0464
  • Hiroki Yamamoto und Fang Chen von Sony Mobile Communications Inc.: CVE-2017-0481
  • Die IBM Security X-Force-Forscher Sagi Kedmi und Roee Hay: CVE-2017-0510
  • Jianjun Dai ( @Jioun_dai ) von Qihoo 360 Skyeye Labs : CVE-2017-0478
  • Jianqiang Zhao ( @jianqiangzhao ) und pjf von IceSword Lab, Qihoo 360: CVE-2016-8416, CVE-2016-8478, CVE-2017-0458, CVE-2017-0459, CVE-2017-0518, CVE-2017-0519 , CVE-2017-0533, CVE-2017-0534
  • Lubo Zhang , Tong Lin , Yuan-Tsung Lo und Xuxian Jiang vom C0RE-Team : CVE-2016-8479
  • Makoto Onuki von Google: CVE-2017-0491
  • Mingjian Zhou ( @Mingjian_Zhou ), Hanxiang Wen und Xuxian Jiang vom C0RE-Team : CVE-2017-0479, CVE-2017-0480
  • Nathan Crandall ( @natecray ): CVE-2017-0535
  • Nathan Crandall ( @natecray ) vom Produktsicherheitsteam von Tesla Motors: CVE-2017-0306
  • Pengfei Ding (丁鹏飞), Chenfu Bao (包 沉浮), Lenx Wei (韦 韬) von Baidu X-Lab (百度 安全 实验室): CVE-2016-8417
  • Qidan He (何 淇 丹) ( @flanker_hqd ) von KeenLab, Tencent: CVE-2017-0337, CVE-2017-0476
  • Qing Zhang von Qihoo 360 und Guangdong Bai vom Singapore Institute of Technology (SIT): CVE-2017-0496
  • Quhe und Wanchouchou vom Ant-Financial Light-Year Security Lab (CVE-2017-0522)
  • Sahara für sichere Kommunikation in DarkMatter: CVE-2017-0528
  • salls ( @chris_salls ) des Shellphish Grill Teams, UC Santa Barbara: CVE-2017-0505
  • Scott Bauer ( @ ScottyBauer1 ): CVE-2017-0504, CVE-2017-0516
  • Sean Beaupre (Beaups): CVE-2017-0455
  • Sieben Shen ( @lingtongshen ) von Trend Micro: CVE-2017-0452
  • Shinichi Matsumoto von Fujitsu: CVE-2017-0498
  • Stéphane Marques von ByteRev : CVE-2017-0489
  • Svetoslav Ganov von Google: CVE-2017-0492
  • Tong Lin , Yuan-Tsung Lo und Xuxian Jiang vom C0RE-Team : CVE-2017-0333
  • VEO ( @VYSEa ) vom Mobile Threat Response Team , Trend Micro : CVE-2017-0466, CVE-2017-0467, CVE-2017-0468, CVE-2017-0469, CVE-2017-0470, CVE-2017-0471, CVE-2017-0472, CVE-2017-0473, CVE-2017-0482, CVE-2017-0484, CVE-2017-0485, CVE-2017-0486, CVE-2017-0487, CVE-2017-0494, CVE- 2017-0495
  • Ich wünsche Wu (w 潍 浠 此 彼) ( @wish_wu ) vom Ant-Financial Light-Year Security Lab (CVE-2017-0477)
  • Yu Pan vom Vulpecker-Team, Qihoo 360 Technology Co. Ltd: CVE-2017-0517, CVE-2017-0532
  • Yuan-Tsung Lo und Xuxian Jiang vom C0RE-Team : CVE-2017-0526, CVE-2017-0527
  • Yuqi Lu ( @ nikos233 ), Wenke Dou , Dacheng Shao , Mingjian Zhou ( @Mingjian_Zhou ) und Xuxian Jiang vom C0RE-Team : CVE-2017-0483
  • Zinuo Han ( weibo.com/ele7enxxh ) vom Chengdu Security Response Center, Qihoo 360 Technology Co. Ltd.: CVE-2017-0475, CVE-2017-0497

Sicherheits-Patch-Stufe 2017-03-01 - Details zu Sicherheitslücken

In den folgenden Abschnitten finden Sie Details zu den Sicherheitslücken, die für die Patch-Version 2017-03-01 gelten. Es gibt eine Beschreibung des Problems, eine Begründung des Schweregrads und eine Tabelle mit dem CVE, den zugehörigen Referenzen, dem Schweregrad, aktualisierten Google-Geräten, aktualisierten AOSP-Versionen (falls zutreffend) und dem gemeldeten Datum. Sofern verfügbar, verknüpfen wir die öffentliche Änderung, mit der das Problem behoben wurde, mit der Fehler-ID, z. B. der AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern verknüpft, die auf die Fehler-ID folgen.

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in OpenSSL & BoringSSL

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in OpenSSL und BoringSSL kann es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei Speicherbeschädigungen während der Datei- und Datenverarbeitung zu verursachen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext eines privilegierten Prozesses als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-2182 A-32096880 Kritisch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 5. August 2016

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Mediaserver kann es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei Speicherbeschädigungen während der Verarbeitung von Mediendateien und Daten zu verursachen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext des Mediaserver-Prozesses als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0466 A-33139050 [ 2 ] Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 25. November 2016
CVE-2017-0467 A-33250932 [ 2 ] Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 30. November 2016
CVE-2017-0468 A-33351708 [ 2 ] Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 5. Dezember 2016
CVE-2017-0469 A-33450635 Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 8. Dezember 2016
CVE-2017-0470 A-33818500 Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 21. Dezember 2016
CVE-2017-0471 A-33816782 Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 21. Dezember 2016
CVE-2017-0472 A-33862021 Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 23. Dezember 2016
CVE-2017-0473 A-33982658 Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 30. Dezember 2016
CVE-2017-0474 A-32589224 Kritisch Alles 7.0, 7.1.1 Google intern

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Wiederherstellungsprüfer

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Wiederherstellungsprüfer kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0475 A-31914369 Kritisch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2. Oktober 2016

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in AOSP Messaging

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in AOSP Messaging kann es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei Speicherbeschädigungen während der Verarbeitung von Mediendateien und Daten zu verursachen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext eines nicht privilegierten Prozesses als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0476 A-33388925 Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 6. Dezember 2016

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in libgdx

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in libgdx kann es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei beliebigen Code im Kontext eines nicht privilegierten Prozesses auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung in einer Anwendung, die diese Bibliothek verwendet, als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0477 A-33621647 Hoch Alles 7.1.1 14. Dezember 2016

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in der Framesequence-Bibliothek

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in der Framesequence-Bibliothek kann es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei beliebigen Code im Kontext eines nicht privilegierten Prozesses auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung in einer Anwendung, die die Framesequence-Bibliothek verwendet, als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0478 A-33718716 Hoch Alles 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 16. Dezember 2016

Erhöhung der Sicherheitsanfälligkeit in NFC

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in NFC kann es einem Angreifer in der Nähe ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als hoch eingestuft, da es verwendet werden kann, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die normalerweise keine Drittanbieteranwendung zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0481 A-33434992 Hoch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 6. November 2016

Erhöhung der Sicherheitsanfälligkeit in Audioserver

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in Audioserver kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als hoch eingestuft, da es verwendet werden kann, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die normalerweise keine Drittanbieteranwendung zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0479 A-32707507 [ 2 ] Hoch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7. November 2016
CVE-2017-0480 A-32705429 [ 2 ] Hoch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 7. November 2016

Denial-of-Service-Sicherheitsanfälligkeit in Mediaserver

Eine Denial-of-Service-Sicherheitsanfälligkeit in Mediaserver kann es einem Angreifer ermöglichen, eine speziell gestaltete Datei zu verwenden, um ein Gerät hängen zu lassen oder neu zu starten. Dieses Problem wird aufgrund der Möglichkeit eines Remote-Denial-of-Service als hochgradig eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0482 A-33090864 [ 2 ] [ 3 ] [ 4 ] [ 5 ] [ 6 ] Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 22. November 2016
CVE-2017-0483 A-33137046 [ 2 ] Hoch Alles 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 24. November 2016
CVE-2017-0484 A-33298089 [ 2 ] Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 1. Dezember 2016
CVE-2017-0485 A-33387820 Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 6. Dezember 2016
CVE-2017-0486 A-33621215 Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 14. Dezember 2016
CVE-2017-0487 A-33751193 Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 19. Dezember 2016
CVE-2017-0488 A-34097213 Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 Google intern

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen in Location Manager

Durch eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in Location Manager kann eine lokale schädliche Anwendung den Schutz des Betriebssystems für Standortdaten umgehen. Dieses Problem wird als mittel eingestuft, da damit möglicherweise ungenaue Daten generiert werden.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0489 A-33091107 Mäßig Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 20. November 2016

Erhöhung der Sicherheitsanfälligkeit in Wi-Fi

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in Wi-Fi kann es einer lokalen bösartigen Anwendung ermöglichen, Benutzerdaten zu löschen. Dieses Problem wird als mittel eingestuft, da es sich um eine lokale Umgehung der Benutzerinteraktionsanforderungen handelt, für die normalerweise entweder eine Benutzerinitiierung oder eine Benutzerberechtigung erforderlich ist.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0490 A-33178389 [ 2 ] [ 3 ] Mäßig Alles 6.0, 6.0.1, 7.0, 7.1.1 25. November 2016

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen in Package Manager

Durch eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in Package Manager kann eine lokale schädliche Anwendung verhindern, dass Benutzer Anwendungen deinstallieren oder Berechtigungen aus Anwendungen entfernen. Dieses Problem wird als mittel eingestuft, da es sich um eine lokale Umgehung der Benutzerinteraktionsanforderungen handelt.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0491 A-32553261 Mäßig Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google intern

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen in der Systembenutzeroberfläche

Durch eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in der Systembenutzeroberfläche kann eine lokale böswillige Anwendung eine Benutzeroberflächenüberlagerung erstellen, die den gesamten Bildschirm abdeckt. Dieses Problem wird als mittel eingestuft, da es sich um eine lokale Umgehung der Benutzerinteraktionsanforderungen handelt, für die normalerweise entweder eine Benutzerinitiierung oder eine Benutzerberechtigung erforderlich ist.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0492 A-30150688 Mäßig Alles 7.1.1 Google intern

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen in AOSP Messaging

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in AOSP Messaging kann es einem Remoteangreifer ermöglichen, mithilfe einer speziell gestalteten Datei auf Daten außerhalb seiner Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um ohne Erlaubnis auf vertrauliche Daten zuzugreifen.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0494 A-32764144 Mäßig Alles 6.0, 6.0.1, 7.0, 7.1.1 9. November 2016

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in Mediaserver kann es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um ohne Erlaubnis auf vertrauliche Daten zuzugreifen.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0495 A-33552073 Mäßig Alles 6.0, 6.0.1, 7.0, 7.1.1 11. Dezember 2016

Denial-of-Service-Sicherheitsanfälligkeit im Setup-Assistenten

Eine Denial-of-Service-Sicherheitsanfälligkeit im Setup-Assistenten kann es einer lokalen bösartigen Anwendung ermöglichen, den Zugriff auf ein betroffenes Gerät vorübergehend zu blockieren. Dieses Problem wird als mittel eingestuft, da möglicherweise ein Zurücksetzen auf die Werkseinstellungen erforderlich ist, um das Gerät zu reparieren.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0496 A-31554152 * Mäßig Keiner** 5.0.2, 5.1.1, 6.0, 6.0.1 14. September 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Google-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Denial-of-Service-Sicherheitsanfälligkeit in Mediaserver

Eine Denial-of-Service-Sicherheitsanfälligkeit in Mediaserver kann es einem Angreifer ermöglichen, eine speziell gestaltete Datei zu verwenden, um ein Gerät hängen zu lassen oder neu zu starten. Dieses Problem wird als mittel eingestuft, da eine ungewöhnliche Gerätekonfiguration erforderlich ist.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0497 A-33300701 Mäßig Alles 7.0, 7.1.1 2. Dezember 2016

Denial-of-Service-Sicherheitsanfälligkeit im Setup-Assistenten

Eine Denial-of-Service-Sicherheitsanfälligkeit im Setup-Assistenten kann es einem lokalen Angreifer ermöglichen, nach einem Zurücksetzen auf die Werkseinstellungen eine Anmeldung für das Google-Konto zu verlangen. Dieses Problem wird als mittel eingestuft, da möglicherweise ein Zurücksetzen auf die Werkseinstellungen erforderlich ist, um das Gerät zu reparieren.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0498 A-30352311 [ 2 ] Mäßig Alles 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google intern

Denial-of-Service-Sicherheitsanfälligkeit in Audioserver

Eine Denial-of-Service-Sicherheitsanfälligkeit in Audioserver kann es einer lokalen schädlichen Anwendung ermöglichen, dass ein Gerät hängen bleibt oder neu gestartet wird. Dieses Problem wird aufgrund der Möglichkeit eines vorübergehenden Denial-of-Service als niedrig eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0499 A-32095713 Niedrig Alles 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 11. Oktober 2016

Sicherheits-Patch-Stufe 2017-03-05 - Details zur Sicherheitsanfälligkeit

In den folgenden Abschnitten finden Sie Details zu den Sicherheitslücken, die für die Patch-Version 2017-03-05 gelten. Es gibt eine Beschreibung des Problems, eine Begründung des Schweregrads und eine Tabelle mit dem CVE, den zugehörigen Referenzen, dem Schweregrad, aktualisierten Google-Geräten, aktualisierten AOSP-Versionen (falls zutreffend) und dem gemeldeten Datum. Sofern verfügbar, verknüpfen wir die öffentliche Änderung, mit der das Problem behoben wurde, mit der Fehler-ID, z. B. der AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern verknüpft, die auf die Fehler-ID folgen.

Erhöhung der Sicherheitsanfälligkeit in MediaTek-Komponenten

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in MediaTek-Komponenten, einschließlich des M4U-Treibers, des Soundtreibers, des Touchscreen-Treibers, des GPU-Treibers und des Befehlswarteschlangentreibers, kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0500 A-28429685 *
M-ALPS02710006
Kritisch Keiner** 27. April 2016
CVE-2017-0501 A-28430015 *
M-ALPS02708983
Kritisch Keiner** 27. April 2016
CVE-2017-0502 A-28430164 *
M-ALPS02710027
Kritisch Keiner** 27. April 2016
CVE-2017-0503 A-28449045 *
M-ALPS02710075
Kritisch Keiner** 28. April 2016
CVE-2017-0504 A-30074628 *
M-ALPS02829371
Kritisch Keiner** 9. Juli 2016
CVE-2017-0505 A-31822282 *
M-ALPS02992041
Kritisch Keiner** 28. September 2016
CVE-2017-0506 A-32276718 *
M-ALPS03006904
Kritisch Keiner** 18. Oktober 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im NVIDIA-GPU-Treiber

Eine Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im NVIDIA-GPU-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0337 A-31992762 *
N-CVE-2017-0337
Kritisch Pixel C. 6. Oktober 2016
CVE-2017-0338 A-33057977 *
N-CVE-2017-0338
Kritisch Pixel C. 21. November 2016
CVE-2017-0333 A-33899363 *
N-CVE-2017-0333
Kritisch Pixel C. 25. Dezember 2016
CVE-2017-0306 A-34132950 *
N-CVE-2017-0306
Kritisch Nexus 9 6. Januar 2017
CVE-2017-0335 A-33043375 *
N-CVE-2017-0335
Kritisch Pixel C. Google intern

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Kernel-ION-Subsystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-ION-Subsystem kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0507 A-31992382 * Kritisch Android One, Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Nexus Player, Pixel C, Pixel, Pixel XL 6. Oktober 2016
CVE-2017-0508 A-33940449 * Kritisch Pixel C. 28. Dezember 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit in Broadcom Wi-Fi-Treibern

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Broadcom Wi-Fi-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0509 A-32124445 *
B-RB # 110688
Kritisch Keiner** 12. Oktober 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Kernel-FIQ-Debugger

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-FIQ-Debugger kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0510 A-32402555 * Kritisch Nexus 9 25. Oktober 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im Qualcomm-GPU-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm-GPU-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-8479 A-31824853 *
QC-CR # 1093687
Kritisch Android One, Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL 29. September 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Kernel-Netzwerksubsystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-Netzwerksubsystem könnte es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-9806 A-33393474
Upstream-Kernel
Kritisch Pixel C, Pixel, Pixel XL 4. Dezember 2016
CVE-2016-10200 A-33753815
Upstream-Kernel
Kritisch Nexus 5X, Nexus 6P, Pixel, Pixel XL 19. Dezember 2016

Sicherheitslücken in Qualcomm-Komponenten

Die folgende Sicherheitsanfälligkeit betrifft Qualcomm-Komponenten und wird im Qualcomm AMSS Security Bulletin vom September 2016 ausführlicher beschrieben.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-8484 A-28823575 ** Kritisch Keiner*** Qualcomm intern
CVE-2016-8485 A-28823681 ** Kritisch Keiner*** Qualcomm intern
CVE-2016-8486 A-28823691 ** Kritisch Keiner*** Qualcomm intern
CVE-2016-8487 A-28823724 ** Kritisch Keiner*** Qualcomm intern
CVE-2016-8488 A-31625756 ** Kritisch Keiner*** Qualcomm intern

* Der Schweregrad für diese Sicherheitsanfälligkeiten wurde vom Anbieter festgelegt.

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

*** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Kernel-Netzwerksubsystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-Netzwerksubsystem kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-8655 A-33358926
Upstream-Kernel
Hoch Android One, Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Nexus Player, Pixel C, Pixel, Pixel XL 12. Oktober 2016
CVE-2016-9793 A-33363517
Upstream-Kernel
Hoch Android One, Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Nexus Player, Pixel C, Pixel, Pixel XL 2. Dezember 2016

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Qualcomm-Eingabehardwaretreiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm-Eingabehardwaretreiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0516 A-32341680 *
QC-CR # 1096301
Hoch Android One, Pixel, Pixel XL 21. Oktober 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen im MediaTek-Hardware-Sensortreiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im MediaTek-Hardware-Sensortreiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0517 A-32372051 *
M-ALPS02973195
Hoch Keiner** 22. Oktober 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Qualcomm ADSPRPC-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm ADSPRPC-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0457 A-31695439 *
QC-CR # 1086123
QC-CR # 1100695
Hoch Nexus 5X, Nexus 6P, Pixel, Pixel XL 22. September 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit in Qualcomm-Treiber für Fingerabdrucksensoren

An elevation of privilege vulnerability in the Qualcomm fingerprint sensor driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0518 A-32370896*
QC-CR#1086530
High Pixel, Pixel XL Oct 24, 2016
CVE-2017-0519 A-32372915*
QC-CR#1086530
High Pixel, Pixel XL Oct 24, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Qualcomm crypto engine driver

An elevation of privilege vulnerability in the Qualcomm crypto engine driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0520 A-31750232
QC-CR#1082636
High Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL Sep 24, 2016

Elevation of privilege vulnerability in Qualcomm camera driver

An elevation of privilege vulnerability in the Qualcomm camera driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0458 A-32588962
QC-CR#1089433
High Pixel, Pixel XL Oct 31, 2016
CVE-2017-0521 A-32919951
QC-CR#1097709
High Nexus 5X, Nexus 6P, Android One, Pixel, Pixel XL Nov 15, 2016

Elevation of privilege vulnerability in MediaTek APK

An elevation of privilege vulnerability in a MediaTek APK could enable a local malicious application to execute arbitrary code within the context of a privileged process. This issue is rated as High due to the possibility of local arbitrary code execution in a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0522 A-32916158*
M-ALPS03032516
High None** Nov 15, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in Qualcomm Wi-Fi driver

An elevation of privilege vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0464 A-32940193
QC-CR#1102593
High Nexus 5X, Pixel, Pixel XL Nov 15, 2016
CVE-2017-0453 A-33979145
QC-CR#1105085
High Nexus 5X, Android One Dec 30, 2016
CVE-2017-0523 A-32835279
QC-CR#1096945
High None* Google internal

* Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in Synaptics touchscreen driver

An elevation of privilege vulnerability in the Synaptics touchscreen driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0524 A-33002026 High Android One, Nexus 5X, Nexus 6P, Nexus 9, Pixel, Pixel XL Nov 18, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Qualcomm IPA driver

An elevation of privilege vulnerability in the Qualcomm IPA driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0456 A-33106520*
QC-CR#1099598
High Nexus 5X, Nexus 6P, Android One, Pixel, Pixel XL Nov 23, 2016
CVE-2017-0525 A-33139056*
QC-CR#1097714
High Nexus 5X, Nexus 6P, Android One, Pixel, Pixel XL Nov 25, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in HTC Sensor Hub Driver

An elevation of privilege vulnerability in the HTC Sensor Hub Driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0526 A-33897738* High Nexus 9 Dec 25, 2016
CVE-2017-0527 A-33899318* High Nexus 9, Pixel, Pixel XL Dec 25, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in NVIDIA GPU driver

An elevation of privilege vulnerability in the NVIDIA GPU driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Critical due to the possibility of a local permanent device compromise, which may require reflashing the operating system to repair the device.

CVE References Severity Updated Google devices Date reported
CVE-2017-0307 A-33177895*
N-CVE-2017-0307
High None** Nov 28, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in Qualcomm networking driver

An elevation of privilege vulnerability in the Qualcomm networking driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0463 A-33277611
QC-CR#1101792
High Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL Nov 30, 2016
CVE-2017-0460 A-31252965*
QC-CR#1098801
High Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Pixel, Pixel XL Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in kernel security subsystem

An elevation of privilege vulnerability in the kernel security subsystem could enable a local malicious application to to execute code in the context of a privileged process. This issue is rated as High because it is a general bypass for a kernel level defense in depth or exploit mitigation technology.

CVE References Severity Updated Google devices Date reported
CVE-2017-0528 A-33351919* High Pixel, Pixel XL Dec 4, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Qualcomm SPCom driver

An elevation of privilege vulnerability in the Qualcomm SPCom driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5856 A-32610665
QC-CR#1094078
High None* Google internal
CVE-2016-5857 A-34386529
QC-CR#1094140
High None* Google internal

* Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in kernel networking subsystem

An information disclosure vulnerability in the kernel networking subsystem could enable a local proximate attacker to gain access to sensitive information. This issue is rated as High because it could be used to access data without permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-8709 A-34077221
Upstream kernel
High Nexus Player Nov 9, 2014

Information disclosure vulnerability in MediaTek driver

An information disclosure vulnerability in the MediaTek driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2017-0529 A-28449427*
M-ALPS02710042
High None** Apr 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in Qualcomm bootloader

An information disclosure vulnerability in the Qualcomm bootloader could help to enable a local malicious application to to execute arbitrary code within the context of the bootloader. This issue is rated as High because it is a general bypass for a bootloader level defense in depth or exploit mitigation technology.

CVE References Severity Updated Google devices Date reported
CVE-2017-0455 A-32370952
QC-CR#1082755
High Pixel, Pixel XL Oct 21, 2016

Information disclosure vulnerability in Qualcomm power driver

An information disclosure vulnerability in the Qualcomm power driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-8483 A-33745862
QC-CR#1035099
High Nexus 5X, Nexus 6P Dec 19, 2016

Information disclosure vulnerability in NVIDIA GPU driver

An information disclosure vulnerability in the NVIDIA GPU driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2017-0334 A-33245849*
N-CVE-2017-0334
High Pixel C Nov 30, 2016
CVE-2017-0336 A-33042679*
N-CVE-2017-0336
High Pixel C Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Denial of service vulnerability in kernel cryptographic subsystem

A denial of service vulnerability in the kernel cryptographic subsystem could enable a remote attacker to use a specially crafted network packet to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-8650 A-33401771
Upstream kernel
High Nexus 5X, Nexus 6P, Pixel, Pixel XL Oct 12, 2016

Elevation of privilege vulnerability in Qualcomm camera driver (device specific)

An elevation of privilege vulnerability in the Qualcomm camera driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-8417 A-32342399
QC-CR#1088824
Moderate Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL Oct 21, 2016

Information disclosure vulnerability in Qualcomm Wi-Fi driver

An information disclosure vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0461 A-32073794
QC-CR#1100132
Moderate Android One, Nexus 5X, Pixel, Pixel XL Oct 9, 2016
CVE-2017-0459 A-32644895
QC-CR#1091939
Moderate Pixel, Pixel XL Nov 3, 2016
CVE-2017-0531 A-32877245
QC-CR#1087469
Moderate Android One, Nexus 5X, Nexus 6P, Pixel, Pixel XL Nov 13, 2016

Information disclosure vulnerability in MediaTek video codec driver

An information disclosure vulnerability in the MediaTek video codec driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0532 A-32370398*
M-ALPS03069985
Moderate None** Oct 22, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Information disclosure vulnerability in Qualcomm video driver

An information disclosure vulnerability in the Qualcomm video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0533 A-32509422
QC-CR#1088206
Moderate Pixel, Pixel XL Oct 27, 2016
CVE-2017-0534 A-32508732
QC-CR#1088206
Moderate Pixel, Pixel XL Oct 28, 2016
CVE-2016-8416 A-32510746
QC-CR#1088206
Moderate Pixel, Pixel XL Oct 28, 2016
CVE-2016-8478 A-32511270
QC-CR#1088206
Moderate Pixel, Pixel XL Oct 28, 2016

Information disclosure vulnerability in Qualcomm camera driver

An information disclosure vulnerability in the Qualcomm camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-8413 A-32709702
QC-CR#518731
Moderate Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL Nov 4, 2016
CVE-2016-8477 A-32720522
QC-CR#1090007 [ 2 ]
Moderate Nexus 5X, Nexus 6, Nexus 6P, Android One, Pixel, Pixel XL Nov 7, 2016

Information disclosure vulnerability in HTC sound codec driver

An information disclosure vulnerability in the HTC sound codec driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0535 A-33547247* Moderate Nexus 9 Dec 11, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Synaptics touchscreen driver

An information disclosure vulnerability in the Synaptics touchscreen driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0536 A-33555878* Moderate Android One, Nexus 5X, Nexus 6P, Nexus 9, Pixel, Pixel XL Dec 12, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in kernel USB gadget driver

An information disclosure vulnerability in the kernel USB gadget driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0537 A-31614969* Moderate Pixel C Google internal

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm camera driver

An information disclosure vulnerability in the Qualcomm camera driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Low because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0452 A-32873615*
QC-CR#1093693
Low Nexus 5X, Nexus 6P, Android One Nov 10, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-03-01 or later address all issues associated with the 2017-03-01 security patch level.
  • Security patch levels of 2017-03-05 or later address all issues associated with the 2017-03-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-03-01]
  • [ro.build.version.security_patch]:[2017-03-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the March 1, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of March 5, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-03-01 and 2017-03-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • March 06, 2017: Bulletin published.
  • March 07, 2017: Bulletin revised to include AOSP links.