Google setzt sich dafür ein, die Rassengerechtigkeit für schwarze Gemeinschaften zu fördern. Siehe wie.
Diese Seite wurde von der Cloud Translation API übersetzt.
Switch to English

Android Security Bulletin - April 2017

Veröffentlicht am 03. April 2017 | Aktualisiert am 17. August 2017

Das Android Security Bulletin enthält Details zu Sicherheitslücken, die Android-Geräte betreffen. Neben dem Bulletin haben wir ein Sicherheitsupdate für Nexus-Geräte über ein OTA-Update (Over-the-Air) veröffentlicht. Die Firmware-Bilder des Google-Geräts wurden auch auf der Google Developer-Website veröffentlicht . Sicherheits-Patch-Levels vom 05. April 2017 oder höher beheben all diese Probleme. Informationen zum Überprüfen der Sicherheits-Patch-Stufe eines Geräts finden Sie im Update-Zeitplan für Pixel und Nexus .

Die Partner wurden am 06. März 2017 oder früher über die im Bulletin beschriebenen Probleme informiert. Quellcode-Patches für diese Probleme wurden im AOSP-Repository (Android Open Source Project) veröffentlicht und über dieses Bulletin verlinkt. Dieses Bulletin enthält auch Links zu Patches außerhalb von AOSP.

Das schwerwiegendste dieser Probleme ist eine kritische Sicherheitslücke, die die Remotecodeausführung auf einem betroffenen Gerät über mehrere Methoden wie E-Mail, Surfen im Internet und MMS bei der Verarbeitung von Mediendateien ermöglichen kann. Die Bewertung des Schweregrads basiert auf den Auswirkungen, die das Ausnutzen der Sicherheitsanfälligkeit möglicherweise auf ein betroffenes Gerät haben würde, vorausgesetzt, die Plattform- und Dienstminderungen sind für Entwicklungszwecke deaktiviert oder werden erfolgreich umgangen.

Wir haben keine Berichte über die aktive Ausbeutung oder den Missbrauch dieser neu gemeldeten Probleme durch Kunden erhalten. Weitere Informationen zum Schutz der Android-Sicherheitsplattform und zum Schutz von Diensten wie SafetyNet , die die Sicherheit der Android-Plattform verbessern, finden Sie im Abschnitt zur Minderung von Android- und Google-Diensten .

Wir empfehlen allen Kunden, diese Updates für ihre Geräte zu akzeptieren.

Ankündigungen

  • Dieses Bulletin enthält zwei Sicherheits-Patch-Level-Zeichenfolgen, die Android-Partnern die Flexibilität bieten, eine Teilmenge von Schwachstellen, die auf allen Android-Geräten ähnlich sind, schneller zu beheben. Weitere Informationen finden Sie unter Allgemeine Fragen und Antworten :
    • 2017-04-01 : Teilweise Sicherheits-Patch-Level-Zeichenfolge. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle mit dem 01.04.2017 verbundenen Probleme (und alle vorherigen Sicherheits-Patch-Level-Zeichenfolgen) behoben sind.
    • 2017-04-05 : Vollständige Zeichenfolge für die Sicherheits-Patch-Ebene. Diese Sicherheits-Patch-Level-Zeichenfolge gibt an, dass alle mit dem 01.04.2017 und dem 05.04.2017 verbundenen Probleme (und alle vorherigen Sicherheits-Patch-Level-Zeichenfolgen) behoben sind.
  • Unterstützte Google-Geräte erhalten ein einzelnes OTA-Update mit der Sicherheits-Patch-Stufe vom 05. April 2017.

Mitigationen für Android- und Google-Dienste

Dies ist eine Zusammenfassung der von der Android-Sicherheitsplattform bereitgestellten Maßnahmen und des Schutzes von Diensten wie SafetyNet. Diese Funktionen verringern die Wahrscheinlichkeit, dass Sicherheitslücken unter Android erfolgreich ausgenutzt werden können.

  • Die Nutzung vieler Probleme unter Android wird durch Verbesserungen in neueren Versionen der Android-Plattform erschwert. Wir empfehlen allen Benutzern, nach Möglichkeit auf die neueste Version von Android zu aktualisieren.
  • Das Android-Sicherheitsteam überwacht mit Verify Apps und SafetyNet aktiv auf Missbrauch. Diese sollen Benutzer vor potenziell schädlichen Anwendungen warnen. Überprüfen Sie, ob Apps auf Geräten mit Google Mobile Services standardmäßig aktiviert sind. Dies ist besonders wichtig für Benutzer, die Anwendungen von außerhalb von Google Play installieren. Geräte-Rooting-Tools sind in Google Play verboten. Verify Apps warnt Benutzer jedoch, wenn sie versuchen, eine erkannte Rooting-Anwendung zu installieren - unabhängig davon, woher sie stammt. Darüber hinaus versucht Verify Apps, die Installation bekannter schädlicher Anwendungen zu identifizieren und zu blockieren, die eine Sicherheitsanfälligkeit bezüglich der Eskalation von Berechtigungen ausnutzen. Wenn eine solche Anwendung bereits installiert wurde, benachrichtigt Verify Apps den Benutzer und versucht, die erkannte Anwendung zu entfernen.
  • Gegebenenfalls übergeben Google Hangouts- und Messenger-Anwendungen Medien nicht automatisch an Prozesse wie Mediaserver.

Danksagung

Wir möchten diesen Forschern für ihre Beiträge danken:

  • Aravind Machiry (Donfos) vom Shellphish Grill Team: CVE-2016-5349
  • Daxing Guo ( @ freener0 ) von Xuanwu Lab, Tencent: CVE-2017-0585, CVE-2017-0553
  • Derrek ( @ derrekr6 ) und Scott Bauer: CVE-2017-0576
  • Gal Beniamini von Project Zero: CVE-2017-0571, CVE-2017-0570, CVE-2017-0572, CVE-2017-0569, CVE-2017-0561
  • Gengjia Chen ( @ chengjia4574 ) und pjf von IceSword Lab, Qihoo 360 Technology Co. Ltd.: CVE-2017-6426, CVE-2017-0581, CVE-2017-0329, CVE-2017-0332, CVE-2017-0566, CVE-2017-0573
  • Guang Gong (龚 广) ( @oldfresher ) vom Alpha-Team, Qihoo 360 Technology Co. Ltd.: CVE-2017-0547
  • Hao Chen und Guang Gong vom Alpha-Team, Qihoo 360 Technology Co. Ltd.: CVE-2017-6424, CVE-2017-0584, CVE-2017-0454, CVE-2017-0574, CVE-2017-0575, CVE-2017 -0567
  • Ian Foster ( @lanrat ): CVE-2017-0554
  • Jack Tang von Trend Micro Inc.: CVE-2017-0579
  • Jianjun Dai ( @Jioun_dai ) von Qihoo 360 Skyeye Labs : CVE-2017-0559, CVE-2017-0541
  • Jianqiang Zhao ( @jianqiangzhao ) und pjf von IceSword Lab, Qihoo 360: CVE-2017-6425, CVE-2016-5346
  • Lubo Zhang ( zlbzlb815@163.com ) vom C0RE-Team und Yonggang Guo ( @guoygang ) vom IceSword Lab, Qihoo 360 Technology Co. Ltd.: CVE-2017-0564
  • Mark Salyzyn von Google: CVE-2017-0558
  • Mike Andereson ( @manderbot ) und Nathan Crandall ( @natecray ) vom Tesla-Produktsicherheitsteam: CVE-2017-0327, CVE-2017-0328
  • Peng Xiao, Chengming Yang, Ning You, Chao Yang und Yang Lied der Alibaba Mobile Security Group: CVE-2017-0565
  • Pengfei Ding (丁鹏飞), Chenfu Bao (包 沉浮) und Lenx Wei (韦 韬) von Baidu X-Lab (百度 安全 实验室): CVE-2016-10236
  • Qidan He (何 淇 丹 - @flanker_hqd ) von KeenLab, Tencent: CVE-2017-0544, CVE-2017-0325
  • Roee Hay ( @roeehay ) von Aleph Research, HCL Technologies: CVE-2017-0582, CVE-2017-0563
  • Scott Bauer ( @ ScottyBauer1 ): CVE-2017-0562, CVE-2017-0339
  • Sieben Shen ( @lingtongshen ) vom TrendMicro Mobile Threat Research Team: CVE-2016-10231, CVE-2017-0578, CVE-2017-0586
  • Tim Becker: CVE-2017-0546
  • Uma Sankar Pradhan ( @umasankar_iitd ): CVE-2017-0560
  • VEO ( @VYSEa ) vom Mobile Threat Response Team , Trend Micro : CVE-2017-0555, CVE-2017-0538, CVE-2017-0539, CVE-2017-0557, CVE-2017-0556
  • Weichao Sun ( @sunblate ) von Alibaba Inc: CVE-2017-0549
  • Wenlin Yang ( @wenlin_yang ), Guang Gong ( @oldfresher ) und Hao Chen vom Alpha-Team, Qihoo 360 Technology Co. Ltd.: CVE-2017-0580, CVE-2017-0577
  • Zinuo Han vom Chengdu Security Response Center der Qihoo 360 Technology Co. Ltd.: CVE-2017-0548
  • Zubin Mithra von Google: CVE-2017-0462

Sicherheits-Patch-Stufe 2017-04-01 - Details zur Sicherheitsanfälligkeit

In den folgenden Abschnitten finden Sie Details zu den Sicherheitslücken, die für die Patch-Ebene 2017-04-01 gelten. Es gibt eine Beschreibung des Problems, eine Begründung zum Schweregrad und eine Tabelle mit dem CVE, den zugehörigen Referenzen, dem Schweregrad und aktualisierte Google-Geräte, aktualisierte AOSP-Versionen (falls zutreffend) und gemeldetes Datum. Sofern verfügbar, verknüpfen wir die öffentliche Änderung, mit der das Problem behoben wurde, mit der Fehler-ID, z. B. der AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern verknüpft, die auf die Fehler-ID folgen.

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Mediaserver kann es einem Angreifer ermöglichen, mithilfe einer speziell gestalteten Datei Speicherbeschädigungen während der Verarbeitung von Mediendateien und Daten zu verursachen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext des Mediaserver-Prozesses als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0538 A-33641588 Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 13. Dezember 2016
CVE-2017-0539 A-33864300 Kritisch Alles 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 23. Dezember 2016
CVE-2017-0541 A-34031018 Kritisch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 1. Januar 2017
CVE-2017-0542 A-33934721 Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 Google intern
CVE-2017-0543 A-34097866 Kritisch Alles 6.0, 6.0.1, 7.0, 7.1.1 Google intern

Erhöhung der Sicherheitsanfälligkeit in CameraBase

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in CameraBase kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code auszuführen. Dieses Problem wird als hoch eingestuft, da es sich um eine lokale Ausführung von beliebigem Code in einem privilegierten Prozess handelt.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0544 A-31992879 Hoch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 6. Oktober 2016

Erhöhung der Sicherheitsanfälligkeit in Audioserver

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in Audioserver kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als hoch eingestuft, da es verwendet werden kann, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die normalerweise keine Drittanbieteranwendung zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0545 A-32591350 Hoch Alles 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 31. Oktober 2016

Erhöhung der Sicherheitsanfälligkeit in SurfaceFlinger

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in SurfaceFlinger kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird als hoch eingestuft, da es verwendet werden kann, um lokalen Zugriff auf erweiterte Funktionen zu erhalten, auf die normalerweise keine Drittanbieteranwendung zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0546 A-32628763 Hoch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 2. November 2016

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in Mediaserver kann es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als hoch eingestuft, da es sich um einen allgemeinen Bypass für den Betriebssystemschutz handelt, mit dem Anwendungsdaten von anderen Anwendungen isoliert werden.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0547 A-33861560 Hoch Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 22. Dezember 2016

Denial-of-Service-Sicherheitslücke in Libskia

Eine Remote-Denial-of-Service-Sicherheitsanfälligkeit in libskia kann es einem Angreifer ermöglichen, eine speziell gestaltete Datei zu verwenden, um ein Gerät hängen zu lassen oder neu zu starten. Dieses Problem wird aufgrund der Möglichkeit eines Remote-Denial-of-Service als hochgradig eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0548 A-33251605 Hoch Alles 7.0, 7.1.1 29. November 2016

Denial-of-Service-Sicherheitsanfälligkeit in Mediaserver

Eine Remote-Denial-of-Service-Sicherheitsanfälligkeit in Mediaserver kann es einem Angreifer ermöglichen, eine speziell gestaltete Datei zu verwenden, um ein Gerät hängen zu lassen oder neu zu starten. Dieses Problem wird aufgrund der Möglichkeit eines Remote-Denial-of-Service als hochgradig eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0549 A-33818508 Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 20. Dezember 2016
CVE-2017-0550 A-33933140 Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 Google intern
CVE-2017-0551 A-34097231 [ 2 ] Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 Google intern
CVE-2017-0552 A-34097915 Hoch Alles 6.0, 6.0.1, 7.0, 7.1.1 Google intern

Erhöhung der Sicherheitsanfälligkeit in libnl

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in libnl kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Wi-Fi-Dienstes auszuführen. Dieses Problem wird als mittel eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss und durch aktuelle Plattformkonfigurationen verringert wird.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0553 A-32342065 Mäßig Alles 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 21. Oktober 2016

Erhöhung der Sicherheitslücke in der Telefonie

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen in der Telefoniekomponente kann es einer lokalen böswilligen Anwendung ermöglichen, auf Funktionen außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um Zugriff auf erweiterte Funktionen zu erhalten, auf die normalerweise keine Drittanbieteranwendung zugreifen kann.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0554 A-33815946 [ 2 ] Mäßig Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 20. Dezember 2016

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen in Mediaserver

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in Mediaserver kann es einer lokalen bösartigen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um ohne Erlaubnis auf Daten zuzugreifen.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0555 A-33551775 Mäßig Alles 6.0, 6.0.1, 7.0, 7.1.1 12. Dezember 2016
CVE-2017-0556 A-34093952 Mäßig Alles 6.0, 6.0.1, 7.0, 7.1.1 4. Januar 2017
CVE-2017-0557 A-34093073 Mäßig Alles 6.0, 6.0.1, 7.0, 7.1.1 4. Januar 2017
CVE-2017-0558 A-34056274 Mäßig Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google intern

Sicherheitslücke bei der Offenlegung von Informationen in Libskia

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen in libskia kann es einer lokalen böswilligen Anwendung ermöglichen, auf Daten außerhalb ihrer Berechtigungsstufen zuzugreifen. Dieses Problem wird als mittel eingestuft, da es verwendet werden kann, um ohne Erlaubnis auf Daten zuzugreifen.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0559 A-33897722 Mäßig Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 25. Dezember 2016

Sicherheitsanfälligkeit bezüglich Offenlegung von Informationen beim Zurücksetzen auf die Werkseinstellungen

Eine Sicherheitsanfälligkeit bezüglich der Offenlegung von Informationen beim Zurücksetzen auf die Werkseinstellungen kann es einem lokalen böswilligen Angreifer ermöglichen, auf Daten des Vorbesitzers zuzugreifen. Dieses Problem wird aufgrund der Möglichkeit, den Geräteschutz zu umgehen, als mittel eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2017-0560 A-30681079 Mäßig Alles 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1 Google intern

Sicherheits-Patch-Stufe 2017-04-05 - Details zur Sicherheitsanfälligkeit

In den folgenden Abschnitten finden Sie Details zu den Sicherheitslücken, die für die Patch-Version 2017-04-05 gelten. Es gibt eine Beschreibung des Problems, eine Begründung des Schweregrads und eine Tabelle mit dem CVE, den zugehörigen Referenzen, dem Schweregrad, aktualisierten Google-Geräten, aktualisierten AOSP-Versionen (falls zutreffend) und dem gemeldeten Datum. Sofern verfügbar, verknüpfen wir die öffentliche Änderung, mit der das Problem behoben wurde, mit der Fehler-ID, z. B. der AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern verknüpft, die auf die Fehler-ID folgen.

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in der Broadcom Wi-Fi-Firmware

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in der Broadcom Wi-Fi-Firmware kann es einem Remote-Angreifer ermöglichen, beliebigen Code im Kontext des Wi-Fi SoC auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext des Wi-Fi-SoC als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0561 A-34199105 *
B-RB # 110814
Kritisch Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9. Januar 2017

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich Remotecodeausführung im Qualcomm Crypto Engine-Treiber

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung im Qualcomm-Krypto-Engine-Treiber kann es einem Remote-Angreifer ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext des Kernels als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-10230 A-34389927
QC-CR # 1091408
Kritisch Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 10. Januar 2017

Sicherheitsanfälligkeit bezüglich Remotecodeausführung im Kernel-Netzwerksubsystem

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung im Kernel-Netzwerksubsystem kann es einem Remote-Angreifer ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung im Kontext des Kernels als kritisch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-10229 A-32813456
Upstream-Kernel
Kritisch Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Google intern

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im MediaTek-Touchscreen-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im MediaTek-Touchscreen-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0562 A-30202425 *
M-ALPS02898189
Kritisch* Keiner** 16. Juli 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Erhöhung der Sicherheitsanfälligkeit im HTC-Touchscreen-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im HTC-Touchscreen-Treiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0563 A-32089409 *
Kritisch Nexus 9 9. Oktober 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Kernel-ION-Subsystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-ION-Subsystem kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird aufgrund der Möglichkeit eines lokalen permanenten Gerätekompromisses als kritisch eingestuft, der möglicherweise ein erneutes Flashen des Betriebssystems zur Reparatur des Geräts erforderlich macht.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0564 A-34276203 *
Kritisch Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Pixel C, Android One, Nexus Player 12. Januar 2017

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitslücken in Qualcomm-Komponenten

Diese Sicherheitsanfälligkeiten betreffen Qualcomm-Komponenten und werden im Qualcomm AMSS-Sicherheitsbulletin vom Oktober 2016 ausführlicher beschrieben.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-10237 A-31628601 **
QC-CR # 1046751
Kritisch Keiner** Qualcomm intern
CVE-2016-10238 A-35358527 **
QC-CR # 1042558
Kritisch Keiner*** Qualcomm intern
CVE-2016-10239 A-31624618 **
QC-CR # 1032929
Hoch Pixel, Pixel XL Qualcomm intern

* Der Schweregrad für diese Sicherheitsanfälligkeiten wurde vom Anbieter festgelegt.

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

*** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Version 8

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Version 8 kann es Remoteangreifern ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung auf Websites als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-5129 A-29178923 Hoch Keiner* 6.0, 6.0.1, 7.0 20. Juli 2016

* Unterstützte Google-Geräte unter Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert wurden, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Freetype

Eine Sicherheitsanfälligkeit bezüglich Remotecodeausführung in Freetype kann es einer lokalen böswilligen Anwendung ermöglichen, eine speziell gestaltete Schriftart zu laden, um in einem nicht privilegierten Prozess eine Speicherbeschädigung zu verursachen. Dieses Problem wird aufgrund der Möglichkeit der Remotecodeausführung in einer Anwendung, die diese Bibliothek verwendet, als hoch eingestuft.

CVE Verweise Schwere Aktualisierte Google-Geräte Aktualisierte AOSP-Versionen Datum der Meldung
CVE-2016-10244 A-31470908 Hoch Keiner* 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0 13. September 2016

* Unterstützte Google-Geräte unter Android 7.0 oder höher, auf denen alle verfügbaren Updates installiert wurden, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Erhöhung der Sicherheitsanfälligkeit im Kernel-Sound-Subsystem

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Kernel-Sound-Subsystem könnte es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2014-4656 A-34464977
Upstream-Kernel
Hoch Nexus 6, Nexus-Spieler 26. Juni 2014

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im NVIDIA-Kryptotreiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im NVIDIA-Kryptotreiber könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0339 A-27930566 *
N-CVE-2017-0339
Hoch Nexus 9 29. März 2016
CVE-2017-0332 A-33812508 *
N-CVE-2017-0332
Hoch Nexus 9 21. Dezember 2016
CVE-2017-0327 A-33893669 *
N-CVE-2017-0327
Hoch Nexus 9 24. Dezember 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Erhöhung der Berechtigungsanfälligkeit in MediaTek Thermal Driver

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im MediaTek-Thermotreiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0565 A-28175904 *
M-ALPS02696516
Hoch Keiner** 11. April 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im MediaTek-Kameratreiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im MediaTek-Kameratreiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0566 A-28470975 *
M-ALPS02696367
Hoch Keiner** 29. April 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Erhöhung der Sicherheitsanfälligkeit in Broadcom Wi-Fi-Treibern

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Broadcom Wi-Fi-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0567 A-32125310 *
B-RB # 112575
Hoch Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 12. Oktober 2016
CVE-2017-0568 A-34197514 *
B-RB # 112600
Hoch Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9. Januar 2017
CVE-2017-0569 A-34198729 *
B-RB # 110666
Hoch Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9. Januar 2017
CVE-2017-0570 A-34199963 *
B-RB # 110688
Hoch Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 9. Januar 2017
CVE-2017-0571 A-34203305 *
B-RB # 111541
Hoch Nexus 6, Nexus 6P, Pixel C, Nexus Player 9. Januar 2017
CVE-2017-0572 A-34198931 *
B-RB # 112597
Hoch Keiner** 9. Januar 2017
CVE-2017-0573 A-34469904 *
B-RB # 91539
Hoch Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player 18. Januar 2017
CVE-2017-0574 A-34624457 *
B-RB # 113189
Hoch Nexus 6, Nexus 6P, Nexus 9, Pixel C. 22. Januar 2017

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Qualcomm Wi-Fi-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm Wi-Fi-Treiber könnte es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0575 A-32658595 *
QC-CR # 1103099
Hoch Nexus 5X, Pixel, Pixel XL 3. November 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im NVIDIA I2C HID-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im NVIDIA I2C-HID-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0325 A-33040280 *
N-CVE-2017-0325
Hoch Nexus 9, Pixel C. 20. November 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

Sicherheitsanfälligkeit bezüglich Erhöhung von Berechtigungen im Qualcomm-Audiotreiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm-Audiotreiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0454 A-33353700
QC-CR # 1104067
Hoch Nexus 5X, Nexus 6P, Pixel, Pixel XL 5. Dezember 2016

Erhöhung der Sicherheitsanfälligkeit bezüglich Berechtigungen im Qualcomm Crypto Engine-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm-Krypto-Engine-Treiber könnte es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0576 A-33544431
QC-CR # 1103089
Hoch Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One 9. Dezember 2016

Erhöhung der Sicherheitsanfälligkeit im HTC-Touchscreen-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im HTC-Touchscreen-Treiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0577 A-33842951 *
Hoch Keiner** 21. Dezember 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Erhöhung der Sicherheitsanfälligkeit in DTS-Soundtreibern

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im DTS-Soundtreiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0578 A-33964406 *
Hoch Keiner** 28. Dezember 2016

* Der Patch für dieses Problem ist nicht öffentlich verfügbar. Das Update ist in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

** Unterstützte Google-Geräte unter Android 7.0 oder höher, die alle verfügbaren Updates installiert haben, sind von dieser Sicherheitsanfälligkeit nicht betroffen.

Sicherheitsanfälligkeit bezüglich Erhöhung der Berechtigungen im Qualcomm-Soundcodec-Treiber

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm-Soundcodec-Treiber kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2016-10231 A-33966912
QC-CR # 1096799
Hoch Pixel, Pixel XL 29. Dezember 2016

Erhöhung der Sicherheitsanfälligkeit in Qualcomm-Videotreibern

Eine Sicherheitsanfälligkeit bezüglich der Erhöhung von Berechtigungen im Qualcomm-Grafiktreiber kann es einer lokalen böswilligen Anwendung ermöglichen, beliebigen Code im Kontext des Kernels auszuführen. Dieses Problem wird als hoch eingestuft, da zunächst ein privilegierter Prozess kompromittiert werden muss.

CVE Verweise Schwere Aktualisierte Google-Geräte Datum der Meldung
CVE-2017-0579 A-34125463 *
QC-CR # 1115406
Hoch Nexus 5X, Nexus 6P, Pixel, Pixel XL 5. Januar 2017
CVE-2016-10232 A-34386696
QC-CR # 1024872 [2]
Hoch Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Jan 10, 2017
CVE-2016-10233 A-34389926
QC-CR#897452
High None** Jan 10, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in NVIDIA boot and power management processor driver

An elevation of privilege vulnerability in the NVIDIA boot and power management processor driver could enable a local malicious application to execute arbitrary code within the context of the boot and power management processor. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0329 A-34115304*
N-CVE-2017-0329
High Pixel C Jan 5, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Synaptics touchscreen driver

An elevation of privilege vulnerability in the Synaptics Touchscreen driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0580 A-34325986*
High None** Jan 16, 2017
CVE-2017-0581 A-34614485*
High None** Jan 22, 2017

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in Qualcomm Seemp driver

An elevation of privilege vulnerability in the Qualcomm Seemp driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0462 A-33353601
QC-CR#1102288
High Pixel, Pixel XL Google internal

Elevation of privilege vulnerability in Qualcomm Kyro L2 driver

An elevation of privilege vulnerability in the Qualcomm Kyro L2 driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6423 A-32831370
QC-CR#1103158
High Pixel, Pixel XL Google internal

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as High because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-9922 A-32761463
Upstream kernel
High Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Android One, Nexus Player Oct 24, 2014

Information disclosure vulnerability in kernel memory subsystem

An information disclosure vulnerability in the kernel memory subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-0206 A-34465735
Upstream kernel
High Nexus 6, Nexus Player May 6, 2014

Information disclosure vulnerability in kernel networking subsystem

An information disclosure vulnerability in the kernel networking subsystem could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2014-3145 A-34469585
Upstream kernel [2]
High Nexus 6, Nexus Player May 9, 2014

Information disclosure vulnerability in Qualcomm TrustZone

An information disclosure vulnerability in the Qualcomm TrustZone could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-5349 A-29083830
QC-CR#1021945 [2] [3] [4]
High Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Jun 1, 2016

Information disclosure vulnerability in Qualcomm IPA driver

An information disclosure vulnerability in the Qualcomm IPA driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as High because it could be used to access sensitive data without explicit user permission.

CVE References Severity Updated Google devices Date reported
CVE-2016-10234 A-34390017
QC-CR#1069060 [2]
High Nexus 5X, Nexus 6P, Pixel, Pixel XL Jan 10, 2017

Denial of service vulnerability in kernel networking subsystem

A denial of service vulnerability in the kernel networking subsystem could enable a remote attacker to use a specially crafted network packet to cause a device hang or reboot. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2014-2706 A-34160553
Upstream kernel
High Nexus Player Apr 1, 2014

Denial of service vulnerability in Qualcomm Wi-Fi driver

A denial of service vulnerability in the Qualcomm Wi-Fi driver could enable a proximate attacker to cause a denial of service in the Wi-Fi subsystem. This issue is rated as High due to the possibility of remote denial of service.

CVE References Severity Updated Google devices Date reported
CVE-2016-10235 A-34390620
QC-CR#1046409
High None** Jan 10, 2017

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Elevation of privilege vulnerability in kernel file system

An elevation of privilege vulnerability in the kernel file system could enable a local malicious application to execute arbitrary code outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-7097 A-32458736
Upstream kernel
Moderate Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Pixel, Pixel XL, Pixel C, Nexus Player Aug 28, 2016

Elevation of privilege vulnerability in Qualcomm Wi-Fi driver

An elevation of privilege vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and because of vulnerability specific details which limit the impact of the issue.

CVE References Severity Updated Google devices Date reported
CVE-2017-6424 A-32086742
QC-CR#1102648
Moderate Nexus 5X, Pixel, Pixel XL, Android One Oct 9, 2016

Elevation of privilege vulnerability in Broadcom Wi-Fi driver

An elevation of privilege vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations.

CVE References Severity Updated Google devices Date reported
CVE-2016-8465 A-32474971*
B-RB#106053
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in HTC OEM fastboot command

An elevation of privilege vulnerability in the HTC OEM fastboot command could enable a local malicious application to execute arbitrary code within the context of the sensor hub. This issue is rated as Moderate because it first requires exploitation of separate vulnerabilities.

CVE References Severity Updated Google devices Date reported
CVE-2017-0582 A-33178836*
Moderate Nexus 9 Nov 28, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Elevation of privilege vulnerability in Qualcomm CP access driver

An elevation of privilege vulnerability in the Qualcomm CP access driver could enable a local malicious application to execute arbitrary code within the context of the kernel. This issue is rated as Moderate because it first requires compromising a privileged process and because of vulnerability specific details which limit the impact of the issue.

CVE References Severity Updated Google devices Date reported
CVE-2017-0583 A-32068683
QC-CR#1103788
Moderate Nexus 5X, Nexus 6P, Pixel, Pixel XL, Android One Google internal

Information disclosure vulnerability in kernel media driver

An information disclosure vulnerability in the kernel media driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2014-1739 A-34460642
Upstream kernel
Moderate Nexus 6, Nexus 9, Nexus Player Jun 15, 2014

Information disclosure vulnerability in Qualcomm Wi-Fi driver

An information disclosure vulnerability in the Qualcomm Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0584 A-32074353*
QC-CR#1104731
Moderate Nexus 5X, Pixel, Pixel XL Oct 9, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Broadcom Wi-Fi driver

An information disclosure vulnerability in the Broadcom Wi-Fi driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0585 A-32475556*
B-RB#112953
Moderate Nexus 6, Nexus 6P, Nexus 9, Pixel C, Nexus Player Oct 27, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

Information disclosure vulnerability in Qualcomm Avtimer driver

An information disclosure vulnerability in the Qualcomm Avtimer driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-5346 A-32551280
QC-CR#1097878
Moderate Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm video driver

An information disclosure vulnerability in the Qualcomm video driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6425 A-32577085
QC-CR#1103689
Moderate Pixel, Pixel XL Oct 29, 2016

Information disclosure vulnerability in Qualcomm USB driver

An information disclosure vulnerability in the Qualcomm USB driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2016-10236 A-33280689
QC-CR#1102418
Moderate Pixel, Pixel XL Nov 30, 2016

Information disclosure vulnerability in Qualcomm sound driver

An information disclosure vulnerability in the Qualcomm sound driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0586 A-33649808
QC-CR#1097569
Moderate Nexus 5X, Nexus 6, Nexus 6P, Pixel, Pixel XL, Android One Dec 13, 2016

Information disclosure vulnerability in Qualcomm SPMI driver

An information disclosure vulnerability in the Qualcomm SPMI driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-6426 A-33644474
QC-CR#1106842
Moderate Pixel, Pixel XL Dec 14, 2016

Information disclosure vulnerability in NVIDIA crypto driver

An information disclosure vulnerability in the NVIDIA crypto driver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it first requires compromising a privileged process.

CVE References Severity Updated Google devices Date reported
CVE-2017-0328 A-33898322*
N-CVE-2017-0328
Moderate None** Dec 24, 2016
CVE-2017-0330 A-33899858*
N-CVE-2017-0330
Moderate None** Dec 24, 2016

* The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Vulnerabilities in Qualcomm components

These vulnerabilities affecting Qualcomm components were released as part of Qualcomm AMSS security bulletins between 2014–2016. They are included in this Android security bulletin to associate their fixes with an Android security patch level.

CVE References Severity Updated Google devices Date reported
CVE-2014-9931 A-35445101** Critical None** Qualcomm internal
CVE-2014-9932 A-35434683** Critical Pixel, Pixel XL Qualcomm internal
CVE-2014-9933 A-35442512** Critical None** Qualcomm internal
CVE-2014-9934 A-35439275** Critical None** Qualcomm internal
CVE-2014-9935 A-35444951** Critical None** Qualcomm internal
CVE-2014-9936 A-35442420** Critical None** Qualcomm internal
CVE-2014-9937 A-35445102** Critical None** Qualcomm internal
CVE-2015-8995 A-35445002** Critical None** Qualcomm internal
CVE-2015-8996 A-35444658** Critical None** Qualcomm internal
CVE-2015-8997 A-35432947** Critical None** Qualcomm internal
CVE-2015-8998 A-35441175** Critical None** Qualcomm internal
CVE-2015-8999 A-35445401** Critical None** Qualcomm internal
CVE-2015-9000 A-35441076** Critical None** Qualcomm internal
CVE-2015-9001 A-35445400** Critical None** Qualcomm internal
CVE-2015-9002 A-35442421** Critical None** Qualcomm internal
CVE-2015-9003 A-35440626** Critical None** Qualcomm internal
CVE-2016-10242 A-35434643** Critical None** Qualcomm internal

* The severity rating for these vulnerabilities was determined by the vendor.

** The patch for this issue is not publicly available. The update is contained in the latest binary drivers for Nexus devices available from the Google Developer site .

*** Supported Google devices on Android 7.0 or later that have installed all available updates are not affected by this vulnerability.

Common Questions and Answers

This section answers common questions that may occur after reading this bulletin.

1. How do I determine if my device is updated to address these issues?

To learn how to check a device's security patch level, read the instructions on the Pixel and Nexus update schedule .

  • Security patch levels of 2017-04-01 or later address all issues associated with the 2017-04-01 security patch level.
  • Security patch levels of 2017-04-05 or later address all issues associated with the 2017-04-05 security patch level and all previous patch levels.

Device manufacturers that include these updates should set the patch string level to:

  • [ro.build.version.security_patch]:[2017-04-01]
  • [ro.build.version.security_patch]:[2017-04-05]

2. Why does this bulletin have two security patch levels?

This bulletin has two security patch levels so that Android partners have the flexibility to fix a subset of vulnerabilities that are similar across all Android devices more quickly. Android partners are encouraged to fix all issues in this bulletin and use the latest security patch level.

  • Devices that use the April 01, 2017 security patch level must include all issues associated with that security patch level, as well as fixes for all issues reported in previous security bulletins.
  • Devices that use the security patch level of April 05, 2017 or newer must include all applicable patches in this (and previous) security bulletins.

Partners are encouraged to bundle the fixes for all issues they are addressing in a single update.

3. How do I determine which Google devices are affected by each issue?

In the 2017-04-01 and 2017-04-05 security vulnerability details sections, each table has an Updated Google devices column that covers the range of affected Google devices updated for each issue. This column has a few options:

  • All Google devices : If an issue affects All and Pixel devices, the table will have "All" in the Updated Google devices column. "All" encapsulates the following supported devices : Nexus 5X, Nexus 6, Nexus 6P, Nexus 9, Android One, Nexus Player, Pixel C, Pixel, and Pixel XL.
  • Some Google devices : If an issue doesn't affect all Google devices, the affected Google devices are listed in the Updated Google devices column.
  • No Google devices : If no Google devices running Android 7.0 are affected by the issue, the table will have "None" in the Updated Google devices column.

4. What do the entries in the references column map to?

Entries under the References column of the vulnerability details table may contain a prefix identifying the organization to which the reference value belongs. These prefixes map as follows:

Prefix Reference
A- Android bug ID
QC- Qualcomm reference number
M- MediaTek reference number
N- NVIDIA reference number
B- Broadcom reference number

Revisions

  • April 03, 2017: Bulletin published.
  • April 05, 2017: Bulletin revised to include AOSP links.
  • April 21, 2017: Attribution for CVE-2016-10231 and CVE-2017-0586 corrected.
  • April 27, 2017: CVE-2017-0540 removed from bulletin.
  • August 17, 2017: Bulletin revised to update reference numbers.