Google si impegna a promuovere l'equità razziale per le comunità nere. Vedi come.
Questa pagina è stata tradotta dall'API Cloud Translation.
Switch to English

Bollettino sulla sicurezza Android — luglio 2017

Pubblicato il 5 luglio 2017 | Aggiornato il 26 settembre 2017

Il Bollettino sulla sicurezza di Android contiene dettagli sulle vulnerabilità della sicurezza che interessano i dispositivi Android. I livelli di patch di sicurezza del 05 luglio 2017 o successivi risolvono tutti questi problemi. Fai riferimento al programma di aggiornamento di Pixel e Nexus per informazioni su come controllare il livello di patch di sicurezza di un dispositivo.

I partner sono stati informati dei problemi descritti nel bollettino almeno un mese fa. Le patch di codice sorgente per questi problemi sono state rilasciate al repository AOSP (Android Open Source Project) e collegate da questo bollettino. Questo bollettino include anche collegamenti a patch al di fuori di AOSP.

Il più grave di questi problemi è una vulnerabilità di sicurezza critica nel framework dei media che potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, presupponendo che le mitigazioni della piattaforma e del servizio siano disattivate per scopi di sviluppo o se vengano aggirate correttamente.

Non abbiamo avuto notizie di sfruttamento attivo dei clienti o abuso di questi problemi appena segnalati. Fai riferimento alla sezione Mitigazioni di Android e Google Play Protect per i dettagli sulle protezioni della piattaforma di sicurezza Android e Google Play Protect, che migliorano la sicurezza della piattaforma Android.

Incoraggiamo tutti i clienti ad accettare questi aggiornamenti per i loro dispositivi.

Nota: le informazioni sugli ultimi aggiornamenti over-the-air (OTA) e le immagini del firmware per i dispositivi Google sono disponibili nella sezione Aggiornamenti dei dispositivi di Google .

Annunci

  • Questo bollettino ha due stringhe a livello di patch di sicurezza per fornire ai partner Android la flessibilità necessaria per correggere più rapidamente un sottoinsieme di vulnerabilità simili a tutti i dispositivi Android. Consulta Domande e risposte comuni per ulteriori informazioni:
    • 01/07/2017 : stringa di livello di patch di sicurezza parziale. Questa stringa a livello di patch di sicurezza indica che tutti i problemi associati a 01/07/2017 (e tutte le stringhe a livello di patch di sicurezza precedenti) vengono risolti.
    • 05/07/2017 : stringa di livello di patch di sicurezza completa. Questa stringa a livello di patch di sicurezza indica che tutti i problemi associati a 2017-07-01 e 2017-07-05 (e tutte le precedenti stringhe a livello di patch di sicurezza) vengono risolti.

Mitigazioni di Android e Google Play Protect

Questo è un riepilogo delle mitigazioni fornite dalla piattaforma di sicurezza Android e delle protezioni del servizio come Google Play Protect . Queste funzionalità riducono la probabilità che le vulnerabilità di sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento per molti problemi su Android è reso più difficile dai miglioramenti nelle nuove versioni della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android ove possibile.
  • Il team di sicurezza di Android monitora attivamente gli abusi tramite Google Play Protect e avvisa gli utenti di applicazioni potenzialmente dannose . Google Play Protect è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano app al di fuori di Google Play.

01/07/2017 livello di patch di sicurezza: dettagli sulla vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2017-07-01. Le vulnerabilità sono raggruppate sotto il componente che interessano. Esiste una descrizione del problema e una tabella con CVE, riferimenti associati, tipo di vulnerabilità , gravità e versioni AOSP aggiornate (ove applicabile). Se disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID bug.

Runtime

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo senza privilegi.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2017-3544 A-35784677 RCE Moderare 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

Struttura

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione locale dannosa che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un'applicazione che utilizza la libreria.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2017-0664 A-36491278 EoP alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0665 A-36991414 EoP alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0666 A-37285689 EoP alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0667 A-37478824 EoP alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0668 A-22011579 ID Moderare 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0669 A-34114752 ID alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0670 A-36104177 DoS alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

biblioteche

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un'applicazione che utilizza la libreria.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2017-0671 A-34514762 * RCE alto 4.4.4
CVE-2016-2109 A-35443725 DoS alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0672 A-34778578 DoS alto 7.0, 7.1.1, 7.1.2

Quadro mediatico

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2017-0540 A-33966031 RCE critico 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0673 A-33974623 RCE critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0674 A-34231163 RCE critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0675 A-34779227 [ 2 ] RCE critico 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0676 A-34896431 RCE critico 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0677 A-36035074 RCE critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0678 A-36576151 RCE critico 7.0, 7.1.1, 7.1.2
CVE-2017-0679 A-36996978 RCE critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0680 A-37008096 RCE critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0681 A-37208566 RCE critico 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0682 A-36588422 * RCE alto 7.0, 7.1.1, 7.1.2
CVE-2017-0683 A-36591008 * RCE alto 7.0, 7.1.1, 7.1.2
CVE-2017-0684 A-35421151 EoP alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0685 A-34203195 DoS alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0686 A-34231231 DoS alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0688 A-35584425 DoS alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0689 A-36215950 DoS alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0690 A-36592202 DoS alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0691 A-36724453 DoS alto 7.0, 7.1.1, 7.1.2
CVE-2017-0692 A-36725407 DoS alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0693 A-36993291 DoS alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0694 A-37093318 DoS alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0695 A-37094889 DoS alto 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0696 A-37207120 DoS alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0697 A-37239013 DoS alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0698 A-35467458 ID Moderare 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0699 A-36490809 ID Moderare 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2

UI di sistema

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2017-0700 A-35639138 RCE alto 7.1.1, 7.1.2
CVE-2017-0701 A-36385715 [ 2 ] RCE alto 7.1.1, 7.1.2
CVE-2017-0702 A-36621442 RCE alto 7.1.1, 7.1.2
CVE-2017-0703 A-33123882 EoP alto 4.4.4, 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0704 A-33059280 EoP Moderare 7.1.1, 7.1.2

2017-07-05 Livello patch di sicurezza: dettagli della vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza applicabili al livello di patch 2017-07-05. Le vulnerabilità sono raggruppate sotto il componente che interessano e includono dettagli come CVE, riferimenti associati, tipo di vulnerabilità , gravità , componente (ove applicabile) e versioni AOSP aggiornate (ove applicabile). Se disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID bug.

Componenti Broadcom

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato prossimo di eseguire codice arbitrario nel contesto del kernel.

CVE Riferimenti genere Gravità Componente
CVE-2017-9417 A-38041027 *
B-RB # 123.023
RCE critico Driver Wi-Fi
CVE-2017-0705 A-34973477 *
B-RB # 119898
EoP Moderare Driver Wi-Fi
CVE-2017-0706 A-35195787 *
B-RB # 120532
EoP Moderare Driver Wi-Fi

Componenti HTC

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2017-0707 A-36088467 * EoP Moderare Driver LED
CVE-2017-0708 A-35384879 * ID Moderare Driver audio
CVE-2017-0709 A-35468048 * ID Basso Driver dell'hub del sensore

Componenti del kernel

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2017-6074 A-35784697
Kernel a monte
EoP alto Sottosistema di rete
CVE-2017-5970 A-35805460
Kernel a monte
DoS alto Sottosistema di rete
CVE-2015-5707 A-35841297
Kernel upstream [ 2 ]
EoP Moderare Driver SCSI
CVE-2017-7308 A-36725304
Kernel upstream [ 2 ] [ 3 ]
EoP Moderare Driver di rete
CVE-2014-9731 A-35841292
Kernel a monte
ID Moderare File system

Componenti MediaTek

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2017-0711 A-36099953 *
M-ALPS03206781
EoP alto Driver di rete

Componenti NVIDIA

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2017-0340 A-33968204 *
N-CVE-2017-0340
EoP alto Libnvparser
CVE-2017-0326 A-33718700 *
N-CVE-2017-0326
ID Moderare Driver video

Componenti Qualcomm

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto del kernel.

CVE Riferimenti genere Gravità Componente
CVE-2017-8255 A-36251983
QC-CR # 985.205
EoP alto Boot loader
CVE-2.016-10.389 A-34500449
QC-CR # 1009145
EoP alto Boot loader
CVE-2017-8253 A-35400552
QC-CR # 1086764
EoP alto Driver della fotocamera
CVE-2017-8262 A-32938443
QC-CR # 2029113
EoP alto Driver GPU
CVE-2017-8263 A-34126808 *
QC-CR # 1107034
EoP alto Sottosistema di memoria condivisa anonimo
CVE-2017-8267 A-34173755 *
QC-CR # 2001129
EoP alto Sottosistema di memoria condivisa anonimo
CVE-2017-8273 A-35400056
QC-CR # 1094372 [ 2 ]
EoP alto Boot loader
CVE-2016-5863 A-36251182
QC-CR # 1102936
EoP Moderare Driver USB HID
CVE-2017-8243 A-34112490 *
QC-CR # 2001803
EoP Moderare Driver SoC
CVE-2017-8246 A-37275839
QC-CR # 2008031
EoP Moderare Driver audio
CVE-2017-8256 A-37286701
QC-CR # 1104565
EoP Moderare Driver Wi-Fi
CVE-2017-8257 A-37282763
QC-CR # 2003129
EoP Moderare Driver video
CVE-2017-8259 A-34359487
QC-CR # 2009016
EoP Moderare Driver SoC
CVE-2017-8260 A-34624155
QC-CR # 2008469
EoP Moderare Driver della fotocamera
CVE-2017-8261 A-35139833 *
QC-CR # 2013631
EoP Moderare Driver della fotocamera
CVE-2017-8264 A-33299365 *
QC-CR # 1107702
EoP Moderare Driver della fotocamera
CVE-2017-8265 A-32341313
QC-CR # 1109755
EoP Moderare Driver video
CVE-2017-8266 A-33863407
QC-CR # 1110924
EoP Moderare Driver video
CVE-2017-8268 A-34620535 *
QC-CR # 2002207
EoP Moderare Driver della fotocamera
CVE-2017-8270 A-35468665 *
QC-CR # 2021363
EoP Moderare Driver Wi-Fi
CVE-2017-8271 A-35950388 *
QC-CR # 2028681
EoP Moderare Driver video
CVE-2017-8272 A-35950805 *
QC-CR # 2028702
EoP Moderare Driver video
CVE-2017-8254 A-36252027
QC-CR # 832.914
ID Moderare Driver audio
CVE-2017-8258 A-37279737
QC-CR # 2005647
ID Moderare Driver della fotocamera
CVE-2017-8269 A-33967002 *
QC-CR # 2013145
ID Moderare Driver IPA

Componenti di origine chiusa Qualcomm

Queste vulnerabilità riguardano i componenti di Qualcomm e sono descritte in dettaglio nei bollettini sulla sicurezza AMSS di Qualcomm nel periodo 2014-2016. Sono inclusi in questo bollettino sulla sicurezza di Android per associare le loro correzioni a un livello di patch di sicurezza di Android. Le correzioni per queste vulnerabilità sono disponibili direttamente da Qualcomm.

CVE Riferimenti genere Gravità Componente
CVE-2014-9411 A-37473054 * N / A alto Componente a sorgente chiuso
CVE-2014-9968 A-37304413 * N / A alto Componente a sorgente chiuso
CVE-2014-9973 A-37470982 * N / A alto Componente a sorgente chiuso
CVE-2014-9974 A-37471979 * N / A alto Componente a sorgente chiuso
CVE-2014-9975 A-37471230 * N / A alto Componente a sorgente chiuso
CVE-2014-9977 A-37471087 * N / A alto Componente a sorgente chiuso
CVE-2014-9978 A-37468982 * N / A alto Componente a sorgente chiuso
CVE-2014-9979 A-37471088 * N / A alto Componente a sorgente chiuso
CVE-2014-9980 A-37471029 * N / A alto Componente a sorgente chiuso
CVE-2015-0575 A-37296999 * N / A alto Componente a sorgente chiuso
CVE-2015-8592 A-37470090 * N / A alto Componente a sorgente chiuso
CVE-2015-8595 A-37472411 * N / A alto Componente a sorgente chiuso
CVE-2015-8596 A-37472806 * N / A alto Componente a sorgente chiuso
CVE-2015-9034 A-37305706 * N / A alto Componente a sorgente chiuso
CVE-2015-9035 A-37303626 * N / A alto Componente a sorgente chiuso
CVE-2015-9036 A-37303519 * N / A alto Componente a sorgente chiuso
CVE-2015-9037 A-37304366 * N / A alto Componente a sorgente chiuso
CVE-2015-9038 A-37303027 * N / A alto Componente a sorgente chiuso
CVE-2015-9039 A-37302628 * N / A alto Componente a sorgente chiuso
CVE-2015-9040 A-37303625 * N / A alto Componente a sorgente chiuso
CVE-2015-9041 A-37303518 * N / A alto Componente a sorgente chiuso
CVE-2015-9042 A-37301248 * N / A alto Componente a sorgente chiuso
CVE-2015-9043 A-37305954 * N / A alto Componente a sorgente chiuso
CVE-2015-9044 A-37303520 * N / A alto Componente a sorgente chiuso
CVE-2015-9045 A-37302136 * N / A alto Componente a sorgente chiuso
CVE-2015-9046 A-37301486 * N / A alto Componente a sorgente chiuso
CVE-2015-9047 A-37304367 * N / A alto Componente a sorgente chiuso
CVE-2015-9048 A-37305707 * N / A alto Componente a sorgente chiuso
CVE-2015-9049 A-37301488 * N / A alto Componente a sorgente chiuso
CVE-2015-9050 A-37302137 * N / A alto Componente a sorgente chiuso
CVE-2015-9051 A-37300737 * N / A alto Componente a sorgente chiuso
CVE-2015-9052 A-37304217 * N / A alto Componente a sorgente chiuso
CVE-2015-9053 A-37301249 * N / A alto Componente a sorgente chiuso
CVE-2015-9054 A-37303177 * N / A alto Componente a sorgente chiuso
CVE-2015-9055 A-37472412 * N / A alto Componente a sorgente chiuso
CVE-2015-9060 A-37472807 * N / A alto Componente a sorgente chiuso
CVE-2015-9061 A-37470436 * N / A alto Componente a sorgente chiuso
CVE-2015-9062 A-37472808 * N / A alto Componente a sorgente chiuso
CVE-2015-9067 A-37474000 * N / A alto Componente a sorgente chiuso
CVE-2015-9068 A-37470144 * N / A alto Componente a sorgente chiuso
CVE-2015-9069 A-37470777 * N / A alto Componente a sorgente chiuso
CVE-2015-9070 A-37474001 * N / A alto Componente a sorgente chiuso
CVE-2015-9071 A-37471819 * N / A alto Componente a sorgente chiuso
CVE-2015-9072 A-37474002 * N / A alto Componente a sorgente chiuso
CVE-2015-9073 A-37473407 * N / A alto Componente a sorgente chiuso
CVE-2.016-10.343 A-32580186 * N / A alto Componente a sorgente chiuso
CVE-2.016-10.344 A-32583954 * N / A alto Componente a sorgente chiuso
CVE-2.016-10.346 A-37473408 * N / A alto Componente a sorgente chiuso
CVE-2.016-10.347 A-37471089 * N / A alto Componente a sorgente chiuso
CVE-2.016-10.382 A-28823584 * N / A alto Componente a sorgente chiuso
CVE-2.016-10.383 A-28822389 * N / A alto Componente a sorgente chiuso
CVE-2.016-10.388 A-32580294 * N / A alto Componente a sorgente chiuso
CVE-2.016-10.391 A-32583804 * N / A alto Componente a sorgente chiuso
CVE-2016-5871 A-37473055 * N / A alto Componente a sorgente chiuso
CVE-2016-5872 A-37472809 * N / A alto Componente a sorgente chiuso

Aggiornamenti del dispositivo Google

Questa tabella contiene il livello della patch di sicurezza nell'ultimo aggiornamento over-the-air (OTA) e le immagini del firmware per i dispositivi Google. Le immagini del firmware del dispositivo Google sono disponibili sul sito per sviluppatori Google .

Dispositivo Google Livello di patch di sicurezza
Pixel / Pixel XL 05 luglio 2017
Nexus 5X 05 luglio 2017
Nexus 6 05 luglio 2017
Nexus 6P 05 luglio 2017
Nexus 9 05 luglio 2017
Nexus Player 05 luglio 2017
Pixel C 05 luglio 2017

Gli aggiornamenti dei dispositivi Google contengono anche patch per queste vulnerabilità di sicurezza, se applicabile:

CVE Riferimenti genere Gravità Componente
CVE-2017-0710 A-34951864 * EoP Moderare TCB

Ringraziamenti

Vorremmo ringraziare questi ricercatori per il loro contributo:

CVE ricercatori
CVE-2017-8263 Billy Lau di Google
CVE-2017-0711 Chengming Yang, Baozeng Ding e Yang Song of Alibaba Mobile Security Group
CVE-2017-0681 Chi Zhang , Hanxiang Wen , Mingjian Zhou ( @Mingjian_Zhou ) e Xuxian Jiang del team C0RE
CVE-2017-0706 Daxing Guo ( @ freener0 ) di Xuanwu Lab, Tencent
CVE-2017-8260 Derrek ( @ derrekr6 ) e Scott Bauer
CVE-2017-8265 Di Shen ( @returnsme ) di KeenLab ( @keen_lab ), Tencent
CVE-2017-0703 Dzmitry Lukyanenka
CVE-2017-0692, CVE-2017-0694 Elphet e Gong Guang del team Alpha, Qihoo 360 Technology Co. Ltd.
CVE-2017-8266, CVE-2017-8243, CVE-2017-8270 Gengjia Chen ( @ chengjia4574 ) e pjf di IceSword Lab, Qihoo 360 Technology Co. Ltd.
CVE-2017-0665 Chi Zhang , Hanxiang Wen , Mingjian Zhou ( @Mingjian_Zhou ) e Xuxian Jiang del team C0RE
CVE-2017-8268, CVE-2017-8261 Jianqiang Zhao ( @jianqiangzhao ) e pjf di IceSword Lab, Qihoo 360
CVE-2017-0698 Marchio Joey di Census Consulting Inc.
CVE-2017-0666, CVE-2017-0684 Mingjian Zhou ( @Mingjian_Zhou ), Chi Zhang e Xuxian Jiang del team C0RE
CVE-2017-0697, CVE-2017-0670 Niky1235 ( @jiych_guru )
CVE-2017-9417 Nitay Artenstein of Exodus Intelligence
CVE-2017-0705, CVE-2017-8259 Scott Bauer
CVE-2017-0667 Timothy Becker di CSS Inc.
CVE-2017-0682, CVE-2017-0683, CVE-2017-0676, CVE-2017-0696, CVE-2017-0675, CVE-2017-0701, CVE-2017-0702, CVE-2017-0699 Vasily Vasiliev
CVE-2017-0695, CVE-2017-0689, CVE-2017-0540, CVE-2017-0680, CVE-2017-0679, CVE-2017-0685, CVE-2017-0686, CVE-2017-0693, CVE- 2017-0674, CVE-2017-0677 VEO ( @VYSEa ) del team mobile di risposta alle minacce , Trend Micro
CVE-2017-0708 Dipartimento di piattaforma di sicurezza Xiling Gong di Tencent
CVE-2017-0690 Yangkang ( @dnpushme ) e Liyadong del Qihoo 360 Qex Team
CVE-2017-8269, CVE-2017-8271, CVE-2017-8272, CVE-2017-8267 Yonggang Guo ( @guoygang ) di IceSword Lab, Qihoo 360 Technology Co. Ltd.
CVE-2017-8264, CVE-2017-0326, CVE-2017-0709 Yuan-Tsung Lo ( computernik@gmail.com ) e Xuxian Jiang del team C0RE
CVE-2017-0704, CVE-2017-0669 Yuxiang Li ( @ Xbalien29 ) del dipartimento della piattaforma di sicurezza di Tencent
CVE-2017-0710 Zach Riggle ( @ ebeip90 ) del team di sicurezza di Android
CVE-2017-0678 Zinuo Han di Chengdu Security Response Center, Qihoo 360 Technology Co. Ltd.
CVE-2017-0691, CVE-2017-0700 Zinuo Han del Chengdu Security Response Center, Qihoo 360 Technology Co. Ltd. e Ao Wang ( @ArayzSegment ) del team Pangu

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che possono verificarsi dopo aver letto questo bollettino.

1. Come posso determinare se il mio dispositivo è stato aggiornato per risolvere questi problemi?

Per informazioni su come controllare il livello della patch di sicurezza di un dispositivo, leggi le istruzioni nel programma di aggiornamento di Pixel e Nexus .

  • I livelli di patch di sicurezza del 2017-07-01 o successivo risolvono tutti i problemi associati al livello di patch di sicurezza 2017-07-01.
  • I livelli di patch di sicurezza del 2017-07-05 o successivo risolvono tutti i problemi associati al livello di patch di sicurezza 2017-07-05 e tutti i livelli di patch precedenti.

I produttori di dispositivi che includono questi aggiornamenti dovrebbero impostare il livello della stringa di patch su:

  • [Ro.build.version.security_patch]: [2017/07/01]
  • [Ro.build.version.security_patch]: [2017/07/05]

2. Perché questo bollettino ha due livelli di patch di sicurezza?

Questo bollettino ha due livelli di patch di sicurezza in modo che i partner Android abbiano la flessibilità di correggere più rapidamente un sottoinsieme di vulnerabilità simili a tutti i dispositivi Android. I partner Android sono incoraggiati a risolvere tutti i problemi in questo bollettino e utilizzare l'ultimo livello di patch di sicurezza.

  • I dispositivi che utilizzano il livello della patch di sicurezza del 01 luglio 2017 devono includere tutti i problemi associati a quel livello di patch di sicurezza, nonché correzioni per tutti i problemi segnalati nei precedenti bollettini sulla sicurezza.
  • I dispositivi che utilizzano il livello di patch di sicurezza del 05 luglio 2017 o più recente devono includere tutte le patch applicabili in questo (e precedenti) bollettini sulla sicurezza.

I partner sono incoraggiati a raggruppare le correzioni per tutti i problemi che stanno affrontando in un singolo aggiornamento.

3. Cosa significano le voci nella colonna Tipo ?

Le voci nella colonna Tipo della tabella dei dettagli della vulnerabilità fanno riferimento alla classificazione della vulnerabilità della sicurezza.

Abbreviazione Definizione
RCE Esecuzione di codice remoto
EoP Elevazione del privilegio
ID Rivelazione di un 'informazione
DoS Negazione del servizio
N / A Classificazione non disponibile

4. Cosa significano le voci nella colonna Riferimenti ?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento.

Prefisso Riferimento
UN- ID bug Android
QC- Numero di riferimento Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA
B- Numero di riferimento Broadcom

5. Che cosa significa un * accanto all'ID bug di Android nella colonna Riferimenti ?

I problemi che non sono disponibili pubblicamente hanno un * accanto all'ID bug di Android nella colonna Riferimenti . L'aggiornamento per quel problema è generalmente contenuto negli ultimi driver binari per i dispositivi Nexus disponibili dal sito degli sviluppatori di Google .

versioni

Versione Data Appunti
1.0 5 luglio 2017 Bollettino pubblicato.
1.1 6 luglio 2017 Bollettino rivisto per includere collegamenti AOSP.
1.2 11 luglio 2017 Bollettino rivisto per aggiornare i riconoscimenti.
1.3 17 agosto 2017 Bollettino rivisto per aggiornare i numeri di riferimento.
1.4 19 settembre 2017 Riconoscimenti aggiornati per CVE-2017-0710.
1.5 26 settembre 2017 Riconoscimenti aggiornati per CVE-2017-0681.