Google si impegna a promuovere l'equità razziale per le comunità nere. Vedi come.
Questa pagina è stata tradotta dall'API Cloud Translation.
Switch to English

Bollettino sulla sicurezza Android: dicembre 2017

Pubblicato 4 dicembre 2017 | Aggiornato il 6 dicembre 2017

Il Bollettino sulla sicurezza di Android contiene dettagli sulle vulnerabilità della sicurezza che interessano i dispositivi Android. I livelli di patch di sicurezza del 2017-12-05 o successivi risolvono tutti questi problemi. Per informazioni su come controllare il livello della patch di sicurezza di un dispositivo, vedere Controlla e aggiorna la versione di Android .

I partner Android vengono informati di tutti i problemi almeno un mese prima della pubblicazione. Le patch di codice sorgente per questi problemi sono state rilasciate al repository AOSP (Android Open Source Project) e collegate da questo bollettino. Questo bollettino include anche collegamenti a patch al di fuori di AOSP.

Il più grave di questi problemi è una vulnerabilità di sicurezza critica nel framework Media che potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, presupponendo che le mitigazioni della piattaforma e del servizio siano disattivate per scopi di sviluppo o se vengano aggirate correttamente.

Non abbiamo avuto notizie di sfruttamento attivo dei clienti o abuso di questi problemi appena segnalati. Fai riferimento alla sezione Mitigazioni di Android e Google Play Protect per i dettagli sulle protezioni della piattaforma di sicurezza Android e Google Play Protect, che migliorano la sicurezza della piattaforma Android.

Nota: le informazioni sull'ultimo aggiornamento over-the-air (OTA) e le immagini del firmware per i dispositivi Google sono disponibili nel Bollettino sulla sicurezza Pixel / Nexus di dicembre 2017 .

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle mitigazioni fornite dalla piattaforma di sicurezza Android e delle protezioni del servizio come Google Play Protect . Queste funzionalità riducono la probabilità che le vulnerabilità di sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento per molti problemi su Android è reso più difficile dai miglioramenti nelle nuove versioni della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android ove possibile.
  • Il team di sicurezza di Android monitora attivamente gli abusi tramite Google Play Protect e avvisa gli utenti di applicazioni potenzialmente dannose . Google Play Protect è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano app al di fuori di Google Play.

01/12/2017 livello di patch di sicurezza: dettagli sulla vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2017-12-01. Le vulnerabilità sono raggruppate sotto il componente che interessano. Esiste una descrizione del problema e una tabella con CVE, riferimenti associati, tipo di vulnerabilità , gravità e versioni AOSP aggiornate (ove applicabile). Se disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID bug.

Struttura

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione locale dannosa di ignorare i requisiti di interazione dell'utente al fine di ottenere l'accesso a autorizzazioni aggiuntive.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2017-0807 A-35056974 * EoP alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0870 A-62134807 EoP alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0871 A-65281159 EoP alto 8.0

Quadro mediatico

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2017-0872 A-65290323 RCE critico 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0876 A-64964675 * RCE critico 6.0
CVE-2017-0877 A-66372937 * RCE critico 6.0
CVE-2017-0878 A-65186291 RCE critico 8.0
CVE-2.017-13.151 A-63874456 RCE critico 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2.017-13.153 A-65280854 EoP alto 8.0
CVE-2017-0837 A-64340921 [ 2 ] EoP alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0873 A-63316255 DoS alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0874 A-63315932 DoS alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0880 A-65646012 [ 2 ] DoS alto 7.0, 7.1.1, 7.1.2
CVE-2.017-13.148 A-65717533 DoS alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

Sistema

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato prossimo di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2.017-13.160 A-37160362 RCE critico 7.0, 7.1.1, 7.1.2, 8.0
CVE-2.017-13.156 A-64211847 EoP alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2.017-13.157 A-32990341 ID alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2.017-13.158 A-32879915 ID alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2.017-13.159 A-32879772 ID alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

05/12/2017 livello di patch di sicurezza: dettagli della vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2017-12-05. Le vulnerabilità sono raggruppate sotto il componente che interessano e includono dettagli come CVE, riferimenti associati, tipo di vulnerabilità , gravità , componente (ove applicabile) e versioni AOSP aggiornate (ove applicabile). Se disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID bug.

Componenti del kernel

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2.017-13.162 A-64216036 * EoP alto Raccoglitore
CVE-2017-0564 A-34276203 * EoP alto ION
CVE-2017-7533 A-63689921
Kernel a monte
EoP alto Gestione dei file
CVE-2.017-13.174 A-63100473 * EoP alto EDL

Componenti MediaTek

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2.017-13.170 A-36102397 *
M-ALPS03359280
EoP alto Driver dello schermo
CVE-2.017-13.171 A-64316572 *
M-ALPS03479086
EoP alto Servizio di prestazioni
CVE-2.017-13.173 A-28067350 *
M-ALPS02672361
EoP alto Server di sistema

Componenti NVIDIA

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2017-6262 A-38045794 *
N-CVE-2017-6262
EoP alto Driver NVIDIA
CVE-2017-6263 A-38046353 *
N-CVE-2017-6263
EoP alto Driver NVIDIA
CVE-2017-6276 A-63802421 *
N-CVE-2017-6276
EoP alto Mediaserver

Componenti Qualcomm

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2.017-11.043 A-64728953
QC-CR # 2067820
RCE critico WLAN
CVE-2016-3706 A-34499281
QC-CR # 1058691 [ 2 ]
RCE critico UDP RPC
CVE-2016-4429 A-68946906
QC-CR # 1058691 [ 2 ]
RCE critico UDP RPC
CVE-2.017-11.007 A-66913719
QC-CR # 2068824
EoP alto fastboot
CVE-2.017-14.904 A-63662821 *
QC-CR # 2109325
EoP alto Gralloc
CVE-2017-9716 A-63868627
QC-CR # 2006695
EoP alto Driver Qbt1000
CVE-2.017-14.897 A-65468973
QC-CR # 2054091
EoP alto Driver RPMB
CVE-2.017-14.902 A-65468970
QC-CR # 2061287
EoP alto MProc
CVE-2.017-14.895 A-65468977
QC-CR # 2009308
EoP alto WLAN

Componenti di origine chiusa Qualcomm

Queste vulnerabilità riguardano i componenti di Qualcomm e sono descritte in maggior dettaglio nel bollettino di sicurezza AMSS Qualcomm appropriato o nell'avviso di sicurezza. La valutazione della gravità di questi problemi è fornita direttamente da Qualcomm.

CVE Riferimenti genere Gravità Componente
CVE-2017-6211 A-36217326 * N / A critico Componente a sorgente chiuso
CVE-2.017-14.908 A-62212840 * N / A alto Componente a sorgente chiuso
CVE-2.017-14.909 A-62212839 * N / A alto Componente a sorgente chiuso
CVE-2.017-14.914 A-62212297 * N / A alto Componente a sorgente chiuso
CVE-2.017-14.916 A-62212841 * N / A alto Componente a sorgente chiuso
CVE-2.017-14.917 A-62212740 * N / A alto Componente a sorgente chiuso
CVE-2.017-14.918 A-65946406 * N / A alto Componente a sorgente chiuso
CVE-2.017-11.005 A-66913715 * N / A alto Componente a sorgente chiuso
CVE-2.017-11.006 A-66913717 * N / A alto Componente a sorgente chiuso

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che possono verificarsi dopo aver letto questo bollettino.

1. Come posso determinare se il mio dispositivo è stato aggiornato per risolvere questi problemi?

Per informazioni su come controllare il livello della patch di sicurezza di un dispositivo, vedere Controlla e aggiorna la versione di Android .

  • I livelli di patch di sicurezza del 2017-12-01 o successivo risolvono tutti i problemi associati al livello di patch di sicurezza 2017-12-01.
  • I livelli di patch di sicurezza del 2017-12-05 o successivo risolvono tutti i problemi associati al livello di patch di sicurezza 2017-12-05 e tutti i livelli di patch precedenti.

I produttori di dispositivi che includono questi aggiornamenti dovrebbero impostare il livello della stringa di patch su:

  • [Ro.build.version.security_patch]: [2017/12/01]
  • [Ro.build.version.security_patch]: [2017/12/05]

2. Perché questo bollettino ha due livelli di patch di sicurezza?

Questo bollettino ha due livelli di patch di sicurezza in modo che i partner Android abbiano la flessibilità di correggere più rapidamente un sottoinsieme di vulnerabilità simili a tutti i dispositivi Android. I partner Android sono incoraggiati a risolvere tutti i problemi in questo bollettino e utilizzare l'ultimo livello di patch di sicurezza.

  • I dispositivi che utilizzano il livello di patch di sicurezza 2017-12-01 devono includere tutti i problemi associati a quel livello di patch di sicurezza, nonché correzioni per tutti i problemi segnalati nei precedenti bollettini sulla sicurezza.
  • I dispositivi che utilizzano il livello di patch di sicurezza del 2017-12-05 o più recente devono includere tutte le patch applicabili in questo (e precedenti) bollettini sulla sicurezza.

I partner sono incoraggiati a raggruppare le correzioni per tutti i problemi che stanno affrontando in un singolo aggiornamento.

3. Cosa significano le voci nella colonna Tipo ?

Le voci nella colonna Tipo della tabella dei dettagli della vulnerabilità fanno riferimento alla classificazione della vulnerabilità della sicurezza.

Abbreviazione Definizione
RCE Esecuzione di codice remoto
EoP Elevazione del privilegio
ID Rivelazione di un 'informazione
DoS Negazione del servizio
N / A Classificazione non disponibile

4. Cosa significano le voci nella colonna Riferimenti ?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento.

Prefisso Riferimento
UN- ID bug Android
QC- Numero di riferimento Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA
B- Numero di riferimento Broadcom

5. Che cosa significa un * accanto all'ID bug di Android nella colonna Riferimenti ?

I problemi che non sono disponibili pubblicamente hanno un * accanto all'ID bug di Android nella colonna Riferimenti . L'aggiornamento per quel problema è generalmente contenuto negli ultimi driver binari per i dispositivi Nexus disponibili dal sito degli sviluppatori di Google .

6. Perché le vulnerabilità di sicurezza sono divise tra questo bollettino e i bollettini sulla sicurezza di dispositivi / partner, come il bollettino Pixel / Nexus?

Le vulnerabilità di sicurezza documentate in questo bollettino sulla sicurezza sono necessarie per dichiarare l'ultimo livello di patch di sicurezza sui dispositivi Android. Ulteriori vulnerabilità di sicurezza documentate nei bollettini sulla sicurezza di dispositivi / partner non sono richieste per dichiarare un livello di patch di sicurezza. I produttori di dispositivi e chipset Android sono invitati a documentare la presenza di altre correzioni sui propri dispositivi attraverso i propri siti Web di sicurezza, come i bollettini sulla sicurezza Samsung , LGE o Pixel / Nexus .

versioni

Versione Data Appunti
1.0 4 dicembre 2017 Bollettino pubblicato.
1.1 6 dicembre 2017 Bollettino rivisto per includere collegamenti AOSP.