Google si impegna a promuovere l'equità razziale per le comunità nere. Vedi come.
Questa pagina è stata tradotta dall'API Cloud Translation.
Switch to English

Bollettino sulla sicurezza Android: gennaio 2018

Pubblicato il 2 gennaio 2018 | Aggiornato il 29 gennaio 2018

Il Bollettino sulla sicurezza di Android contiene dettagli sulle vulnerabilità della sicurezza che interessano i dispositivi Android. I livelli di patch di sicurezza del 05-01-2018 o successivi risolvono tutti questi problemi. Per informazioni su come controllare il livello della patch di sicurezza di un dispositivo, vedere Controllare e aggiornare la versione di Android .

I partner Android vengono informati di tutti i problemi almeno un mese prima della pubblicazione. Le patch di codice sorgente per questi problemi sono state rilasciate al repository AOSP (Android Open Source Project) e collegate da questo bollettino. Questo bollettino include anche collegamenti a patch al di fuori di AOSP.

Il più grave di questi problemi è una vulnerabilità di sicurezza critica nel framework Media che potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato. La valutazione della gravità si basa sull'effetto che lo sfruttamento della vulnerabilità potrebbe avere su un dispositivo interessato, presupponendo che le mitigazioni della piattaforma e del servizio siano disattivate per scopi di sviluppo o se vengano aggirate correttamente.

Non abbiamo avuto notizie di sfruttamento attivo dei clienti o abuso di questi problemi appena segnalati. Fai riferimento alla sezione Mitigazioni di Android e Google Play Protect per i dettagli sulle protezioni della piattaforma di sicurezza Android e Google Play Protect, che migliorano la sicurezza della piattaforma Android.

Nota: le informazioni sull'ultimo aggiornamento over-the-air (OTA) e le immagini del firmware per i dispositivi Google sono disponibili nel Bollettino sulla sicurezza Pixel / Nexus di gennaio 2018.

Annunci

Abbiamo lanciato un nuovo bollettino sulla sicurezza Pixel / Nexus , che contiene informazioni su vulnerabilità di sicurezza aggiuntive e miglioramenti funzionali che vengono affrontati sui dispositivi Pixel e Nexus. I produttori di dispositivi Android possono scegliere di affrontare questi problemi sui propri dispositivi. Vedi Domande e risposte comuni per ulteriori informazioni.

Mitigazioni dei servizi Android e Google

Questo è un riepilogo delle mitigazioni fornite dalla piattaforma di sicurezza Android e delle protezioni del servizio come Google Play Protect . Queste funzionalità riducono la probabilità che le vulnerabilità di sicurezza possano essere sfruttate con successo su Android.

  • Lo sfruttamento per molti problemi su Android è reso più difficile dai miglioramenti nelle nuove versioni della piattaforma Android. Incoraggiamo tutti gli utenti ad aggiornare all'ultima versione di Android ove possibile.
  • Il team di sicurezza di Android monitora attivamente gli abusi tramite Google Play Protect e avvisa gli utenti di applicazioni potenzialmente dannose . Google Play Protect è abilitato per impostazione predefinita sui dispositivi con Google Mobile Services ed è particolarmente importante per gli utenti che installano app al di fuori di Google Play.

01/01/2018 Livello di patch di sicurezza: dettagli della vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2018-01-01. Le vulnerabilità sono raggruppate sotto il componente che interessano. Esiste una descrizione del problema e una tabella con CVE, riferimenti associati, tipo di vulnerabilità , gravità e versioni AOSP aggiornate (ove applicabile). Se disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID bug.

Runtime Android

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto di ignorare i requisiti di interazione dell'utente al fine di ottenere l'accesso a autorizzazioni aggiuntive.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2.017-13.176 A-68341964 EoP alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1

Quadro mediatico

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2.017-13.177 A-68320413 RCE critico 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.178 A-66969281 RCE critico 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.179 A-66969193 RCE critico 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.180 A-66969349 EoP alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.181 A-67864232 EoP alto 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.182 A-67737022 EoP alto 8.0, 8.1
CVE-2.017-13.184 A-65483324 EoP alto 8.0, 8.1
CVE-2017-0855 A-64452857 DoS alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2.017-13.191 A-64380403 DoS alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.192 A-64380202 DoS alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.193 A-65718319 DoS alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.195 A-65398821 DoS alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.196 A-63522067 DoS alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.197 A-64784973 DoS alto 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.199 A-33846679 DoS alto 8.0, 8.1

Sistema

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2.017-13.208 A-67474440 RCE critico 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.209 A-68217907 [ 2 ] [ 3 ] EoP alto 8.0, 8.1
CVE-2.017-13.210 A-67782345 EoP alto 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0, 8.1
CVE-2.017-13.211 A-65174158 DoS alto 8.0

05/01/2018 Livello patch di sicurezza: dettagli sulla vulnerabilità

Nelle sezioni seguenti, forniamo i dettagli per ciascuna delle vulnerabilità di sicurezza che si applicano al livello di patch 2018-01-05. Le vulnerabilità sono raggruppate sotto il componente che interessano e includono dettagli come CVE, riferimenti associati, tipo di vulnerabilità , gravità , componente (ove applicabile) e versioni AOSP aggiornate (ove applicabile). Se disponibile, colleghiamo la modifica pubblica che ha risolto il problema all'ID bug, come l'elenco delle modifiche AOSP. Quando più modifiche si riferiscono a un singolo bug, riferimenti aggiuntivi sono collegati ai numeri che seguono l'ID bug.

Componenti HTC

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto di provocare una negazione del servizio in un processo di sistema critico.

CVE Riferimenti genere Gravità Componente
CVE-2.017-13.214 A-38495900 * DoS alto Decodificatore HEVC hardware

Componenti del kernel

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2.017-14.497 A-66694921
Kernel a monte
EoP alto Elaborazione di pacchetti TCP
CVE-2.017-13.215 A-64386293
Kernel a monte
EoP alto Skcipher
CVE-2.017-13.216 A-66954097 * EoP alto Ashmem
CVE-2.017-13.218 A-68266545 * ID alto Timer ad alta precisione

Componenti LG

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2.017-13.217 A-68269077 * EoP alto Boot loader

Quadro mediatico

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Versioni AOSP aggiornate
CVE-2.017-13.183 A-38118127 EoP alto 8.1

Componenti NVIDIA

La vulnerabilità più grave in questa sezione potrebbe consentire a un'applicazione dannosa locale di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2017-0869 A-37776156 *
N-CVE-2017-0869
EoP alto Driver Nvidia

Componenti Qualcomm

La vulnerabilità più grave in questa sezione potrebbe consentire a un utente malintenzionato remoto che utilizza un file appositamente predisposto di eseguire codice arbitrario nel contesto di un processo privilegiato.

CVE Riferimenti genere Gravità Componente
CVE-2.017-15.849 A-66937641
QC-CR # 2046572
EoP alto Schermo
CVE-2.017-11.069 A-65468974
QC-CR # 2060780
EoP alto Boot loader

Componenti di origine chiusa Qualcomm

Queste vulnerabilità riguardano i componenti di Qualcomm e sono descritte in modo più dettagliato nel bollettino di sicurezza AMSS o avviso di sicurezza appropriato. La valutazione della gravità di questi problemi è fornita direttamente da Qualcomm.

CVE Riferimenti genere Gravità Componente
CVE-2.017-14.911 A-62212946 * N / A critico Componente a sorgente chiuso
CVE-2.017-14.906 A-32584150 * N / A alto Componente a sorgente chiuso
CVE-2.017-14.912 A-62212739 * N / A alto Componente a sorgente chiuso
CVE-2.017-14.913 A-62212298 * N / A alto Componente a sorgente chiuso
CVE-2.017-14.915 A-62212632 * N / A alto Componente a sorgente chiuso
CVE-2013-4397 A-65944893 * N / A alto Componente a sorgente chiuso
CVE-2.017-11.010 A-66913721 * N / A alto Componente a sorgente chiuso

Domande e risposte comuni

Questa sezione risponde alle domande più comuni che possono verificarsi dopo aver letto questo bollettino.

1. Come posso determinare se il mio dispositivo è stato aggiornato per risolvere questi problemi?

Per informazioni su come controllare il livello della patch di sicurezza di un dispositivo, vedere Controlla e aggiorna la versione di Android .

  • I livelli di patch di sicurezza del 01-01-2018 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza 2018-01-01.
  • I livelli di patch di sicurezza del 05-01-2018 o successivi risolvono tutti i problemi associati al livello di patch di sicurezza 2018-01-05 e tutti i livelli di patch precedenti.

I produttori di dispositivi che includono questi aggiornamenti dovrebbero impostare il livello della stringa di patch su:

  • [Ro.build.version.security_patch]: [2018/01/01]
  • [Ro.build.version.security_patch]: [2018/01/05]

2. Perché questo bollettino ha due livelli di patch di sicurezza?

Questo bollettino ha due livelli di patch di sicurezza in modo che i partner Android abbiano la flessibilità di correggere più rapidamente un sottoinsieme di vulnerabilità simili a tutti i dispositivi Android. I partner Android sono incoraggiati a risolvere tutti i problemi in questo bollettino e utilizzare l'ultimo livello di patch di sicurezza.

  • I dispositivi che utilizzano il livello di patch di sicurezza 2018-01-01 devono includere tutti i problemi associati a quel livello di patch di sicurezza, nonché correzioni per tutti i problemi segnalati nei precedenti bollettini sulla sicurezza.
  • I dispositivi che utilizzano il livello di patch di sicurezza del 05-01-2018 o più recente devono includere tutte le patch applicabili in questo (e precedenti) bollettini sulla sicurezza.

I partner sono incoraggiati a raggruppare le correzioni per tutti i problemi che stanno affrontando in un singolo aggiornamento.

3. Cosa significano le voci nella colonna Tipo ?

Le voci nella colonna Tipo della tabella dei dettagli della vulnerabilità fanno riferimento alla classificazione della vulnerabilità della sicurezza.

Abbreviazione Definizione
RCE Esecuzione di codice remoto
EoP Elevazione del privilegio
ID Rivelazione di un 'informazione
DoS Negazione del servizio
N / A Classificazione non disponibile

4. Cosa significano le voci nella colonna Riferimenti ?

Le voci nella colonna Riferimenti della tabella dei dettagli della vulnerabilità possono contenere un prefisso che identifica l'organizzazione a cui appartiene il valore di riferimento.

Prefisso Riferimento
UN- ID bug Android
QC- Numero di riferimento Qualcomm
M- Numero di riferimento MediaTek
N- Numero di riferimento NVIDIA
B- Numero di riferimento Broadcom

5. Che cosa significa un * accanto all'ID bug di Android nella colonna Riferimenti ?

I problemi che non sono disponibili pubblicamente hanno un * accanto all'ID bug di Android nella colonna Riferimenti . L'aggiornamento per quel problema è generalmente contenuto negli ultimi driver binari per i dispositivi Nexus disponibili dal sito degli sviluppatori di Google .

6. Perché le vulnerabilità di sicurezza sono divise tra questo bollettino e i bollettini sulla sicurezza di dispositivi / partner, come il bollettino Pixel / Nexus?

Le vulnerabilità di sicurezza documentate in questo bollettino sulla sicurezza sono necessarie per dichiarare l'ultimo livello di patch di sicurezza sui dispositivi Android. Ulteriori vulnerabilità di sicurezza documentate nei bollettini sulla sicurezza di dispositivi / partner non sono richieste per dichiarare un livello di patch di sicurezza. I produttori di dispositivi e chipset Android sono invitati a documentare la presenza di altre correzioni sui propri dispositivi attraverso i propri siti Web di sicurezza, come i bollettini sulla sicurezza Samsung , LGE o Pixel / Nexus .

versioni

Versione Data Appunti
1.0 2 gennaio 2018 Bollettino pubblicato.
1.1 3 gennaio 2018 Bollettino aggiornato con l'annuncio di CVE-2017-13218.
1.2 5 gennaio 2018 Bollettino rivisto per includere collegamenti AOSP.
1.3 29 gennaio 2018 CVE-2017-13225 è passato al Bollettino sulla sicurezza Pixel / Nexus .