Google setzt sich dafür ein, die Rassengerechtigkeit für schwarze Gemeinschaften zu fördern. Siehe wie.
Diese Seite wurde von der Cloud Translation API übersetzt.
Switch to English

Android Security Bulletin - Dezember 2017

Veröffentlicht am 4. Dezember 2017 | Aktualisiert am 6. Dezember 2017

Das Android Security Bulletin enthält Details zu Sicherheitslücken, die Android-Geräte betreffen. Sicherheits-Patch-Levels vom 05.12.2017 oder höher beheben all diese Probleme. Informationen zum Überprüfen der Sicherheits-Patch-Stufe eines Geräts finden Sie unter Überprüfen und Aktualisieren Ihrer Android-Version .

Android-Partner werden mindestens einen Monat vor der Veröffentlichung über alle Probleme informiert. Quellcode-Patches für diese Probleme wurden im AOSP-Repository (Android Open Source Project) veröffentlicht und über dieses Bulletin verlinkt. Dieses Bulletin enthält auch Links zu Patches außerhalb von AOSP.

Das schwerwiegendste dieser Probleme ist eine kritische Sicherheitslücke im Media Framework, die es einem Remoteangreifer ermöglichen kann, mithilfe einer speziell gestalteten Datei beliebigen Code im Kontext eines privilegierten Prozesses auszuführen. Die Bewertung des Schweregrads basiert auf den Auswirkungen, die das Ausnutzen der Sicherheitsanfälligkeit möglicherweise auf ein betroffenes Gerät haben würde, vorausgesetzt, die Plattform- und Dienstminderungen werden für Entwicklungszwecke deaktiviert oder bei erfolgreicher Umgehung.

Wir haben keine Berichte über die aktive Ausbeutung oder den Missbrauch dieser neu gemeldeten Probleme durch Kunden erhalten. Weitere Informationen zum Schutz der Android-Sicherheitsplattform und zu Google Play Protect, die die Sicherheit der Android-Plattform verbessern, finden Sie im Abschnitt zur Minderung von Android- und Google Play Protect-Maßnahmen .

Hinweis: Informationen zu den neuesten drahtlosen Updates (OTA) und Firmware-Images für Google-Geräte finden Sie im Pixel / Nexus Security Bulletin vom Dezember 2017 .

Mitigationen für Android- und Google-Dienste

Dies ist eine Zusammenfassung der von der Android-Sicherheitsplattform bereitgestellten Maßnahmen und des Schutzes von Diensten wie Google Play Protect . Diese Funktionen verringern die Wahrscheinlichkeit, dass Sicherheitslücken unter Android erfolgreich ausgenutzt werden können.

  • Die Nutzung vieler Probleme unter Android wird durch Verbesserungen in neueren Versionen der Android-Plattform erschwert. Wir empfehlen allen Benutzern, nach Möglichkeit auf die neueste Version von Android zu aktualisieren.
  • Das Android-Sicherheitsteam überwacht den Missbrauch über Google Play Protect aktiv und warnt Benutzer vor potenziell schädlichen Anwendungen . Google Play Protect ist standardmäßig auf Geräten mit Google Mobile Services aktiviert und besonders wichtig für Benutzer, die Apps von außerhalb von Google Play installieren.

01.12.2017 Sicherheits-Patch-Stufe - Details zur Sicherheitsanfälligkeit

In den folgenden Abschnitten finden Sie Details zu den Sicherheitslücken, die für die Patch-Version 2017-12-01 gelten. Sicherheitslücken werden unter der Komponente zusammengefasst, die sie betreffen. Es gibt eine Beschreibung des Problems und eine Tabelle mit dem CVE, den zugehörigen Referenzen, der Art der Sicherheitsanfälligkeit , dem Schweregrad und den aktualisierten AOSP-Versionen (falls zutreffend). Sofern verfügbar, verknüpfen wir die öffentliche Änderung, mit der das Problem behoben wurde, mit der Fehler-ID, z. B. der AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern verknüpft, die auf die Fehler-ID folgen.

Rahmen

Die schwerwiegendste Sicherheitsanfälligkeit in diesem Abschnitt kann es einer lokalen bösartigen Anwendung ermöglichen, die Benutzerinteraktionsanforderungen zu umgehen, um Zugriff auf zusätzliche Berechtigungen zu erhalten.

CVE Verweise Art Schwere Aktualisierte AOSP-Versionen
CVE-2017-0807 A-35056974 * EoP Hoch 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2
CVE-2017-0870 A-62134807 EoP Hoch 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0871 A-65281159 EoP Hoch 8.0

Medienrahmen

Die schwerwiegendste Sicherheitsanfälligkeit in diesem Abschnitt kann es einem Remoteangreifer ermöglichen, mithilfe einer speziell gestalteten Datei beliebigen Code im Kontext eines privilegierten Prozesses auszuführen.

CVE Verweise Art Schwere Aktualisierte AOSP-Versionen
CVE-2017-0872 A-65290323 RCE Kritisch 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0876 A-64964675 * RCE Kritisch 6.0
CVE-2017-0877 A-66372937 * RCE Kritisch 6.0
CVE-2017-0878 A-65186291 RCE Kritisch 8.0
CVE-2017-13151 A-63874456 RCE Kritisch 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13153 A-65280854 EoP Hoch 8.0
CVE-2017-0837 A-64340921 [ 2 ] EoP Hoch 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0873 A-63316255 DOS Hoch 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0874 A-63315932 DOS Hoch 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-0880 A-65646012 [ 2 ] DOS Hoch 7.0, 7.1.1, 7.1.2
CVE-2017-13148 A-65717533 DOS Hoch 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

System

Die schwerwiegendste Sicherheitsanfälligkeit in diesem Abschnitt kann es einem Angreifer in der Nähe ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen.

CVE Verweise Art Schwere Aktualisierte AOSP-Versionen
CVE-2017-13160 A-37160362 RCE Kritisch 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13156 A-64211847 EoP Hoch 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13157 A-32990341 ICH WÜRDE Hoch 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13158 A-32879915 ICH WÜRDE Hoch 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0
CVE-2017-13159 A-32879772 ICH WÜRDE Hoch 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1, 7.1.2, 8.0

Sicherheits-Patch-Stufe 2017-12-05 - Details zur Sicherheitsanfälligkeit

In den folgenden Abschnitten finden Sie Details zu den Sicherheitslücken, die für die Patch-Version 2017-12-05 gelten. Sicherheitslücken werden unter der Komponente zusammengefasst, die sie betreffen, und enthalten Details wie CVE, zugehörige Referenzen, Art der Sicherheitsanfälligkeit , Schweregrad , Komponente (falls zutreffend) und aktualisierte AOSP-Versionen (sofern zutreffend). Sofern verfügbar, verknüpfen wir die öffentliche Änderung, mit der das Problem behoben wurde, mit der Fehler-ID, z. B. der AOSP-Änderungsliste. Wenn sich mehrere Änderungen auf einen einzelnen Fehler beziehen, werden zusätzliche Referenzen mit Nummern verknüpft, die auf die Fehler-ID folgen.

Kernel-Komponenten

Die schwerwiegendste Sicherheitsanfälligkeit in diesem Abschnitt kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen.

CVE Verweise Art Schwere Komponente
CVE-2017-13162 A-64216036 * EoP Hoch Bindemittel
CVE-2017-0564 A-34276203 * EoP Hoch ION
CVE-2017-7533 A-63689921
Upstream-Kernel
EoP Hoch Dateiverwaltung
CVE-2017-13174 A-63100473 * EoP Hoch EDL

MediaTek-Komponenten

Die schwerwiegendste Sicherheitsanfälligkeit in diesem Abschnitt kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen.

CVE Verweise Art Schwere Komponente
CVE-2017-13170 A-36102397 *
M-ALPS03359280
EoP Hoch Bildschirmtreiber
CVE-2017-13171 A-64316572 *
M-ALPS03479086
EoP Hoch Leistungsservice
CVE-2017-13173 A-28067350 *
M-ALPS02672361
EoP Hoch Systemserver

NVIDIA-Komponenten

Die schwerwiegendste Sicherheitsanfälligkeit in diesem Abschnitt kann es einer lokalen bösartigen Anwendung ermöglichen, beliebigen Code im Kontext eines privilegierten Prozesses auszuführen.

CVE Verweise Art Schwere Komponente
CVE-2017-6262 A-38045794 *
N-CVE-2017-6262
EoP Hoch NVIDIA-Treiber
CVE-2017-6263 A-38046353 *
N-CVE-2017-6263
EoP Hoch NVIDIA-Treiber
CVE-2017-6276 A-63802421 *
N-CVE-2017-6276
EoP Hoch Medienserver

Qualcomm-Komponenten

Die schwerwiegendste Sicherheitsanfälligkeit in diesem Abschnitt kann es einem Remoteangreifer ermöglichen, mithilfe einer speziell gestalteten Datei beliebigen Code im Kontext eines privilegierten Prozesses auszuführen.

CVE Verweise Art Schwere Komponente
CVE-2017-11043 A-64728953
QC-CR # 2067820
RCE Kritisch WLAN
CVE-2016-3706 A-34499281
QC-CR # 1058691 [ 2 ]
RCE Kritisch UDP RPC
CVE-2016-4429 A-68946906
QC-CR # 1058691 [ 2 ]
RCE Kritisch UDP RPC
CVE-2017-11007 A-66913719
QC-CR # 2068824
EoP Hoch Fastboot
CVE-2017-14904 A-63662821 *
QC-CR # 2109325
EoP Hoch Gralloc
CVE-2017-9716 A-63868627
QC-CR # 2006695
EoP Hoch Qbt1000-Treiber
CVE-2017-14897 A-65468973
QC-CR # 2054091
EoP Hoch RPMB-Treiber
CVE-2017-14902 A-65468970
QC-CR # 2061287
EoP Hoch MProc
CVE-2017-14895 A-65468977
QC-CR # 2009308
EoP Hoch WLAN

Qualcomm Closed-Source-Komponenten

Diese Sicherheitsanfälligkeiten betreffen Qualcomm-Komponenten und werden im entsprechenden Qualcomm AMSS-Sicherheitsbulletin oder in der Sicherheitswarnung ausführlicher beschrieben. Die Bewertung des Schweregrads dieser Probleme wird direkt von Qualcomm bereitgestellt.

CVE Verweise Art Schwere Komponente
CVE-2017-6211 A-36217326 * N / A Kritisch Closed-Source-Komponente
CVE-2017-14908 A-62212840 * N / A Hoch Closed-Source-Komponente
CVE-2017-14909 A-62212839 * N / A Hoch Closed-Source-Komponente
CVE-2017-14914 A-62212297 * N / A Hoch Closed-Source-Komponente
CVE-2017-14916 A-62212841 * N / A Hoch Closed-Source-Komponente
CVE-2017-14917 A-62212740 * N / A Hoch Closed-Source-Komponente
CVE-2017-14918 A-65946406 * N / A Hoch Closed-Source-Komponente
CVE-2017-11005 A-66913715 * N / A Hoch Closed-Source-Komponente
CVE-2017-11006 A-66913717 * N / A Hoch Closed-Source-Komponente

Häufige Fragen und Antworten

Dieser Abschnitt beantwortet häufig gestellte Fragen, die nach dem Lesen dieses Bulletins auftreten können.

1. Wie stelle ich fest, ob mein Gerät aktualisiert wurde, um diese Probleme zu beheben?

Informationen zum Überprüfen der Sicherheits-Patch-Stufe eines Geräts finden Sie unter Überprüfen und Aktualisieren Ihrer Android-Version .

  • Sicherheits-Patch-Levels vom 01.12.2017 oder höher beheben alle Probleme, die mit dem Sicherheits-Patch-Level 2017-12-01 verbunden sind.
  • Sicherheits-Patch-Levels vom 05.12.2017 oder höher beheben alle Probleme im Zusammenhang mit dem Sicherheits-Patch-Level 2017-12-05 und allen vorherigen Patch-Levels.

Gerätehersteller, die diese Updates enthalten, sollten die Patch-Zeichenfolge auf Folgendes einstellen:

  • [ro.build.version.security_patch]: [2017-12-01]
  • [ro.build.version.security_patch]: [2017-12-05]

2. Warum hat dieses Bulletin zwei Sicherheits-Patch-Stufen?

Dieses Bulletin verfügt über zwei Sicherheits-Patch-Ebenen, sodass Android-Partner die Flexibilität haben, eine Teilmenge von Schwachstellen, die auf allen Android-Geräten ähnlich sind, schneller zu beheben. Android-Partner werden aufgefordert, alle Probleme in diesem Bulletin zu beheben und die neueste Sicherheits-Patch-Stufe zu verwenden.

  • Geräte, die die Sicherheitspatch-Stufe 2017-12-01 verwenden, müssen alle mit dieser Sicherheitspatch-Stufe verbundenen Probleme sowie Korrekturen für alle in früheren Sicherheitsbulletins gemeldeten Probleme enthalten.
  • Geräte, die die Sicherheits-Patch-Stufe vom 05.12.2017 oder neuer verwenden, müssen alle zutreffenden Patches in diesem (und früheren) Sicherheitsbulletins enthalten.

Partner werden aufgefordert, die Korrekturen für alle Probleme, die sie beheben, in einem einzigen Update zu bündeln.

3. Was bedeuten die Einträge in der Spalte Typ ?

Einträge in der Spalte Typ der Tabelle mit den Sicherheitsanfälligkeitsdetails verweisen auf die Klassifizierung der Sicherheitsanfälligkeit.

Abkürzung Definition
RCE Remote-Codeausführung
EoP Erhöhung des Privilegs
ICH WÜRDE Offenlegung von Informationen
DOS Denial of Service
N / A Klassifizierung nicht verfügbar

4. Was bedeuten die Einträge in der Spalte Referenzen ?

Einträge in der Spalte " Referenzen" der Tabelle mit den Schwachstellendetails können ein Präfix enthalten, das die Organisation angibt, zu der der Referenzwert gehört.

Präfix Referenz
EIN- Android Bug ID
QC- Qualcomm Referenznummer
M- MediaTek-Referenznummer
N- NVIDIA-Referenznummer
B- Broadcom Referenznummer

5. Was bedeutet ein * neben der Android-Fehler-ID in der Spalte " Referenzen" ?

Probleme, die nicht öffentlich verfügbar sind, haben ein * neben der Android-Fehler-ID in der Spalte " Referenzen" . Das Update für dieses Problem ist im Allgemeinen in den neuesten Binärtreibern für Nexus-Geräte enthalten, die auf der Google Developer-Website verfügbar sind.

6. Warum werden Sicherheitslücken zwischen diesem Bulletin und Sicherheitsbulletins für Geräte / Partner wie dem Pixel / Nexus-Bulletin aufgeteilt?

Sicherheitslücken, die in diesem Security Bulletin dokumentiert sind, sind erforderlich, um die neueste Sicherheits-Patch-Stufe auf Android-Geräten zu deklarieren. Zusätzliche Sicherheitslücken, die in den Sicherheitsbulletins für Geräte / Partner dokumentiert sind, sind nicht erforderlich, um eine Sicherheits-Patch-Stufe zu deklarieren. Hersteller von Android-Geräten und Chipsätzen werden aufgefordert, das Vorhandensein anderer Korrekturen auf ihren Geräten über ihre eigenen Sicherheitswebsites wie die Sicherheitsbulletins von Samsung , LGE oder Pixel / Nexus zu dokumentieren.

Versionen

Ausführung Datum Anmerkungen
1.0 4. Dezember 2017 Bulletin veröffentlicht.
1.1 6. Dezember 2017 Bulletin überarbeitet, um AOSP-Links aufzunehmen.