بولتن امنیتی اندروید - دسامبر 2018

منتشر شده در 3 دسامبر 2018 | به روز شده در 5 دسامبر 2018

بولتن امنیتی اندروید حاوی جزئیاتی از آسیب پذیری های امنیتی است که بر دستگاه های اندرویدی تأثیر می گذارد. سطوح وصله امنیتی 05/12/2018 یا بعد از آن همه این مسائل را برطرف می کند. برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

شرکای Android حداقل یک ماه قبل از انتشار از همه مشکلات مطلع می شوند. وصله کد منبع برای این مشکلات در مخزن پروژه منبع باز Android (AOSP) منتشر شده و از این بولتن پیوند داده شده است. این بولتن همچنین شامل پیوندهایی به وصله های خارج از AOSP است.

شدیدترین این مشکلات یک آسیب پذیری امنیتی مهم در چارچوب Media است که می تواند یک مهاجم راه دور را با استفاده از یک فایل ساخته شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند. ارزیابی شدت مبتنی بر تأثیری است که بهره‌برداری از آسیب‌پذیری احتمالاً روی دستگاه آسیب‌دیده می‌گذارد، با این فرض که پلت‌فرم و کاهش خدمات برای اهداف توسعه خاموش شده‌اند یا اگر با موفقیت دور زده شوند.

ما هیچ گزارشی مبنی بر بهره برداری یا سوء استفاده فعال مشتری از این مشکلات گزارش شده جدید نداشته ایم. برای جزئیات بیشتر در مورد حفاظت های پلتفرم امنیتی اندروید و Google Play Protect که امنیت پلتفرم اندروید را بهبود می بخشد، به بخش کاهش دهنده های Android و Google Play Protect مراجعه کنید.

توجه: اطلاعات مربوط به آخرین به‌روزرسانی خارج از هوا (OTA) و تصاویر میان‌افزار دستگاه‌های Google در بولتن امنیتی Pixel/Nexus دسامبر 2018 موجود است.

کاهش خدمات اندروید و گوگل

این خلاصه‌ای از کاهش‌های ارائه شده توسط پلتفرم امنیتی Android و محافظت‌های خدماتی مانند Google Play Protect است. این قابلیت ها احتمال سوء استفاده موفقیت آمیز از آسیب پذیری های امنیتی در اندروید را کاهش می دهد.

  • بهره برداری از بسیاری از مسائل در اندروید با بهبود نسخه های جدیدتر پلت فرم اندروید دشوارتر شده است. ما همه کاربران را تشویق می کنیم تا در صورت امکان به آخرین نسخه اندروید بروزرسانی کنند.
  • تیم امنیتی Android به طور فعال از طریق Google Play Protect برای سوء استفاده نظارت می کند و به کاربران در مورد برنامه های بالقوه مضر هشدار می دهد. Google Play Protect به طور پیش‌فرض در دستگاه‌های دارای سرویس‌های تلفن همراه Google فعال است و به ویژه برای کاربرانی که برنامه‌هایی را از خارج از Google Play نصب می‌کنند، مهم است.

جزئیات آسیب پذیری سطح وصله امنیتی 01/12/2018

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی مربوط به سطح وصله 2018-12-01 را ارائه می‌کنیم. آسیب‌پذیری‌ها بر اساس مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند. شرحی از مشکل و جدولی با CVE، مراجع مرتبط، نوع آسیب‌پذیری ، شدت و نسخه‌های به‌روزرسانی‌شده AOSP (در صورت لزوم) وجود دارد. زمانی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است به شناسه اشکال مرتبط می کنیم، مانند لیست تغییرات AOSP. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعداد زیر شناسه اشکال مرتبط می شوند.

چارچوب

شدیدترین آسیب پذیری در این بخش می تواند یک برنامه مخرب محلی را قادر سازد تا کد دلخواه را در چارچوب یک فرآیند ممتاز اجرا کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2018-9547 الف-114223584 EoP بالا 8.1، 9
CVE-2018-9548 الف-112555574 شناسه بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9

چارچوب رسانه ای

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم راه دور را با استفاده از یک فایل ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2018-9549 الف-112160868 RCE بحرانی 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2018-9550 الف-112660981 RCE بحرانی 9
CVE-2018-9551 الف-112891548 RCE بحرانی 9
CVE-2018-9552 الف-113260892 شناسه بحرانی 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2018-9553 الف-116615297 RCE بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2018-9538 الف-112181526 EoP بالا 8.1، 9
CVE-2018-9554 الف-114770654 شناسه بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم از راه دور را با استفاده از یک انتقال ساخته‌شده خاص قادر به اجرای کد دلخواه در چارچوب یک فرآیند ممتاز کند.

CVE منابع تایپ کنید شدت نسخه های AOSP به روز شده
CVE-2018-9555 الف-112321180 RCE بحرانی 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2018-9556 الف-113118184 RCE بحرانی 9
CVE-2018-9557 A-35385357 * EoP بالا 7.0، 7.1.1، 7.1.2
CVE-2018-9558 الف-112161557 EoP بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2018-9559 الف-112731440 EoP بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9
CVE-2018-9560 A-79946737 EoP بالا 9
CVE-2018-9562 الف-113164621 شناسه بالا 9
CVE-2018-9566 A-74249842 شناسه بالا 7.0، 7.1.1، 7.1.2، 8.0، 8.1، 9

جزئیات آسیب پذیری سطح وصله امنیتی 05/12/2018

در بخش‌های زیر، جزئیات مربوط به هر یک از آسیب‌پذیری‌های امنیتی مربوط به سطح وصله 2018-12-05 را ارائه می‌کنیم. آسیب‌پذیری‌ها تحت مؤلفه‌ای که بر آن تأثیر می‌گذارند گروه‌بندی می‌شوند و شامل جزئیاتی مانند CVE، مراجع مرتبط، نوع آسیب‌پذیری ، شدت ، مؤلفه (در صورت لزوم)، و نسخه‌های به‌روزرسانی‌شده AOSP (در صورت لزوم) می‌شوند. زمانی که در دسترس باشد، تغییر عمومی را که مشکل را حل کرده است به شناسه اشکال مرتبط می کنیم، مانند لیست تغییرات AOSP. هنگامی که تغییرات متعدد به یک باگ مربوط می شود، ارجاعات اضافی به اعداد زیر شناسه اشکال مرتبط می شوند.

سیستم

شدیدترین آسیب‌پذیری در این بخش می‌تواند منجر به افشای اطلاعات از راه دور و بدون نیاز به امتیازات اجرایی اضافی شود.

CVE منابع تایپ کنید شدت مولفه
CVE-2018-9565 A-16680558 * شناسه بالا OMA-DM

اجزای HTC

شدیدترین آسیب‌پذیری در این بخش می‌تواند یک مهاجم محلی را قادر سازد تا الزامات تعامل کاربر را برای دسترسی به مجوزهای اضافی دور بزند.

CVE منابع تایپ کنید شدت مولفه
CVE-2018-9567 A-65543936 * EoP بالا بوت لودر

اجزای هسته

شدیدترین آسیب پذیری در این بخش می تواند یک مهاجم محلی را قادر سازد تا کد دلخواه را در چارچوب یک فرآیند ممتاز اجرا کند.

CVE منابع تایپ کنید شدت مولفه
CVE-2018-10840 الف-116406508
هسته بالادست
EoP بالا فایل سیستم ext4
CVE-2018-9568 الف-113509306
هسته بالادست
EoP بالا شبکه

قطعات کوالکام

این آسیب‌پذیری‌ها بر اجزای کوالکام تأثیر می‌گذارند و با جزئیات بیشتر در بولتن امنیتی یا هشدار امنیتی کوالکام توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه می شود.

CVE منابع تایپ کنید شدت مولفه
CVE-2018-11960 الف-114042002
QC-CR#2264832
N/A بالا HWEngines
CVE-2018-11961 الف-114040881
QC-CR#2261813
N/A بالا GPS_AP_LINUX
CVE-2018-11963 الف-114041685
QC-CR#2220770
N/A بالا چند رسانه ای خودرو

اجزای منبع بسته کوالکام

این آسیب‌پذیری‌ها بر اجزای کوالکام تأثیر می‌گذارند و با جزئیات بیشتر در بولتن امنیتی یا هشدار امنیتی کوالکام توضیح داده شده‌اند. ارزیابی شدت این مسائل به طور مستقیم توسط کوالکام ارائه می شود.

CVE منابع تایپ کنید شدت مولفه
CVE-2017-8248 A-78135902 * N/A بحرانی جزء منبع بسته
CVE-2017-11004 A-66913713 * N/A بحرانی جزء منبع بسته
CVE-2017-18141 A-67712316 * N/A بحرانی جزء منبع بسته
CVE-2018-5913 A-79419833 * N/A بحرانی جزء منبع بسته
CVE-2018-11279 A-109678200 * N/A بحرانی جزء منبع بسته
CVE-2017-18319 A-78284753 * N/A بالا جزء منبع بسته
CVE-2017-18321 A-78283451 * N/A بالا جزء منبع بسته
CVE-2017-18322 A-78285196 * N/A بالا جزء منبع بسته
CVE-2017-18323 A-78284194 * N/A بالا جزء منبع بسته
CVE-2017-18324 A-78284517 * N/A بالا جزء منبع بسته
CVE-2017-18327 A-78240177 * N/A بالا جزء منبع بسته
CVE-2017-18331 A-78239686 * N/A بالا جزء منبع بسته
CVE-2017-18332 A-78284545 * N/A بالا جزء منبع بسته
CVE-2017-18160 A-109660689 * N/A بالا جزء منبع بسته
CVE-2017-18326 A-78240324 * N/A بالا جزء منبع بسته
CVE-2017-8276 A-68141338 * N/A بالا جزء منبع بسته
CVE-2017-18328 A-78286046 * N/A بالا جزء منبع بسته
CVE-2017-18329 A-73539037 * N/A بالا جزء منبع بسته
CVE-2017-18330 A-73539235 * N/A بالا جزء منبع بسته
CVE-2018-3595 A-71501115 * N/A بالا جزء منبع بسته
CVE-2017-18320 A-33757308 * N/A بالا جزء منبع بسته
CVE-2018-11999 A-74236942 * N/A بالا جزء منبع بسته
CVE-2018-5867 A-77485184 * N/A بالا جزء منبع بسته
CVE-2018-5868 A-77484529 * N/A بالا جزء منبع بسته
CVE-2018-5869 A-33385206 * N/A بالا جزء منبع بسته
CVE-2017-5754 A-79419639 * N/A بالا جزء منبع بسته
CVE-2018-5915 A-79420511 * N/A بالا جزء منبع بسته
CVE-2018-11267 A-109678338 * N/A بالا جزء منبع بسته
CVE-2018-11922 A-112279564 * N/A بالا جزء منبع بسته

پرسش و پاسخ متداول

این بخش به سوالات رایجی که ممکن است پس از خواندن این بولتن رخ دهد پاسخ می دهد.

1. چگونه تشخیص دهم که آیا دستگاه من برای رفع این مشکلات به روز شده است؟

برای آشنایی با نحوه بررسی سطح وصله امنیتی دستگاه، به بررسی و به‌روزرسانی نسخه Android خود مراجعه کنید.

  • سطوح وصله امنیتی 01/12/2018 یا بعد از آن همه مسائل مرتبط با سطح وصله امنیتی 01/12/2018 را برطرف می‌کند.
  • سطوح وصله امنیتی 2018-12-05 یا جدیدتر، تمام مسائل مرتبط با سطح وصله امنیتی 2018-12-05 و تمام سطوح وصله قبلی را بررسی می کند.

سازندگان دستگاه‌هایی که شامل این به‌روزرسانی‌ها می‌شوند باید سطح رشته وصله را روی موارد زیر تنظیم کنند:

  • [ro.build.version.security_patch]:[01-12-2018]
  • [ro.build.version.security_patch]:[05-12-2018]

2. چرا این بولتن دارای دو سطح وصله امنیتی است؟

این بولتن دارای دو سطح وصله امنیتی است تا شرکای Android انعطاف پذیری لازم را داشته باشند تا زیرمجموعه ای از آسیب پذیری ها را که در همه دستگاه های اندرویدی مشابه هستند با سرعت بیشتری برطرف کنند. شرکای Android تشویق می شوند تا همه مشکلات موجود در این بولتن را برطرف کنند و از آخرین سطح وصله امنیتی استفاده کنند.

  • دستگاه‌هایی که از سطح وصله امنیتی 2018-12-01 استفاده می‌کنند باید همه مشکلات مرتبط با آن سطح وصله امنیتی و همچنین رفع تمام مشکلات گزارش‌شده در بولتن‌های امنیتی قبلی را داشته باشند.
  • دستگاه‌هایی که از سطح وصله امنیتی 05/12/2018 یا جدیدتر استفاده می‌کنند باید همه وصله‌های قابل‌اجرا در این (و قبلی) بولتن‌های امنیتی را شامل شوند.

شرکا تشویق می شوند تا اصلاحات مربوط به همه مشکلاتی را که در حال رفع آنها هستند در یک به روز رسانی واحد جمع کنند.

3. ورودی های ستون Type به چه معناست؟

ورودی های ستون نوع جدول جزئیات آسیب پذیری به طبقه بندی آسیب پذیری امنیتی اشاره دارد.

مخفف تعریف
RCE اجرای کد از راه دور
EoP بالا بردن امتیاز
شناسه افشای اطلاعات
DoS خود داری از خدمات
N/A طبقه بندی در دسترس نیست

4. ورودی های ستون References به چه معناست؟

ورودی‌های زیر ستون مراجع جدول جزئیات آسیب‌پذیری ممکن است حاوی پیشوندی باشد که سازمانی را که مقدار مرجع به آن تعلق دارد، مشخص می‌کند.

پیشوند ارجاع
آ- شناسه باگ اندروید
QC- شماره مرجع کوالکام
M- شماره مرجع مدیاتک
N- شماره مرجع NVIDIA
ب- شماره مرجع Broadcom

5. یک * در کنار شناسه باگ اندروید در ستون References به چه معناست؟

مسائلی که به صورت عمومی در دسترس نیستند دارای یک * در کنار شناسه اشکال Android در ستون References هستند. به‌روزرسانی برای آن مشکل عموماً در آخرین درایورهای باینری دستگاه‌های Pixel/Nexus موجود در سایت Google Developer موجود است.

6. چرا آسیب‌پذیری‌های امنیتی بین این بولتن و بولتن‌های امنیتی دستگاه/شریک، مانند بولتن Pixel/Nexus تقسیم می‌شوند؟

آسیب پذیری های امنیتی که در این بولتن امنیتی مستند شده اند برای اعلام آخرین سطح وصله امنیتی در دستگاه های اندرویدی مورد نیاز هستند. آسیب‌پذیری‌های امنیتی اضافی که در بولتن‌های امنیتی دستگاه/شریک مستند شده‌اند، برای اعلام سطح وصله امنیتی لازم نیست. به تولیدکنندگان دستگاه‌های اندروید و چیپ‌ست‌ها توصیه می‌شود تا از طریق وب‌سایت‌های امنیتی خودشان، مانند بولتن‌های امنیتی Samsung ، LGE ، یا Pixel/Nexus ، وجود اصلاحات دیگر را در دستگاه‌های خود مستند کنند.

نسخه ها

نسخه تاریخ یادداشت
1.0 3 دسامبر 2018 بولتن منتشر شد
1.1 5 دسامبر 2018 بولتن اصلاح شد تا شامل پیوندهای AOSP باشد.